Слаута Андрей

81
Рейтинг

Андрей Слаута
Стил



  •   Регистрация: 20.10.2011 (5 лет назад)

  •   Был(а) на сайте: 22.03.2017


Группы

Профессиональный разработчик

Рейтинг 81

Публикации

24.01.2015
Внешняя печатная форма "Товарный чек". 1С: Управление небольшой фирмой 1.4 Для документов "Заказ покупателя" и "Расходная накладная".

26.03.2014
Внешние печатные формы для 1С: Бухгалтерия предприятия 3.0 1. Акт списания - для документа "Требование-накладная" 2. Акт переработки - для документа "Отчет производства за смену"

30.08.2013
Печатная форма используется при необходимости печати "Расходной накладной" до факта реализации товара документом "Реализация товаров и услуг".

12.08.2013
Если основной реквизит формы имеет тип значения ДокументОбъект.<Имя>, то для данной формы действует расширение формы документа. Посредством него решаются вопросы специфичной функциональности формы документа. Расширение помогает обрабатывать различные команды пользователя, выполнять предварительные проверки и другие сервисные действия. Кроме того, действие расширения формы документа распространяется и на механизмы записи и проведения документа. При этом неважно, была вызвана запись документа интерактивными действиями пользователя в форме документа или средствами языка Записать(). Рассмотрим ряд примеров работы этих механизмов.

03.09.2012
В данной публикации рассматривается перенос данных из "1С:Бухгалтерии 7.7" в "1С:Бухгалтерию 8".

28.07.2012
Внешняя печатная форма Расходный ордер документа Выдача денежных документов (типовая)

16.05.2012
Обработка формирует документы "Выдача денежных документов" на основании документов "Авансовый отчет".

Комментарии

DevADODB.Connection: Не удается найти указанный поставщик#1 15.03.17 18:54
Код
Процедура Выполнить() Экспорт
   
   path2accessDbFile = "E:\Users\a.slauta\Desktop\Обработка\Обработка 8.2\bsc-doc-counter.accdb";
   
   conn_str = "Provider=Microsoft.ACE.OLEDB.12.0; Data Source=" + path2accessDbFile + ";""";
   
   cn = Новый COMОбъект("ADODB.Connection");
   
   cn.Open(conn_str);   
   
КонецПроцедуры


Имеется клиент серверная база. Сервер 1С на одном сервере. SQL на другом. Работают на других серверах.
1С 64 бит. Сервера тоже 64 бит.
Ставил Microsoft Access Database Engine 2010 Redistributable 64 бит на Сервер 1С. Как я понимаю ставить его нужно именно сюда, ведь операция выполняется на сервере. Не помогло.
Может я не туда ставлю или какие-то права нужны?
Подскажите кто сталкивался
DevНе обновляется конфигурация поставщика#1 06.10.16 19:03
Есть база Ликероводочный завод (на основе УПП 1.3) доработанная.
Выгружаю из нее конфигурацию поставщика. Загружаю в чистую базу. Получается типовая конфа.
Начинаю обновлять через поддержка - обновить конфигурацию.
Основная конфигурация обновляется, а поставщика нет.
Что это такое?
Может ли быть дело в ключе, т.к. обновляю на компе без ключа.
DevПодключение внешней формы#1 15.09.16 20:07
Конфигурация 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК (2.0.65.10).
Документ УПЖКХ_Предупреждение.
Форма документа управляемая, но конфигурация работает в обычном приложении.
Как для такого документа сделать внешнюю печатную форму?
Делать СведенияОВнешнейОбработке и подключать в обычном приложении через справочник дополнительных обработок?
DevНайтиФайлы(). Клиент-Серверная база#3 14.05.15 9:15
Код выполняется на сервере.
Код
&НаСервере
Процедура НайтиФайлыИЗагрузить(Стр)
   
   Файлы = НайтиФайлы(Каталог + "\images", Стр.Артикул + ".*"); 
   
   Если Файлы.Количество() > 0 Тогда
      ДобавитьИзображение(Файлы[0]);      
   КонецЕсли;
   
КонецПроцедуры
DevНайтиФайлы(). Клиент-Серверная база#1 14.05.15 9:02
Метод НайтиФайлы() возвращает пустой массив при использоании клиент-серверного варианта работы.
В аналогичной файловой базе тот же код возвращает заполненный массив.
В чем может быть причина?
DevКак убить процесс 1С одного конкретного пользователя#5 19.02.15 16:24
(4) Bienko, Обмен с сайтом в реальном времени. И запускать через планировщик. Ну капец.
DevКак убить процесс 1С одного конкретного пользователя#3 19.02.15 9:02
(2) Xershi, Да что-то попробовал taskkill, вроде и пользователя в строке указал. А он мне все процессы поубивал.
DevКак убить процесс 1С одного конкретного пользователя#1 19.02.15 8:47
Суть проблемы:
Имеется сервер, к нему подулючаются пользователи для работы с 1С (файловая).
На одном пользователе крутится сеанс 1С для обмена с сайтом.
Обмен по непонятным причинам время от времени прекращает работать. Помогает перезапуск сеанса.
Хотелось бы сделать батник, чтобы пользователи сами могли перезапустить сеанс.
Как запустить 1С в командной строке я знаю. А вот как завершить этот один конкретный сеанс для обмена понятия не имею.
БУВнешняя печатная форма "Товарный чек". УНФ 1.4#0 24.01.15 14:10
Внешняя печатная форма "Товарный чек".
1С: Управление небольшой фирмой 1.4
Для документов "Заказ покупателя" и "Расходная накладная".
DevОшибка при вызове метода контекста (ПрочитатьXML)#1 07.12.14 18:00
Данный код возвращает Неопределенно.
Ошибка в строке
КоммерческаяИнформацияXDTO = ПараметрыОбмена.МояФабрикаXDTO.ПрочитатьXML(ОбъектXML);

Ошибка при вызове метода контекста (ПрочитатьXML)

Из-за чего такое может быть? До сегодняшнего процедура обрабатывалась без ошибок


Код
   ОбъектXML = Новый ЧтениеXML;
   
   Попытка
      
      ОбъектXML.УстановитьСтроку(СтрокаXML);
      
   Исключение
      
      СообщитьПодробно("Не удалось прочитать XML.", ПараметрыОбмена);   
      
      Возврат Неопределено;
      
   КонецПопытки;
   
   Попытка
      КоммерческаяИнформацияXDTO = ПараметрыОбмена.МояФабрикаXDTO.ПрочитатьXML(ОбъектXML);
   Исключение
      
      СообщитьПодробно("Не удалось прочитать XML.", ПараметрыОбмена);   
      
      Возврат Неопределено;
      
   КонецПопытки;
   
   Возврат КоммерческаяИнформацияXDTO;