Барилко Виталий

2257
Рейтинг

Виталий Барилко
Diversus



  •   Регистрация: 18.08.2008 (8 лет назад)

  •   Был(а) на сайте: 26.05.2017


Группы

Партнер IS-SP

Профессиональный разработчик

Партнеры ТОП-100 продаж

Партнер IS-WP

IE 2013 REV Докладчик

IE 2014 Участник

IE 2015 Участник

IE 2016 Участник

Карта покупателя SILVER

Компания


Системные решения для 1С
softonit.ru

Компания занимается разработкой коммерческого программного обеспечения.
Среди наших решений:
* Управление IT-отделом 8
* Журнал регистрации изменений во внешней БД MS SQL Server
* Система поддержки пользователей для платформы 1С:Предприятие Softonit Control
* Внешняя компонента MediaBuild
* И другие
Помимо этого мы занимаемся внедрением и сопровождение типовых конфигураций 1С.

04.11.2014    4751   

Рейтинг 2257

Сервис SMS-рассылок SMS.RU для конфигурации 1С:Фитнес клуб 2

Администратор Программист Бухгалтер Менеджер v8 1cv8.cf Взаимоотношения с клиентами (СRM) Абонемент ($m)

Предлагаем вашему вниманию обработку для конфигурации 1С:Фитнес клуб 3.1 для отправки SMS-сообщений с помощью "не родных" сервисов. Цены на отправку СМС для этой конфигурации по умолчанию достаточно высокие, постараемся их уменьшить за счет использования стороннего шлюза рассылки.

1 стартмани

20.03.2017    1121    2    0    

Как сделать активное окно в 1С максимально большим? 59

v8 1cv8.cf Бесплатно (free)

В 1С:Предприятие 8.3 есть специальная возможность, о которой мало кто знает, но она может оказаться полезной для тех, кто хочет максимального обзора в текущей активной форме 1С в режиме Предприятия. Что же это?

09.12.2016    5793    0    22    

FAQ: Продажа собственного программного обеспечения - теория и практика 127

Россия Бесплатно (free)

Разбор основных вопросов, связанных с продажей собственного ПО, тонкости в лицензионных договорах и условия лицензирования ПО. Как начать продавать ПО и что для этого нужно? Все нюансы и описание тонкостей. Часто встречающиеся вопросы и ответы на них собраны в этой статье. Приведены примеры из личного опыта.

18.01.2016    13176    0    25    

Помощник бухгалтера. Печать на конвертах в 1С 7

Бухгалтер v8 1cv8.cf Делопроизводство и документооборот Платные (руб)

Решение, которое позволит экономить время простого бухгалтера или делопроизводителя на заполнении писем! Внешняя печатная форма для типовых конфигураций 1С:Предприятие с автоматическим заполнением данными контрагентов (клиентов и поставщиков) и возможностью создания собственных настраиваемых шаблонов с логотипом организации и текстом. Вставили пустой конверт в принтер, открыли 1С, выбрали контрагентов для печати, получили заполненный конверт.

5000 руб.

12.11.2015    9843    21    7    

Infostart Event 2015 Connection с практической точки зрения 57

Бесплатно (free)

Прошла почти неделя после завершения IE 2015, мысли вернулись в рабочее русло, куча докладов сначала оставила после себя кашу, но прошло немного времени и захотелось поговорить про конференцию с практической точки зрения. Что дала конференция персонально для меня и для всех остальных?

24.10.2015    7402    0    32    

Создание договоров по шаблонам Word в УТ 11.2, БП 3.0 с возможностью хранения в справочнике "Файлы" 18

Менеджер v8 БП3.0 УТ11 УУ Делопроизводство и документооборот Абонемент ($m)

Публикация предназначена тем, кто ведет договоры в УТ 11 не только в справочнике "Договоры с контрагентами", но также формирует и согласовывает с контрагентами договоры в формате Word (*.doc). А так как программисты люди ленивые и я не являюсь исключением в этом (хорошем) смысле :), была создана эта печатная форма. Но это не простая печатная форма, а инструмент, который позволяет на основании шаблона, хранящегося в информационной базе в справочнике "Файлы", быстро заполнять и сохранять тут же в справочник "Файлы", но в другую папку, уже заполненный на основании шаблона договор в формате Word.

1 стартмани

08.10.2015    9002    83    17    

Контроль возврата оригиналов первичных документов в типовых конфигурациях (для бухгалтеров) 65

Аналитик Бухгалтер Директор v8 1cv8.cf БУ Делопроизводство и документооборот Бесплатно (free)

Очень часто перед рядовым (и не очень) бухгалтером встает вопрос о том, как контролировать получение оригиналов документов от покупателей/поставщиков на примере типовой бухгалтерии. В статье опишем несколько методик учета и попытаемся раскрыть все плюсы и минусы каждой из них. Опытным бухгалтерам и программистам в статье может показаться все банальным, но я думаю, все равно будет полезно ее прочесть и, возможно, кому-то это поможет.

15.07.2015    10887    0    17    

Создание связных объектов, как аналог "Создания на основании" в конфигурациях на основе БСП 33

Программист v8 1cv8.cf Абонемент ($m)

Не все знают, что конфигурации на основе БСП (УТ 11, БП 3.0, ЗУП 3.0 и т.д.) имеют механизм, который позволяет создавать связанные объекты, что в какой-то мере является аналогом создания на основании.

1 стартмани

26.06.2015    9316    9    10    

Программное добавление элементов к графической схеме (управляемые формы) 29

Программист v8 1cv8.cf Абонемент ($m)

Почему то фирма "1С" пошла особым путем и лишила нас, программистов, возможности полноценно работать с таким объектом, как графическая схема. Точнее, работать-то с ней можно, но как то однобоко...

1 стартмани

17.03.2015    8390    50    10    

Мульти рассылка СМС из 1С для типовых и нетиповых конфигураций, на управляемых и обычных формах 80

Менеджер v8 1cv8.cf Взаимоотношения с клиентами (СRM) Абонемент ($m)

Очень часто в торговых организациях проводятся рассылки своим покупателям об акциях, скидках, новых поступлениях и т.д. Для этих целей была создана одна универсальная обработка, которая поможет осуществить рассылку в любой конфигурации 1С. Для отправки используется несколько сервисов на выбор: sms.ru, smsc.ru, p1sms.ru, smsgorod.ru, которые по нашему мнению являются одними из самых функциональных в интернете. Так же есть возможность для юридических лиц заключения договора и оплата безналичным расчетом. Наша обработка не просто может отправлять СМС, но и позволяет автоматически заполнять сотовые(!) телефонные номера из базы 1С, делать как общие рассылки так и персонализированные, подставляя значения переменных, которые вычисляются для каждого адресата, будь то его долг или фамилия имя, например, узнать баланс и т.д. Но обо всем по порядку...

1 стартмани

03.02.2015    17141    272    57    

Infostart Event 2014 глазами участника 41

Бесплатно (free)

Это уже становится традицией дать некий feedback и подвести черту после прошедшего Event'а не будем отставать от прошлого года и прошлой моей статьи про IE 2013 Revolution и опишу все те мысли, которые появились до, во время и после конференции, дабы осознать масштаб того, что произошло.

03.11.2014    8946    0    18    

Универсальные подбор и обработка объектов для конфигураций на 8.3 без использования режима модальности 16

v8 1cv8.cf Абонемент ($m)

Универсальные подбор и обработка объектов для конфигураций на 8.3 без использования режима модальности.

1 стартмани

24.10.2014    9826    174    3    

Установка изображений (картинок) для номенклатуры УТ 10.3, УТ 11, УПП 1.3, УТП, УНФ, КА, Розница 2 из интернета, FTP, файловой системы 35

Менеджер v8 УТ10 Розница УПП1 УНФ УТ11 КА2 Платные (руб)

Очень часто у торговых организаций возникает потребность работы с изображениями номенклатуры, например, для дальнейшей выгрузки на сайт, или для того, чтобы продавцы могли ориентироваться в номенклатуре. Самостоятельно фотографировать всё и вся - не выход из ситуации. Предлагаем решение, которое позволит управлять изображениями номенклатуры в УТ 10.3, УТ 11, УПП 1.3, УТП, УНФ, КА, Розница 2.

2000 руб.

18.08.2014    26082    0    67    

Интерфейс "Такси", или как настроить Бухгалтерию 3.0 для удобной работы 119

v8 БП2.0 Бесплатно (free)

Новомодный интерфейс "Такси" застал пользователей врасплох и многие не знают как дальше "в этом" работать. А между прочим, фирма 1С сделала его достаточно удобным, если знать как правильно его "готовить" :) Итак, для начала включим интерфейс "Такси", рассмотрим все на примере конфигурации "Бухгалтерия 3.0".

09.07.2014    51047    0    117    

Внешняя печатная форма "Лист учета рабочего времени" для БП 3.0 5

Бухгалтер v8::БУ БП3.0 БУ УУ Учет рабочего времени Абонемент ($m)

Внешняя печатная форма для 1С-конфигурации Бухгалтерии предприятия 3.0. Используется при учете рабочего времени у клиентов. Позволяет без изменения конфигурации добавить возможность использовать собственную печатную форму. Появляется дополнительный пункт "Лист учета рабочего времени" в меню "Печать" в документах "Счет на оплату покупателю", "Реализация товаров и услуг" и в справочнике "Контрагенты".

1 стартмани

14.05.2014    11128    30    6    

Softonit Control - система удаленной поддержки пользователей для платформы 1С:Предприятие 65

Администратор Платные (руб)

Представьте, если бы у Вас под рукой был мощный инструмент для поддержки пользователей сочетающий в себе: сетевой стартер (лаунчер) конфигураций 1С, блокировщик доступа к ЛЮБЫМ информационным базам (файловым, клиент-серверным), подключение информационных баз пользователю в один клик, корпоративный чат, систему удаленного управления пользователями, чистка кэша 1С удаленно, быстрое скрытие информационных баз и т.д. и все это в одном программном комплексе? Заинтересовались? Такая программа заинтересует любого программиста или системного администратора, кому приходилось иметь дело с платформой 1С. Мы сделали такой программный комплекс!

4500 руб.

03.04.2014    22487    410    45    

Infostart Event 2013 Revolution или субъективно об объективном 32

Бесплатно (free)

Пока свежи воспоминания, почему бы ими не поделиться с остальными?

09.11.2013    13635    0    345    

Акт приема-передачи неисключительных прав для БП 3.0 10

Бухгалтер v8 БП3.0 БУ Оптовая торговля Розничная торговля Абонемент ($m)

Внешняя печатная форма для документа "Реализация товаров и услуг" для конфигурации Бухгалтерия предприятия 3.0 (БП 3.0)

1 стартмани

25.09.2013    10909    20    22    

Внешняя компонента MediaBuild (создание фото и видео с веб-камер и IP-камер) для 1С:Предприятие 8.2, 8.3, 8.4 (NativeAPI) 21

Программист v8 1cv8.cf Платные (руб)

Внешняя компонента для 1С:Предприятие 8.2, 8.3, 8.4 реализованная по технологии NativeAPI. Предназначена для работы с мультимедиа устройствами для создания фото и видео с помощью WEB и IP-камер, с монитора, или других устройств записи, а так же дальнейшей обработки полученных данных. Решение не привязано к конкретным механизмам платформы, или методам типовых конфигураций 1С - используйте внешнюю компоненту в любых конфигурациях, которые используете. В комплект включены подсистемы и расширения для типовых конфигураций.

10000 руб.

01.08.2013    22639    332    76    

Управление ИТ отделом 8, редакция 3.0 117

Администратор Программист Директор v8 Информационные технологии, веб-сервисы Платные (руб)

Управление ИТ отделом 8, редакция 3.0 - это комплексное решение для ИТ-подразделений любой организации и компаний, занимающихся обслуживанием клиентов. Содержит в себе полный комплекс средств для работы службы технической поддержки, программистов, системных администраторов. Позволяет эффективно организовать их работу и взаимодействие с сотрудниками организаций.

12500 руб.

22.04.2013    92193    617    193    

Отправка SMS в 1С:Предприятие 7.7 "Торговля + Склад", 1С:Предприятие 8 "УТ 10.3", "УТ 11", "БП 3.0" по справочнику контрагенты 22 копейки за СМС 42

v8 УТ10 1С7:ТиС Абонемент ($m)

Очень часто в торговых организациях проводятся рассылки своим покупателям об акциях, скидках, новых поступлениях и т.д. Для этих целей мы создали комплекс внешних обработок, которые помогут осуществить рассылку. Для отправки используем сервис sms.ru, который является дешевым: 22 копеек за 1 SMS, если количество отправленных SMS перевалило через сумму 5 т.р. то цена снижается до 7 копеек за SMS. Плюс, этот вариант давно обкатан на наших клиентах.

1 стартмани

01.04.2013    23663    314    22    

Установка изображения номенклатуры из интернета для УТ 10.3, УПП 1.3 19

v8 УТ10 Абонемент ($m)

Данная обработка позволяет установить изображения номенклатуры в конфигурации Управление торговлей 10.3, УПП 1.3 из интернета.

1 стартмани

20.03.2013    12259    189    43    

Работа с криптографией на примере получения хэша SHA-512 в 1С 19

Программист v8 Абонемент ($m)

Понадобилось мне как то сделать одну СМС-рассылку в 1С с методом усиленной авторизации, в которой необходимо было получить хэш SHA-512. Было перерыто половина интернета и ничего толкового именно по SHA-512 найдено так и не было... В результате был найден способ как получить криптографическую функцию в 1С не копаясь в RFC и спецификациях относительно быстро и самое главное отлаженную от и до.

1 стартмани

25.02.2013    11410    30    16    

Микрографики в динамическом списке 1С 8.2 97

Программист v8 1cv8.cf Абонемент ($m)

Пример использования микрографиков в динамическом списке

1 стартмани

11.02.2013    13619    88    24    

Журнал регистрации изменений во внешней информационной базе 1С (управляемые и обычные формы, демо-сервер) 165

Администратор v8 1cv8.cf Платные (руб)

Давно известно, что стандартный журнал регистрации фирмой 1С достаточно плохо продуман и реализован. Допустим, он предоставляет информацию об идентификаторе транзакции, но не предоставляет сведения о том какой реквизит был изменен, что, по моему мнению, более важно. Далее самый больной вопрос, как быть, если пользователей работает много, изменений производится тоже достаточно много и Вы пытаетесь, в стандартном журнале найти, кто изменил документ? Как это не печально, но подобная, в общем случае, тривиальная задача займет у Вас очень много времени, т.к. открывается и ищется все чудовищно долго. Простой отбор по какому-нибудь документу может занимать 5-10 минут, а время, как известно, деньги… Так же в стандартном журнале нельзя увидеть, что было изменено в объекте. Т.е. на вопрос, какой конкретно реквизит или строчка в табличной части были изменены, ответа мы не получим. Зачастую нерадивые сотрудники этим пользуются, аргументируя, что они просто открыли документ и вместо кнопки «Закрыть» нажали «OK» ничего не изменив. Не получится настроить встроенный журнал, чтобы из открытого документа или справочника можно было бы нажатием одной кнопки увидеть всю историю изменений. А это очень удобно!

15000 руб.

04.02.2013    82759    627    265    

Sidebar Gadget Sticky Notes с синхронизацией через DropBox для Windows 7 9

Абонемент ($m)

Очень долго я искал для себя маленькую записную книжку для хранения важной информации на компьютере, которая была бы на моем рабочем столе на работе и дома. Пока не решил сделать гаджет самостоятельно. В Windows 7 есть даже специальная программка, которая называется Sticky Notes, она всем хороша, но имеет три существенных (для меня) минуса: 1. Она не имеет встроенной синхронизации с несколькими компьютерами (точнее сделать то ее можно, через тот же DropBox, но с бубном); 2. Она постоянно висит в панели задач в списке открытых окон; 3. При нажатии на Ctrl+D (свернуть все окна), она сворачивается, как и любое другое окно. Что не очень удобно.

1 стартмани

20.09.2012    9332    34    7    

Сотрудники, у которых изменилась должность для ЗУП 10

Бухгалтер v8 ЗУП2.5 Россия Персонал, кадры Абонемент ($m)

Отчет по изменениям должностей для сотрудников по организации за период для ЗУП

1 стартмани

20.03.2012    7320    66    5    

Как программисту не потерять уверенности в себе и подзаработать 573

Россия Бесплатно (free)

Добрый день уважаемые читатели. Сегодня я расскажу Вам свою историю, историю программиста, который когда то почти отчаялся от безысходности и не востребованности профессии программист как таковой, но пережил этот не простой этап своей жизни.

16.12.2010    21115    0    172    

Управление ИТ отделом 8 151

Администратор Программист v8 1cv8.cf Информационные технологии, веб-сервисы Россия УУ Абонемент ($m)

Готовое решение для автоматизации ИТ-отдела. Позволяет в едином информационном пространстве успешно вести многовекторный учет системным администраторам, программистам, техникам компьютерных сетей. Простота и удобство работы сделают данную конфигурацию незаменимым помощником.

1 стартмани

23.11.2010    45835    2637    207    

Отчет по залежавшейся номенклатуре на складах БП 1.6 4

Аналитик Бухгалтер v8 БП1.6 Россия УУ Учет ТМЦ Абонемент ($m)

Недавно, бухгалтерия попросила отчет по номенклатуре, которая слишком долго лежит на складах. Т.е. им нужна вся номенклатура, которая есть на остатке 10 счета на данный момент, со сведениямяи когда она была куплена. Если используется метод определения себестоимости при списании МПЗ – FIFO, все хорошо, можно стандартной ОСВ по счету, в разрезе партий, увидеть, когда к нам пришла данная номенклатура. Но у них по среднему… Проблема…

1 стартмани

17.08.2010    6569    88    11    

Резервное копирование на FTP средствами SQL Server 15

Администратор Россия Абонемент ($m)

Тема резервного копирования баз данных SQL актуальна будет всегда, поэтому привожу свой пример решения этой задачи. Скрпит SQL-сервера для создания бэкапов на FTP, при ошибке отправляется письмо администратору. Все операции выполняются штатными средствами SQL-сервера и Windows.

1 стартмани

20.07.2010    11419    190    5    

Уменьшенные на половину листа РКО и ПКО (внешние печатные формы) для БП 1.6, 2.0 28

Бухгалтер v8 БП2.0 БП1.6 Россия БУ Кассовые операции Абонемент ($m)

Актуально во время кризиса. Типовые формы, просто уменьшенные на половину листа А4 для экономии бумаги.

1 стартмани

11.03.2010    10608    485    12    

Оборотно-сальдовая ведомость по счету с кодом для субконто "Номенклатура" и единицей измерения для БП 1.6 14

Бухгалтер v8 Россия БУ Оборотно-сальдовая ведомость, Анализ счета Абонемент ($m)

Потребовалась как-то оборотно-сальдовая ведомость по счету, такая, что бы везде где встречается номенклатура, был код номенклатуры и основная единица измерения. Выкладываю, мало ли, может кому нибудь пригодится...

1 стартмани

02.02.2010    7611    298    4    

Выгрузка из конфигурации 1С: Предприятие 7.7 + SQL SERVER 2005 с работающими пользователями 11

Администратор Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Методика получения выгрузки средствами 1С, конфигурации 1С: Предприятие 7.7 + SQL SERVER 2005 с работающими пользователями.

1 стартмани

28.10.2009    13738    96    10    

Статья из цикла «Личный опыт» «Устранение ошибок выгрузки, загрузки конфигураций в 1С: Предприятие 7.7» 78

Администратор Программист v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Возможно, эта статья поможет кому-нибудь, это не свод правил как устранить ту или иную проблему с выгрузкой или загрузкой – это примеры, как попытаться «вылечить» базу данных, если стандартные средства не помогают. Они описывают именно те методы и механизмы, которые были опробованы мною лично и реально мне помогли, а так же сам механизм поиска проблем.

06.10.2009    11065    0    17    

ActiveX компонент для визуальной работы с железно-дорожным транспортом из 1С 35

Программист v8 1cv8.cf Россия Абонемент ($m)

ActiveX компонент для визуальной работы с железно-дорожным транспортом из 1С с тестовой конфигурацией для 1С: 8.1 с исходниками

1 стартмани

13.08.2009    7023    167    8    

Open Calc Report System 49

Программист Россия Абонемент ($m)

Open Calc Report System это внешняя компонента, которая позволяет строить отчеты в OpenOffice Calc. Использует схожую с 1С технологию вывода информации в OpenOffice - посекционную. Внешняя компонента идет с исходниками и примером на 1С v7.7, для 8-ки аналогичное применение...

1 стартмани

07.07.2009    7346    201    16    

Комментарии

НовостиВ 8.3.11 добавят историю данных#6 26.05.17 20:44
(3) 1С не дремлет :)
Этого стоило ожидать. Вопрос о том кто, что изменил, какое было старое значений и как это вернуть обратно, задача часто встречающаяся. Логично, что 1С, в конце концов, обратила на это внимание.
Не беда, что это случилось (это говорю как автор приведенной ссылки) все движется и развивается и я рад, что такая проблема будет решена самой платформой.
AdminЖурнал регистрации изменений во внешней информационной базе 1С (управляемые и обычные формы, демо-сервер)#272 26.05.17 20:37
(269) Спасибо за ссылку. Этого рано или поздно стоило ожидать...
AdminЖурнал регистрации изменений во внешней информационной базе 1С (управляемые и обычные формы, демо-сервер)#268 24.05.17 13:47
(266)
Цитата
но посмотреть кто заходил в документы, даже если ничего не менял в них? Это регистр
Да, простите не ответил вовремя. Спасибо Максим за комментарий, все верно. Есть спец. процедуры и события, которые уже идут с подсистемой, но они нигде не вызываются и должны быть заложены во все формы (или только в некоторые) самостоятельно.
Добавление этих событий увеличивает размер журнала, поэтому мы оставили это на откуп пользователей, но инструментарий соответствующий имеется.
НовостиВ Ставрополе создали нового «убийцу Windows» – Ivan ОS#22 23.05.17 9:18
(4)
Цитата
Если ты спишь с дочками нефтебаронов, можно и бесплатно.
Линус Торвальдс - сделал в свое время это бесплатным и он не спал с дочками нефтебаронов.
НовостиВ Ставрополе создали нового «убийцу Windows» – Ivan ОS#2 22.05.17 17:56
40 млн за форк Linux... А кто-то делает это и бесплатно.
Абалдеть...
УчетУправление ИТ отделом 8, редакция 3.0#197 22.05.17 10:07
Обновление Управление IT-отделом 8 от 16.05.2016 релиз 3.0.35.2
УчетУправление ИТ отделом 8, редакция 3.0#196 22.05.17 10:04
Обновление Управление IT-отделом 8 от 12.05.2016 релиз 3.0.35.1
DevУниверсальная процедура по загрузке файла из интернета#1 18.05.17 10:00
Процедура не универсальна. Она, например, не анализирует то, что было на веб-сервере перемещено и отдает статус 301 (страница, которая была перемещена и по старому адресу происходит редирект).

Вот универсальная, автор Поручик (если не ошибаюсь):
Код
Функция ПолучитьСодержимоеВебАдреса(Знач СерверПриемник, Знач АдресСтраницы = "",
                Знач ПараметрыСоединения = Неопределено, ЗаголовкиHTTP = Неопределено,
                Знач ПолучитьКакДвоичныеДанные = Ложь, Знач ЗащищенноеСоединение = Ложь) Экспорт
    Перем ИмяФайлаОтветаКодированное, ИмяФайлаОтвета, Порт, Логин, Пользователь, Пароль, Прокси, Таймаут;

    Если Не ЗначениеЗаполнено(СерверПриемник) Тогда Возврат Неопределено; КонецЕсли;
    Если ТипЗнч(ЗаголовкиHTTP) <> Тип("Соответствие") Тогда ЗаголовкиHTTP = Новый Соответствие; КонецЕсли;
    Если Найти(Нрег(СерверПриемник), "https://") = 1 Тогда ЗащищенноеСоединение = Истина; КонецЕсли;

    Протокол = ?(Найти(Нрег(СерверПриемник), "https://") = 1 ИЛИ ЗащищенноеСоединение, "https://", "http://");
    Если Лев(НРег(СерверПриемник), СтрДлина(Протокол)) = Протокол Тогда
        СерверПриемник = Сред(СерверПриемник, СтрДлина(Протокол) + 1);
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(АдресСтраницы) Тогда
        Позиция = Найти(СерверПриемник, "/");
        Если Позиция > 0 Тогда
            АдресСтраницы = Сред(СерверПриемник, Позиция, СтрДлина(СерверПриемник));
            СерверПриемник = Лев(СерверПриемник, Позиция - 1);
        Иначе
            АдресСтраницы = "/";
        КонецЕсли;
    КонецЕсли;

    СерверПриемник = СтрЗаменить(СерверПриемник, "/", "");

    //Выделяем порт из доменного имени
    ПозицияДвоеточия = Найти(СерверПриемник, ":");
    Если ПозицияДвоеточия > 0 Тогда
        Порт = Число(Сред(СерверПриемник, ПозицияДвоеточия + 1));
        СерверПриемник = Лев(СерверПриемник, ПозицияДвоеточия - 1);
    КонецЕсли;

    Если ТипЗнч(ПараметрыСоединения) = Тип("Структура") Тогда
        Для каждого КлючЗначение из ПараметрыСоединения Цикл
            Значение = КлючЗначение.Значение; Выполнить(КлючЗначение.Ключ + " = Значение;");
        КонецЦикла;
        Пользователь = ?(ЗначениеЗаполнено(Пользователь), Пользователь, Логин);
    КонецЕсли;
    НТТР = Новый HTTPСоединение(СерверПриемник, Порт, Пользователь, Пароль, Прокси, Таймаут,
                        ?(ЗащищенноеСоединение, Новый ЗащищенноеСоединениеOpenSSL(), Неопределено));

    //Ответ от сервера получим в возвращаемом значении типа HTTPОтвет
    ОтветHTTP = НТТР.Получить(Новый HTTPЗапрос(АдресСтраницы, ЗаголовкиHTTP)); //
    ОшибкаЗапроса = (ОтветHTTP.КодСостояния >= 400);

    //После получения ответа сервера необходимо проверить статус или код состояния.
    //http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html
    //Если сервер вернул один из статусов переадресации
    //301 Moved Permanently («перемещено навсегда») или 302 Moved Temporarily («перемещено временно»),
    //то в этом случае можно попытаться перейти на ресурс, на который переадресовал сервер
    Если ОтветHTTP.КодСостояния = 301 или ОтветHTTP.КодСостояния = 302 Тогда

        Если ОтветHTTP.Заголовки.Количество() > 0 Тогда
            //Адрес страницы переадресации содержится в поле Location заголовка ответа
            АдресСтраницы = ОтветHTTP.Заголовки["Location"]; //
            Если ЗначениеЗаполнено(АдресСтраницы) Тогда
                Если Найти(НРег(АдресСтраницы), "http://") = 0 И Найти(НРег(АдресСтраницы), "https://") = 0 Тогда
                    АдресСтраницы = ?(Лев(АдресСтраницы, 1) = "/", Сред(АдресСтраницы, 2), АдресСтраницы);
                    Если Найти(АдресСтраницы, СерверПриемник + "/") = 0  Тогда
                        АдресСтраницы = Протокол + СерверПриемник + ?(ЗначениеЗаполнено(Порт), ":" + Порт, "") + "/" + АдресСтраницы;
                    КонецЕсли;
                КонецЕсли;

                //Если сервер вернул cookies (http://ru.wikipedia.org/wiki/HTTP_cookie, http://www.faqs.org/rfcs/rfc6265.html?#41;,
                //вставим их в заголовки для передачи на страницу перехода
                Куки = ОтветHTTP.Заголовки["Set-Cookie"];//
                Если ЗначениеЗаполнено(Куки) Тогда ЗаголовкиHTTP.Вставить("Cookie", Куки); КонецЕсли;

                //Рекурсивный вызов
                Возврат ПолучитьСодержимоеВебАдреса(АдресСтраницы, , , ЗаголовкиHTTP, ПолучитьКакДвоичныеДанные, ЗащищенноеСоединение);//

            КонецЕсли;
        КонецЕсли;

    ИначеЕсли ОтветHTTP.КодСостояния >= 100 И ОтветHTTP.КодСостояния <= 200 Тогда
        //Статус ответа в интервале между 100 и 200 Ok говорит о нормальном результате HTTP-запроса
        Если ОтветHTTP.Заголовки.Количество() > 0 Тогда
            ТипСодержимого = ОтветHTTP.Заголовки["Content-Type"];
            //http://ru.wikipedia.org/wiki/Список_MIME-типов
            Если Найти(ТипСодержимого, "text/") = 1 ИЛИ Найти(ТипСодержимого, "/javascript")
                ИЛИ Найти(ТипСодержимого, "+xml") ИЛИ Найти(ТипСодержимого, "/xml") <> 0 ИЛИ Найти(ТипСодержимого, "/json") <> 0 Тогда
                ПолучитьКакДвоичныеДанные = Ложь;
            ИначеЕсли Найти(ТипСодержимого, "image/") = 1 ИЛИ Найти(ТипСодержимого, "video/") = 1 
                ИЛИ Найти(ТипСодержимого, "application/") = 1 ИЛИ Найти(ТипСодержимого, "audio/") = 1 Тогда
                //Если содержимое полученного ответа представляет собой изображение, видео, приложение,
                //возвращаем двоичные данные, так как возвращать в виде строки не имеет смысла.
                ПолучитьКакДвоичныеДанные = Истина;
            КонецЕсли;
            //Некоторые сервера возвращают в типе содержимого имя отданного файла, например image/png; name="Имя файла.png"
            //или отдают в заголовке Content-Disposition: attachment; filename=Имя файла.png (http://www.http11.ru/post.php?post=2)
            Если ОтветHTTP.Заголовки["Content-Disposition"] <> Неопределено Тогда
                ТипСодержимого = ОтветHTTP.Заголовки["Content-Disposition"];
            КонецЕсли;
            ТипСодержимого = СтрЗаменить(СтрЗаменить(ТипСодержимого, """", ""), "'", "");

            //в ключе filename*=UTF-8'' содержится url-кодированное имя файла
            ПозицияИмениФайла = Найти(ТипСодержимого, "filename*=UTF-8");
            Если ПозицияИмениФайла <> 0 Тогда
                ИмяФайлаОтветаКодированное = Сред(ТипСодержимого, ПозицияИмениФайла + СтрДлина("filename*=UTF-8"));
                ПозицияДвоеточия = Найти(ИмяФайлаОтветаКодированное, ";");
                Если ПозицияДвоеточия <> 0 Тогда
                    ИмяФайлаОтветаКодированное = Лев(ИмяФайлаОтветаКодированное, ПозицияДвоеточия - 1);
                КонецЕсли;
            КонецЕсли;

            //в ключе filename= содержится обычное имя файла
            ПозицияИмениФайла = Найти(ТипСодержимого, "name=");
            Если ПозицияИмениФайла <> 0 Тогда
                ИмяФайлаОтвета = Сред(ТипСодержимого, ПозицияИмениФайла + СтрДлина("name="));
                ПозицияДвоеточия = Найти(ИмяФайлаОтвета, ";");
                Если ПозицияДвоеточия <> 0 Тогда
                    ИмяФайлаОтвета = Лев(ИмяФайлаОтвета, ПозицияДвоеточия - 1);
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

    ЗаголовкиHTTP = ОтветHTTP.Заголовки;
    //Добавляем в заголовки ответа код состояния (ответа) HTTP-сервера и имя файла содержимого, если есть.
    ЗаголовкиHTTP.Вставить("StatusCode", ОтветHTTP.КодСостояния);
    Если ЗначениеЗаполнено(ИмяФайлаОтвета) Тогда ЗаголовкиHTTP.Вставить("FileName", ИмяФайлаОтвета); КонецЕсли;
    Если ЗначениеЗаполнено(ИмяФайлаОтветаКодированное) Тогда
        ЗаголовкиHTTP.Вставить("EncodeFileName", ИмяФайлаОтветаКодированное);
    КонецЕсли;

    Если ОшибкаЗапроса ИЛИ НЕ ПолучитьКакДвоичныеДанные Тогда Возврат ОтветHTTP.ПолучитьТелоКакСтроку(); КонецЕсли;
    Возврат ОтветHTTP.ПолучитьТелоКакДвоичныеДанные();

КонецФункции // ПолучитьСодержимоеВебАдреса()
AdminЖурнал регистрации изменений во внешней информационной базе 1С (управляемые и обычные формы, демо-сервер)#265 11.05.17 9:52
(264) Нет. Подсистема работает только в режиме предприятия, через подписки на события и предназначена для отслеживания изменений объектов.
Выгрузка в dt - это работа в пакетном режиме по сути или в режиме конфигуратора.
УчетУправление ИТ отделом 8, редакция 3.0#195 05.05.17 12:42
(194) Да, думаем это включить в мобильное приложение.