Формирование Акта сверки взаиморасчетов

Обработки - Обработка документов

Пакетное формирование документов Акт сверки взаиморасчетов

Очень облегчает работу бухгалтера в конце отчетного периода. Обработка сделана в вариантах аналитики КОНТРАГЕНТ-ДОГОВОР (для типового акта сверки) И КОНТРАГЕНТ по всем договорам контрагента.
Для Аналилики КОНТРАГЕНТ я переделал документ Акт сверки взаиморасчетов. Если в документе не заполнено поле Договор, то формирование и печать ведется по всем договорам с анализом в табличной части - Начальное сальдо - Обороты(Дт,Кт) - Конечное сальдо. Процедуру ЗаполнитьСписокСчетовЗначениямиПоУмолчанию() перенес из модуля формы в модуль объекта, и объявил ее экспортной для вызова из внешней процедуры. Сама идея оформления не моя, но на 90% переделано.

Скачать файлы

Наименование Файл Версия Размер
ФормированиееАктовСверкиВзаиморасчетов.epf
.epf 16,43Kb
14.12.11
53
.epf 16,43Kb 53 Скачать

См. также

Комментарии
0. AER Рючин (AER) 38 14.12.11 19:12 Сейчас в теме
Пакетное формирование документов Акт сверки взаиморасчетов

Перейти к публикации

1. AER Рючин (AER) 38 14.12.11 19:12 Сейчас в теме
Принимаю вопросы по переделке типового дока Акт сверки взаиморасчетов.
2. Игорь Игорь (sdsmax) 25.01.12 18:47 Сейчас в теме
Ставлю плюс, хотелось бы пользоваться обработкой в Бухгалтерии Предприятия.
3. Dima (kubfest) 16.02.12 08:34 Сейчас в теме
+++, одназначно +, т.к. только дали такую же задачу, как сразу её нашел, спасибо)))
4. AER Рючин (AER) 38 16.02.12 08:52 Сейчас в теме
(3) kubfest, спасибо. Только плюса пока не вижу.
6. Эвелина (Эвелина) 01.07.13 09:10 Сейчас в теме
{Форма.Форма.Форма(36)}: Метод объекта не обнаружен (ЗаполнитьСписокСчетовЗначениямиПоУмолчанию)
ДокументОбъект.ЗаполнитьСписокСчетовЗначениямиПоУмолчанию();

Что это значит? как сделать чтобы работало в КА?
7. AER Рючин (AER) 38 01.07.13 09:43 Сейчас в теме
(6) Эвелина,
Акт сверки писался под УПП.
В Вашем случае программа не находит функцию ЗаполнитьСписокСчетовЗначениямиПоУмолчанию()
Может быть у Вас эта функция есть, но по-другому называется.
В компплексной должна быть такая функция.

Скачайте УПП и перенесите функцию в КА.
8. AER Рючин (AER) 38 01.07.13 09:58 Сейчас в теме
(6) Эвелина, Эту функцию ищите в документе АктСверкиВзаиморасчетов в "Комплексной Автоматизации".
9. Эвелина (Эвелина) 01.07.13 10:13 Сейчас в теме
(8) AER, к сожалению я не программист. я могу в конфигураторе только что нибудь совсем простенькое сделать..
спасибо за совет
10. AER Рючин (AER) 38 01.07.13 10:18 Сейчас в теме
Ничего сложного. В конфигураторе открываете этот документ и поиском по тексту ЗаполнитьСписокСчетовЗначениямиПоУмолчанию.
Или наверху кнопка Глобального поиска, там набираете ЗаполнитьСписокСчетовЗначениямиПоУмолчанию. Будет искать по всей конфе. К сожалению у меня нет сейчас КА...
11. Эвелина (Эвелина) 01.07.13 10:23 Сейчас в теме
(10) AER, я ее нашла, только что с ней дальше делать я ее коменты заделала, но все равно не работает
12. AER Рючин (AER) 38 01.07.13 10:29 Сейчас в теме
13. AER Рючин (AER) 38 01.07.13 10:30 Сейчас в теме
(11) Эвелина, Где Вы нашли функцию? И как она называется? Если в моей обработке, то это просто вызов функции. Сама функция должна быть в документе АкСверкиВзаиморасчетов.
14. Эвелина (Эвелина) 01.07.13 11:29 Сейчас в теме
Процедура ЗаполнитьПоДаннымБухгалтерскогоУчета(ФильтрСписокСчетов = неопределено) Экспорт

КоличествоСчетов = СписокСчетов.Количество();
Если ФильтрСписокСчетов = неопределено Тогда
ФильтрСписокСчетов = Новый массив();
Для каждого СтрокаСчета Из СписокСчетов Цикл
Если НЕ ЗначениеЗаполнено(СтрокаСчета.Счет) или СтрокаСчета.УчаствуетВРасчетах = Ложь Тогда
Продолжить;
Иначе
ФильтрСписокСчетов.Добавить(СтрокаСчета.Счет);
КонецЕсли;
КонецЦикла;

Если ФильтрСписокСчетов.Количество() = 0 Тогда
ОбщегоНазначения.СообщитьОбОшибке("Неверно задан список счетов, по которым производится сверка!",,,СтатусСообщения.Важное);
Возврат;
КонецЕсли;

КонецЕсли;

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДатаНачала", ?(НЕ ЗначениеЗаполнено(ДатаНачала), Неопределено, ДатаНачала));
Запрос.УстановитьПараметр("ДатаОкончания", ?(НЕ ЗначениеЗаполнено(ДатаОкончания), Неопределено, КонецДня(ДатаОкончания)));
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
и так далее.....


может эта процедура?
15. AER Рючин (AER) 38 01.07.13 11:50 Сейчас в теме
(14) Эвелина, Попробуйте в обработке закомментировать эту строку.(два правых слеша //)

//ДокументОбъект.ЗаполнитьСписокСчетовЗначениямиПоУмолчанию();
16. Эвелина (Эвелина) 01.07.13 11:54 Сейчас в теме
(15) AER, так делала- формирует, но при этом в списке счетов ничего не заполнено. Но уже лучше..спасибо за подсказки
Оставьте свое сообщение