gifts2017

Поиск русских букв в артикуле

Опубликовал Сергей Б (0rb) в раздел Администрирование - Поиск данных

Бывают ситуации, когда пользователи ленятся переключать раскладку и в артикул пишут "одинаковые" с латинскими буквы кириллицы. Найти такие случаи поможет этот отчет.

Номенклатурные позиции, в артикулах которых имеются буквы, не совпадающие с латинскими ("Ц", "Ю", "Ъ" и т.д.) - в выборку не попадают. Считается количество (различных) "неправильных" букв.

При необходимости можно легко доделать автозамену, запрос для этого править не придется.

Скачать файлы

Наименование Файл Версия Размер
Русские буквы в артикуле 23
.erf 6,38Kb
16.12.11
23
.erf 6,38Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. JER MARK (JER_MARK) 27.12.11 12:35
Частый случай - спасибо автору. Работа, основанная на артикулах иногда требует проверки.
2. Лёша Авто (Lesha1C) 03.01.12 14:44
Может кому пригодиться..

Проверка на запрещенные символы

Вызов проверки
ЗапрещенныеСимволы = Проверить(Отказ);
		 Если Отказ Тогда
			 Сообщить("Внимание! Существуют недопустимые символы:
			 |	" + ЗапрещенныеСимволы, СтатусСообщения.Важное);
		 КонецЕсли;
...Показать Скрыть



&НаСервере
 Функция Проверить(отказ)
	 ВремVIN = Объект.VIN;
	 Результат = "";
	 
	 Пока СтрДлина(ВремVIN)>0 Цикл
		 СимволVIN = Лев(ВремVIN, 1);
		 Если Найти(РазрешенныеСимволыVIN, СимволVIN)=0 Тогда
			 Если Найти(Результат, СимволVIN) = 0 Тогда
				 Результат = Результат + ?(Результат = "", "", ", ") + СимволVIN;
			 КонецЕсли;
			 Отказ = Истина;
		 КонецЕсли;
		 ВремVIN=Сред(ВремVIN,2);
	 КонецЦикла;

	 
	 возврат результат;	
 КонецФункции

 РазрешенныеСимволыVIN="0123456789abcdefghijklmnopqrstuvwxyzA­BCDEFGHIJKLMNOPQRSTUVWXYZ- ";

...Показать Скрыть