gifts2017

Доработка конфигурации Конвертация Данных (вер. 2.1.5.1)

Опубликовал г. Казань Рустем Гумеров (Rustig) в раздел Программирование - Инструментарий

Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1):
1) появляющиеся подсказки по обработчикам
2) аналог "Найти в списке"
3) историю переходов по объектам ПКО

Собственную адаптацию конфигурации Конвертация Данных я проводил на уже доработанной конфигурации, взятой из статьи Totoro http://infostart.ru/public/72813/. Поэтому мой cf-шник содержит разработки Tormozit и Totoro

Теперь отдельно о небольших моих доработках.

1) Добавил в конфигурацию измененную обработку "Информация об обработчиках_2", в которой изменил цветовое выделение слов в отличие от типовой. Изменил вызов обработки: теперь при открытии любого обработчика события появляется окно, информирующее о доступных параметрах обработчика.

Реализовано так: в процедурах "...АлгоритмыПриСменеСтраницы" прописал вызов обработки "Информация об обработчиках_2":

Процедура ПанельАлгоритмыПриСменеСтраницы(Элемент, ТекущаяСтраница)

   
ОбновитьПиктограммыАлгоритмов(мМассивОбработчиков, ЭлементыФормы.ПанельАлгоритмы, ЭлементыФормы);
   
//гумеров
   
ОткрытьОписаниеОбработчикаСобытия("ПравилаВыгрузкиДанных", ЭлементыФормы.ПанельАлгоритмы.ТекущаяСтраница.Имя, ЭтаФорма);

КонецПроцедуры
// ПанельАлгоритмыПриСменеСтраницы()

Процедура ОткрытьОписаниеОбработчикаСобытия имеет следующий код:

Процедура ОткрытьОписаниеОбработчикаСобытия(ИмяОбъекта, ИмяОбработчика, ФормаВладелец = Неопределено) Экспорт

   
ФормаПросмотра = Обработки.ИнформацияОбОбработчиках_2.ПолучитьФорму("Форма",ФормаВладелец);
   
//Если ФормаПросмотра.Открыта() Тогда
    //    ФормаПросмотра.Закрыть();
    //КонецЕсли;
   
ФормаПросмотра.РазделДляОткрытия = ИмяОбъекта + ИмяОбработчика;
   
ФормаПросмотра.Открыть();

КонецПроцедуры
// ОткрытьОписаниеОбработчиковСобытий()

2) Добавил в конфигурацию аналог "Найти объект в списке" - когда из любого окна обработчика события можно перейти в окно правил обмена,например, на соответствующий объект ПКО.

Реализовано по кнопке "Конвертация":

Процедура КоманднаяПанель1Действие4(Кнопка)

   
ОбщаяФорма = ПолучитьОбщуюФорму("ПравилаОбмена");
   
ОбщаяФорма.Конвертация = ЭтотОбъект.Владелец;
   
ОбщаяФорма.Открыть();

   
ОбщаяФорма.ЭлементыФормы.ПанельВерхняя.ТекущаяСтраница = ОбщаяФорма.ЭлементыФормы.ПанельВерхняя.Страницы.ПВД;
   
ОбщаяФорма.ЭлементыФормы.ПравилаВыгрузкиДанных.ТекущаяСтрока = Ссылка;

КонецПроцедуры

3) Добавил историю переходов по объектам ПКО - теперь не приходится искать объекты ПКО перелистыванием строк списка ПКО, достаточно выбрать объект ПКО в окне истории.

//ведение истории
Процедура ПравилаКонвертацииОбъектовПриАктивизацииСтроки(Элемент)

    Если
Элемент.ТекущиеДанные = Неопределено Тогда
        Возврат;
    КонецЕсли;

   
// гумеров начало блока
   
Если НЕ Элемент.ТекущиеДанные.Ссылка.ЭтоГруппа И История.Найти(Элемент.ТекущиеДанные.Ссылка, "СсылкаПКО") = Неопределено Тогда
       
История.Добавить().СсылкаПКО = Элемент.ТекущиеДанные.Ссылка;
    КонецЕсли;

   
// гумеров конец блока

   
...

КонецПроцедуры

//позиционирование на нужном ПКО
Процедура ИсторияПриАктивизацииСтроки(Элемент)
   
ЭлементыФормы.ПравилаКонвертацииОбъектов.ТекущаяСтрока = ЭлементыФормы.История.ТекущиеДанные.СсылкаПКО;
КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
Информация об обработчиках_2.epf 95
.epf 220,39Kb
24.12.11
95
.epf 220,39Kb Скачать
cf-шник для адаптации 76
.cf 8,00Mb
24.12.11
76
.cf 8,00Mb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
0. г. Казань Рустем Гумеров (Rustig) 24.12.11 21:35
Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1):
1) появляющиеся подсказки по обработчикам
2) аналог "Найти в списке"
3) историю переходов по объектам ПКО


Перейти к публикации

1. Сергей Ожерельев (Поручик) 24.12.11 21:35
(0) Вещь полезная. Для релиза КД 2.1.5.1 пойдёт?
2. г. Казань Рустем Гумеров (Rustig) 24.12.11 21:38
(1) у меня как раз релиз 2.1.5.1.
3. Олег Иванов (ogeniv) 25.12.11 11:07
Интересная штука, подсказки и переход по объектам будут полезны
4. A (Kochevnic) 25.12.11 18:54
Спасибо! Попробуем на практике
5. Fomix (fomix) 26.12.11 11:44
(2) Rustig, Что-то я не понял для чего эта штука в КД?! Может поподробнее опишете... Заранее спасибо!
6. г. Казань Рустем Гумеров (Rustig) 26.12.11 13:14
(5) Если вы работаете с КД вплотную, тогда вы сможете оценить полезность этих доработок: ускоряется навигация по объектам КД. А если соответственно не работаете вплотную, например, через раз или вообще чаще используете типовые сценарии обмена, тогда возможно не стоит тратить время на доработку КД.
7. Модератор раздела Артур Аюханов (artbear) 23.01.12 17:45
Хорошие доработки.
Пожалуйста, добавь в название и в описание инфу о конкретной версии КД, для которой подходит публикация.
2.1.5.1
8. Александр (Мощный) 23.01.12 21:22
Даж заманчиво, попробовать что ле ?
9. WendyH (WendyH) 28.01.12 08:30
Тогда, желательно, в описании перечислить ВСЕ отличия от типовой. Измменения tormizit и Ваши.
10. Владимир Клименко (KliMich) 05.02.12 20:30
(6)
Если вы работаете с КД вплотную, тогда вы сможете оценить полезность этих доработок: ускоряется навигация по объектам КД
Прямо в точку! Респект! Очень нужная доработка.

P.S. Как дополнение (может кому пригодиться), для КД типа 77 -> 82 использую
"Запись текста модуля ерт-файла из текстового файла" http://infostart.ru/public/78941/ от Абадонна (за что ему огромный респект)
11. Александр (Мощный) 10.02.12 10:27
Есть ли какая нибудь возможность настройки для выскакивающих при переходе на обработчики по свойствам описаний.. Наверное, иногла это и бывают удобным, но когда попрыгаешь по свойствам десятки, сотни раз, то тут вот количество клацеы увеличивается в два раза.. Зайти в свойства-выйти из описания.. Не предусмотрена ли у вас где-нибудь настройка для включения и отключения..
Конечно и сам могу отцепить, но м.быть есть настройка..
12. Александр (Мощный) 12.02.12 13:31
И как же достучаться до автора
13. г. Казань Рустем Гумеров (Rustig) 13.02.12 11:11
(11), (12) добрый день, Мощный! видел все ваши сообщения, спасибо за обратную связь.
По поводу доработок, увы, на них нет времени. Все в ваших руках. Я даже в последнее время занимаюсь всеми задачами кроме связанных с КД. Поэтому специально переключаться на КД, доработку КД, новое выкладывание на ИС - нет планов. А вообще, разве нельзя через правую кнопку закрыть все соединяемые окна единоразово? Аналогичная ситуация с окнами возникает, когда вы открываете расшифровки в рег.отчетах в конфигурации по бухгалтерии. И в этих конфах нет настройки, которую вы просите. Так что, может "оно и не надо".
14. Галина Галина (a4a) 13.02.12 11:50
Пытаюсь работать с конфигурацией "Конвертация данных", очень востребован ее функционал. Но не могу похвастать, что удается так сразу в ней разобраться как следует, а очень хочется. Поэтому очень приветствую разработку, усиливающую ее возможности. Спасибо!
15. Александр (Мощный) 13.02.12 19:30
(13) Rustig, Ок, траблы Ваши понятны, буду сам..
касаемо "нужно или не нужно" отвечу однозначно "нужно".. Переходы по свойствам даже за день в обьеме достигают нескольких сотен.. Можно конечно, сбрасывать через ESC, но предел терпения достигается слишком быстро.. увы..
16. Alex Koso (AlexKoso) 27.02.12 09:42
Сначала накатил изменения, поюзал...и понял что ни к чему мне автоматически выскакивающее окно со справкой. В итоге в типовую обработку Информация об обработчика вставил макеты Рустема, а вызов справки сделал по Ctrl + F1. На том и спасибо :)
17. Максим Евсенкин (tehas) 10.03.12 21:19
Ща гляну, кстати ни кто не посоветует учебник с примерами по КД 2.1 желательно в электронном виде, а если у кого есть буду благодарен
18. Максим Евсенкин (tehas) 08.08.12 11:16
удобно, ни чего не скажешь )
19. Алекс Ю (AlexO) 19.03.13 16:10
(17) tehas,
кстати ни кто не посоветует учебник с примерами по КД 2.1

По КД нет учебников.
Есть куцая книжка Бояркина и немного инфы в инете.
Ну и да, различные веселые супер-пупер курсы.