bdd2

С наступающим Новым Годом (Елочка, зажгись)

Опубликовал dmsoft (dmsoft) в раздел Сообщество - Поздравления

Подборка новогодних анимированных елочек на рабочий стол (26)

В архиве 26 елочек. Кидаем в сетевую папку , расшариваем.

2 константы (активность сервиса и путь к папке) 

В процедуру ПриНачалеРаботыСистемы() прописываем процедуру  ЕлочкаЗажгись()

Процедура ЕлочкаЗажгись() Экспорт
Если Константы.ЕлочкаЗажгись.Получить() = Истина Тогда
ПутьКПапке = Константы.ЕлочкаПуть.Получить();

МассивНайденных = НайтиФайлы(ПутьКПапке, "*.exe"); 

МассивНайденных.Количество();

ГСЧ = Новый ГенераторСлучайныхЧисел();

Если МассивНайденных.Количество() <> 0 Тогда
СлучЧисло = ГСЧ.СлучайноеЧисло(0 , МассивНайденных.Количество()-1);
ПутьКЕлочке = МассивНайденных.Получить(СлучЧисло).ПолноеИмя;

 ЗапуститьПриложение(ПутьКЕлочке);
КонецЕсли;
КонецЕсли;
КонецПроцедуры 

 

P.S. Внимание, ехе очень любят прописываться в автозагрузку.  

Скачать файлы

Наименование Файл Версия Размер
ChristmasTrees.rar
.rar 7,57Mb
26.12.11
42
.rar 7,57Mb 42 Скачать

См. также

Добавить вознаграждение
Комментарии
0. dmsoft (dmsoft) 102 01.01.70 03:00 Сейчас в теме
Подборка новогодних анимированных елочек на рабочий стол (26)

Перейти к публикации

1. Igоr Sаulеviсh (gutentag) 249 27.12.11 02:00 Сейчас в теме
Спасибо. а как в бух-2.0 дописать новые константы идописать процедуру ПриНачалеРаботыСистемы() , не снимая конфу с поддержки 1С ?

Спасибо за ответ :)
2. Angry (Angry) 11 28.12.11 08:32 Сейчас в теме
Нужно включить возможность изменения.
Это с поддержки не снимет, но автоматического обновления не будет.
3. Наталья Литвин (НатальяАлекс) 28.12.11 12:49 Сейчас в теме
Идея не нова. Зачем 26 елочек?
4. Наталья Литвин (НатальяАлекс) 28.12.11 12:51 Сейчас в теме
И снимать с поддержки ради елочки не улыбается.
5. Oleg Inkeri (accnt) 28.12.11 14:58 Сейчас в теме
6. иван новиков (icich) 28.12.11 16:03 Сейчас в теме
здорово, что там именно 26 елочек . Праздника очень хочется! А настроения нет...
7. Pavellons (lonsby) 30.12.11 12:40 Сейчас в теме
Для терминалки добавил код при завершении 1с, чтобы убирался процесс

Процедура ПриЗавершенииРаботыСистемы()
	КомандаСистемы("TASKKILL /F /FI ""USERNAME eq " + ИмяПользователя());
	//КомандаСистемы("TASKKILL /F /FI ""USERNAME eq " + ИмяПользователя() + """ /IM "+ ИмяПроцесса);	
КонецПроцедуры