gifts2017

Обрезание изменений данных в планах обмена 8.2 (управляемая форма)

Опубликовал Golovkin Andrey (saub) в раздел Администрирование - Распределенная БД (УРИБ, УРБД)

Задача - удалить из системы все регистрации изменений документов до определенной даты (изменений данных в планах обмена 8.2)

Писалось для клиента: пользователи часто лазят в предыдущие периоды и при обмене УТ -> БП в бухгалтерии слетают движения. По хорошему конечно регулировать надо это датой запрета изменения данных - но если случилось так уже случилось.
Задача - удалить из системы все регистрации изменений документов до определенной даты
Реализация - обработка перебирает все узлы, всех планов счетов и перебирая изменения анализирует дату (сравнение на Если Изменения.Дата // очищаем изменения
КонецЕсли;

код полностью открытый - пользуйтесь

з.ы. При очистке или оставлении изменений обработка комментирует все что делает через сообщения.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Очистка изменений в планах обмена до определенной даты
.epf 6,00Kb
06.02.13
41
.epf 6,00Kb 41 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 03.02.12 20:03
В качестве очень простой обработки для обычного бухгалтера сгодится, хотя данную задачу можно решить с помощью некоторых обработок, вываленных на сайте.
2. Golovkin Andrey (saub) 06.02.12 09:12
так и задумывалось, что просто для бухгалтера - или начинающим программерам как пример
3. Ламия 01.05.12 11:34
Это каждый раз перед обменом придется данную обработку запускать, я верно поняла?
4. Вячеслав Яштаев (xslava2008) 18.07.13 21:38
Здравствуйте! Я не совсем понял что делает данная обработка. Если я правильно понял то после обмена в ЦБ через какое то время при обнаружении ошибок можно как бы "ОТКАТИТЬ"? А в ПБ что? там то изменения остануться. В таком случае им снова делать образ?
5. Shrek Shrek (Shrek2015) 18.07.13 22:55
а зачем надо обнулять регистрацию изменений то?
6. Осипов Сергей (fixin) 28.12.15 10:28
Доделал обработку и под обычные формы, т.к. понадобилось экстренно почистить в УТ 10.3, где было запущено восстановление последовательности и доки зарегистрировались в бухию.

Странно, файл не прикрепляется. https://yadi.sk/d/kKo-Wh58mXwoG

У обработки есть недостаток - документ это или нет определяет по наличию поля "Дата", т.е. очищает договора, например.
Я это поправил:


Процедура ПроизвестиОчистку(ДоДаты)
	Для каждого ПлО из ПланыОбмена цикл
		Выборка=ПлО.Выбрать();
		
		Пока Выборка.Следующий() цикл                                     
			
			УзелИнформационнойБазы=Выборка.Ссылка;
			Если УзелИнформационнойБазы.НомерОтправленного=0 тогда
				Продолжить;
			КонецЕсли;
			ВыборкаДанных = ПланыОбмена.ВыбратьИзменения(УзелИнформационнойБазы,УзелИнформационнойБазы.НомерОтправленного+1);
			Пока ВыборкаДанных.Следующий() Цикл
				СсылкаДок = ВыборкаДанных.Получить();
				МД = Метаданные.НайтиПоТипу(ТипЗнч(СсылкаДок));
				Если МД = Неопределено ИЛИ НЕ  Метаданные.Документы.Содержит(МД) Тогда
					Продолжить;
				КонецЕсли;
				ДатаДок=СсылкаДок.Дата;
				Если ДатаДок<=ДоДаты тогда
					ПланыОбмена.УдалитьРегистрациюИзменений(УзелИнформационнойБазы,СсылкаДок.Ссылка);
					Сообщить("Очистили изменения "+СсылкаДок.Ссылка);
				Иначе
					Сообщить("Оставляем "+СсылкаДок.Ссылка);
				КонецЕсли;
				ОбработкаПрерыванияПользователя();
			КонецЦикла;		
		КонецЦикла;
	КонецЦикла;
КонецПроцедуры

...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа