gifts2017

Экспорт налоговых накладных в XML (Украина). Импорт даты внесения в реестр ДПА из системы документооборота М.E.Doc

Опубликовал Serg (Sykoku) в раздел Обработки - Обработка документов

Обработка (для 1С 7.7. АБТ 3.5.5 и выше)  позволяет сделать экспорт проведенных налоговых накладных указанной Организации за выбранный период по указанному пути с последующим импортом в OPZ или М.E.Doc.
Также выполняется импорт результатов внесения в реестр ДПА (даты занесения в реестр) из М.E.Doc в 1С.

Данная обработка позволяет экспортировать Ваши налоговые накладные за указанный период и сохраняет по пути, встроенному в отчет, в формате XML OPZ или BEST(последний неупакован и до конца не изучен - поля кирпичного цвета - пользоваться им рекомендуется осторожно)  в файлах, имена которых выглядят следующим образом:

[номер из цифр, начиная с  с 5-й  - впереди, обычно, идет разделитель учета и тире]_[месяц]_[год].xml

Путь для сохранения "спрятан". чтобы рядовой бух не сохранял где попало. Другие параметры настройки экспорта минимальны, но необходимы -
- диапазон дат, за который будет проводиться экспорт;
- предельная сумма НДС неподакцизных товаров, которые не обязательно включать в реестр;
- флажок, отвечающий за выгрузку НН неплательщиков НДС;
- флажок, отвечающий за повторную выгрузку уже выгруженных ранее документов;
- флажок, отвечающий за повторное вычисление признака подакцизного товара;
- фирма, по которой собственно и будет проводится выгрузка документов;
- формат вывода - OPZ или BEST.

Перед экспортом Вы можете создать список НН для просмотра на экране и ручного снятия/установки флажка - признака выгрузки.


Особенности экспорта

При смене "Даты С" автоматически идет присвоение такого же значения "Дате По" - обычно, экспортируют за 1 день. При открытии программы "Дате С" автоматически назначается предыдущий день.


Экспортирование

В ходе экспора получаете сообщения в окне уведомлений о номерах и общем количестве выгруженных документов.


Импортирование в М.E.Doc

Открываете М.E.Doc, переходите в раздел "Главное меню" -> "Податкові накладні". Выбираете необходимый период отчетности - месяц, год.
Далее - "Файл" -> "Импорт XML"-> открываете вашу папку с только что экспортированными накладными и выделяете все необходимые. Если не знаете, какие именно Вам нужны - отсортируйте список файлов по дата создания и выберите те, которые только что создались - они должны быть самыми первыми.  В системе OPZ Вам придется импортировать их по одной. Или изменить процедуру присвоения имени файла,  присвоив ему имя в стандарте ДПА, и путь. заменим его на папку "OPZ / XML". Затем выполнить через пункт меню команду "Синхронизация".
Обе программы задумаются на какое-то время. Список импортированных/сбойных НН в МеДОС Вам покажут в виде всплывающего экранного сообщения, а в OPZ Вы самостоятельно должны будете отследить их количество по пунктам в меню открываемых документов.

В М.E.Doc все импортированные НН хранятся в одноименной папке, отображающей их статус. После того, как Вы их проверите, подпишете (скопом получится только в случае занесенных Контрагентов во внутреннюю базу М.E.Doc) и отправите в ДПА, можете отдохнуть до получения ответных сообщений. Описывать процедуры проверки/исправления ошибок  я не вижу смысла.

Импортирование принятых НН из М.E.Doc

Открываете М.E.Doc и  переходите к НН в папке  "Зарєестровані". Выбираете пукнт меню "Файл" -> "Експортувати в DBF дату реєстрації  в ЄРПН". Выбираете папку и интервал экспорта и получаете там файл примерно такого имени     "OUTNAKLKVT.dbf"

Зайдя в программу 1С вы открываете отчет и перейдя на вкладку "Загрузка" выбираете это файл как параметр импорта. При импорте, в случае его успешного окончания, в поле НН, отведенное для хранения даты внесения в ЄРПН, будет загружена дата внесения в реестр.


Настройки

Для корректной работы необходим справочник "НалоговыеИнспекции". Если его у Вас нет  -  занесите ее код вручную в соответствующее поле. Также проверьте правильность имен полей - признаков выгрузки и поля для загрузи даты регистрации в ДПА.


Особенности

Замечено, что М.E.Doc не позволяет скопом подписать импортированные накладные, если клиентов нет в его справочнике. БЭСТ

Формат XML-отчета MeDoc'а отличается от стандарта (OPZ) наличием 6-ти "лишних" полей.

Необходимости в изменении имен СправочниковФирмы, Клиентов и Документа.НалоговаяНакладная на полный перечень с возможностью выбора я не вижу  смысла - это не универсальная обработка для любого документа и любой конфигурации.


Планы       

Расшифровать окончательно формат БЭСТА и найти способ упаковки отчета в формат Packed_XML.
Убрать ошибку 1С с программным сбоем переключения закладки.
 
 
 P.S.

Утилита распаковки Packed_XML найдена. Путь - opz.org.ua/forum/viewtopic.php?f=1&t=933#p6428. А вот упаковки пока нет...


 

17/01/2012

Добавлена отдельная утилита импорта даты внесения в реестр из М.E.Doc

С ее помощью Вы можете внести из М.E.Doc в Реквизит типа "Дата" НалоговойНакладнуой  1С (АБТ 3.5.5 и выше) дату внесения в реестр ДПА.

 

Как пользоваться

Открываете М.E.Doc и  переходите к НН в папке  "Зарєестровані". Выбираете пукнт меню "Файл" -> "Експортувати в DBF дату реєстрації  в ЄРПН". Выбираете папку и интервал экспорта и получаете там файл примерно такого имени    

                         "OUTNAKLKVT.dbf"

Зайдя в программу 1С вы открываете отчет, выбираете этот файл как параметр импорта.
При импорте, в случае его успешного окончания, в поле НН, отведенное для хранения даты внесения в ЄРПН, будет загружена дата внесения в реестр.


Настройки

Правильно укажите диапазон знаков, по  которым будет сверяться номер НН.
Не используйте длинные имена файлов.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
EPRN.ert (+БЕСТ)
.ert 250,00Kb
17.01.12
50
.ert 250,00Kb 50 Скачать
Packed XML Extractor
.exe 11,00Kb
17.01.12
20
.exe 11,00Kb 20 Скачать
Импорт_даты_ЄРПН
.ert 33,50Kb
17.01.12
9
.ert 33,50Kb 9 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Литовченко (kompas-dm) 07.01.12 12:11
(0) Все-таки нужно усложнить:
1.Сначала заполнить таблицу на форме, пусть посмотрят и пометят документы для выгрузки.
2.Дать переменные для дозаполнения : свои коды по организации, налоговой инсп. и т.д.
И будет в шоколаде. Нужная Обработка, "+"
seidametov-a; +1 Ответить 4
2. Serg (Sykoku) 07.01.12 21:56
(1) kompas-dm,
Не вопрос, сделаю - оглашайте весь список. Моей "конфе" больше 10-ти лет. За это время она раза в три "толще" стала. У других - аналогично, я думаю.
3. Serg (Sykoku) 07.01.12 21:56
Сделал в черновом виде выброс в БЭСТ-формате - не все поля пока ясно, как заполнять. Скажу откровенно - ИнтеллектСервисовцы структуру создавали явно на скорую руку ...
4. Александр Гнитка (smitti911) 10.01.12 12:05
5. Serg (Sykoku) 10.01.12 12:44
(4) smitti911,

Уточняем.
1. Релизы 1С разные
2. Ваш требует дополнительных "телодвижений" - проверки наличия шаблона, ВК, настройки.
3. Нумерация НН, согласно описания к обработке, может не совпасть с номером документа.
4. Если это экспорт только НН, зачем там с полсотни шаблонов OPZ, которые отношения к НН не имеют никакого, тем более, если они не актуальны...
5. Ну и, наконец, просто выдает с десяток ошибок при работе.
6. Serg (Sykoku) 10.01.12 14:45
Дополнения.

1. В талице XML
<HORIG1>[?(Число(КлиентНалогНомер)<>0," ","1")]</HORIG1>
<HTYPR>[?(Число(КлиентНалогНомер)<>0," ","02")]</HTYPR>


2. Во вложении - для БУ Украины, проверено на 7.70.259

P.S.
Форму БЭСТ для БУУ не переделывал - по заявкам.
Прикрепленные файлы:
EPRN.ert
7. Ruslan (rus128) 11.01.12 11:30
Хорошая идея.
Жаль, что БУ Украины 7.70.259 уже не актуально.
8. Serg (Sykoku) 11.01.12 12:46
Маленькое дополнение - проверка необходимости включать НН в реестр. Признак проверки - наличие кода ТНВЕД в Товаре.

Для хранения в системе 1С рекомендуется дополнить Реквизиты НН переменной ЄПРН.
(Для обновленных конфигураций БУУ это поле ТребуетВклВЕдРеестрНН)
Также рекомендуется хранить признак выгруженности (для БУУ это Реквизит ЕРНН).

Процедура Проверка_ЄРПН()

ЄРПН=0;

ВыбратьСтроки();

Пока ( ПолучитьСтроку() > 0 ) Цикл
Если ТМЦ.ТВЕД<>0 Тогда
ЄРПН=1;
Прервать;
КонецЕсли;
КонецЦикла;

КонецПроцедуры
9. Serg (Sykoku) 11.01.12 14:00
(7) rus128,

Верю.

С учетом того, какие сейчас "сопровожденцы", лучше я сам корпеть буду.
Предновогодний пример. Киевский филиал "БИТа". 02/11/2011 заключен договор на перенос справочников и остатков до 6-го класса включительно за 14 рабочих дней. В декабре уже все все поняли и потребовали денег взад. До сих 2,500$ не вернули...
10. Алексей Плутенко (Noy) 12.01.12 11:07
(6) На всякий случай уточню:
Если Число(КлиентНалогНомер)=0 то такие налоговые вообще не надо регистрировать
11. Serg (Sykoku) 12.01.12 11:28
(10) Noy,
В законе сказано ВСЕ, в которых есть импортный товар. То, что клиент не обратится за возмещением НДС не означает, что я ее не обязан регистрировать. Лучше "перебдеть".
А вот что достойно воспевания потомками, так это список ответов налоговой, представившей форму заполнения с кодами ТНВЕД, разделенными по классам (пробелы), но указавшей в комментарии, что заполнение должно быть без пробелов.
Кстати, вчера один бух был жутко перепуган, когда после 19-00 в МЕДОС вернулась квитанция с требованием до полуночи срочно зарегистрировать коригування по 2-м накладным. И еще с десяток пришли с милым сообщением что "Продавець не є платником ПДВ станом на 05.01.2012". Оказалось, что это просто их сервер был слегка перегружен...
12. Алексей Плутенко (Noy) 12.01.12 12:41
(11) Вы не правы, в законе четко описаны критерии. И будет правильно их учитывать при написании ПО.
13. Serg (Sykoku) 12.01.12 15:49
(12) Noy,

1. Вот разъяснение ДПА (взято с их сайта)

Про обов’язкову реєстрацію в ЄРПН податкових накладних

ДО УВАГИ ПЛАТНИКІВ ПОДАТКІВ!

З 1 січня 2012 року згідно з вимогами Податкового кодексу України обов’язковій реєстрації в ЄРПН підлягають податкові накладні із сумою ПДВ понад 10 тис. грн. в одній накладній, а також податкові накладні, виписані при здійсненні операцій з постачання підакцизних товарів та товарів, ввезених на митну територію України, незалежно від розміру ПДВ в одній податковій накладній.
Звертаємо увагу: що факт виписування податкових накладних без реєстрації їх у Єдиному реєстрі податкових накладних позбавляє покупця права формування податкового кредиту.

2. А теперь задача на одно неизвестное.
Порядок НН должен быть сквозной за месяц. И выписываться они должны неплательщикам также. Просто не отдаются в руки. Ну и как соблюсти сквозную нумерацию при регистрации НН в ЄЦРПН, если их не все туда отправлять? Другой номер присваивать? - До первой проверки. Не все регистрировать - пропуски делать - нарушение способа ведения отчетности. Как по мне - второе дешевле. предложите ваш вариант решения - без обязательных штрафов. С удовольствием применю.

А на Закон ссылаться не надо - вон Фокса задним числом НДС-а лишили, а они об этом узнали через 2 недели -законно?
Прикрепленные файлы:
ERPN.ert
14. Yaroslav (maddy) 12.01.12 18:59
Я наверно чего-то пропустил. Где озвученно требование о непрерывности нумерации в ЕРПН? Раньше было "в реестрах выданных/полученных"? Хотя непрерывность нумерации в реестр полученных это отдельный хит.
15. Алексей Плутенко (Noy) 12.01.12 19:22
(14) да нет такого требования. Просто в схеме файла есть такой реквизит как номер документа в периоде, который только сбивает с толку людей. В частночти в ОПЗ эти номера присваиваются по порядку (в пределах отчетного периода) для каждого вида документа по мере их ввода.

Теоретически можно при отправке формировать номер для каждой отправляемой накладной. Лично я просто номер налоговой в это поле вбиваю. Никакого контроля нумерации со стороны ДПА нет.
16. Serg (Sykoku) 12.01.12 20:33
(14) maddy,
Не помню, где. Найду - скажу.
Пока могу только сказать, что есть коллизия в п.п.3 и 4 Порядка ведення Єдиного реєстру податкових накладних
(КМУ №1246):
п.3
регистрировать необходимо ВСЕ корректировки. Если НН не была зарегистрирована, ее регистрируют независимо от того, когда она была создана (я так понимаю, и независимо от того на кого - плательщика или нет).
п.4.
Регистрации не подлежит то, что не выдается.

Ну и что делать - если командир не прав, смотрим п.№1?


(15) Noy,
Если номер документа совпадет с уже отправленным - в пределах отчетного периода - старая информация заменится новой.
17. Dmitry (teleport7) 13.01.12 04:40
Очень выручила обработка. +
Пришлось прикрутить ее сильно модифицированную на АБТ 3.6.5
Все получилось!

В процессе внес несколько косметических изменений в оригинальную обработку:

1) В XML файле в числах сохраняются группы разрядов для больших сумм. Может вызвать неоднозначную реакцию проверяющего ПО. Можно, например, формат чисел “#N017.2.,” заменить на “#N017.2.”

2) Если в НН предусмотрено отдельно поле код УТК ВЭД товара, вероятно, лучше брать из табличной части НН, а не из справочника ТМЦ.
Пока ( ТекДок.ПолучитьСтроку() > 0 ) Цикл
УКТВЭД = СтрЗаменить(ТекДок.ПолучитьАтрибут("КодУКТВЭД"), " ", "");
......
3) При выгрузке не убираются дефисы и пр. в телефоне контрагента, хотя это предусмотрено обработкой.
18. Serg (Sykoku) 13.01.12 15:35
(17) teleport7,
Рад, что Вам пригодилось.

XML формат плохо относится к символам, типа &.

1C 7.7.27 не всегда адекватно форматирует большие числа. Неоднократно получал значения типа "9,999.99", когда что-то не складывалось у нее в голове - например, если заменить в строке формата "N" на "Ч".

Если Вам необходимо использовать откорректированный номер, то Ваша переменная "Клиент_Телефоны", а не реквизит из справочника. Просто у меня давным давно разнесены код города, телефон. индекс. улица и т.д. - примерно, как сейчас в 8-ке додумались.

Ну а свой номер телефона подкорректировать уже и самому можно...




Мало ли, вдруг пригодится - я при выгрузке Реестра НН использую

Функция Акронимы(Имя)

Имя = СтрЗаменить(Имя,"Приватне підприємство","ПП");
Имя = СтрЗаменить(Имя,"Товариство з обмеженою відповідальністю","ТзОВ");
Имя = СтрЗаменить(Имя,"науково-виробниче підприємство","НВП");
Имя = СтрЗаменить(Имя,"Суб'єкт підприємницької діяльності","СПД");
Имя = СтрЗаменить(Имя,"Науково-Виробничий комплекс","НВК");
Имя = СтрЗаменить(Имя,"Рекламне Агентство","РА");
Имя = СтрЗаменить(Имя,"Фізична особа-підприємець","ФО-П");
Имя = СтрЗаменить(Имя,"&","&");
Имя = СтрЗаменить(Имя,"Акціонерне товариство","АТ;");
Возврат(Имя);

КонецФункции

// ===============================
19. Dmitry (teleport7) 13.01.12 16:10
(18) Sykoku,
С телефонами разобрался. Спасибо. Больше переживал за числа "9,999.99" - у вас они нормально до этого выгружались? (У меня 1C 7.7.27, Win 2003 rus)
Просто незнакомая конфигурация, да еще завалы с этой отчетностью.
С 1С знакомлюсь только по необходимости. Поддерживаю сейчас экспорт из базы SQL в УТП 8.2

P.S. Все таки придется на выходных предусмотреть какую-ту простейшую схему учета зарегистрированных накладных.
Видел что в последней версии обработки это предусмотрено, но не разбирался еще как работает.
20. Serg (Sykoku) 13.01.12 17:57
(19) teleport7,

Если формат изначально работает правильно, потом сбои будут только при глобальных (виндосовских) проблемах - типа "Ошибка чтения по адресу", "Недостаточно памяти" и т.д. Хотя были случаи, если память дешевая - типа ГудРам - когда в 1С пущает, но дальше при попытке открыть БОЛЬШОЙ справочник или провести документ получаешь вылет.

Насчет учета в документах признаков необходимости выгрузки - комментарий №8 - проверка наличия кодов + проверку на сумму можете в конце добавить -

Если Итог("НДС")>10000 Тогда
ЄРПН=1;
КонецЕсли;

В Конфигурации в Реквизитах документа НН добавьте 2 числовых поля длиной 1 разряд , например ЄПРН - признак выгружаемости и Звіт - было ли экспортирование. И в документе на процедуры "Печать" и "ПриЗаписи" включаете проверку/расчет поля ЄПРН.

А в обработке выгрузки заполняете поле Звіт. Как это сделать - скачайте версию отчета из комментария №13 - строки "Документ.Записать" и чуть выше.

P.S.
Можно обойтись и одной переменной - только тогда запомнить, что в ней должно быть
Например
0 - Не установлено
1 - Меньше 10 000
2 - есть подакцизные товары
3 - не плательщик НДС

И с состоянием выгрузки (+4 к начальному значению)

4 - выгружали, но непонятно зачем
5 - выгружали, но меньше 10 000
6 - выгружали и так надо
7 - выгружали, хоть и неплательщик


На самой рабочей форме документа где-то поставьте пару нередактируемых Флажков с присвоением им значений в процедуре "ПриОткрытии" - если для 2-х переменных -

Флаг_Звіт =Звіт;
Флаг_ЄРПН=ЄРПН;

Если для одной

Если ЄРПН=2 Тогда
Флаг_ЄРПН =1;
КонецЕсли;

Если ЄРПН>3 Тогда
Флаг_Звіт =1;
КонецЕсли;
21. Dmitry (teleport7) 13.01.12 20:08
(20) Sykoku,
По поводу флага ЄРПН, то его заполнение я ранее взял с Бухгалтерии для Украины:
Процедура ПроверкаТребуетВклВЕдРеестрНН()
	// поставим флаг "Требует регистрация в реестре"
	Если Оставляем = 1 Тогда
		// мы не управляем флажком ТребуетВключенияВЕдиныйРеестрНалоговыхНакладных
		// для налоговых накладных, которые не выдаются покупателю
		// согласно разъяснению ЕБНЗ такие налоговые не должны регистрироваться в Едином реестре
	Иначе	
		ТребуетВклВЕдРеестрНН = 0;
		Если Валюта = Гривня Тогда
			НДСРегл = Итог("НДС");
		//Иначе
		//	НДСРегл = глПересчет(Итог("НДС"),Валюта,Гривня,Курс,ДатаДок);
		КонецЕсли;
		Если ДатаДок >= '01.01.12' Тогда
			// или сумма НДС в документе больше 10 000 грн
			Если НДСРегл > 10000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
				
			// или имеются подакцизные/импортированные товары
			// этот факт определим так - если в строке указан код УКТЗЭД - считаем что условие выполняется.
			Иначе   
				ВыбратьСтроки();
				Пока ПолучитьСтроку() = 1 Цикл
					Если ПустоеЗначение(КодУКТВЭД) = 0 Тогда
						ТребуетВклВЕдРеестрНН = 1;
						Прервать;
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
		ИначеЕсли ДатаДок >= '01.07.11' Тогда
			// сумма НДС в документе больше 100 000 грн
			Если НДСРегл > 100000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
			КонецЕсли;
		ИначеЕсли ДатаДок >= '01.04.11' Тогда
			// сумма НДС в документе больше 500 000 грн
			Если НДСРегл > 500000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
			КонецЕсли;
		ИначеЕсли ДатаДок >= '01.01.11' Тогда
			// сумма НДС в документе больше 1 000 000 грн
			Если НДСРегл > 1000000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
			КонецЕсли;
		КонецЕсли;
		Если (ТребуетВклВЕдРеестрНН = 1) И (ЕРНН = 0) Тогда
			Сообщить("Требуется включение документа Налоговая накладная № "+ СокрЛП(НомерДок)+" от "+ ДатаДок  + " в единый реестр налоговых накладных!", "!"); 
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры 
...Показать Скрыть

Немаленький, но вполне приятный код.
А за варианты со статусов - спасибо. Еще думаю нужно добавить статус "Успешно зарегистрировано ЕРПН". Только ради него и думал делать контроль.
22. Serg (Sykoku) 13.01.12 20:25
(21) teleport7,
Тогда уже не флажок, а поле типа "Дата" - Дата регистрации в ДПА.
МеДОС позволяет выбросить любой реестр за период (в том числе и НН - зарегистрированных, например) в файл формата DBF. Его структура достаточно и процедура чтения из-под 1С будет несложной. Надо - сделаю и выложу.
23. Dmitry (teleport7) 13.01.12 23:21
(22) Sykoku,
МеДОС еще не смотрел, но информация полезная.

Подожду месяц - может устаканится процедура регистрации НН.
Для неподдерживаемой никем АБТ 3.5 не уверен что буду делать обратную связь, а вот для УТП - думаю попробую.
Посмотрю еще как АББИ реализует обработку квитанций с 1С-звит. Может и делать ничего не придется.

А так обратная связь должна быть. Задача так и просится на автоматизацию.
30. Serg (Sykoku) 17.01.12 12:54
(1) kompas-dm,

Усложнил, почти до безобразия...
31. Serg (Sykoku) 17.01.12 20:46
Замечено, что МеДОС сообщает об ошибке, если нумерация строк в исходном документе XML непоследовательна, например, "1","3","4" . Такое возникает, если 1) брать нумерацию из самого документа. а не использовать свой счетчик строк;
2) при редактировании НН или ее документа-основания какие-то строки удалялись, а перенумерация не была выполнена.
32. Alex Melnichuk (Amel2010) 18.01.12 11:18
Спасибо за обработку!
Будем разбираться...
Не знаете, как формируется имя файла для документа в стандарте OPZ?
Хочется, чтобы автоматом втягивало из папки XML.
33. Serg (Sykoku) 18.01.12 11:46
(32) Amel2010,


Имена файлов формируются в соответствии с значения элементов заголовка документа (DECLARHEAD) по такому принципу:

· Позиции с 1 по 4 включительно содержат код ГНИ получателя, в которую подается оригинал или копия документа (4 символа), состоящий из кода области, на территории которой располагается налоговая инспекция (отделения) (значение элемента C_REG, дополненного слева нулем до 2 символов ), и кода административного района, на территории которого располагается налоговая инспекция (отделения) (значение элемента C_RAJ, дополненного слева нулем до 2 символов);

Вот как формируется имя файла:

· Позиции с 5 по 14 включительно содержат код плательщика согласно ЕГРПОУ (Регистрационный (учетный) номер из Временного реестра ГНА Украины) или регистрационный номер учетной карточки плательщика (номер паспорта) (значение элемента TIN, дополненного слева нулями до 10 символов);

· Позиции с 15 по 17 включительно содержат код документа (значение элемента C_DOC);

· Позиции с 18 по 20 содержат подтип документа (значение элемента C_DOC_SUB);

· Позиции с 21 по 22 содержат номер версии документа (значение элемента C_DOC_VER, дополненного слева нулем до 2 символов);

· Позиции 23 содержит признак состояния документа (значение элемента C_DOC_STAN);

· Позиции с 24 по 25 содержат номер нового отчетного (уточняющего) документа в отчетном периоде (значение элемента C_DOC_TYPE, дополненного слева нулем до 2 символов). Для отчетного документа Позиции 24 ... 25 содержать значение 00;

· Позиции с 26 по 32 содержат порядковый номер документа, может подаваться несколько раз в одном отчетном периоде (значение элемента C_DOC_CNT, дополненного слева нулями до 7 символов). Если отчет подается только один раз, то позиции 26 ... 32 содержать значение 0000001;

· Позиция 33 содержит числовой код типа отчетного периода (1-месяц, 2-квартал, 3-полугодие, 4-девять месяцев, 5-год) (значение элемента PERIOD_TYPE);

· Позиции с 34 по 35 содержат значения отчетного месяца (значение элемента PERIOD_MONTH дополненного слева нулем до 2 символов);

· Позиции с 36 по 39 содержат значения отчетного года (значение элемента PERIOD_YEAR);

· Позиции с 40 по 43 содержат код налоговой инспекции, в которую подается оригинал документа (значение элемента C_STI_ORIG, дополненного слева нулями до 4 символов). Если документ является оригиналом, а не копией, то позицию 40 ... 43 будут соответствовать позициям 1 ... 4;

· Файл имеет расширение xml.


Картинка тут
http://www.sta.gov.ua/control/uk/publish/article?art_id=308728&cat_id=249256&showHidden=1
34. Alex Melnichuk (Amel2010) 18.01.12 12:25
Спасибо за подсказку и ссылку!

На закладке "Настройки" очепятка: "Поле признака поризошедшей..."
А нужно: "Поле признака произошедшей..."
35. Alex Melnichuk (Amel2010) 18.01.12 12:38
Не сохраняются в настройках поля признака. Только их значения
36. Serg (Sykoku) 18.01.12 12:40
(34) Amel2010,

Спасибо, исправлю. Просто у меня в помещении +14 самая высокая температура - тетя Клава не всегда корректно воспринимает нажатия. Я когда описание прочел - штук 10 орфографических ошибок нашел...
Хотя можно было бы и проверить чем-нибудь перед отправкой ...
37. Alex Melnichuk (Amel2010) 18.01.12 13:06
(36) Sykoku,
Сочувствую по поводу климата...

Дорабатываю под свою конфигурацию...
Не работает при льготах на НДС - неправильно выгружаются реквизиты (не в те колонки суммы и т.п.).
38. Alex Melnichuk (Amel2010) 18.01.12 13:25
В итоге все-таки мне лучше подошла для выгрузки эта разработка: http://infostart.ru/public/104504/
Завелось сразу и правильно выгружает как с НДС так и без.

А вот импорт дат регистрации сейчас попробуем...

А Вы не планируете случайно автоматизировать проверку входящих налоговых накладных на предмет регистрации в ЕРНН?
Вот было бы здорово!
39. Serg (Sykoku) 18.01.12 13:32
(35) Amel2010,
В смысле - поля из реквизитов НН?
Предполагается их самостоятельная замена на предустановленные в Вашей конфигурации - строки 528, 538, 548 Модуля.
Точно так же, как и не сохраняется параметр выбора строки кода Налоговой Инспекции.

Хотя, согласен, можно было и сохранить.
40. Serg (Sykoku) 18.01.12 13:34
(35) Amel2010,

Если очень надо - вот измененные процедуры кода

// ===============================
Процедура ВыборРеквизитов(Наше_Поле, Его_Тип, Имя_по_Умолчанию)


СменитьФирму();

Док = СоздатьОбъект("Документ.НалоговаяНакладная");
ДокНН = Метаданные.Документ(Док.Вид());

// реквизиты шапки документа
Для Сч=1 по ДокНН.РеквизитШапки() Цикл

Реквизит=ДокНН.РеквизитШапки(Сч);
Значение=Реквизит.Идентификатор;
ТипРекв=Реквизит.Тип;

Если (ТипРекв=Его_Тип) Тогда
Наше_Поле.ДобавитьЗначение(Реквизит.Идентификатор + "/" + Сч); //+"/" + ТипРекв
КонецЕсли;

КонецЦикла;

Для Сч=1 по Наше_Поле.РазмерСписка() Цикл
ТекСтрока = Наше_Поле.ПолучитьЗначение(Сч);
Если Найти(ТекСтрока,Имя_по_Умолчанию)<>0 Тогда
Наше_Поле.УдалитьВсе();
Наше_Поле.ДобавитьЗначение(ТекСтрока);
Прервать;
КонецЕсли;
КонецЦикла;


КонецПроцедуры


// ===============================

Процедура ПриОткрытии()

Фирма=Константа.БазФирма.Получить(ТекущаяДата());

ДатаС = ТекущаяДата()-1;
ДатаПо = ДатаС;


ВосстановитьЗначение("ЕПРН_Предел",Предел);
Если ПустоеЗначение(Предел)=1 Тогда
Предел =10000; // Предельная сумма НДС не включения в отчет не акцизного товара
КонецЕсли;

ВосстановитьЗначение("ЕПРН_НДС",НДС_Х);
Если ПустоеЗначение(НДС_Х)=1 Тогда
НДС_Х = 1; // Включать ли в экспорт неплательщиков НДС
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Экспорт",Экспортировано);
Если ПустоеЗначение(Экспортировано)=1 Тогда
Экспортировано = 0; // Учитывать ли экспортированные
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Старт",СтартНН);
Если ПустоеЗначение(СтартНН)=1 Тогда
СтартНН = 5;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Стоп",СтопНН);
Если ПустоеЗначение( СтопНН)=1 Тогда
СтопНН = 10;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_OPZ",OPZ);
Если ПустоеЗначение(OPZ)=1 Тогда
OPZ =1;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Признак",Признак);
Если ПустоеЗначение(Признак)=1 Тогда
Признак=0;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Файл",Файл);
Если ПустоеЗначение(Файл)=1 Тогда
Файл="OUTNAKLKVT20120113.dbf";
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Каталог",Каталог);
Если ПустоеЗначение(Каталог)=1 Тогда
Каталог="\\trodat-ua\1cv77\medoc\report\dpa\";
КонецЕсли;

ВосстановитьЗначение("Поле_ЕРПН",Поле_ЕРПН);
Если ПустоеЗначение(Поле_ЕРПН)=1 Тогда
ВыборРеквизитов(Поле_ЕРПН,"Число","ЄРПН");
КонецЕсли;

ВосстановитьЗначение("Знач_ЕРПН",Знач_ЕРПН);
Если ПустоеЗначение(Знач_ЕРПН)=1 Тогда
Знач_ЕРПН=0;
КонецЕсли;

ВосстановитьЗначение("Поле_Звит",Поле_Звит);
Если ПустоеЗначение(Поле_Звит)=1 Тогда
ВыборРеквизитов(Поле_Звит,"Число","Звіт");
КонецЕсли;

ВосстановитьЗначение("Знач_Звит",Знач_Звит);
Если ПустоеЗначение(Знач_Звит)=1 Тогда
Знач_Звит=1;
КонецЕсли;

ВосстановитьЗначение("Поле_ДПА",Поле_ДПА);
Если ПустоеЗначение(Поле_ДПА)=1 Тогда
ВыборРеквизитов(Поле_ДПА,"Дата","ДПА");
КонецЕсли;


ИмяФайлаЗагрузки = Каталог + Файл;

Форма.ИспользоватьЗакладки(1);
Форма.Закладки.ДобавитьЗначение(1,"Выгрузка");
Форма.Закладки.ДобавитьЗначение(2,"Загрузка");
Форма.Закладки.ДобавитьЗначение(3,"Настройки");
Форма.Закладки.ДобавитьЗначение(4,"Списки_НН");
Форма.ИспользоватьСлой("Основной, Выгрузка",2);


КонецПроцедуры

// ===============================

Процедура ПриЗакрытии()

СохранитьЗначение("ЕПРН_Предел",Предел);

СохранитьЗначение("ЕПРН_НДС",НДС_Х);

СохранитьЗначение("ЕПРН_Экспорт",Экспортировано);

СохранитьЗначение("ЕПРН_Старт",СтартНН);

СохранитьЗначение("ЕПРН_Стоп",СтопНН);

СохранитьЗначение("ЕПРН_OPZ",OPZ);

СохранитьЗначение("ЕПРН_Признак",Признак);

СохранитьЗначение("ЕПРН_Файл",Файл);

СохранитьЗначение("ЕПРН_Каталог",каталог);

СохранитьЗначение("Поле_ЕРПН",Поле_ЕРПН);

СохранитьЗначение("Знач_ЕРПН",Знач_ЕРПН);

СохранитьЗначение("Поле_Звит",Поле_Звит);

СохранитьЗначение("Знач_Звит",Знач_Звит);

СохранитьЗначение("Поле_ДПА",Поле_ДПА);



КонецПроцедуры
41. Alex Melnichuk (Amel2010) 18.01.12 13:35
(39) Sykoku,
да там просто галочку нужно было поставить "Сохранять при сохранении настройки"
42. Serg (Sykoku) 18.01.12 13:43
(38) Amel2010,

Буду, конечно, но со входящими есть засада - для того, чтобы их проверить, их требуется сначала внести ручками. В тот же МеДОС, например. Или экспортировать из 1С. Автоматический запрос в налоговую с пустыми полями реквизитов входящих НН возвращает пустой же ответ. Вот и вся сказка про электронный документооборот.
А отправлять партнеру - опять же заносить его в справочник, корректно указывать адрес электронной почты и дай бог, чтобы там это письмо открылось в МеДОСе, а не секретаршей. Через Сервер ДПА не получится....
43. Serg (Sykoku) 18.01.12 13:46
(41) Amel2010,

Ни один из моих бухов про возможность сохранять настройки ни сном ни духом. А записывать за мной и учиться им лень....

А по ссылке - там для БухУчет для Украины. Я выкладывал адаптированную обработку для этой конфигурации отдельным файлом в комментариях - модераторы прибили - типа так теперь нельзя.

Надо адаптировать - скажите, для чего. Файлообменники и личную переписку еще никто не отменял.
44. Alex Melnichuk (Amel2010) 18.01.12 15:32
(42) Sykoku,
Я себе представляю такую схему.
Бухи на участках вносят приходные документы (в т.ч. налоговую накладную).
Ставят галку типа "Должно быть зарегистрировано в ЕРНН".
Обработка выгружает их в запрос в виде файла XML для ДПА.
Медос или что-то типа того импортирует запрос, отправляет в ДПА, получает ответ.
Бух, который работает с Медос разносит в 1С галки типа "Зарегистрировано в ЕРНН".
45. Serg (Sykoku) 18.01.12 16:16
(44) Amel2010,
МеДОС не умеет импортировать "Отримані" налоговые накладные.
Зато он умеет импортировать весь реестр "Отриманих та виданих" - вот при его отправке, по идее, и можно будет искать дату внесения в реестр ДПА входящей НН. (Предпоследнее поле - Реєстрація).
Только вот сохраняет их МеДОС по одной в фомате OPZ J1201505, да еще и с ошибками - вместе с данными идет и мусор

....
<TAB1><![CDATA[]]></TAB1>
....
<TAB2><![CDATA[<Дата_НН>|<Дата_еще_раз>||<код НН> - ПН|<Поставщик>|<его_ИНН>|<Сумма_С_НДС>|<Сумма_Без_НДС>|<НДС>|||||||1]]></TAB2>
....

Рез-т удручает.
46. Alex Melnichuk (Amel2010) 18.01.12 17:01
(45) Sykoku,
Для определения статуса регистрации в ЕРНН в Медос (как и в Арт-Звите) есть специальный бланк запроса к реестру, в котором перечисляются номера/даты накладных, по которым хочешь получить справку.
Потом этот документ (бланк запроса) пересылается в ДПА.
На него приходит ответ - какие зарегистрированы, а какие нет.

Я об этом механизме писал.
47. Serg (Sykoku) 18.01.12 17:50
(46) Amel2010,
Я знаю, только в этот бланк как заносятся данные?
А хотелось бы как?
48. Alex Melnichuk (Amel2010) 18.01.12 18:02
(47) Sykoku,
Заносятся данные (номера и даты накладных) вручную.
А хотелось бы формировать в 1С автоматически.
В Медос только импортировать готовый документ XML для отправки в ДПА.
49. Serg (Sykoku) 18.01.12 18:10
(48) Amel2010,
Если не сложно - дайте ссылку на Вашу статью-описание МеДОСа (или сообщите код этого XML-документа - я что-то не припомню, чтобы в МеДОСе был именно импорт "Отриманих"...)
50. Alex Melnichuk (Amel2010) 18.01.12 18:18
ща качну, поставлю Медос, сделаю пару скриншотов - станет понятно, о чем я говорю.
Речь идет не об импорте накладных, а об импорте документа-запроса к ДПА, если такое вообще возможно.

Вот, кстати, пока нашел в руководстве пользователя Медос:
http://screencast.com/t/blkEQGnZfnXx

в OPZ эта справка про регистрацию накладной в ЕРНН имеет код F1300101

Вот для примера, что сформировал ОПЗ:
<?xml version="1.0" encoding="windows-1251" ?>
- <DECLAR xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="F1300101.xsd">
- <DECLARHEAD>
<TIN>43287687</TIN>
<C_DOC>F13</C_DOC>
<C_DOC_SUB>001</C_DOC_SUB>
<C_DOC_VER>1</C_DOC_VER>
<C_DOC_TYPE>0</C_DOC_TYPE>
<C_DOC_CNT>2</C_DOC_CNT>
<C_REG>23</C_REG>
<C_RAJ>1</C_RAJ>
<PERIOD_MONTH>1</PERIOD_MONTH>
<PERIOD_TYPE>1</PERIOD_TYPE>
<PERIOD_YEAR>2012</PERIOD_YEAR>
<C_STI_ORIG>2301</C_STI_ORIG>
<C_DOC_STAN>1</C_DOC_STAN>
<LINKED_DOCS xsi:nil="true" />
<D_FILL>18012012</D_FILL>
<SOFTWARE>OPZ 1.29.20</SOFTWARE>
</DECLARHEAD>
- <DECLARBODY>
<HNUM />
<HNAME>Добро, ООО</HNAME>
<HTIN>43287687</HTIN>
<HNPDV />
<HKSTI />
<HSTI>2301 ДПI У М.ЧЕРКАСИ</HSTI>
<HEMAIL />
<T1RXXXXG21 ROWNUM="1">1111111111</T1RXXXXG21>
<T1RXXXXG3D ROWNUM="1">01012012</T1RXXXXG3D>
<T1RXXXXG5 ROWNUM="1">4398098045</T1RXXXXG5>
<HFILL>18012012</HFILL>
<HKBOS>4398098045</HKBOS>
<HBOS>Іванов І.І.</HBOS>
</DECLARBODY>
</DECLAR>
51. Serg (Sykoku) 18.01.12 19:32
(50) Amel2010,

Этот документ я знаю. Я думал что-то еще появилось.

У меня он делается на основании документа СтраницаКнигиПриобретений. Выложить могу, только у меня АБТ. А там его отродясь не было. Я его создавал для заполнения раз в месяц.

Под БУУ можно попытаться адаптировать.
52. Taras Shewchenko (yuyu1) 25.01.12 11:53
а вот импорт налоговой накладной формата XML В 1С никто не написал.... прийдется самому
53. Dmitry (teleport7) 25.01.12 12:16
(52) yuyu1,
вероятно от того что это слишком нетиповая задача.
Подскажите для чего это Вам? Интересно настолько ли это необходимо. Может есть более простые способы решения Вашей задачи.
54. Serg Sokoloff (Sykoky) 25.01.12 13:27
(52) yuyu1,
Для какой версии 7-ки?

Еще пара вопросов
- поиск Фирмы / Клиента - по ИНН или ЭДРПОУ ? - Если реквизит периодический - фигвам.
- поиск ТМЦ по Наименованию - еще один фигвам.

А в остальном - очень даже несложно:


// ===============================


Процедура Парсинг(Стр)

НовСтр=СтрЗаменить(Стр," ", "");
Если Найти(НовСтр,"<C_DOC>")=1 Тогда
Если СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<C_DOC>",""),"</C_DOC>",""))<>"J12" Тогда
Сообщить("Это не документ J12 НН !");
Стоп=1;
КонецЕсли;
КонецЕсли;

Если Найти(НовСтр,"<C_DOC_SUB>")=1 Тогда
Если Число(СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<C_DOC_SUB>",""),"</C_DOC_SUB>","")))<>10 Тогда
Сообщить("Это не документ J12010 НН !");
Стоп=1;
КонецЕсли;
КонецЕсли;

Если Найти(НовСтр,"<HFILL>")=1 Тогда
HFILL=СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HFILL>",""),"</HFILL>",""));
ТекДок.ДатаДок=Дата(Сред(HFILL,5,4),Сред(HFILL,3,2),Сред(HFILL,1,2));
КонецЕсли;

Если Найти(НовСтр,"<HNUM>")=1 Тогда
ТекДок.НомерДок=СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HNUM>",""),"</HNUM>",""));
КонецЕсли;

Если Найти(НовСтр,"<H02G1S>")=1 Тогда
ТекДок.Умова=СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<H02G1S>",""),"</H02G1S>",""));
КонецЕсли;

Если Найти(НовСтр,"<HKSEL>")=1 Тогда
HKSEL=Число(СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HKSEL>",""),"</HKSEL>","")));
Фирмы=СоздатьОбъект("Справочник.Фирмы");
Если Фирмы.НайтиПоРеквизиту("ИНН",HKSEL,1)=0 Тогда
Сообщить("Не найден продавец !");
Стоп=1;
Иначе
ТекДок.Фирма=Фирмы.ТекущийЭлемент();
КонецЕсли;
Фирма=0;
КонецЕсли;

Если Найти(НовСтр,"<HKBUY>")=1 Тогда
HKBUY=Число(СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HKBUY>",""),"</HKBUY>","")));
Клиент=СоздатьОбъект("Справочник.Клиенты");
Если Клиент.НайтиПоРеквизиту("ИНН",HKBUY,1)=0 Тогда
Сообщить("Не найден покупатель !");
Стоп=1;
Иначе
ТекДок.Клиент=Клиент.ТекущийЭлемент();
КонецЕсли;
Клиент=0;
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG3SROWNUM=")=1 Тогда
ТМЦ=СтрЗаменить(СтрЗаменить(Стр,"<RXXXXG3S ROWNUM=>",""),"</RXXXXG3S>","");
ТМЦ=СокрЛП(Сред(ТМЦ,Найти(ТМЦ,">")+1));

ТекДок.НоваяСтрока();

Товар=СоздатьОбъект("Справочник.ТМЦ");
Если Товар.НайтиПоНаименованию(ТМЦ,0,1)=0 Тогда
Сообщить("Не найден ТМЦ "+ ТМЦ +"!");
Стоп=1;
Иначе
ТекДок.ТМЦ=Товар.ТекущийЭлемент();
КонецЕсли;
ТМЦ=0;
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG5ROWNUM=")=1 Тогда
Кво=СтрЗаменить(СтрЗаменить(Стр,"<RXXXXG5 ROWNUM=>",""),"</RXXXXG5>","");
ТекДок.Кво=Число(СокрЛП(Сред(Кво,Найти(Кво,">")+1)));
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG6ROWNUM=")=1 Тогда
Цена=СтрЗаменить(СтрЗаменить(НовСтр,"<RXXXXG6ROWNUM=>",""),"</RXXXXG6>","");
ТекДок.Цена=Число(СокрЛП(СтрЗаменить(СтрЗаменить(Сред(Кво,Найти(Кво,">")+1),",",""),".",","))); // убираем триады и заменяем точку на запятую
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG7ROWNUM=")=1 Тогда
Сумма=СтрЗаменить(СтрЗаменить(НовСтр,"<RXXXXG7ROWNUM=>",""),"</RXXXXG7>","");
ТекДок.СуммаБезНДС=Число(СокрЛП(СтрЗаменить(СтрЗаменить(Сред(Сумма,Найти(Сумма,">")+1),",",""),".",","))); // убираем триады и заменяем точку на запятую
КонецЕсли;

КонецПроцедуры



// ===============================
Процедура ЗагрузитьНН()


Стоп=-1;

Если ФС.СуществуетФайл(ИмяФайлаЗагрузки)=0 Тогда
Предупреждение("Указанный файл не существует!", 5);
Стоп=0;
Возврат ;
Иначе

Стоп=0;

ТекДок = СоздатьОбъект("Документ.НалоговаяНакладная");
ТекДок.Новый();

Попытка

Т=СоздатьОбъект("Текст");
Т.Открыть(ИмяФайлаЗагрузки);

Если Т.КоличествоСтрок()=0 Тогда
Сообщить("Файл пустой: "+ИмяФайлаЗагрузки, "!");
Возврат;
КонецЕсли;


Для Сч=1 По Т.КоличествоСтрок() Цикл

Стр=Т.ПолучитьСтроку(Сч);

Если ПустаяСтрока(Стр)=1 Тогда
Продолжить;
КонецЕсли;

//перекодировка
Если ДОС=1 Тогда
Стр=OemToAnsi(Стр);
// Стр=СтрЗаменить(Стр,"\"+Симв(34),Симв(34));
КонецЕсли;

Парсинг(Стр);

Если Стоп=1 Тогда
Сообщить("Ошибка содержимого файла!");
Стоп=0;
Возврат;
КонецЕсли;

КонецЦикла;

Исключение

Сообщить("Загрузка не выполнена. Длинное имя файла?");

КонецПопытки;


КонецЕсли;

ТекДок.Записать();

Стоп=0;

КонецПроцедуры



Строчку с именем файла сами вставите в окно формы?
Я-бы с радостью - но меня забанили на 4-ре недели без объявления войны (2 дня на форуме вообще не появлялся...)
55. Dmitry (teleport7) 25.01.12 20:06
(54) Sykoky,
Хотя да, возможность загружать из унифицированной формы налоговой сразу приходы в базу - достаточно перспективна.
Больше всего смущает отсутствие артикулов, но можно как-то решить этот вопрос организационно в большинстве компаний.
Думаю на сайте стоит ожидать появления отдельной, универсальной под все конфигурации, разработки на эту тему. Вероятно - будет популярна.
Все зависит от продуманности работы с номенклатурой.
56. Serg Sokoloff (Sykoky) 25.01.12 21:13
57. MIXOH (MIXOH) 01.02.12 12:58
Да уж.....у самого самописная (как и конфа) обработка по выгрузке на регистрацию в Медок, так же разобрался и с импортом даты регистрации из медка в обратку. По существу этой обработки могу пожелать дальнейших успехов и добавить пару комментов:
Действительно пока сам не нашел нормального решения по импорту в медок номеров НН для формирования запроса о регистрации а соответственно и вытяга с реестра данных по входящим НН от поставщиков.....единственное пока более менее решение это импорт номеров в OPZ затем переброска из него-же в медок....прямого импорта к сожалению пока не реализовали в медке.
И еще один комментарий....(регулярно сталкиваюсь) некоторые НН при регистрации отклоняются по причине некорректного кода УКТЗЕД, его проверка осуществляется медком при регистрации, беда в том что частенько поставщики ошибаются с этим кодом, приходится потом его уточнять и направлять НН на регистрацию повторно, встречал в сети как справочник (выгруженный из медка кстати) так и обработку по актуализации этих данных в самой 1С, (у себя еще не реализовал но планирую, и Вам советую) логично было-бы делать попутную проверку кодов в НН выгружаемых этой обработкой на валидность сверяя с данным справочником, дабы избежать возможных ошибок при регистрации медком (на самой выгрузке это не отражается, т.к. обработка пишет в xml все что не подсунешь).
З.Ы. Да.....еще тут проскакивал вопрос о необходимости регистрации НН неплательщикам....так вот их выгружать, а следовательно и регистрировать (ставить галочку в печатной форме) не нужно.
58. Serg Sokoloff (Sykoky) 01.02.12 13:55
(57) MIXOH,
По проверке кодов.
Занятие бесполезное, т.к. коды таможенной службы и ДПА не совпадают. Нарывался неоднократно. Периодически сервер ДПА посылает контрагентов с моим кодом, хотя у меня с этим же кодом НН зарегистрирована.

По неплательщикам.
Можно пока и не выгружать, пока он не запросит корректировку или не захочет вернуть. Тогда - обязательно.

По импорту запроса входящих НН.
Каждому буху все равно придется вносить в программу входящие НН. Сделать отчет за период по журналу этих документов и сохранить его в виде XML для последующего импорта в MEDOC несложно. В OPZ J1400101
59. seidametov-a (seidametov-a) 13.02.12 17:40
(1) kompas-dm, Хорошая выгрузка, удобная, к своей нестандартной базе прикрутил на УРА!!! Только много мелких недоработок, например точки в датах. Но в общем работает отлично. Спасибо +
60. Serg (Sykoku) 17.02.12 16:27
Вышли новые версии документов XML - Додатка №1 и Додатка №5.
Всех изменений - сменить номера версий документов - это строки
<C_DOC_VER>9</C_DOC_VER> и
<C_DOC_VER>2</C_DOC_VER> соответственно надо заменить на

<C_DOC_VER>10</C_DOC_VER> и
<C_DOC_VER>3</C_DOC_VER>.
61. Serg (Sykoku) 15.03.12 11:57
Изменен формат экспорта даты внесения в реестр - поля переставлены местами.

Старый порядок -
DATE_REG NUMBER DATEDOC EDRPOU INN NUM_SVD TYPE

Новый порядок -
KVTIMPDT REGNUM TYPE NUM_SVD INN EDRPOU DATEDOC NUMBER DATE_REG + возможность экспортироватьне все их них.

Это идет с обновлением Медка 10.00.59 + дается возможность выбора полей для экспорта (без возможности сохранения настройки по завершению программы).

Так как у нас поля выбирались по имени, а не по номеру столбца (а оные не изменились), то программа продолжает работать.
НО.
Медос как формировал дату внесения в реестр НН ДО 29-го февраля, так и продолжает игнорировать мартовские документы. Ошибка не исправлена. Ждем-с.
62. Serg (Sykoku) 31.03.12 16:10
Через 3 недели ИтеллектСервисовские программеры нашли баг. Обещали в 63-й версии исправить. Причем - на мой страх и риск. М-да... Меня, кстати, туда звали на работу лет 20-ть назад. Может оно и хорошо, что не согласился.
63. Sergey S (stagov) 01.12.12 03:58
...(для 1С 7.7. АБТ 3.5.5 и выше).... за 10 лет с 1С раза 2 сталкивался с этим чудом. Конфа не супер распространенная, ну и громоздкая
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа