Счет-фактура 2012 для 1С 7.7 Комплексная конфигурация

Опубликовал Андрей Вершинин (&-rey) в раздел Печать - Печатные формы документов

Счет-фактура образца 2012 г. для Комплексной конфигурации. ВНИМАНИЕ! Файл перезалит, приведен в соответствие с опубликованной версией счета фактуры!!!

Внешняя печатная форма Счет-фактуры образца 2012 г. для Комплексной конфигурации. Сделана на скорую руку, но вполне годится. Исправление номер и дата - просто выводит на форму без функционала.

ВНИМАНИЕ!!! Файл перезалит, форма приведена в соответствие с опубликованным 16 января новой версией счета-фактуры! Версия выпущенная 1С от 5-го января и от 19 января тоже различаются! К сожалению, у нас в России всегда так - 26 приняли что с 1 января надо новую, опубликовали уже 16-го да и то с изменениями уже! 

Вобщем... не говорите, сам тащусь))) 

Скачать файлы

Наименование Файл Версия Размер
Внешняя печатная форма
.ert 112,00Kb
31.01.12
130
.ert 112,00Kb 130 Скачать

См. также

Комментарии
1. наталья Измайлова (nata0579) 06.01.12 18:13 Сейчас в теме
2. Алексей Споров (Timesoft) 271 06.01.12 21:44 Сейчас в теме
А чем не устраивают\чем эта лучше форм от 1С ???
3. Алексей Споров (Timesoft) 271 06.01.12 21:45 Сейчас в теме
+2 Они и к бух и к упрощенке и к ПУБ. Для предпринимателя нет только, но там беда - нет механизма внешних форм- придётся релиз ждать
4. наталья Измайлова (nata0579) 06.01.12 23:43 Сейчас в теме
для 1 с бухгалтерия не пошло ругается Если глЕстьРеквизитМнЧ<<?>>("СуммаНП", ВидОсн) = 0 Тогда
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(154)}: Функция не обнаружена (глЕстьРеквизитМнЧ)
Если глЕстьРеквизитМнЧ<<?>>("СуммаНДС", ВидОсн) = 0 Тогда
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(161)}: Функция не обнаружена (глЕстьРеквизитМнЧ)
МнЧ.СуммаНДС = глФРМ<<?>>(ТаблицаОснования.СуммаНДС);
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(200)}: Функция не обнаружена (глФРМ)
МнЧ.СуммаНП = глФРМ<<?>>(ТаблицаОснования.СуммаНП);
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(201)}: Функция не обнаружена (глФРМ)
МнЧ.Сумма = глФРМ<<?>>(ТаблицаОснования.Сумма);
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(203)}: Функция не обнаружена (глФРМ)
МнЧ.Цена = глФРМ<<?>>(?(ТаблицаОснования.Количество = 0, 0, ТаблицаОснования.Сумма/ТаблицаОснования.Количество));
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(211)}: Функция не обнаружена (глФРМ)
МнЧ.Цена = глФРМ<<?>>(?(ТаблицаОснования.Количество = 0, 0, ТаблицаОснования.Сумма/ТаблицаОснования.Количество));
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(224)}: Функция не обнаружена (глФРМ)
МнЧ.ВсегоСНДС = глФРМ<<?>>(ТаблицаОснования.Сумма + ТаблицаОснования.СуммаНДС);
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(229)}: Функция не обнаружена (глФРМ)
Итоги.ДобавитьЗначение(глФРМ<<?>>(ТаблицаОснования.Итог("Сумма")), "ИтогСумма");
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(348)}: Функция не обнаружена (глФРМ)
Итоги.ДобавитьЗначение(глФРМ(ТаблицаОснования.Итог("Сумма")<<?>>), "ИтогСумма");
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(348)}: Неопознанный оператор
Итоги.ДобавитьЗначение(глФРМ(ТаблицаОснования.Итог("Сумма")), "ИтогСумма")<<?>>;
{C:\USERS\ТС\DOWNLOADS\FACTURA2012 (1).ERT(348)}: Ожидается ключевое слово 'КонецФункции' ('EndFunction')
5. Алексей Споров (Timesoft) 271 06.01.12 23:49 Сейчас в теме
Эта - естественно не пойдёт, поскольку структура документов абсолютно разная и процедуры глобального модуля тоже. Чем не устраивают формы 2012 от фирмы 1С для всех конфигураций ???
6. наталья Измайлова (nata0579) 07.01.12 00:09 Сейчас в теме
Для 7 пока не нашла , я так поняла обновление 1 с не выпустила , есть тока для восьмерки
7. Алексей Споров (Timesoft) 271 07.01.12 00:20 Сейчас в теме
для 7ки вчера утром SF_2012.ERT - бух,УСН, торг, комплексная, ПУБ

Данная печатная форма предназначена для печати счета-фактуры
в соответствии с проектом Постановлением Правительства
РФ "О счетах-фактурах и признании утратившими силу некоторых
нормативных актов Правительства Российской Федерации".
ВНИМАНИЕ!
На момент публикации печатных форм Постановление Правительства
подписано но еще не опубликовано.
После опубликования формы будут приведены в соответствие Постановлению.

SF_2012.ert - внешняя форма счета фактуры;
SF_2012.efd - дополнительный файл внешней формы счета-фактуры.
8. Алексей Споров (Timesoft) 271 07.01.12 00:21 Сейчас в теме
Пардон,это было уже позавчера утром (5го)
9. Михаил Кувичко (Michael_K) 7 07.01.12 08:20 Сейчас в теме
nata0579 пишет:

Для 7 пока не нашла , я так поняла обновление 1 с не выпустила , есть тока для восьмерки

Наталья, а ткните носом в новые восьмерочные СФ, искал, не нашел, взаимообразно готов поделиться сф для 7.7.
10. Алексей Споров (Timesoft) 271 07.01.12 11:12 Сейчас в теме
Это не про них ?
Версия 2.0.30
Новое в версии

...........
Реализованы изменения в учете НДС в соответствии с Проектом Постановления Правительства РФ "О счетах-фактурах и признании утратившими силу некоторых нормативных актов Правительства Российской Федерации";
12. Михаил Кувичко (Michael_K) 7 07.01.12 13:27 Сейчас в теме
(10) Timesoft, о, спасибо, что значит годовой отчет, устанавливаю обновления, а "матчасть" вдумчиво прочесть некогда! :(
13. Алексей Споров (Timesoft) 271 07.01.12 13:53 Сейчас в теме
Да не за что - я сам такой - "ред.ми не барское дело" :)
14. Андрей Вершинин (&-rey) 59 09.01.12 10:45 Сейчас в теме
Да, для семерки появились оказывается, думал не дождемся, многие с 3-го уже на работе, в панике, как выписывать счет-фактуру!) Пришлось срочно делать для комплексной, и уже собирался начать делать для торговли, бух и Производства. Хорошо для всех уже есть, а то 10-го все выйдут и начнется!))
15. rdv (rdv) 11.01.12 06:40 Сейчас в теме
Вот гады, еще им коды измерений товаров надо, вот для чего, делают вид, что не зря бабки получают.
16. Алексей (Alav) 13 23.01.12 00:00 Сейчас в теме
Автор не зачет

Счет фактура НЕ ПРАВИЛЬНАЯ
Она сделана по проекту, в финальной версии есть некоторые изменения, т.е. счет-фактура печатается НЕПРАВИЛЬНО.

Будьте внимательны и осторожны
17. Андрей Вершинин (&-rey) 59 23.01.12 19:07 Сейчас в теме
а что там в финальной версии изменилось? Я вывел счет фактуру в восьмерке и по ней рисовал форму в семерке)) возможно что в Комплексной автоматизации 1.1.17.1 что то было по проекту, сегодня вышла 1.1.18.1 нада глянуть может там что то поменялось, но не уверен
18. Андрей Вершинин (&-rey) 59 23.01.12 19:10 Сейчас в теме
кстати эта форма подходит для старой комплексной прекрасно, если давно не обновляли. Если свежая конфа, то стандартная форма счет-фактуры уже вышла, можете использовать их. Для старой конфы их не применишь, нада править.
19. Жека Moscow (SpartakM) 32 23.01.12 21:59 Сейчас в теме
Подскажите, для ТиС подойдет?
20. Андрей Вершинин (&-rey) 59 24.01.12 10:34 Сейчас в теме
Для ТиС уже есть стандартная. В ней все просто - если у тебя ТиС не обновленная, то у тебя нет глобальной переменной глДатаПостановления451 и будет давать ошибку. Закомментируй строки в модуле

// Если Докум.ДатаДок >= глДатаПостановления451 Тогда
Рекв.ДобавитьЗначение(Шаблон("Продавец: [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");

// Иначе
// Рекв.ДобавитьЗначение(Шаблон("Продавец: [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");

// КонецЕсли;

и все пойдет
21. Владимир Говонкин (Neon3) 25.01.12 11:42 Сейчас в теме
Скачал. Прикрепил К !с7.7 конфигурация старючая лет 5-6 необновлялась, писаная переписаная и нечего номально работает проблем пока незаметил
22. Андрей Вершинин (&-rey) 59 25.01.12 12:13 Сейчас в теме
to Neon3

я перезалил форму - чуть поменял в соответствии с опубликованной версией, там все таки есть изменения небольшие: вместо слов "показатель отсутствует" нужно теперь ставить прочерк (разумнее хоть!) ну и добавили шапку, нижние комментарии убрали и добавили "уполномоченное лицо", так что если кому - качайте заново.

Да, плюсы не помешают! ;-)
23. Жека Moscow (SpartakM) 32 26.01.12 13:43 Сейчас в теме
(20) так и сделал, но для некоторых счет-фактур, вылетает вот такая ошибка:
МнЧ.СтранаК = РаспредГТД.Страна.Код;
{D:\BASE\EXTFORMS\PRNFORMS\SF2012.ERT(491)}: Значение не
представляет агрегатный объект (Код)
24. Андрей Вершинин (&-rey) 59 26.01.12 14:11 Сейчас в теме
Нужно обновить ТиС до последней версии, только тогда появится код у справочника. В старой версии ТиС-а справочник страна имел представление в виде наименования с нулевой длинной кода, т.е. просто название стран хранилось в базе. Поэтому код взять неоткуда. Нужно обновить конфу
25. Жека Moscow (SpartakM) 32 26.01.12 14:46 Сейчас в теме
26. Денис (xdenx) 27.01.12 15:11 Сейчас в теме
МнЧ.СтранаК = РаспредГТД.Страна.Код;
{D:\BASE\EXTFORMS\PRNFORMS\SF2012.ERT(491)}: Значение не представляет агрегатный объект (Код)

Нужно обновить ТиС до последней версии, только тогда появится код у справочника. В старой версии ТиС-а справочник страна имел представление в виде наименования с нулевой длинной кода, т.е. просто название стран хранилось в базе. Поэтому код взять неоткуда. Нужно обновить конфу

Это не решит проблему, к тому же, в ТиС начиная с релиза 929 справочник "ОКСМ" (Страны) изначально имеет Код длиной 3.

Решение проблемы:
Добавить строку с кодом:

ИначеЕсли КолСтрокГТД = 1 Тогда
// одна строка в таблице. Товара с номером ГТД и страной в одной строке
РаспредГТД.ПолучитьСтрокуПоНомеру(1);

МнЧ.НомерГТД = РаспредГТД.Номер;
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = РаспредГТД.Страна.Код;
emptyteam; +1 Ответить
27. Владимир Саблин (emptyteam) 30.01.12 21:09 Сейчас в теме
Добавить строку с кодом:

ИначеЕсли КолСтрокГТД = 1 Тогда
// одна строка в таблице. Товара с номером ГТД и страной в одной строке
РаспредГТД.ПолучитьСтрокуПоНомеру(1);

МнЧ.НомерГТД = РаспредГТД.Номер;
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = РаспредГТД.Страна.Код;

Спасибо! Помогло!
28. Elena Z (Sirena) 31.01.12 15:49 Сейчас в теме
для 1c 7.7 23.01.12 выпустили стандартную с/ф для бухгалтерии предприятия
29. Сергей Муравьёв (murenysh) 10 31.01.12 16:19 Сейчас в теме
проверьте правильность заголовка 9го столбца - кавычки не нужны и текст другой
30. Владимир Говонкин (Neon3) 31.01.12 16:49 Сейчас в теме
(24) &-rey, Такой вопрос про счет фактуру с выбором грузополучателя выдает ошибку в теме где она есть толком не подсказали что делать может вы подскажите

Константа.СуммыВПечатныхФормахПоУчету;
{Глобальный модуль(328)}: Поле агрегатного объекта не обнаружено (СуммыВПечатныхФормахПоУчету)

Также подскажите в печатной форме в шапки грузополучатель пишется (он же)налоговая не придерется? Может там должно дублироваться то что в плательщике.
31. Андрей Вершинин (&-rey) 59 31.01.12 17:56 Сейчас в теме
(30) Neon3, Я не понял почему у вас ошибка в Глобальном модуле! Обновляли конфу частично? Или Недостающую функцию вставили в глобальный модуль? Тогда идите в константы, создать новую.
Идентификатор: СуммыВПечатныхФормахПоУчету
Синоним: Суммы В Печатных Формах По Учету
Тип значения: Число
Длина: 1 Точность: 0

сохраните конфигурацию, запустите 1С, заходим в константы и ставим значение новой константе равное 1.

на счет "онже" - читайте пояснения к постановлению - приложение 1, там сказано как заполнять и про "онже". Все верно, не придерется.

(29) murenysh, да, поспешил, у себя поменял, сюда залил версию до того как это сам увидел. Там кстати не только 9-й, и другие чуточку поменяли. Перезалил.
32. Владимир Говонкин (Neon3) 01.02.12 09:15 Сейчас в теме
(31) &-rey, конфа не обновлялась уже лет 5-6 ее оч сильно ктото не один оч сильно переписывал под предприятие теперь никто недает ее обновить боятся что чтонибуть слетит
33. И С (irishen) 04.02.12 12:34 Сейчас в теме
Для ТиС уже есть стандартная. В ней все просто - если у тебя ТиС не обновленная, то у тебя нет глобальной переменной глДатаПостановления451 и будет давать ошибку. Закомментируй строки в модуле

// Если Докум.ДатаДок >= глДатаПостановления451 Тогда
Рекв.ДобавитьЗначение(Шаблон("Продавец: [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");

// Иначе
// Рекв.ДобавитьЗначение(Шаблон("Продавец: [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");

// КонецЕсли;

Спасибо, помогло!
34. none too (1csus) 04.02.12 12:40 Сейчас в теме
а кто-нибудь подскажет, естли в последих релирах 7-ки корректировочные СФ и Книги покупок/продаж по пост. 1137 ?