gifts2017

Счет-фактура 2012 года с выбором грузополучателя для 1С 7.7 Торговля и Склад + Комплексная конфигурация

Опубликовал Gavdis Gavdis (Gavdis) в раздел Печать - Печатные формы документов

Счет-фактура 2012 года с выбором грузополучателя для 1С 7.7 Торговля и Склад + Комплексная конфигурация.
В соответствии приложению N 1 к постановлению Правительства Российской Федерации от 26 декабря 2011 г. N 1137

Печатная форма счета-фактуры 2012 года с выбором грузополучателя для 1С 7.7 Торговля и Склад + Комплексная конфигурация.

 

08.01.2012 Исправлены строки 1а и 5 на соответствие законодательству:

1а) Исправление № показатель отсутствует от показатель отсутствует

5) К платежно-расчетному документу № показатель отсутствует от показатель отсутствует

 В строке 7 для рублей РФ следует использовать код 643, т.е. должно быть  "Валюта: наименование, код Российский рубль, 643"

 

20.01.2012 Добавлена шапка документа "Приложение N 1 к постановлению Правительства Российской Федерации от 26 декабря 2011 г. N 1137"

 

21.01.2012 Форма приведена в соответствии с  постановлением Правительства Российской Федерации от 26 декабря 2011 г. N 1137

22.01.2012 Добавлено повторение шапки таблицы на каждой странице + номер страницы документа в верхнем правом углу (начиная со второго листа).

Скачать файлы

Наименование Файл Версия Размер
SF2012gr.zip 220
.zip 27,55Kb
22.01.12
220
.zip 27,55Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Gavdis Gavdis (Gavdis) 08.01.12 13:24
Счет-фактура 2012 года с выбором грузополучателя для 1С 7.7 Торговля и Склад + Комплексная конфигурация.
В соответствии приложению N 1 к постановлению Правительства Российской Федерации от 26 декабря 2011 г. N 1137

Перейти к публикации

1. Роман Хусяинов (rom-x) 08.01.12 13:24
На счет исправления это конечно плохо, не вставлять же каждый раз при печати: показатель отсутствует .
2. Изучающий Изуча (Изучающий1С) 08.01.12 14:05
в номер платежного документа так же надо вставлять "показатель отсутствует" от "показатель отсутствует"
3. Gavdis Gavdis (Gavdis) 08.01.12 15:03
Исправлены строки 1а и 5 на соответствие законодательству:

1а) Исправление № показатель отсутствует от показатель отсутствует

5) К платежно-расчетному документу № показатель отсутствует от показатель отсутствует

В строке 7 для рублей РФ следует использовать код 643, т.е. должно быть "Валюта: код 643 наименование Российский рубль"
4. Юрий Щербаков (ufo58) 09.01.12 13:07
а что, заголовок шапки типа:

Приложение № 1
к постановлению Правительства
Российской Федерации
от ___________ № ___________

уже упразднено?
и .... форма уже утверждена?
5. lemaxs (lemaxs) 18.01.12 13:41
Выдает такое сообщение
Если Докум.ДатаДок >= глДатаПостановления451 <<?>>Тогда
{F:\VYZOVSKIY\EXTFORMS\PRNFORMS\SF2012GR.ERT(158)}: Переменная не определена (глДатаПостановления451)
БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок, Докум.ДокОснование.КодОперации);
{F:\VYZOVSKIY\EXTFORMS\PRNFORMS\SF2012GR.ERT(400)}: Функция не обнаружена (глБратьСуммыИзУчета)
БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок);
{F:\VYZOVSKIY\EXTFORMS\PRNFORMS\SF2012GR.ERT(402)}: Функция не обнаружена (глБратьСуммыИзУчета)
6. Василий (bbuilder) 20.01.12 13:59
(5) lemaxs,
На последней торговле работает, у тебя релиз старый.
7. Василий (bbuilder) 20.01.12 14:18
Итог по колонке 5 по ходу не нужен. По крайней мере его нет в бухгалтерии.
8. Gavdis Gavdis (Gavdis) 20.01.12 17:35
Добавлена шапка документа "Приложение N 1 к постановлению Правительства Российской Федерации от 26 декабря 2011 г. N 1137"
9. Olga K (dnc) 21.01.12 19:42
Как же всё таки правильно заполнять сч.фактуру с 24 января (строки 1а и 5) с прочерком или с "показатель отсутствует"??

http://правительство.рф/gov/results/17759/ здесь из Приложения 1
"в строке 1а - порядковый номер внесенного в счет-фактуру исправления и дата внесения этого исправления. При составлении счета-фактуры до внесения в него исправлений в этой строке ставится прочерк";
10. Gavdis Gavdis (Gavdis) 21.01.12 22:51
Форма приведена в соответствии с постановлением Правительства Российской Федерации от 26 декабря 2011 г. N 1137
11. Gavdis Gavdis (Gavdis) 22.01.12 17:55
Добавлено повторение шапки таблицы на каждой странице + номер страницы документа в верхнем правом углу (начиная со второго листа).
12. lemaxs (lemaxs) 23.01.12 15:23
А на последней торговле такой результат:
МнЧ.ЕдиницаКод = Докум.Единица.ОКЕИ.Код;
{C:\DB\EXTFORMS\PRNFORMS\SF2012GR.ERT(746)}: Поле агрегатного объекта не обнаружено (ОКЕИ)(6) bbuilder, (6) bbuilder,
chikanog; 789456; +2 Ответить
13. Дмитрий Самохин (samokhin) 24.01.12 12:14
По последним данным из Консультанта: в строке 1а - порядковый номер внесенного в счет-фактуру исправления и дата внесения этого исправления. При составлении счета-фактуры до внесения в него исправлений в этой строке ставится прочерк
14. Сергей Смирнов (discorat) 24.01.12 14:20
ответвсвенностью !!
16. Анна Егорова (anata) 24.01.12 15:05
Просматривала файл тотал комендером (F3). Т.к. пишет что зип архив не архив.
17. 17031703 (SergeyRomanov) 24.01.12 15:30
Если скачивали не ИнтернетЭксплорером - то такое бывает (что качаются архивы битыми). Попробуйте зайти и Скачать ИнтернетЭксплорером.
18. Елена Л (ElenkaLisenka) 24.01.12 15:36
Если Докум.СФНаАванс = 1 Тогда
{E:\ОБМЕН\DB\EXTFORMS\PRNFORMS\SF2012GR.ERT(973)}: Значение не представляет агрегатный объект (СФНаАванс)
на релизе 967 вот такая ошибка
19. Дмитрий Крепак (warewolf) 24.01.12 18:03
(18) ElenkaLisenka, попробуй обновить до 970
20. 0pex 0pex (0pex) 24.01.12 23:44
Спасибо! Сэкономили мне кучу времени =)
21. 0pex 0pex (0pex) 24.01.12 23:46
(18) ElenkaLisenka, обработку вместе с файлом EFD нужно закинуть в папку ExtForms\PrnForms папки вашей рабочей базы и вызывать через печать из документа счет-фактура выданный. Если просто открывать обработку через "Файл-открыть" в обработку не передается ссылка на счет фактуру, поэтому не может быть проверен атрибут "СФНаАванс" и вываливается ошибка.
22. Татьяна Вамзачем (tadem) 25.01.12 07:54
На комплексной 7.7 заработало без проблем
На Складе и ТОрговля выдает ошибки. Возможно релиз старый. Нашла в инете именно для старых релизов!
23. lemaxs (lemaxs) 25.01.12 11:23
(22) tadem,УМОЛЯЮ поделитесь ссылкой
альберт мх; +1 Ответить
24. Владимир Говонкин (Neon3) 25.01.12 12:13
Подскажите. С толкнулся с такой проблемой обычную счет фактуру брал тутже прикрепил все нормально работает. А которая с выбором грузополучателя выдает следующую ошибку.
Возврат Константа.СуммыВПечатныхФормахПоУчету;
{Глобальный модуль(328)}: Поле агрегатного объекта не обнаружено (СуммыВПечатныхФормахПоУчету)

что надо поправить? Конфигурация 1с 7.7 комплексная
25. Оля К (ssst) 25.01.12 14:16
Пойду форму ручками поправлю))) через конфигуратор)))
26. Владимир Говонкин (Neon3) 25.01.12 14:27
выложи потом исправленную или напиши что поправить надо
27. Елена Л (ElenkaLisenka) 25.01.12 16:49
МнЧ.СтранаК = РаспредГТД.Страна.Код;
{E:\ОБМЕН\МУРАШОВ\DB\EXTFORMS\PRNFORMS\SF2012GR.ERT(379)}: Значение не представляет агрегатный объект (Код)
Что делать с такой ошибкой??? Она появляется не во всех, а только в некоторых.
Я так поняла что ошибка появляется там где в счете у некоторой номенклатуры нет страны происходжения.
pingakyla; +1 Ответить
28. Елена Л (ElenkaLisenka) 25.01.12 18:08
Пришлось добавить такие строки, может кому-нибудь пригодится:
Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;
29. Май МММ (may1c) 26.01.12 00:12
Очень знакомая форма. Только сегодня исправляла аналогичную обработку для ТиС. Надо было раньше глянуть... и другим бы помочь сумела..
30. Елена Белова (Lenusa) 26.01.12 15:09
После чего именно добавить :Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;
31. sanches (sanches) 26.01.12 22:10
Если Докум.ДатаДок >= глДатаПостановления451 Тогда
		Рекв.ДобавитьЗначение(Шаблон("Продавец [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");
		
	Иначе
		Рекв.ДобавитьЗначение(Шаблон("Продавец [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");
		
	КонецЕсли;	
...Показать Скрыть


не могу найти различия в условии :)
У меня тоже древняя конфа, тут можно проще убрать условие,чтобы у тех, кто долго не обновлялся не было проблем.
32. sanches (sanches) 26.01.12 23:09
(30) Lenusa,
КолСтрокГТД = РаспредГТД.КоличествоСтрок();
			
			Если КолСтрокГТД = 0 Тогда
				// нет распределения по ГТД
				// Заполним номер ГТД и Страну из Номенклатуры, если там есть...
				Если ПустоеЗначение(ТекТМЦ.НомерГТД) = 0 Тогда
					МнЧ.НомерГТД = СокрЛП(ТекТМЦ.НомерГТД);   
				КонецЕсли;
				
				Если ПустоеЗначение(ТекТМЦ.СтранаПроисхождения) = 0 Тогда
					МнЧ.СтранаН = СокрЛП(ТекТМЦ.СтранаПроисхождения);
					МнЧ.СтранаК = СокрЛП(ТекТМЦ.СтранаПроисхождения.Код);
				КонецЕсли;
				
			ИначеЕсли КолСтрокГТД = 1 Тогда
				РаспредГТД.ПолучитьСтрокуПоНомеру(КолСтрокГТД);
				// одна строка в таблице. Товара с номером ГТД и страной в одной строке
				МнЧ.НомерГТД    = РаспредГТД.Номер;
				МнЧ.СтранаН     = РаспредГТД.Страна;
				МнЧ.СтранаК     = РаспредГТД.Страна.Код;
				
			Иначе
				
				РаспредГТД.ВыбратьСтроки();
				Пока РаспредГТД.ПолучитьСтроку() = 1 Цикл
					
					МнЧ.НоваяСтрока();
					МнЧ.Номенклатура = "     в т.ч.";
					МнЧ.Цена		 = КороткийПрочерк;
					МнЧ.Сумма		 = КороткийПрочерк;
					МнЧ.СтавкаНДС	 = КороткийПрочерк;
					МнЧ.СуммаНДС	 = КороткийПрочерк;
					МнЧ.СуммаНП		 = КороткийПрочерк;
					МнЧ.ВсегоСНДС	 = КороткийПрочерк;
					
					МнЧ.Единица     = ТекЕдиница;
					МнЧ.ЕдиницаКод  = ТекЕдиницаКод;
					МнЧ.Количество  = РаспредГТД.Колво;
					МнЧ.НомерГТД    = РаспредГТД.Номер;
					МнЧ.СтранаН     = РаспредГТД.Страна;
					МнЧ.СтранаК     = РаспредГТД.Страна.Код;
					
					Если (МнЧ.Количество - Цел(МнЧ.Количество)) > 0 Тогда
					    ФорматКоличества = "Ч10.3";
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
...Показать Скрыть

Добавте такую строку
РаспредГТД.ПолучитьСтрокуПоНомеру(КолСтрокГТД);
33. miaow 27.01.12 03:50
(32) sanches, в какое место кода ее добавлять?
34. sanches (sanches) 27.01.12 05:44
(33) miaow,
Я скинул кусок кода из обработки найдите эту строку там и у себя поправьте.
578 строка обработки
35. Елена Л (ElenkaLisenka) 27.01.12 10:37
(30) Lenusa, чтоб долго не искать куда добавить, нажмите два раза в Предприятии на строку с этой ошибкой и тогда в конфигураторе курсор станет на эту строку , допишите Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
выше неё, и КонецЕсли; ниже неё.
36. Елена Белова (Lenusa) 27.01.12 10:38
(33) miaow,
добавила строку в обработку ошибка как выходила так и выходит :МнЧ.СтранаК = РаспредГТД.Страна.Код;
........EXTFORMS\PRNFORMS\SF1137.ERT(528)}: Значение не представляет агрегатный объект (Код)
37. Елена Белова (Lenusa) 27.01.12 10:44
(35) ElenkaLisenka, Спасибо получилось! Только в печатную форму не выходит цифровой код страны. Почему?
38. sanches (sanches) 27.01.12 10:46
(35) ElenkaLisenka,
Вы код посмотрите внимательно. По вашему сегда страна будет пустой, а она есть. да и код ваш работать не будет.
39. Владимир Владимиров (Wladimir) 27.01.12 10:57
Добрый день, подскажите плизззз, у нас ТиС релиз 941 и ваша обработка не выдает печатную форму. Это связано со "старостью" нашего релиза ил по другим причинам? Да и операционка на компе Виста, может с этим связано?
40. Кирилл Крутиков (Редкий Гад) 27.01.12 11:03
показатель отсутствует обязательно?
41. Кирилл Крутиков (Редкий Гад) 27.01.12 11:04
если написано Исправление -- от -- это норм или неправильно?
42. Елена Белова (Lenusa) 27.01.12 11:10
(38) sanches, Это не у меня а в обработке SF1137.ERT скачанной с сайта 1с. Так и не понятно код должен выходить на печать или нет?
43. sanches (sanches) 27.01.12 11:38
(42) Lenusa, Мы наверно про разные ошибки говорим. Я писал как исправить ошибку
МнЧ.СтранаК = РаспредГТД.Страна.Код;
{E:\ОБМЕН\МУРАШОВ\DB\EXTFORMS\PRNFORMS\SF2012GR.ERT(379)}: Значение не представляет агрегатный объект (Код)
У меня здесь был затык и я поправил способом описанныйм выше.
44. Елена Л (ElenkaLisenka) 27.01.12 12:09
(38) sanches, с чего вы взяли что по моему коду страна всегда будет пустой? Слово "Если" ни о чем не говорит???
тут просто идет проверка если Страна пустая то и код будет пустой, у меня все работает. До исправления была такая ошибка если в табличной части у какой-нибудь номенклатуры была пустой страна, вот и программа не знала что делать с кодом страны. А если в табл части вся номенклатура была с указанной страной, то ошибка не появлялась.
45. Dima Kravchenko (dimawolf) 27.01.12 16:29
Люди помогите пожалуйста форма не как не становится 1с7.7 комплексная не обновлялась 3 года нечего не получается
46. Евгений Евгений (ape) 27.01.12 20:21
(32) sanches,

а если появляется та же самая ошибка , но уже в следующей строке ?

МнЧ.СтранаК = РаспредГТД.Страна.Код;,

Если (МнЧ.Количество - Цел(МнЧ.Количество)) > 0 Тогда
ФорматКоличества = "Ч10.3";
47. sanches (sanches) 27.01.12 20:41
(46) ape,
Здесь видимо у вас в таблице РаспредГТД не заполнена страна. У меня такого не попадалось пока. Не разбирался.
48. Евгений Евгений (ape) 28.01.12 10:50
sanches,
Дикая просьба помочь,
у меня сейчас вопросы будут, возможно, неожиданные, т.к. в коде я не Моцарт

Перед первым МнЧ.СтранаК = РаспредГТД.Страна.Код; я поставил вашу строку РаспредГТД.ПолучитьСтрокуПоНомеру(КолСтрокГТД);
1.Если я поставлю эту строку и перед вторым МнЧ.СтранаК, то ошибки не будет и сформируется СФ


но в ней нет разбивки "в т.ч."

2. Я попробовал перед вторым поставить как написала ElenkaLisenka
Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;


тогда разбивка появляется, но без кода и страны


3. А вот так СФ выглядит в 2006


Что вообще происходит ? =)
49. Евгений Евгений (ape) 28.01.12 11:13
50. sanches (sanches) 28.01.12 14:23
(49) ape,
Подставлять код, который я приводил выше надо только в ветку условия, когда в таблице РаспредГТД одна строка
ИначеЕсли КолСтрокГТД = 1 Тогда
РаспредГТД.ПолучитьСтрокуПоНомеру(КолСтрокГТД);
// одна строка в таблице. Товара с номером ГТД и страной в одной строке

Вы подставили в ту ветку условия, где несколько строк в таблице РаспредГТД и он вам выводит страну только для первой строки везде одну
51. sanches (sanches) 28.01.12 14:28
Вышлите базу хотя бы с парочкой проблемный счет-фактур.Если не разберетесь сами.sanches80 dog mail.ru. Или же смотрите в отладчике что не так. У меня тоже древняя ТИС, но заработало сразу после внесенного мною кода приведенного ранее.
Видимо по какой-то причине у вас в партиях страна происхождения не указывается..
52. Евгений Евгений (ape) 28.01.12 21:36
(51) sanches,
Да, я посмотрел, в некоторых партиях страна происхождения не указана.

Может какое-то условие нужно куда-нибудь вбить, чтобы если не указано - ставить прочерк, например?
В старой СФ ведь работало без стран.
53. sanches (sanches) 28.01.12 22:28
(52) ape, Возможно в старой версии страна из справочника бралась.
Тогда вы все верно сделали в п.2 поста (48). Нет страны нет и кода страны
Можете сделать так

Если ПустоеЗначение(РаспредГТД.Страна) = 1 Тогда
МнЧ.СтранаН     = "----";
МнЧ.СтранаК     = "----";
Иначе
МнЧ.СтранаН     = РаспредГТД.Страна;
МнЧ.СтранаК     = РаспредГТД.Страна.Код;

КонецЕсли;
...Показать Скрыть
54. Елена Л (ElenkaLisenka) 29.01.12 10:37
(48) ape,
2. Я попробовал перед вторым поставить как написала ElenkaLisenka
Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;

тут надо
МнЧ.СтранаН = РаспредГТД.Страна;
Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;
55. Евгений Евгений (ape) 29.01.12 20:09
(53) sanches,
я было обрадовался, что все заработало, но это произошло на тестовой базе, где у обеих партий заполнено поле Страна происхождения.

Опять на этих "в т.ч." запнулось:
если у одной партии стоит, например, Корея, а у другой - ничего не заполнено, то ошибка снова вылезает.
56. Евгений Евгений (ape) 29.01.12 20:10
(54) ElenkaLisenka,
я пробовал и так, не работает
57. Настя МММ (Floory) 30.01.12 10:21
Не совсем понятно, с какого числа начинает официально действовать новая форма.
58. Евгений Евгений (ape) 30.01.12 12:08
(57) Floory,
наш главбух сказал, что с 24 января уже действует, в газете какой-то написано было;
нам новые СФ уже приходят от других клиентов
59. Евгений Евгений (ape) 30.01.12 16:08
(54) ElenkaLisenka, (53) sanches,

всем спасибо! выбрал в итоге меньшее зло: код страны не появляется в некоторых случаях, а сама страна и номер ГТД отображается
60. Галина Шуваева (lunx) 30.01.12 16:26
СпрОКСМ = СоздатьОбъект("Справочник.ОКСМ");
Если СпрОКСМ.НайтиПоНаименованию(СокрЛП(РаспредГТД.Страна)) = 1 Тогда
МнЧ.СтранаН = СпрОКСМ.Наименование;
МнЧ.СтранаК =СпрОКСМ.Код;
Иначе
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = "";
КонецЕсли;


Я так решила.. в моем случае с этими т.ч. помогло
61. sanches (sanches) 30.01.12 21:40
(59) ape, Странно конечно как-то. Кода страны нет, а ее название есть...
62. Test Testers (chetirepda) 31.01.12 07:12
Выдает такое сообщение
Если Докум.ДатаДок >= глДатаПостановления451 <<?>>Тогда
{F:\VYZOVSKIY\EXTFORMS\PRNFORMS\SF2012GR.ERT(158)}: Переменная не определена (глДатаПостановления451)
БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок, Докум.ДокОснование.КодОперации);
{F:\VYZOVSKIY\EXTFORMS\PRNFORMS\SF2012GR.ERT(400)}: Функция не обнаружена (глБратьСуммыИзУчета)
БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок);
{F:\VYZOVSKIY\EXTFORMS\PRNFORMS\SF2012GR.ERT(402)}: Функция не обнаружена (глБратьСуммыИзУчета)

Такая же ошибка, как исправить ?
63. Артём Шалнев (88wau24ru) 31.01.12 07:30
64. Jeam Stone (jeam) 31.01.12 11:32
Вставил такой код (по наработкам sanches и ElenkaLisenka)
            КолСтрокГТД = РаспредГТД.КоличествоСтрок();
         
         Если КолСтрокГТД = 0 Тогда
            // нет распределения по ГТД
            // Заполним номер ГТД и Страну из Номенклатуры, если там есть...
            Если ПустоеЗначение(ТекТМЦ.НомерГТД) = 0 Тогда
               МнЧ.НомерГТД = СокрЛП(ТекТМЦ.НомерГТД);   
            КонецЕсли;
            
            Если ПустоеЗначение(ТекТМЦ.СтранаПроисхождения) = 0 Тогда
               МнЧ.СтранаН = СокрЛП(ТекТМЦ.СтранаПроисхождения);
               МнЧ.СтранаК = СокрЛП(ТекТМЦ.СтранаПроисхождения.Код);
            КонецЕсли;
            
         ИначеЕсли КолСтрокГТД = 1 Тогда
            РаспредГТД.ПолучитьСтрокуПоНомеру(КолСтрокГТД);
            // одна строка в таблице. Товара с номером ГТД и страной в одной строке
            МнЧ.НомерГТД    = РаспредГТД.Номер;
            МнЧ.СтранаН     = РаспредГТД.Страна;
            МнЧ.СтранаК     = РаспредГТД.Страна.Код;
            
         Иначе
            
            РаспредГТД.ВыбратьСтроки();
            Пока РаспредГТД.ПолучитьСтроку() = 1 Цикл
               
               МнЧ.НоваяСтрока();
               МнЧ.Номенклатура = "     в т.ч.";
               МнЧ.Цена       = КороткийПрочерк;
               МнЧ.Сумма       = КороткийПрочерк;
               МнЧ.СтавкаНДС    = КороткийПрочерк;
               МнЧ.СуммаНДС    = КороткийПрочерк;
               МнЧ.СуммаНП       = КороткийПрочерк;
               МнЧ.ВсегоСНДС    = КороткийПрочерк;
               
               МнЧ.Единица     = ТекЕдиница;
               МнЧ.ЕдиницаКод  = ТекЕдиницаКод;
               МнЧ.Количество  = РаспредГТД.Колво;
               МнЧ.НомерГТД    = РаспредГТД.Номер;
               МнЧ.СтранаН     = РаспредГТД.Страна;
				Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
				МнЧ.СтранаК = РаспредГТД.Страна.Код;
				КонецЕсли; 
               
               Если (МнЧ.Количество - Цел(МнЧ.Количество)) > 0 Тогда
                   ФорматКоличества = "Ч10.3";
               КонецЕсли;
               
            КонецЦикла;
         КонецЕсли;
			
		КонецЕсли;
...Показать Скрыть

Но все равно получаю ошибку в строке после "Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда" :

МнЧ.СтранаК = РаспредГТД.Страна.Код;
{E:\1C\BADDB\EXTFORMS\PRNFORMS\SF1137.ERT(528)}: Значение не представляет агрегатный объект (Код)


Гуру, спасайте! А то скоро начнут убивать...
pavlovskiy; +1 Ответить 2
65. Елена Л (ElenkaLisenka) 31.01.12 13:45
(64) jeam, у Вас
Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;


тут надо
МнЧ.СтранаН = РаспредГТД.Страна;
Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
МнЧ.СтранаК = РаспредГТД.Страна.Код;
КонецЕсли;
66. Владимир Говонкин (Neon3) 31.01.12 16:12
Подскажите всетаки что с такой ошибкой то делать
Возврат Константа.СуммыВПечатныхФормахПоУчету;
{Глобальный модуль(328)}: Поле агрегатного объекта не обнаружено (СуммыВПечатныхФормахПоУчету)
67. Jeam Stone (jeam) 31.01.12 16:45
(65) ElenkaLisenka,

А у меня так и написано в коде:

МнЧ.СтранаН = РаспредГТД.Страна;
            Если ПустоеЗначение(МнЧ.СтранаН)=0 Тогда
            МнЧ.СтранаК = РаспредГТД.Страна.Код;
            КонецЕсли; 

Не в этом дело.

Прикладываю 100 % работающий модуль Счета-фактуры 2012 в моей базе Торговля и Склад R770970.
Буду благодарен за комменты о работоспособности.
Прикрепленные файлы:
SF1137.ERT
red-IV; vevga2; +2 Ответить 2
68. Владимир Говонкин (Neon3) 31.01.12 17:20
Попробовал поставить 100% который неработает выдает все тоже
Возврат Константа.СуммыВПечатныхФормахПоУчету;
{Глобальный модуль(328)}: Поле агрегатного объекта не обнаружено (СуммыВПечатныхФормахПоУчету)
70. Елена Л (ElenkaLisenka) 01.02.12 20:07
(67) jeam,просто у вас вставлено не в том месте кода, надо было в этом:
ИначеЕсли КолСтрокГТД = 1 Тогда
РаспредГТД.ПолучитьСтрокуПоНомеру(КолСтрокГТД);
// одна строка в таблице. Товара с номером ГТД и страной в одной строке
МнЧ.НомерГТД = РаспредГТД.Номер;
МнЧ.СтранаН = РаспредГТД.Страна;
МнЧ.СтранаК = РаспредГТД.Страна.Код;
, ну думаю вопрос закрыт , раз у вас все получилось)))
71. Степан Мамонтов (Snowin) 03.02.12 12:14
(5) lemaxs, тоже самое выдавало! Завелось отсюда: http://infostart.ru/public/114658/
72. Евгений Вохмин (vevga2) 06.02.12 10:02
jeam спасибо, все работает!
73. Decker (twilight5023) 08.02.12 02:06
http://infostart.ru/public/114658/ - вот здесь две формы СФ для ТиС (с выбором грузоотправителя, грузополучателя и без), которые во-первых работают со всеми релизами ТиС, даже с самыми древними (тестировалось начиная с 7.70.927), во-вторых в них сразу исправлена ошибка в (64), в-третьих если эта форма сделана на основе официальных - то в ней присутствует еще одна ошибка - на некоторых реализациях в цикле ГТД обработка уходит в бесконечный цикл (ошибка кроется в функции ПодготовитьМнЧосн ;) Т.е. пользователи так и не увидят печатной формы. Со всеми этими проблемами я уже сталкивался. Вообщем - кому интересно, качаем.

p.s. Нисколько не хотел обидеть автора, просто вижу что у людей в теме давно решенные проблемы.
Ruslangab; Gavdis; +2 Ответить 2
74. Алексей Микрюков (masters1980) 20.02.12 11:23
Подскажите, пож-та, можно доработать сч/Ф так, чтобы не было разбивания ГТД по партиям таким образом (т.е. без в т.ч.), а каждую партию заполняла полностью: наименование, цена, .... страна, гтд? Многие покупатели не довольны этим "в т.ч." И наши поставщики выставляют нам именно такие сч\Ф без разбивания на "в т.ч.", а каждую строчку партии прописывают полностью.
75. Елена Л (ElenkaLisenka) 21.02.12 12:49
(74) masters1980, без табличной части тоже можно сделать
76. Алексей Микрюков (masters1980) 22.02.12 14:00
ElenkaLisenka, Вам очень трудоемко будет подсказать как это сделать?
Заранее благодарен!
78. Елена Л (ElenkaLisenka) 02.03.12 19:48
(75) Wladimir, Зайдите в справочник Валюты и измените код у рубля на 643.
79. Эдуард Лысенко (pingakyla) 12.03.12 12:49
(67) jeam, спасибо. все заработало. А то всю голову сломал.
80. Ruslan Gabidullin (Ruslangab) 12.03.12 19:39
(73) twilight5023,
Спасибо скачал, все работает
81. Руслан Владимирович (RASH999) 27.03.12 01:12
№ показатель отсутствует от показатель отсутствует, пишет когда не заполнены значения, не подскажите как довести до формы "К платежно-расчетному документу №_______от_________ ? бухгалтерия 7.7
82. элла иванова (2011b11) 04.04.12 12:17
(73) twilight5023, Спасибо Вам за подсказку все скачала, заработало, а то всю голову сломала как сделать новую счет-фактуру для старых релизов Торговли и Склад. Ещё раз большое спасибочки Вам.
83. Don Jon (donjon) 28.04.12 20:41
(75) Wladimir,
Дело скорее всего в том, что "код" - это код страны по ОКСМ: Россия - 643
Не надо путать с кодом валюты, где код рубля - 810
84. Эд Хз (Tatar_Ed) 05.12.13 10:44
Столкнулся как многие с необходимостью. данной печатной формы. Но текущая не подходит. не подскажите где найти.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа