gifts2017

7 печатных форм Счет-Фактур для использования в 2012 году

Опубликовал Тарас Лохтин (Одинец) в раздел Печать - Печатные формы документов

19 июля 2011 года Президент подписал закон № 245-ФЗ. Среди прочего, закон наконец-то вводит понятие «корректировочный счет-фактура», т.е. счет-фактура, составляемый при изменении цены реализации, если такое изменение произошло уже после отгрузки продукции (товаров) или выполнения работ (услуг).  Вот взял и адаптировал под действующую "Управление Торговлей, ред.10.3" печатные формы счет-фактур, что были под рукой.
24.01.2012 добавил новую печатную форму по постановлению Правительства Российской Федерации от 26 декабря 2011 г. № 1137

1. Постарался "отвязать" от общих модулей, путем переноса функций в модуль обработки.

2. Вставил проверку на существование реквизитов "НаАванс", "УдаленНаАванс" типа:      

МетаданныеДокумента = СсылкаНаОбъект.Метаданные();
     Если ЕстьРеквизитДокумента("НаАванс", МетаданныеДокумента) Тогда
            Если СсылкаНаОбъект.НаАванс = Истина Тогда
                   Возврат Неопределено;
            КонецЕсли;
      ИначеЕсли ЕстьРеквизитДокумента("УдалитьНаАванс", МетаданныеДокумента) Тогда
             Если СсылкаНаОбъект.УдалитьНаАванс = Истина Тогда
                    Возврат Неопределено;
      КонецЕсли;
  КонецЕсли;
3.  Поправил шапки печатных форм, шрифт, масштаб, ориентацию везьде сделал ТРАДИЦИОННОЙ :) 
4.  Авторегистрация.

Скачать файлы

Наименование Файл Версия Размер
PrnForms_SF2012.rar 223
.rar 187,47Kb
24.01.12
223
.rar 187,47Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Prozer (Prozer) 19.01.12 14:53
Судя по приведённому коду применен классический метод создания печатной формы с копированием процедур и функций печати в обработку с добавлением "СсылкаНаОбъект" и т.д. незабываем что существует еще метод с заменой контекста формы описанный http://infostart.ru/public/66588/. Замечательно что автор попытался отвязаться от релиза внеся общие модули в обработку и тем самым продлить жизнь своей разработке. Не забывайте указывать что ваши формы работают только с толстым клиентом и давать ваши комментарии о управляемом приложении. За оперативность "отлично".
2. Тарас Лохтин (Одинец) 24.01.12 09:37
Под действующую "Управление Торговлей, ред.10.3.15.6" (на платформе 8.2) добавил новую печатную форму по постановлению Правительства Российской Федерации от 26 декабря 2011 г. № 1137 тут: http://infostart.ru/public/103895/
3. Сергей Ожерельев (Поручик) 24.01.12 09:44
(2) >>>> Под действующую "Управление Торговлей, ред.10.3.15.6"
Слепнем?

Управление торговлей, редакция 10.3 Версия 10.3.15.6
Релиз конфигурации, опубликованный на данной странице, предназначен только для тестирования!
4. Александр Беляев (~gekK@~) 24.01.12 15:15
Быстро и качественно. незаменимая помошь в ежедневном монотонном кодинге. отличная вещь однозначно попадает в стандартный набор
5. Александр Шувалов (ssh1972) 24.01.12 19:04
Тарас, здравствуйте! Прилип с новой формой счет фактуры на УТ10,3 платформа 8.2 - пришлите пожалуйста Вашу внешнюю печатную форму , если не трудно ssh1972@mail.ru Заранее спасибо! PS. Скачать с infostart баллов пока не хватает
6. Airat Ya (Trium) 24.01.12 23:58
Хорошая разработка. Автору респект.
7. евгений крутицин (dkal) 25.01.12 00:31
Хотелось бы узнать работают данные формы для версии 8,2 редакция 10.3 (10.3.7.8)?
8. Alexey Drujkov (extremehelp) 25.01.12 00:54
Спасибо очень вовремя, а то все бухгалтера в ауте.
9. Steve Gordon (SGordon1) 25.01.12 11:11
10. Ев Ау (ev9457) 25.01.12 13:48
Новые печатные формы счетов-фактур и корректировочных счетов-фактур
http://its.1c.ru/invoice1137/
абсолютно без платно
AloneWolf; +1 Ответить
11. Alik Gap (lahaine) 26.01.12 11:46
(7) dkal, Для версии 8.1 не работает не может конвертировать, а 8.2 не пробовал. Скачивал с http://www.its.1c.ru/invoice1137/
12. Сергей Журавлев (Серж69) 26.01.12 15:51
большое дело сделали!
спасибо!
13. Гость 26.01.12 17:01
14. lol lol (hellchief) 26.01.12 17:05
спасибо очень помогло ,!
17. Алекс Ю (AlexO) 28.01.12 00:49
(11) lahaine,
конечно, у 1с ни один объект не конвертируется из 8.2 в 8.1.
18. WendyH (WendyH) 28.01.12 08:05
(11) lahaine, Интересно, а почему люди до сих пор работают с 1с 8.1 и не переходят на 8.2?
19. Darkid Darkid (Darkid) 28.01.12 19:28
Подскажите, где найти новую счет-фактуру для УТ 10.2 под 8.1????? Или, хотя бы, под 8.2
20. Petr (sevipa) 29.01.12 23:20
почему не переходят на 8.2? Ну у меня тут недавно появился такой клиент, у них был собственный программист, который так систему перелопатил, что при обновлении на 82 система просто рушится, и теперь надо все либо переписать но уже на 82, либо попытаться научить их работать в типовой конфе...
21. Настя МММ (Floory) 30.01.12 11:51
Спасибо!
Как раз вовремя
22. Iwan Pleshkow (Iwan777) 31.01.12 12:01
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (ВидСчетаФактуры)

СчетФактура1137.epf

Платформа 8.2.15.289
УТ 10.3.14.5

В чём проблема?
23. NtS (NtS) 31.01.12 20:06
спасибо, 1с как всегда...... до сих пор новая УТ не выпущена
24. Ionmuerto 01.02.12 12:46
Для конфигурации управления торговлей 11 как запустить печатную форму из формы без подключения дополнительных печатных форм.?
25. Ильнур Муртазин (capricorn2828) 03.02.12 23:42
26. StronG-X (Dethmond) 03.02.12 23:45
Большое спасибо, реально помогли)))
27. Вадим Сайфутдинов (svad1) 05.02.12 09:41
28. Rino (Rino) 08.02.12 12:26
Большое спасибо, реально помогли)))
29. nshrek nshrek (nshrek) 10.02.12 20:18
а есть внешние печатные формы для 1с 8.1 конфигурации Бухгалтерия 1.6? А то очень надо. самому лень делать, но знакомые просят, буду признателен.
31. serg85 (serg85) 26.04.12 16:51
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа