gifts2017

Универсальный Реестр 8.2

Опубликовал Владислав Данилин (Legavaz) в раздел Отчеты - Разное

Реестр документов для конфигураций 8.2 изначально писалось для УТ 11 версии.(управ. форма)
Адаптирован под компоновку данных
Выбор любых полей по документу
Функционал множественного Отбора
расчет итогов "СуммаДокумента",(для ут11 Сумма без НДС)

Реестр документов для конфигураций 8.2 изначально писалось для УТ 11 версии, для чего установлен блок кода дополнительного расчета колонки НДС.
В отчете есть недочеты:
1)Нельзя открыть документ, используя механизм расшифровки.
2)Расчет НДС  происходит не в запросе.
за что прошу прощения у пользователей и коллег.

Код открыт и доступен.

Кто сможет подсказать по поводу расшифровки обязательно доработаю.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Реестр Документов
.erf 12,72Kb
08.02.12
206
.erf 12,72Kb 206 Скачать
Реестр Документов с возможностью подключения внешнего отчета.
.erf 14,83Kb
08.02.12
30
.erf 14,83Kb 30 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Marysia Marysia (Marysia) 18.01.12 06:43
Универсальный Реестр 8.2 - т.е. получается что на любой конфигурации будет работать, или это только в теории?
2. vain79 (vain79) 18.01.12 07:44
Вопрос автору, итоги есть?
3. Владислав Данилин (Legavaz) 18.01.12 08:49
(1) Универсальный это значит для любой 8.2
(2) Обязательно
4. Marysia Marysia (Marysia) 18.01.12 08:52
(3) Legavaz, Спасибо за ответ. Будем пробовать.
5. rasswet (rasswet) 25.01.12 13:33
я знаю что если в отчетах управляемая форма а конфа обычная скажем ЗУП, формы не открываются эти. как тут? откроется?
6. Владислав Данилин (Legavaz) 25.01.12 15:38
если обычное приложение то вы ничего не увидите, упр. приложение обязательно.
7. Владимир Андреев (ulovka) 26.01.12 02:15
В УТ 11.0.7.13 в администрирование - дополнительные отчеты и обработки прописываю вашу обработку. Указываю раздел командного интерфейса, скажем для раздела администрирование. Далее пытаюсь вызвать через администрирование - дополнительные отчеты. Пишет "Дополнительные отчеты не предусмотрены для раздела: Раздел "Аминистрирование". В итоге получается запустить отчет только через файл-открыть. Что я делаю не так?
8. Владислав Данилин (Legavaz) 26.01.12 09:24
в настоящее время обработка не может использоваться в спр. внешних обработок, в ближайшее время этот недочет будет устранен. Спасибо за комментарий.
9. Владимир Андреев (ulovka) 27.01.12 23:49
(8) Legavaz,
Плюсую авансом, ждем доработанную версию.
11. Lizi60 (Lizi60) 08.03.12 12:42
Конечно плюсую. Спасибо за красивый отчет.
12. Фаниль Хасанов (Fanil) 11.03.12 14:17
Очень хорошая обработка Все работает ставим +
13. Александр (dex3) 22.03.12 15:00
При задании периода на сегодня ( например 20.03.12-20.03.12) дает не все документы ( например реализации), а если захватывать следующий день (20.03.12-21.03.12), до дает инфу всю за 20.0.3.12 и часть по 21.03.12.
14. Владислав Данилин (Legavaz) 22.03.12 22:39
(13)ок, проверю и исправлю.
спасибо.
15. protlt (protlt) 22.03.12 23:07
Плюс. Намного лучше типового реестра.
16. ut2k5 (ut2k5) 21.04.12 20:09
Автор, однозначно тебе респект. На текущий момент лучший реестр!
17. ut2k5 (ut2k5) 21.04.12 21:31
Вставь нижеследующий код в модуль объекта твоего отчета
И получишь полноценно подключаемый внешний отчет (ут 11.0.7.19)
... (код писал на скоряк, больше копи-пастом, сильно не ругайте, не было времени)

//
// СЛУЖЕБНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ РЕГИСТРАЦИИ ОБРАБОТКИ
//

// Сервисная экспортная функция. Вызывается в основной программе при регистрации обработки в информационной базе
// Возвращает структуру с параметрами регистрации
//
// Возвращаемое значение:
//		Структура с полями:
//			Вид - строка, вид обработки, один из возможных: "ДополнительнаяОбработка", "ДополнительныйОтчет", 
//					"ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов"
//			Назначение - Массив строк имен объектов метаданных в формате: 
//					<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//					Например, "Документ.СчетЗаказ" или "Справочник.*". Параметр имеет смысл только для назначаемых обработок, для глобальных может не задаваться.
//			Наименование - строка - Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию.
//			Информация  - строка - Краткая информация или описание по обработке.
//			Версия - строка - Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу.
//			БезопасныйРежим - булево - Принимает значение Истина или Ложь, в зависимости от того, требуется ли устанавливать или отключать безопасный режим 
//							исполнения обработок. Если истина, обработка будет запущена в безопасном режиме. 
//
//
Функция СведенияОВнешнейОбработке() Экспорт
	
	//Инициализируем структуру с параметрами регистрации
	ТекстОписания	= "Реестр документов с возможностью СКД";
	
		
	ПараметрыРегистрации = ПолучитьПараметрыРегистрации(, "Реестр документов", ТекстОписания);
	ПараметрыРегистрации.Версия = "1.1";

	ТаблицаКоманд = ПолучитьТаблицуКоманд();

	ДобавитьКоманду(ТаблицаКоманд,
		"Реестр документов (универс.)",			// Представление команды в пользовательском интерфейсе
		"РеестрДокументов_СКД",					// Уникальный идентификатор команды
		"ОткрытиеФормы"
	);

	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

	Возврат ПараметрыРегистрации;

КонецФункции

//
// ВСПОМОГАТЕЛЬНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ РЕГИСТРАЦИИ ОБРАБОТКИ
//

// Формирует структуру с параметрами регистрации регистрации обработки в информационной базе
//
// Параметры:
//	ОбъектыНазначенияФормы - Массив - Массив строк имен объектов метаданных в формате: 
//					<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//					или строка с именем объекта метаданных 
//	НаименованиеОбработки - строка - Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию.
//							Необязательно, по умолчанию синоним или представление объекта
//	Информация  - строка - Краткая информация или описание обработки.
//							Необязательно, по умолчанию комментарий объекта
//	Версия - строка - Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу.
//
//
// Возвращаемое значение:
//		Структура
//
Функция ПолучитьПараметрыРегистрации(ОбъектыНазначенияФормы = Неопределено, НаименованиеОбработки = "", Информация = "", Версия = "1.0")

	Если ТипЗнч(ОбъектыНазначенияФормы) = Тип("Строка") Тогда
		ОбъектНазначенияФормы = ОбъектыНазначенияФормы;
		ОбъектыНазначенияФормы = Новый Массив;
		ОбъектыНазначенияФормы.Добавить(ОбъектНазначенияФормы);
	КонецЕсли; 
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");

	ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
	ПараметрыРегистрации.Вставить("Назначение", ОбъектыНазначенияФормы);
	
	Если Не ЗначениеЗаполнено(НаименованиеОбработки) Тогда
		НаименованиеОбработки = ЭтотОбъект.Метаданные().Представление();
	КонецЕсли; 
	ПараметрыРегистрации.Вставить("Наименование", НаименованиеОбработки);
	
	Если Не ЗначениеЗаполнено(Информация) Тогда
		Информация = ЭтотОбъект.Метаданные().Комментарий;
	КонецЕсли; 
	ПараметрыРегистрации.Вставить("Информация", Информация);
	
	ПараметрыРегистрации.Вставить("Версия", Версия);

	Возврат ПараметрыРегистрации;

КонецФункции


// Формирует таблицу значений с командами печати
//	
// Возвращаемое значение:
//		ТаблицаЗначений
//
Функция ПолучитьТаблицуКоманд()

	Команды = Новый ТаблицаЗначений;
	
	//Представление команды в пользовательском интерфейсе
	Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
	
	//Уникальный идентификатор команды или имя макета печати
	Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
	
	//Способ вызова команды: "ОткрытиеФормы", "ВызовКлиентскогоМетода", "ВызовСерверногоМетода"
	// "ОткрытиеФормы" - применяется только для отчетов и дополнительных отчетов
	// "ВызовКлиентскогоМетода" - вызов процедуры Печать(), определённой в модуле формы обработки
	// "ВызовСерверногоМетода" - вызов процедуры Печать(), определённой в модуле объекта обработки
	Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
	
	//Показывать оповещение.
	//Если Истина, требуется показать оповещение при начале и при завершении работы обработки. 
	//Имеет смысл только при запуске обработки без открытия формы
	Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
	
	//Дополнительный модификатор команды. 
	//Используется для дополнительных обработок печатных форм на основе табличных макетов.
	//Для таких команд должен содержать строку ПечатьMXL
	Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

	Возврат Команды;

КонецФункции

// Вспомогательная процедура.
//
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор = "ФормаОтчета")

	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = Представление;
	НоваяКоманда.Идентификатор = Идентификатор;
	НоваяКоманда.Использование = Использование;
	НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
	НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры
...Показать Скрыть
18. Наталья Рома (Naton) 21.03.13 12:29
(14) Legavaz,
Не создает реестр документов по перемещениям в Рознице 2.0
С чем это связано?
19. Наталья Рома (Naton) 21.03.13 12:38
Вопрос снят - при формировании отбора выбрала не тот реквизит
20. Александр Хомяк (logarifm) 10.02.14 12:35
Ошибка при выполнении файловой операции 'E:\data\1C_ERP-prof\Хомяк\FastReports\Other\РеестрДокументовУФ.erf'
по причине:
Неверный формат хранилища данных.

Платформа: 1С:Предприятие 8.3 (8.3.4.389)

Не открывается ни в конфигураторе ни в предприятии соответственно.
21. Роман Озеряный (rozer) 22.09.14 22:18
(3) Legavaz, подскажу по расшифровке:

1) в форме добавить реквизит "ДанныеРасшифровки" (тип Строка)

2) поменять код на

ДанныеРасшифровкиСКД  = Новый ДанныеРасшифровкиКомпоновкиДанных;
КомпоновщикМакета 	= Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(МакетСКД,
Настройки, ДанныеРасшифровкиСКД);
ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеНаборыДанных,ДанныеРасшифровкиСКД, Истина);
ДанныеРасшифровки = ПоместитьВоВременноеХранилище(ДанныеРасшифровкиСКД, ЭтаФорма.УникальныйИдентификатор);
...Показать Скрыть


3) добавить обработку расшифровки для поля табл. документа "Результат"

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;     
	ИсточникНастроек = Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет);     
	ОбработкаРасшифровкиКД = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, ИсточникНастроек);           
	ВыполненноеДействие = Неопределено;     
	ПараметрДействия = Неопределено;     
	ОбработкаРасшифровкиКД.ВыбратьДействие(Расшифровка, ВыполненноеДействие, ПараметрДействия);           
	Если ВыполненноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда                       
		Если ВыполненноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда                                   
			ОткрытьЗначение(ПараметрДействия);                             
		КонецЕсли;                  
	КонецЕсли;    
КонецПроцедуры
...Показать Скрыть


Бинго!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа