gifts2017

Для бухгалтера. Устанавливаем новые ставки налогов и отчислений 2012. Бух Украина.

Опубликовал Дмитрий Литовченко (kompas-dm) в раздел Обработки - Универсальные обработки

Устанавливаем для расчета заработной платы новые ставки налогов на 2012 г. Просто выполнить обработку и не забыть отправить благодарность автору. Писал для своих клиентов. Помогу и Вам, бухгалтера.

Обработка простейшая - найти и установить, а польза большая ...

Не забываем посмотреть что нового в "Пакете отчетов"

Скачать файлы

Наименование Файл Версия Размер
СтавкиНалогов2012 6
.ert 182,50Kb
19.01.12
6
.ert 182,50Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Ленгин (vlengin) 20.01.12 10:23
"Писал для своих клиентов."
Отрываем обработку "ОбновлениеРелиза", ищем строку "291", вырезаем кусок "ИначеЕсли КонецЕсли", комментарим две строки, вставляем в новую обработку. Все. Написал.
2. Дмитрий Литовченко (kompas-dm) 20.01.12 11:20
(1)Указано : "Для бухгалтера". Обновление релиза "типовой обработкой", вслепую, можно просто уложить базу клиента. Решение за Вами. Вырезайте "ИначеЕслиКонецЕсли" для себя.
3. Владимир Ленгин (vlengin) 20.01.12 13:21
"Вырезайте "ИначеЕслиКонецЕсли" для себя".
Давно сделал, точней сказать - не вырезал, а скопировал. Меня смутил глагол "писал" в Вашей публикации (ведь не надо и строчки кода, что-бы сделать эту обработку). Хотя может Вы и действительно это писали? Кто знает?
4. Дмитрий Литовченко (kompas-dm) 20.01.12 13:33
(3)Похоже, вы даже не смотрели программный код...

Перем СпрНиО;
Процедура изменить(ЧтоНалог)
Если СпрНиО.НайтиПоКоду(ЧтоНалог) = 1 Тогда
СпрНиО.Дополнительно.Установить('01.01.12', "Макс. база=18241;");
СпрНиО.Дополнительно.Установить('01.04.12', "Макс. база=18598;");
СпрНиО.Дополнительно.Установить('01.07.12', "Макс. база=18734;");
СпрНиО.Дополнительно.Установить('01.10.12', "Макс. база=19006;");
СпрНиО.Дополнительно.Установить('01.12.12', "Макс. база=19278;");
сообщить("Изменен "+ЧтоНалог+" Дополнительно");
КонецЕсли;
конецпроцедуры
Процедура изменить_предел(ЧтоНалог)
Если СпрНиО.НайтиПоКоду(ЧтоНалог) = 1 Тогда
СпрНиО.Предел.Установить('01.01.12', 1073);
СпрНиО.Предел.Установить('01.04.12', 1094);
СпрНиО.Предел.Установить('01.07.12', 1102);
СпрНиО.Предел.Установить('01.10.12', 1118);
СпрНиО.Предел.Установить('01.12.12', 1134);
сообщить("Изменен "+ЧтоНалог+" Предел");
КонецЕсли;
конецпроцедуры


Процедура Сформировать()

СпрНиО = СоздатьОбъект("Справочник.НалогиОтчисления");
Если СпрНиО.НайтиПоКоду("НДФЛОсн") = 1 Тогда
СпрНиО.Предел.Установить('01.01.12', 10730);
сообщить("Изменен Предел НДФЛОсн");
КонецЕсли;
Если СпрНиО.НайтиПоКоду("ЛьготыНДФЛ") = 1 Тогда
//Порог льготы НДФЛ равен ПрожМинТруд*1,4 округлено до 10 грн,
СпрНиО.Дополнительно.Установить('01.01.12', "Порог=1500;Коэф.уменьшения=0.5;");
сообщить("Изменен Дополнительно ЛьготыНДФЛ");
КонецЕсли;
изменить_предел("ПрожМинТруд") ;
изменить_предел("МинЗарплата") ;
изменить("ЕдиныйВзнос") ;
изменить("ФЗПЕСВ") ;
изменить("ФЗПЕСВЛет") ;
изменить("ФЗПЕСВБюдж") ;
изменить("ФЗПЕСВИнв") ;
изменить("ФЗПЕСВгпх") ;
изменить("ФЗПЕСВБольн") ;
предупреждение("Выполнено");

конецпроцедуры

Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа