gifts2017

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД

Опубликовал Lel Braun (lelbraun) в раздел Программирование - Практика программирования

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

Ошибка возникает по причине того, что расчет ставки налога ФФОМС и ТФОМС идут следом друг за другом и вычисленная ставка налога для ФФОМС затирается затем ставкой налога для ТФОМС (которая в этом году равна 0%)

Для исправления этой ситуации было добавлено пару строк в модуль документа "ЗакрытиеМесяца". 

со строки № 7254

было:

Если РезультатФФОМС <> 0 Тогда
ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);
ТаблицаРаспределения.ВыбратьСтроки();
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
КонецЦикла;
КонецЕсли;

стало:

Если РезультатФФОМС <> 0 Тогда
ИмяШкалыВзносов = "ФФОМС"; //добавлено LB2012
СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,ДатаКон) / 100; //добавлено LB2012

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);
ТаблицаРаспределения.ВыбратьСтроки();
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
КонецЦикла;
КонецЕсли;

------

и со  строки №7263

было:

Если РезультатТФОМС <> 0 Тогда 

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);

ТаблицаРаспределения.ВыбратьСтроки();

Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл

СформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);

СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);

КонецЦикла;

КонецЕсли;


стало:

Если РезультатТФОМС <> 0 Тогда 

ИмяШкалыВзносов = "ТФОМС";//добавлено LB2012

СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,ДатаКон) / 100;//добавлено LB2012

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);

ТаблицаРаспределения.ВыбратьСтроки();

Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл

СформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);

СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);

КонецЦикла;

КонецЕсли;

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Lel Braun (lelbraun) 09.02.12 16:46
При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".


Перейти к публикации

1. 1801 09.02.12 16:46
Спасибо, полтора часа убил на поиск так и не нашел ошибки! А тут готовое решение.
Еще исправьте ошибку в тексте публикации, а то при копировании в модуль ругается на синтаксис.
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 ЦиклСформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения,
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа