gifts2017

Редактирование журнала расчетов в 1С v7.7.

Опубликовал Слава Кирлан (Ягг) в раздел Обработки - Обработка документов

Универсальная обработка для редактирование результатов в журнале расчетов в 1С v7.7.

Обработка предназначена для редактирования результатов расчетов журнала расчета в текущем периоде.

На закладке «Расчеты подлежащие редактированию» выбираются виды расчетов, которые планируются редактировать.

В список «Сотрудники» добавляются сотрудники, чьи расчеты планируются к редактированию.

Нажатием кнопки «Загрузить» происходит чтение журнала расчетов.

В колонке «Результат» можно вбить новое значение (поле 1).

Строки, которые нужно сохранить, отмечаются в колонке «Исправить» (поле 2) – это дополнительная защита от случайного исправления. Вообще-то в колонке  предполагается вывод картинки, но с целью универсальности вывод картинки отключен (можно включить в коде), и просто выводится 1 или ничего.

По нажатии кнопки «Сохранить» те записи, у которых у которых в поле «Исправить» стоит «1», редактируются в журнале расчетов.

Примечание. Была обнаружена ошика в модуле обработки (из-за изменения состава процедур глобального модуля). Ошибка устранена 27.03.2012.

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Редактирование журнала расчетов
.ert 71,00Kb
27.03.12
56
.ert 71,00Kb 56 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Виктор Клименко (dicwork) 01.02.12 14:18
Не работает - выдает ошибки
Подозреваю, что в глобальном модуле требуется процедура ПредставлениеВР
ТаблЗап.вид=ПредставлениеВР<<?>>(Жрн.ВидРасч);
{C:\TEST\KLIMENKO\РЕДАКТИРОВАНИЕ ЖУРНАЛА ЗАРПЛАТ.ERT(60)}: Функция не обнаружена (ПредставлениеВР)
Расчеты.ДобавитьЗначение(рас,СокрЛП(ПредставлениеВР<<?>>(рас)));
{C:\TEST\KLIMENKO\РЕДАКТИРОВАНИЕ ЖУРНАЛА ЗАРПЛАТ.ERT(90)}: Функция не обнаружена (ПредставлениеВР)
Расчеты.ДобавитьЗначение(рас,СокрЛП(ПредставлениеВР(рас)<<?>>));
{C:\TEST\KLIMENKO\РЕДАКТИРОВАНИЕ ЖУРНАЛА ЗАРПЛАТ.ERT(90)}: Неопознанный оператор
<<?>>КонецЦикла;
{C:\TEST\KLIMENKO\РЕДАКТИРОВАНИЕ ЖУРНАЛА ЗАРПЛАТ.ERT(92)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
2. Слава Кирлан (Ягг) 03.02.12 07:00
Видимо в конфигруации в глобальном модуле отсуствует функция ПредставлениеВР. Страно, раньше была.
Смысл этой функции на самом деле просто в текстовом виде представить вид расчета - не самая важная процедура.

Предлагаюв этом случае в модуль формы обработки добавить функцию

Функция ПредставлениеВР(ВидРасч)
возврат СокрЛП(ВидРасч)
КонецФункции
3. Евгений Конов (Евгений34) 16.03.12 15:01
вот и и справляй, а не вылаживай жалобу за фуфло на тебя нужно подать чтоб проверял что вылаживаеш пусть забанят
4. Слава Кирлан (Ягг) 27.03.12 12:14
(3) Евгений34, Конфигурации время от времени меняются, и, к сожалению, отслеживать все изменения во всех внешних обработках задача не благодарная. Тем более, что на моих семерошных базах она работает (они конечно очень давно не обновлялись - процентов на 80 это уже самописные базы).

Впрочем, согласен, ее надо было проверить на типовой (виноват). Исправлю.

Исправил :)
5. Светлана Иванова (Cvetic) 29.03.12 09:20
В стандартной конфигурации ЗиК для исправлений существует Документ.Исправление. Документ используется для исправления архивных данных для того, чтобы "подогнать" эти данные под отчеты. Он вызывается из пункта "Исправления" меню "Документы". В документе выбирается сотрудник, которому нужно внести исправления, и конкретный архивный период. При выборе периода в окне отображаются все данные из журнала расчетов за этот выбранный период. В графе "Исправления" дублируются данные результатов, дней, часов, которые можно изменять.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа