gifts2017

Отключение интернет-поддержки при старте БП 2.0.32.4

Опубликовал Дядя Федор (dachnik) в раздел Администрирование - Сервисные утилиты

С обновлением на БП 2.0.32.4 у многих возникла проблема с запуском - база зависала на старте на попытке подключения к web-ИТС. Данная обработка предназначена для отключения интернет-поддержки без ковыряния конфигурации.

С обновлением на БП 2.0.32.4 у многих возникла проблема с запуском - база зависала на старте на попытке подключения к web-ИТС. Данная обработка предназначена для отключения интернет-поддержки без ковыряния конфигурации.

 

 

Можно просто запустить следующий код на выполнение при помощи похожей обработки.


ВыбПользователи   = ПользователиИнформационнойБазы.ПолучитьПользователей();

Если ВыбПользователи.Количество()>0 тогда
       Для Каждого Пользователь Из ВыбПользователи Цикл
             ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей","ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь, , Пользователь.Имя);
             ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь , Пользователь.Имя);
             Сообщить("Для пользователя " + Пользователь.Имя + " интернет-поддержка отключена");
       КонецЦикла;
 Иначе
       ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь);
       ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
       Сообщить("Интернет-поддержка отключена");
КонецЕсли;

 

Если конфигурацию не жалко, можно и просто снять выполнение процедуры Интернет-поддержки. Для этого

В модуле обычного приложения ищем процедуру ПроверитьЗапускСтартовогоПомощникаИПанелиФункций()

В ней в самом конце комментируем строчку
// Запуск интернет-поддержки работы пользователей.
ИнтернетПоддержкаПользователейКлиент.СтартоватьМеханизм("systemStart");

Проверка web-ИТС теперь отключена при запуске.

 

UPD 04/04/12  Обработка исправлена для работы с более поздними версиями

 

 

Скачать файлы

Наименование Файл Версия Размер
отключениеПроверки.epf 351
.epf 5,71Kb
04.04.12
351
.epf 5,71Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
Комментарии
1. Сергей Ожерельев (Поручик) 26.01.12 21:01
2. Сергей Ожерельев (Поручик) 26.01.12 21:06
Плагиат, надранный с мисты и отсюда.
3. Дядя Федор (dachnik) 26.01.12 21:08
(1) Позвольте поинтересоваться, вы сравнивали обработки или просто чешется?
4. q_i 27.01.12 17:32
а мне эта публикация даже больше нравится, чем "Установка даты напоминания интернет поддержки БП 2.0.32", т.к. здесь прямо в тексте написано какой код выполнить.
CrazyCD; wolfsoft; +2 Ответить
5. q_i 31.01.12 11:10
по-моему, запятой не хватает:
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь , Пользователь.Имя);
даже если просто сравнить с:
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей","ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь, , Пользователь.Имя);
6. heseh (heseh) 01.02.12 09:03
Если конфигурацию не жалко

Жалко знаете ли...

Поручик +1
7. Александр Хоменко (scape) 01.02.12 10:16
8. avers (Hellisad) 01.02.12 16:48
9. Сергей Шепелев (redgoll) 03.02.12 12:49
Главное, что рейтинг не нужно тратить, скачивая обработку. Так что +1 от меня товарищи.
10. Алексей (artspeed) 04.02.12 14:16
Не нарушает ли эта обработка
1) конфигурацию
2) Права 1С.

???

За идею +1
11. Елена * (Lenka_Boo) 06.02.12 09:19
Миста, не миста, а флудить вынуждают.
Информацию считаю пользительной.
Так что +1.
12. q_i 07.02.12 11:48
(9) redgoll, хочешь завещать свой рейтинг детям? ;)
13. Сергей Шепелев (redgoll) 07.02.12 12:14
(12) q_i, просто, дружище, он не настолько высок, чтобы его тратить понапрасну. А сидеть-накручивать, честно говоря, некогда.
spetzpozh; +1 1 Ответить
14. Максим 1 (maxster545) 09.02.12 08:55
15. Евген Каравашкин (Lokiy) 12.03.12 07:45
В Типовой бухгалтерии появился общий модуль Пользователи - теперь обработка выпадает с ошибкой,
автор- переименуй переменную.

вот модуль:

Процедура КнопкаВыполнитьНажатие(Кнопка)
ВыбПользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
Если ВыбПользователи.Количество()>0 тогда
Для Каждого Пользователь Из ВыбПользователи Цикл
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь, , Пользователь.Имя);
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь , Пользователь.Имя);
Сообщить("Для пользователя " + Пользователь.Имя + " интернет-поддержка отключена");
КонецЦикла;
Иначе
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь);
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
Сообщить("Интернет-поддержка отключена");
КонецЕсли;
КонецПроцедуры
16. Дядя Федор (dachnik) 05.04.12 01:43
(15) Lokiy, спасибо, исправился. Моя локальная переменная пересеклась с появившейся глобальной. Теперь работает и в версии 34.7
17. Серж Иванов (adminfo2002) 13.04.12 12:43
(2) Поручик, какая разница, плагиат или нет? Главное, что увидел тут и воспользовался.

Миста - вообще скатилась до уровня быдло-форума.
spetzpozh; ArikiteSun; +2 1 Ответить 1
18. Сергей Ожерельев (Поручик) 13.04.12 12:47
(17) Ты о чём? Все уже давно забыли эту хрень.
19. Александр Фонарев (vfon) 16.07.12 15:18
Автору спасибо! Рекомендую!

Эта СУПЕР-поддержка достала!
....Для НЕ продвинутых пользователей - она слишком сложна и путана
....Для Продвинутых пользователей (когда это необходимо) - нет проблем - адрес в браузер и ву-а-ля....
А вот задержка ПРИ КАЖДОМ ЗАПУСКЕ на 5-15 сек (в зависимости от состояния сервера и интернета) это слишком.
Вот не пробовал, а сколько она будет ждать, если не доберется до узла 1С при неполадках в Интернете?


Алгоритм реализован в '1С:Предприятие 8.2 (8.2.15.318)' для 'Бухгалтерия предприятия, редакция 2.0 (2.0.37.10)'
Сделана внешняя обработка (она не затрагивает конфигурацию, находящуюся на поддержке).
Однократный запуск и ЭТО отключено.
Возможно после обновления конфы эти параметры снова сбросятся на вкл. Web-поддержки.
Придется обработку повторить.
prettyj; spetzpozh; +2 1 Ответить
20. Arikite (ArikiteSun) 12.09.12 17:58
Автору спасибо за идею.

Немного модифицировал обработку и раздал своим лентяям :)

Еще раз спасибо
+1
spetzpozh; +1 1 Ответить
21. Михаил Ражиков (tango) 12.09.12 18:06
22. Дядя Федор (dachnik) 25.09.12 14:17
(21) tango, простите новичка, просто нужен был рейтинг, а он пропал у меня, после того как по просьбе я снял свою первую публикацию с адаптациями сф1137 от 1с под старые конфы.
Впрочем, я считаю, что моя публикация хоть и дублирует функционал обработки, на которую ссылается Поручик (она у меня, кстати не сработала, т.к. на тот момент не работала с базами без пользователей), но оформлена лучшим образом. Пусть будет.
linuxmaster; +1 Ответить
23. Лев Корл (lev6975) 20.06.14 13:05
Создайте внешнюю обработку с формой по умолчанию, и в событии кнопки"Выполнить"вставьте:
ИнтернетПоддержкаПользователейВызовСервера.УстановитьНастройкуПовторитьПопыткуПодключенияПриСтартеПрогр­аммы(Ложь);
Ну, и, исполните её в предприятии, оно и исчезнет(пока в сервисе не нажмёте на"интернет-поддержка пользователей":-)))