gifts2017

Внешние формы Торг-12 и СФ для типовой бухии 7.7. Печать как выданных, так и полученных (ну, т.е. от поставщика) из документов поступления

Опубликовал Саша (Хряк) в раздел Печать - Печатные формы документов

Ничего особенного. Кладём формы в ExtForms\PrnForms, регистрируем для нужных документов, пользуемся при печати.
Если зарегистрировать формы для доков поступления (например, ПоступлениеМатериалов),- распечатаются как документы от поставщика.
СФ печатаются по 1137, 451 и 283 постановлениям в зависимости от даты.
Если положить в прнформс ещё и эту разработку http://infostart.ru/public/89294/, то можно и фио руководителей-гавбухов и проч реквизиты заполнять во входящих документах.
Может кому и пригодится.

Ничего особенного. Кладём формы в ExtForms\PrnForms, регистрируем для нужных документов, пользуемся при печати.
Если зарегистрировать формы для доков поступления (например, ПоступлениеМатериалов),- распечатаются как документы от поставщика.
СФ печатаются 1137, 451 и 283 в зависимости от даты.
Если прнформс ещё и эту разработку http://infostart.ru/public/89294/, то можно и фио руководителей-гавбухов и проч реквизиты заполнять во входящих документах.
Может кому и пригодится.

Однако, в доке ПоступлениеТоваров нет кнопки печать...
Добавим?
Для желающих, опишу последовательность действий, они не сложны, с копи-пастом, думаю, все справятся.
зы:Описываю что и где копировать из конфигурации, но можно копировать и отсюда.

1.Открываем форму дока, где есть кнопа Печать, например, ПоступлениеМатериалов.
2.Копируем кнопку Печать и слева от неё кнопу выбора печформы и вставляем в форму ПоступлениеТоваров.
3.Открываем модуль формы ПоступлениеМатериалов, вверху модкля копируем

Перем ТаблицаПечФорм;  // список печатных форм документа
Перем НомерТекущейФормы;

аналогично вставляем в начало модуля формы ПоступлениеТоваров

4.Идем вниз модуля формы ПоступлениеМатериалов, копируем

ТаблицаПечФорм  = СоздатьОбъект("ТаблицаЗначений");
ТаблицаПечФорм.НоваяКолонка("Название","Строка",,,,30);
ТаблицаПечФорм.НоваяКолонка("Файл","Строка",,,"Файл",10);
ТаблицаПечФорм.НоваяКолонка("Кнопка","Строка",,,,10);
ТаблицаПечФорм.НоваяКолонка("ФайлОписания","Строка");
 
вставляем в самый конец модуля формы ПоступлениеТоваров после строк

СписокВариантовОтраженияВозврата.ДобавитьЗначение(1, "в книге покупок");
СписокВариантовОтраженияВозврата.ДобавитьЗначение(0, "в книге продаж");

 5.Ищем в модуле формы ПоступлениеМатериалов 2 процедуры
//******************************************************************************
// ПоКнопкеПечать()
//
// Вызывается из формул элементов диалога:
//  Кнопка "кнПечать".
//
// Описание:
//  Определяется соответствующая печатная форма.
//  
Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
 
 Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
  НомерТекущейФормы = 1;
  Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
 КонецЕсли;
 
 Если НомерТекущейФормы = 1  Тогда
  Печать();
  
 Иначе
  Параметры = СоздатьОбъект("СписокЗначений");
  Параметры.ДобавитьЗначение(Контекст, "Контекст");
  Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
  Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
  
  ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
 КонецЕсли;
 
КонецПроцедуры // ПоКнопкеПечать()

//******************************************************************************
// ПоКнопкеВыборПечатнойФормы()
//
// Вызывается из формул элементов диалога:
//  Кнопка "кнВыбПечать".
//
// Описание:
//  - открывает список для выбора способа печати.
//  - формирует таблицу по выбранному способу.
//
Процедура ПоКнопкеВыборПечатнойФормы()
 
    ВыбНомер = глВыборПечатнойФормы("Документ." + Вид(), ТаблицаПечФорм);
 Если ВыбНомер > 0 Тогда
  НомерТекущейФормы = ВыбНомер;
  Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
  ПоКнопкеПечать();
 КонецЕсли;

КонецПроцедуры // ПоКнопкеВыборПечатнойФормы()

копируем и вставляем в конце модуля ПоступлениеТоваров перед строкой

//******************************************************************************
Новый = 0;

Во вставленном тексте процедуру ПоКнопкеПечать заменить на этот текст, либо заккоментировать строки (т.е. поставить // в начале стоки) как показано ниже

//******************************************************************************
// ПоКнопкеПечать()
//
// Вызывается из формул элементов диалога:
//  Кнопка "кнПечать".
//
// Описание:
//  Определяется соответствующая печатная форма.
//  
Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
 
 кСтрок=ТаблицаПечФорм.КоличествоСтрок();
 Если кСтрок>0 Тогда
  Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
   НомерТекущейФормы = 1;
   Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
  КонецЕсли;
  
//  Если НомерТекущейФормы = 1  Тогда
   //Печать();
   
//  Иначе
   Параметры = СоздатьОбъект("СписокЗначений");
   Параметры.ДобавитьЗначение(Контекст, "Контекст");
   Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
   Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
   
   ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
//  КонецЕсли;
 КонецЕсли;
 
КонецПроцедуры // ПоКнопкеПечать()

 6. Ищем в модуле формы ПоступлениеМатериалов конец процедуры поиском по "// ПриОткрытии",  строки

 // Заполним таблицу для выбора печатной формы
 НомерТекущейФормы = глУстановкаКнопкиПечать(Контекст, "Документ." + Вид(),ТаблицаПечФорм);

копируем и вставляем по аналогии в конец процедуры ПриОткрытии формы ПоступлениеТоваров

 

Собссно всё. Сохраняем, пользуемся, наслаждаемя.

Не забываем, что вы внесли изменения в конфигурацию при обновлении.

Но даже если забыли, это не критично, на данные не влияет, повторяем вышеописанные действия и всё.

В общем, при определенной сноровке, делов на 5 мин.

Всем Удачи!

Скачать файлы

Наименование Файл Версия Размер
внешняя форма Торг-12 180
.ert 69,50Kb
02.05.12
180
.ert 69,50Kb Скачать
внешняя форма СФ 106
.ERT 68,50Kb
02.05.12
106
.ERT 68,50Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Саша (Хряк) 02.02.12 17:37
Ничего особенного. Кладём формы в ExtForms\PrnForms, регистрируем для нужных документов, пользуемся при печати.
Если зарегистрировать формы для доков поступления (например, ПоступлениеМатериалов),- распечатаются как документы от поставщика.
СФ печатаются по 1137, 451 и 283 постановлениям в зависимости от даты.
Если положить в прнформс ещё и эту разработку http://infostart.ru/public/89294/, то можно и фио руководителей-гавбухов и проч реквизиты заполнять во входящих документах.
Может кому и пригодится.



Перейти к публикации

1. Владимир Говонкин (Neon3) 02.02.12 17:37
Вопрос такой. Эта счет фактура выданная новой формы уже и будит ли она работать на комплексной конфигурации?
2. Саша (Хряк) 02.02.12 21:57
формы сф и новой 1137, и старой 451, и ещё старее 283. Печатаются в зависимости от даты документа, новая - с 24.01.12
Вроде в заголовке написано - для типовой бухии, в комплексной работать врятли будет.
3. Елена Иванчеглова (morpod) 25.04.12 16:59
Документы от поставщика печатаются только из поступления товаров, а не материалов, печально:(
4. Саша (Хряк) 25.04.12 21:21
не понял, переведи, какие документы не печатаются из поступления материалов
5. Елена Иванчеглова (morpod) 21.05.12 10:49
Извините, не увидела сразу ответа. У Вас 2 обработки и та которая - торг 12 подхватывается только из документов поступлений товара. Счет-фактура нормально выводится, только номер счет фактуры ставит такой же как номер поступления.
6. Саша (Хряк) 21.05.12 13:31
хммм, ничё не понимаю
торг-12 и из поступления материалов печатается
вы зарегистрировали форму для пост.материалов?
8. Andrey Lipin (LipinAA) 13.07.12 14:35
Автору респект! работает
9. krreezz krreezz (krreezz) 22.05.13 15:49
нужна новая счет-фактура 1137 ...
10. Александр (AlexInqMetal) 07.11.13 15:29
Спасибо, работает. А для УСН никто не видел похожей разработки?
11. Александр (AlexInqMetal) 07.11.13 17:22
(10), + нашел вот такую для УСН http://infostart.ru/public/14582/ немного подправить и работает
12. Ольга - (ENITA) 24.05.14 16:14
(9) krreezz, Вы не нашли сч/ф по форме 1137. Если нашли, дайте ссылку, пжл.
13. Павел Ефимов (masticore) 24.05.14 16:43
По бухгалтерии 7.7 здесь только транспортную накладную оперативно не выложили, остальное либо 1с реализовала, либо здесь.
Эта обработка печатает и по 1137.
Есть внешняя печатная форма (в том числе и под старые релизы) причём выложена "в открытом виде", можете обновить бухгалтерию предприятия до 542 версии (не требует подписки на ИТС, но и новая РСВ не будет функционировать).

Учтите, что в Торговле и Склад функционал страна-код ОКСМ уже был, а в бухгалтерии/УСН он доделывался средствами 1с, да и в неоптимальном виде (в справочнике ГТД добавили третий параметр без выбора из имеющегося справочника стран мира).
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа