gifts2017

Счёт-фактура 2012 по форме пост. 1137 для "старой" ТиС 7.7 (делалась под релиз 932) с учетом ИП

Опубликовал Alexander Volkov (anvpro) в раздел Печать - Печатные формы документов

Счёт-фактура 2012 по форме пост. 1137 для "старой" ТиС 7.7 (делалась под релиз 932) с учетом ИП.
Не секрет, что выпущенная 1C форма счета-фактуры не работает в старых релизах, а обновить переработанную конфигурацию очень сложно.
Более того "старые" релизы "выгибались" для реализации учета в ИП. Представляю один из вариантов нового счета-фактуры для таких случаев.

Тестировал на двух разных базах при чем довольно сильно переработанных.

Отличительной особенностью здесь является реакция на счет-фактуры где не указана страна - ошибка не выдается а берется по-умолчанию Россия, так же идет проверка ИП это или нет по анализу того что вписано в реквизиты Главбуха - если там цифры - значит это свидетельство и выводим как ИП берем от туда свидетельство.

сам бланк был подредактирован в плане того, что когда фио предпринимателя длинные они не помещаются на строке - было отменено объединение ячеек - чтоб помещалось (это может не треоваться). свиду - все как в оригинале.

ниже вывод комманды diff в сравнении с текстом оригинала 1С - думаю тут все должно быть понятно:

 

80,87c80
<     
<     Если Докум.ДатаДок >= глДатаПостановления451 Тогда
<         Рекв.ДобавитьЗначение(Шаблон("Продавец [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");
<         
<     Иначе
<         Рекв.ДобавитьЗначение(Шаблон("Продавец [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");
<         
<     КонецЕсли;    
---
>     Рекв.ДобавитьЗначение(Шаблон("Продавец [Докум.Фирма.ЮрЛицо.ПолнНаименование]"), "Поставщик");
109,112c102,108
<     
<         // Индивидуальный предприниматель
<     Если Докум.Фирма.ЮрЛицо.ИндивидуальныйПредприниматель = 1 Тогда
<         Рекв.ДобавитьЗначение("", "РуководительРасшифровка");
---
>
>     ИП=0; //Если в главбухе нет цифр - значит это не перекривленная под ИП старая база
>     Для iИП=0 По 9 Цикл
>      ИП=ИП+Найти(Докум.Фирма.ЮрЛицо.ГлБухгалтер.Получить(Докум.ДатаДок),Формат(iИП,"N"));    
>     КонецЦикла;
>     Если (ИП > 0) Тогда
>         Рекв.ДобавитьЗначение("", "РуководительРасшифровка");
114,115c110,111
<         Рекв.ДобавитьЗначение(Шаблон("№ [Докум.Фирма.ЮрЛицо.СвидетельствоСерияНомер] от [Докум.Фирма.ЮрЛицо.СвидетельствоДатаВыдачи] г."), "ПредпринимательРеквизитыСвидетельства");
<         Рекв.ДобавитьЗначение(Шаблон("/[Докум.Фирма.ЮрЛицо.Руководитель.Получить(Докум.ДатаДок)]/"),"ПредпринимательРасшифровка");
---
>         Рекв.ДобавитьЗначение(Шаблон("/[Докум.Фирма.ЮрЛицо.Руководитель.Получить(Докум.ДатаДок)]/"),"ПредпринимательРасшифровка");
>         Рекв.ДобавитьЗначение(Шаблон("/[Докум.Фирма.ЮрЛицо.ГлБухгалтер.Получить(Докум.ДатаДок)]/"), "ПредпринимательРеквизитыСвидетельства");
335,343c331,339
<     Если глЕстьРеквизитШапки("КодОперации", ВидОсн) = 1 Тогда
<         БратьСуммыИзУчета = глБратьСуммыИзУчета(Докум.ДатаДок, Докум.ДокОснование.КодОперации);
<     Иначе
<         БратьСуммыИзУчета = глБратьСуммыИзУчета(Докум.ДатаДок);
<     КонецЕсли;
<     
<     Если БратьСуммыИзУчета = 1 Тогда
<         СкорректироватьТаблицуОснования(Докум, ТаблицаОснования, ВидОсн);
<     КонецЕсли;
---
> //    Если глЕстьРеквизитШапки("КодОперации", ВидОсн) = 1 Тогда
> //        БратьСуммыИзУчета = глБратьСуммыИзУчета(Докум.ДатаДок, Докум.ДокОснование.КодОперации);
> //    Иначе
> //        БратьСуммыИзУчета = глБратьСуммыИзУчета(Докум.ДатаДок);
> //    КонецЕсли;
>     
> //    Если БратьСуммыИзУчета = 1 Тогда
> //        СкорректироватьТаблицуОснования(Докум, ТаблицаОснования, ВидОсн);
> //    КонецЕсли;
486c482,492
<             
---
>
>
>             //Добавим реакцию на отсутсвие страны - если нет - Россия (643)
>             Попытка
>                     СтранаН = РаспредГТД.Страна;
>                     СтранаК = РаспредГТД.Страна.Код;
>             Исключение
>                     СтранаН = "Россия";
>                     СтранаК = "643";
>             КонецПопытки;
>
497a504,508
>                 
>                 Если (МнЧ.СтранаН = "") И (МнЧ.СтранаК = "")  Тогда
>                     МнЧ.СтранаН = СтранаН;
>                     МнЧ.СтранаК = СтранаК;
>                 КонецЕсли;
503,504c514,515
<                 МнЧ.СтранаН     = РаспредГТД.Страна;
<                 МнЧ.СтранаК     = РаспредГТД.Страна.Код;
---
>                 МнЧ.СтранаН     = СтранаН;
>                 МнЧ.СтранаК     = СтранаК;
524,525c535,536
<                     МнЧ.СтранаН     = РаспредГТД.Страна;
<                     МнЧ.СтранаК     = РаспредГТД.Страна.Код;
---
>                     МнЧ.СтранаН     = СтранаН;
>                     МнЧ.СтранаК     = СтранаК;

 

Кстати, порадую людей знакомых с Linux вышеуказанным текстом можно пропатчить оригинальный 1совый текст и получить подправленный.

Скачать файлы

Наименование Файл Версия Размер
SF1137_TIS_OLD.zip 21
.zip 15,53Kb
16.05.12
21
.zip 15,53Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Alexander Volkov (anvpro) 14.02.12 01:02
Счёт-фактура 2012 по форме пост. 1137 для "старой" ТиС 7.7 (делалась под релиз 932) с учетом ИП.
Не секрет, что выпущенная 1C форма счета-фактуры не работает в старых релизах, а обновить переработанную конфигурацию очень сложно.
Более того "старые" релизы "выгибались" для реализации учета в ИП. Представляю один из вариантов нового счета-фактуры для таких случаев.


Перейти к публикации

1. Alexey Drujkov (extremehelp) 14.02.12 01:02
У нас на складе тоже старая ТИС и очень нужна эта новая форма , подредактировали и всё работает ...
Спасибо большое за данную обработку . А то бухгалтера весь мозг выели, всё думал, как я буду все это делать и рисовать? А тут добрый человек все за нас сделал и нарисовал, за это ему большой респект и жирный плюс . Еще раз спасибо большое за обработку и за скорость и оперативность .
2. Руслан Владимирович (RASH999) 02.04.12 22:42
а счет фактуру на аванс печатает?
3. Alexander Volkov (anvpro) 03.04.12 00:10
нет, к сожалению, только обычная счет-фактура. Просто небыло задачи так глубоко рыть :-)
4. Руслан Владимирович (RASH999) 03.04.12 00:22
с авансами такая дрянь щас((( сделать надо а толком кодов нет, да и в конфе перемещали коды как через мясорубку, не пойму где эта зараза сворачивает все строки в одну сумму(
5. Дмитрий Ширшов (zoomer120) 15.05.12 11:32
ДА не могу же я скачать её.........
6. Alexander Volkov (anvpro) 17.05.12 08:31
(5) zoomer120, Действительно был какой-то сбой, и файл перестал закачиваться, но теперь все - ок, можно пользоваться :-)