gifts2017

Ведомость по партиям товаров на складах по Видам документов (Детализация по операциям) УТ 10.3

Опубликовал Юрий Зайцев (Yury1001) в раздел Отчеты - Управленческие

В стандартный отчет Ведомости по партиям 10-й торговли добавлено поле Вид документа, которое можно использовать для группировки строк или колонок. К стандартным показателям добавлены тоннаж (кг) и литраж в декалитрах.

Для тех, кто ещё помнит ТиС 9.2 (7.7) поясню коротко: там в некоторых отчетах (по партиям, расчетам, кассе) есть галка Детализация по операциям – это что-то типа того.

 

Для тех, кому интересна механика, рассказываю:

//К стандартному запросу для построителя отчетов добавляем поле ВидДокумента следующего содержания:

ПодТекстЗапроса = "";

//Так как я не знаю как получить вид документа как самостоятельное поле в запросе написал SELECT…CASE так сказать:)

Для Каждого Документа из Метаданные.Документы Цикл

Если Документа.Движения.Содержит(Метаданные.РегистрыНакопления.ПартииТоваровНаСкладах) Тогда

// Имя каждого документа, который двигает нужный нам регистр добавляем в ВЫБОР

                МеждуСтрок = "ВЫБОР КОГДА ИсточникДанных.Регистратор ССЫЛКА Документ."

                                                   + Документа.Имя +

                                                  " ТОГДА """

                                                   + Документа.Синоним +

                                                  """ ИНАЧЕ ""не выбран"" КОНЕЦ";

// Каждый следующий документ добавляем в ИНАЧЕ предыдущего, последний останется для остатков

                ПодТекстЗапроса = ?(ПодТекстЗапроса = "", МеждуСтрок,

                                    СтрЗаменить(ПодТекстЗапроса, """не выбран""", МеждуСтрок));

КонецЕсли;

КонецЦикла;


Остается лишь вставить Подстоку + «КАК ВидДокумента» и наслаждаться.

 

Некоторые мои клиенты, главные бухгалтера в основном, любят отчет по партиям как инструмент глобального контроля ситуации, оперативного поиска «косяков» и всё такое. Представленное дополнение повышает наглядность просторов выполненных операций и облегчает поиск исключительных ситуаций и всяких там неожиданностей.

 

Тоннаж и литраж использует стандартные реквизиты единицы измерения (Ед. для отчетов) Вес и Объём, последний делится на 10.

  

Отчет «тугой» ибо включена принудительно периодичность Регистратор.

Модуль без пароля.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ВедомостьПартииТоваровНаСкладахПоВидам
.erf 19,84Kb
09.07.15
222
.erf 19,84Kb 222 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. grozen 06.04.12 14:19
Отчет пригодился. +.

Только в SQL не заработал в "чистом виде".

Ошибка СУБД:
Microsoft OLE DB Provider for SQL Server: Выражения Case могут быть вложенными только до уровня 10.

Пришлось модифицировать код, оставив только интересующие меня виды документов:

Если Найти("ВозвратТоваровПоставщику/ВозвратТоваровПоставщикуИзНТТ/Спис­аниеТоваров/ПеремещениеТоваров/РеализацияТоваровУслуг/ОтчетО­РозничныхПродажах", Документа.Имя) = 0 Тогда
Продолжить;
КонецЕсли;
2. Юрий Зайцев (Yury1001) 06.04.12 15:58
3. Антон Чарушкин (hulio) 06.04.12 16:05
(1) grozen, интересно, а какая у вас версия SQL?
6. Андрей Пашин (Andryxa) 23.10.12 22:12
Гениально, спасибо Юрий! Очень пригодился отчет именно в таком виде!
7. andrey dyak (dyak84) 24.01.13 15:51
Автор отчет то что нужно только подскажите будет ли работать в УТ для украины. Зарание спасибо за ответ
8. Sergey Samartsev (Evgenych) 06.03.13 08:25
9. Ольга (tarkyl) 17.09.13 13:45
10. rjhonson 05.02.14 11:32
Отличный отчет, очень пригодился
Все наглядно и интуитивно понятно
11. mic auto (4ur) 06.02.14 13:07
Интересно, есть ли такой отчет хотя бы в одной из конфигураций на СКД?
12. mic auto (4ur) 23.05.14 16:56
Интересно, а на СКД такой отчет уже реализован, или пока все только на Построителе отчетов?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа