bdd2

Резервы отпусков. Оценочные обязательства (96 счет)

Опубликовал Владимир Анашкин (kondrp) в раздел Отчеты - Бухгалтерские

Обработка позволяет:
- рассчитывать сумму оценочных обязательств предстоящих отпусков по каждому сотруднику;
- рассчитывать сумму страховых взносов по оценочным обязательствам;
- формировать проводки по оценочным обязательствам (кредит 96 счета);
- проводить инвентаризацию оценочных обязательств;
- получать отчет по сформированным оценочным обязательствам (механизм СКД);
- максимально использовать типовые механизмы расчета дней отпуска и сумм среднего заработка, заложенные в ЗУП 2.5 и УПП 1.3.


Версия 1.24 от 15.03.2016

Исправлено:

1. Исправлена ошибка возникающая при проведении инвентаризации отпусков;

2. Внесены изменения в обработку начального заполнения настроек;

3. Изменено заполнение служебного документа "Начисление отпуска" для корректного расчета среднего заработка.



Версия 1.23 от 26.11.2015

Исправлено:

1. Установка аналитики для 2 и 3 субконто в проводках по бухгалтерскому и налоговому учету;

2. При расчете страховых взносов учитывается ставка ФСС для временно пребывающих иностранцев.


Добавлено:

1. Подсистема работы с сохранением данных расчета. Новая подсистема позволяет ускорить расчет среднего заработка, а также обеспечить корректность получения сумм начальных остатков отпусков. Для хранения данных используется справочник "ХранилищеДополнительнойИнформации".

2. Раздел "Данные для расчета текущего месяца". Содержит список сохраненных настроек расчета за ближайшие 6 месяцев. Если установлен флаг "Использовать сохраненные данные" и выбрана настройка, то при расчете среднего заработка суммы будут браться из сохраненных данных.

3. Раздел "Сумма среднего заработка". Позволяет при расчете среднего в текущем месяце использовать данные среднего заработка предыдущего месяца. (При этой методике средний заработок остается неизменным каждый месяц периода).

4. Контекстная справка ко всем пунктам закладки "Параметры". При нажатии на символ "?" происходит переход к интересующему разделу обработки;

5. Таблица соответствий статей затрат начислений и статей затрат страховых взносов и ФСС НС. Таблица дает возможность установить в обработке отличные от типовых статьи затрат отражения проводок по страховым взносам и ФСС НС. Переход к таблице осуществляется по гиперссылке "Проверить соответствие статей затрат";

6. В таблице "Резервы" изменены иконки для состояний физлиц: "Иностранец", "Отпуск по уходу", "Превышен предел ПФР", "Уволен", "Инвалид";

7. Расширены возможности ручного редактирования реквизитов табличной части "Резервы". Измененные вручную строки отмечаются цветом. При нажатии на правую кнопку мыши на нужной строке -> можно отменить ручные изменения и вернуться к авторасчету;

8. Возможность редактировать остатки отпусков и открывать типовую справку по отпуску на выбранного сотрудника. (При нажатии на правую кнопку мыши на нужной строке табличной части "Резервы");

9. Кнопка "Сравнить". Открывает форму встроенного отчета. Отчет позволяет сравнить суммы по типовому расчету резервов и расчету, выполненному с помощью обработки.

 

 

 

История вопроса:

Как известно, до 1 января 2011 года организации имели право создавать резервы в целях равномерного включения предстоящих расходов в издержки производства или обращения отчетного периода, например по оплате вознаграждений по итогам года.

В 2012 в соответствии с ПБУ 8/2010 «Оценочные обязательства, условные обязательства и условные активы» организации обязаны отражать в отчетности оценочные обязательства. Это положение обязательно для всех организации, кроме субъектов малого предпринимательства.

 

Так как наша организация далеко не субъект малого предпринимательства, встал вопрос - как же теперь рассчитывать оценочные обязательства (резервы предстоящих расходов).

Выяснилось, что специального порядка для расчета величины оценочного обязательства в ПБУ не предусмотрено, но сказано, что денежная оценка такого обязательства должна отражать наиболее реальную величину расходов, необходимых для расчетов по нему.

 

Типовая конфигурация "1С:Зарплата и управление персоналом 8" предлагает для расчета оценочных обязательств метод, предусмотренный статьей 324.1 НК РФ.

Суть метода заключается в том, что отраженный в учетной политике процент умножается на сумму расходов по оплате труда и страховых взносов за каждый месяц. Полученная сумма записывается в документ "Отражение зарплаты в регламентированном учете" в виде проводок Дт "счет затрат" - Кт 96.

Закрытие оценочных обязательств (Дт96 - Кт70, Дт96 - Кт69) также происходит в документе "Отражение зарплаты в регламентированном учете", но при условии наличия в этом месяце документов "Начисление отпуска сотрудникам организаций".

Кроме того, с помощью настроек учетной политики можно добиться отражения оценочных обязательств только по бухгалтерскому учету. В этом случае по налоговому учету будут формироваться суммы временных разниц. Эти суммы временных разниц, в свою очередь, закрываются автоматически при закрытии оценочных обязательств.

Механизм отличный ! А самое главное полностью реализован в типовой конфигурации. Казалось бы - живи и радуйся. Но, как часто бывает, бухгалтерию такой механизм не устроил. Поэтому была поставлена задача написать новый механизм расчета и начисления оценочных обязательств.

Результатом плодотворного сотрудничества с бухгалтерией стала внешняя обработка табличной части документа "Отражение зарплаты в регламентированном учете". Ее я и представляю на Ваше рассмотрение.

 

Как это работает:

Принцип действия обработки достаточно прост. Как известно, типовой механизм "1С:Зарплата и управление персоналом 8" по учету остатков отпусков предоставляет возможность получать остатки неиспользованного отпуска на любую дату. Поэтому, используя дату начала текущего месяца, дату начала следующего месяца и количество дней использованного отпуска можно легко получить количество дней отпуска, которое необходимо начислить по сотруднику в текущем месяце.

Далее получаем средний заработок за предыдущие 12 месяцев.

Умножаем количество дней отпуска на средний заработок и получаем сумму оценочного обязательства.

От полученной суммы расчетным путем находим суммы страховых взносов, с учетом предела дохода с начала года.

И все! Готово!

Все необходимые суммы у нас на руках, остается только сформировать проводки Дт "счет затрат" - Кт96. Счета затрат и аналитика (способ отражения в бух.учете) выбираются по упрощенному аналогу типового механизма формирования проводок.

Проводки по закрытию(зачету) оценочных обязательств обработка не затрагивает, т.к. типовая конфигурация "1С:Зарплата и управление персоналом 8" отлично справляется с этой задачей.

 

Как подключить: (Видео)


 

Как провести инвентаризацию по оценочным обязательствам: (Видео)



 

Как настроить учетную политику по оценочным обязательствам:

Для настройки учетной политики необходимо зайти в справочник "Организации". Выбрать нужную организацию и нажать кнопку "Перейти" -> "Настройки параметров учета" в верхней панели списка организаций.

Подробное описание настройки учетной политики по оценочным обязательтсвам здесь...

 

 

Как получать обновления после приобретения обработки:

Если Вы уже приобрели данную обработку (начиная с версии 1.23), то можете бесплатно получать обновления.

Данная схема получения бесплатных обновлений действует в течение всего 2016 года.

 

 

Feedback (Обратная связь).

Данную обработку я постарался сделать максимально простой и понятной.

Но с Вашей помощью обработка может стать еще более удобной и универсальной!

Поэтому я жду от Вас предложений по дальнейшему развитию, а также информацию о возможных ошибках и неточностях.

Гарантия возврата денег

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
Распределение оценочных обязательств v1.24 от 15.03.2015
17.03.2016
3000 руб.

Моментальная
доставка

См. также

Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Юлия Мазур (JJMM) (86.00 $m)
Добавить вознаграждение
Комментарии
101. plushe4ka 24 05.04.12 13:23 Сейчас в теме
обновлена до 2.5.49.1, поэтому и удивилась
102. Владимир (vladir) 104 05.04.12 13:29 Сейчас в теме
(100)В случае если сформировано новое подразделение и в него набраны новые сотрудники, то в документ "Отражение ЗП в регл учете" за этот месяц будет добавлена строка по этому подразделению с нулевой суммой.
В процедуре КнопкаПеренестиДанныеВДокументНажатие(Элемент) добавить проверку
	// Переносим данные в табличную часть "ОтражениеВУчете"
	Для Каждого СтрокаПромежуточная из ТаблицаПромежуточная Цикл
		Если СтрокаПромежуточная.Сумма <> 0 Тогда 
			СтрокаОтражениеВУчете = ОбъектЗаполнения.ОтражениеВУчете.Добавить();
			ЗаполнитьЗначенияСвойств(СтрокаОтражениеВУчете, СтрокаПромежуточная);
		КонецЕсли;
	КонецЦикла;
...Показать Скрыть
103. Павел Никифоров (Lyns_owner) 259 05.04.12 13:35 Сейчас в теме
Я, видимо, чего-то не понимаю, но почему не воспользоваться типовым механизмом расчета резервов отпусков?
104. Владимир Анашкин (kondrp) 889 05.04.12 13:38 Сейчас в теме
(101) plushe4ka,
Хорошо. Обязательно проверю. По результатам напишу комментарий или обновлю публикацию.
105. Владимир (vladir) 104 05.04.12 13:41 Сейчас в теме
(103) Типовой механизм работает отлично, вот только понять бы, как вычислить процент... :(
106. Владимир Анашкин (kondrp) 889 05.04.12 13:44 Сейчас в теме
(105) vladir,
Извините, но не до конца понял вопрос: Какой процент ?
107. Павел Никифоров (Lyns_owner) 259 05.04.12 13:47 Сейчас в теме
(105) vladir, Есть множество материала в интернете по этому поводу.
108. Владимир Анашкин (kondrp) 889 05.04.12 13:49 Сейчас в теме
(103) Lyns_owner,
Ну наверное потому что типовой механизм считает процент от базы и совершенно не учитывает остатки дней по отпускам, а также количество дней будущего отпуска, которое начисляется каждому сотруднику в текущем месяце.
109. Владимир (vladir) 104 05.04.12 14:18 Сейчас в теме
(107) Lyns_owner, статьи читал, мнения очень разноречивые и готовой таблетки, как посчитать процент отчислений от базы в резерв не нашел. Каждый делает так, как ему кажется правильным. :)
110. Павел Никифоров (Lyns_owner) 259 05.04.12 14:22 Сейчас в теме
(109) vladir, В такой стране живем)
111. Владимир (vladir) 104 05.04.12 14:32 Сейчас в теме
(110) Дык отож... :) Еще бы понять, каким документом в конце года закрыть этот резерв, начислить - то начислили а не израсходовали... :(
112. Павел Никифоров (Lyns_owner) 259 05.04.12 14:49 Сейчас в теме
(111) vladir, Есть обратный вариант, более интересный: что делать, если перерасходовали? вариантов несколько...
113. Владимир (vladir) 104 05.04.12 14:54 Сейчас в теме
(112) Доначислить руками в доке "Отражение ЗП в регл. учете" по нужному подразделению скоко надо.
114. Владимир Анашкин (kondrp) 889 05.04.12 15:03 Сейчас в теме
(111) vladir, (112) Lyns_owner,

1. Если начислили и неизрасходовали, то в конце года по результатам инвентаризации делается доначисление. Желательно в декабре.
2. Если начислили меньше чем израсходовали, то те же проводки, что при доначислении только с минусом. Опять же в декабре.

Функционал инвентаризации остатков отпусков еще не настроен, но обязательно будет реализован в обсуждаемой нами обработке.
115. Владимир (vladir) 104 05.04.12 15:20 Сейчас в теме
(114) Спасибо, kondrp, будем ждать. Очень уж расплывчатая эта инвентаризация, нигде не нашел толкового ей объяснения... Опять же у меня не ЗУП, а КА, надо будет под неё подстраивать. Ещё маленький вопросик. Это у меня в КА только или в ЗУП так же, что при выборе "порядка оценочных обязательств" => "по сумме начислений", упорно ставила "Ставку ПФР страховая" не нулевую, ну и соответственно считала сумму? Или это задумка такая? Пришлось немного допилить.
116. Владимир Анашкин (kondrp) 889 05.04.12 15:34 Сейчас в теме
(115) vladir,
А какую ставку ставила? не 10% случайно ?
И можно узнать, что такое КА ?
117. Владимир (vladir) 104 05.04.12 15:36 Сейчас в теме
Да кажется 10, брала из СтавкаПФРСолидарная = 10. Не очень понимаю, что это...
118. Владимир (vladir) 104 05.04.12 15:37 Сейчас в теме
КА это комплексная автоматизация :)
119. Владимир Анашкин (kondrp) 889 05.04.12 15:55 Сейчас в теме
(117) vladir, (118) vladir,

"Комплексная автоматизация" - конечно, как сам не догадался.

Солидарная часть пенсии, та часть которая начисляется даже когда доходы перевалили за 512000 рублей. Но при способе расчета резерва "По начислениям" солидарной части быть не должно. Это ошибка обработки. Исправлю и выложу новый релиз.
120. Владимир (vladir) 104 05.04.12 16:30 Сейчас в теме
(119) Сделал так: В процедуре ЗаполнитьТаблицуРезервы() после коммента

	// Определяем ставки страховых взносов
	...
	СтавкаПФРСтраховая      = СтруктураСтавкиСтраховыхВзносов.СтавкаПФРСтраховая; 
	СтавкаПФРНакопительная  = СтруктураСтавкиСтраховыхВзносов.СтавкаПФРНакопительная;
	Если СтавкаПФРНакопительная = 0 И СтавкаПФРСтраховая = 0 Тогда 
		СтавкаПФРСолидарная = 0;
	Иначе 
		СтавкаПФРСолидарная = 10;
	КонецЕсли;
...Показать Скрыть
122. Владимир Анашкин (kondrp) 889 05.04.12 18:28 Сейчас в теме
(120) vladir,
Можно конечно и так, но в публикации будет несколько иначе.
123. Sieg Heil (mdie) 74 06.04.12 06:52 Сейчас в теме
(100) kondrp, подтверждаю, что в 49-й зарплате отсутствует в этом регистре данное поле.
124. Владимир Анашкин (kondrp) 889 06.04.12 07:55 Сейчас в теме
(123) mdie,
Согласен с Вами. Ошибка действительно есть и она исправлена в релизе v1.08 от 06.04.2012.
Новый релиз уже размещаю.
125. Оксана Проненко (prochka) 09.04.12 11:50 Сейчас в теме
kondrp,
Есть такая важная бяка - Способ отражения в бух.учете.
Однако если у сотрудника было изменение этой бяки отличное от изначальной, то обработка почему-то не учитывает этот нюанс.
126. Андрей (magru) 09.04.12 12:03 Сейчас в теме
Если отпуск переходящий, например с января на февраль, то попадает сумма отпуска только января. Можно сделать, чтобы выходила сумма полностью по документу отпуска, т.к. человека расчитали в январе полностью.
127. Владимир Анашкин (kondrp) 889 09.04.12 12:35 Сейчас в теме
(126) magru,
Можно если в параметрах учета на закладке "Кадровый учет" установить значение переключателя "Остатки отпусков будут уменьшаться при регистрации фактических отпусков:" в значение "Кадровыми приказами"
128. Владимир Анашкин (kondrp) 889 09.04.12 12:37 Сейчас в теме
(125) prochka,
Вы имеете в виду, не учитывать способ отражения установленный документами "Ввод сведений об учете заработка работников" ?
129. Оксана Проненко (prochka) 09.04.12 14:18 Сейчас в теме
(128) kondrp,
Наоборот, обязательно учитывать. Но я почему-то этого не вижу, т.е. ставит способ отражения, зарегистрированный более ранним документом, а надо последним.
130. Владимир Анашкин (kondrp) 889 09.04.12 16:49 Сейчас в теме
(129) prochka,
Обязательно проверю. По результатам либо напишу комментарий, либо обновлю публикацию
131. Sieg Heil (mdie) 74 09.04.12 19:07 Сейчас в теме
Предусмотреть бы в ней изначальную поддержку УПП, а то не ЗУПом единым...
132. Владимир Анашкин (kondrp) 889 09.04.12 19:19 Сейчас в теме
(131) mdie,
Это конечно не моя первоочередная задача, но если будет время - возможно добавлю поддержку УПП
133. Соколов Вадим (vvsokolov) 282 10.04.12 14:57 Сейчас в теме
(103) Lyns_owner,
существует 2 способа расчета резервов: основной и упрощенный. В конфигурациях 1С реализован только упрощенный, т.е. процентом.
134. IrinaYr 10.04.12 15:01 Сейчас в теме
Наша бухгалтерия тоже закрепила в учетной политике основной способ расчета резервов. Теперь жалеют, так как погрешность упрощенного невелика. Но Учетную политику в этой части надо соблюдать не менее 2 лет.
135. Владимир Анашкин (kondrp) 889 10.04.12 18:37 Сейчас в теме
(134) IrinaYr,
А чем же не нравится способ, который сейчас закрепили ?
136. Андрей (magru) 11.04.12 11:41 Сейчас в теме
(127) kondrp,
В параметрах учета поставил "Кадровыми приказами", создал документ отпуска организаций по этому человеку. При заполнении документа "Отражение зарплаты в регл.учете" на закладе "основные начисления" 2 строки : одна за январь, другая за февраль. Но при расчете оценочных обязательств все равно берется в расчет только сумма января. Можно поподробнее как сделать, чтобы учитывалась полностью сумма переходящего отпуска.
137. Владимир Анашкин (kondrp) 889 11.04.12 13:17 Сейчас в теме
(136) magru,
Дело в том, что после изменения параметров на "Кадровые приказы" движения по регистру накопления "Фактические отпуска" будут делать не расчетные, а кадровые документы.

Т.е., в Вашем случае, после изменения параметров учета нужно перепровести кадровый документ "Отпуска организаций" и документ "Начисление отпуска сотрудникам организаций".
138. Владимир (vladir) 104 11.04.12 13:33 Сейчас в теме
(137) kondrp,
Существуют маленькие грабельки. У пользователя который запимается документами "Отражение зарплаты в регл.учете" нет "Полных прав доступа". => при закрытии обработки фиктивный документ "Начисление отпуска" удаляться не будет, что приведет к замусориванию базы...
139. Владимир Анашкин (kondrp) 889 11.04.12 16:11 Сейчас в теме
(138) vladir,
Согласен с Вами, есть такой неприятный момент.
В ближайшей публикации сделаю этот документ элементом формы с возможностью пометки его на удаление. (сейчас происходит полное удаление - если есть права).
140. Владимир (vladir) 104 11.04.12 17:29 Сейчас в теме
(139)kondrp,
Не знаю может быть пригодится? Немного добавил в обработку. Если фиктивного дока нет, тогда он создается, а в комменты пишется типа "@@@ Служебный документ для резервов отпусков @@@". При последующих запусках обработки по комменту находится этот фиктивный док. и используется для расчетов. Ну и соответственно при закрытии просто очищаются таб. части, а сам док не удаляется.
141. Владимир (vladir) 104 11.04.12 17:33 Сейчас в теме
И ещё. Не могу сообразить, нельзя ли сделать так, что бы при закрытии дока "Отражение ЗП.." закрывалась и обработка?
142. Владимир Анашкин (kondrp) 889 11.04.12 22:22 Сейчас в теме
(141) vladir,
Спасибо за комментарии. Реализую в ближайшие дни (как только время найду).
143. Insanity Coming (Insanity) 68 13.04.12 08:57 Сейчас в теме
(142) kondrp, У меня в базе несколько обособленных подразделений, на каждое настроены соответствующие права, и когда кадровики (без прав расчетчика) запускали эту обработку, начинали множиться документы "Начисление отпуска" (т.к. у них не было прав на непосредственное удаление этого дока). Права конечно я перенастроил, но считаю что было-бы неплохо предусмотреть такой вариант в обработке, и ПриЗакрытии() удалять документ в Попытке. Где-то так:

Попытка
НачислениеОтпускаОбъект.Удалить();
Исключение
НачислениеОтпускаОбъект.УстановитьПометкуУдаления(Истина);
НачислениеОтпускаОбъект.Записать(РежимЗаписиДокумента.Запись);
КонецПопытки;

это в продолжение (139) kondrp
144. dimon80 dimon80 (Dim_a_p) 13.04.12 09:00 Сейчас в теме
Также изменил запрос по периодам фактических отпусков, теперь должна браться не дата приказа, а период регистрации из регистра накопления "Фактические отпуска".
Правда есть одно "Но":
- Если в настройках выбрано "Отражать фактические отпуска расчетными документами", тогда при начислении переходящего отпуска в регистре накопления "Фактические отпуска" будет создано 2 записи (по одной на каждый месяц).
Т.е. при отражении фактических отпусков кадровыми документами переходящий отпуск в обработке будет отображаться в одном месяце (Считаю, что это некорректной работой типовой конфигурации).
Добавил возможность выводить данные по дополнительным отпускам (Количество дней дополнительного отпуска складывается с основным отпуском.)
145. Нина (нинас) 18.04.12 05:33 Сейчас в теме
Обработка очень нужная. А в КА будет работать?
146. Нина (нинас) 18.04.12 06:50 Сейчас в теме
При запуске вашей обработки в КА выдает ошибку
{Форма.Форма.Форма(1773)}: Значение не является значением объектного типа (ПериодРегистрации)
НачалоПериода = НачалоМесяца(ОбъектЗаполнения.ПериодРегистрации);
147. Владимир Анашкин (kondrp) 889 18.04.12 07:56 Сейчас в теме
(146) нинас,
Обработка изначально разрабатывалась для "1С:Зарплата и управление персоналом 8", затем, по просьбам трудящихся, я добавил поддержку "1С:Управление производственным предприятием 8". Но к сожалению у меня нет в наличии конфигурации "1С:Комплексная автоматизация 8", чтобы с нем можно было поэкспериментировать и реализовать совместимость обработки с данной конфигурацией.
Если у Вас есть метод решения проблемы совместимости обработки с КА, то опишите его, я возьму этот метод за основу в следующих публикациях.

Заранее благодарен.
148. Нина (нинас) 18.04.12 10:19 Сейчас в теме
Подцепила вашу обработку в КА, Работает. Не совсем поняла, Я должна настраивать учетную политику по учету оценочных обязательств?
149. Владимир Анашкин (kondrp) 889 18.04.12 11:00 Сейчас в теме
(148) нинас,
Учетная политика настраивается в параметрах каждой организации.

В моей обработке в форме "Настройки" на закладке "Параметры" также есть возможность просмотреть и изменить некоторые параметры учетной политики по оценочным обязательствам, но эти параметры действуют только пока обработка открыта и не сохраняются в системе.
150. f (juliad) 13 18.04.12 22:07 Сейчас в теме
спасибо огромное! очень пригодилась!
151. Василий (васисубатор) 64 19.04.12 11:44 Сейчас в теме
Подход к реализации - респект, расчет среднего лучше сделать без использования служебного документа (будет быстрее). На большой базе расчетчикам не позавидуешь.
152. Владимир Анашкин (kondrp) 889 19.04.12 13:12 Сейчас в теме
(151) васисубатор,
Нужно было сделать быстро, поэтому использовал документ.
В дальнейшем возможно уберу документ, но предусмотреть все ситуации, которые обрабатывает типовой расчет среднего заработка - немалый труд.
153. Alex Gru (Alexey_Gru) 35 19.04.12 13:30 Сейчас в теме
Очень полезная разработка! Большое спасибо!

Обнаружил следующую ошибку (версия обработки 1.09, версия ЗУП 2.5.49.2):
Обработка не работает у пользователей без роли "ПолныеПрава".

При запуске создается документ "НачислениеОтпускаРаботникамОрганизаций" с незаполненным полем "Сотрудник", которое обязательно для заполнения. Если у пользователя полные права, то сохранение документа (почему-то) выполняется. У расчетчиков зарплаты, кто пользуется данной обработкой роли "Пользователь", "РасчетчикРегламентированнойЗарплаты", "ИспользованиеВнешнихОтчетовИОбработок", и при попытке сохранения этого документа возникает ошибка "Недостаточно прав для выполнения операции с базой данных".

Я добавил перед записью документа заполнение поля "Сотрудник" первым сотрудником по списку (все равно при выполнении расчетов данное поле перезаполняется). После этого всё стало работать.
154. Владимир Анашкин (kondrp) 889 19.04.12 13:34 Сейчас в теме
(153) Alexey_Gru,
Спасибо за комментарий, обязательно проанализирую и исправлю.
155. Василий (васисубатор) 64 20.04.12 14:37 Сейчас в теме
исправил процедуру, для обязательств теперь две статьи соответствия (обязательства для начислений и обязательства для страховых)
Функция ПолучитьСтруктуруСоответствияСтатейЗатрат()

СтруктураСоответствиеСтатейЗатрат = Новый Структура;

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
| СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатратНачисления КАК СтатьяЗатратНачисления,
| СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатрат КАК СтатьяЗатратОтчисления
|ИЗ
| РегистрСведений.СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете КАК СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете
|ГДЕ
| СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.ВидСтатьиЗатрат = &ВидСтатьиЗатрат
|
|СГРУППИРОВАТЬ ПО
| СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатратНачисления,
| СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатрат";

Запрос.УстановитьПараметр("ВидСтатьиЗатрат", ОценочноеОбязательствоДляОтпуска);

Результат = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();

//начало исправления
//Если ВыборкаДетальныеЗаписи.Следующий() Тогда
// СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратНачисления" , ВыборкаДетальныеЗаписи.СтатьяЗатратНачисления);
// СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратСтраховыеВзносы", ВыборкаДетальныеЗаписи.СтатьяЗатратСтраховыеВзносы);
//Иначе
// СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратНачисления" , Справочники.СтатьиЗатрат.ПустаяСсылка());
// СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратСтраховыеВзносы", Справочники.СтатьиЗатрат.ПустаяСсылка());
//КонецЕсли;
Если ВыборкаДетальныеЗаписи.Количество() > 0 Тогда
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Если ВыборкаДетальныеЗаписи.СтатьяЗатратНачисления.ВидРасходовНУ = Перечисления.ВидыРасходовНУ.ОплатаТруда Тогда
СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратНачисления" , ВыборкаДетальныеЗаписи.СтатьяЗатратОтчисления);
ИначеЕсли ВыборкаДетальныеЗаписи.СтатьяЗатратНачисления.ВидРасходовНУ = Перечисления.ВидыРасходовНУ.СтраховыеВзносы Тогда
СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратСтраховыеВзносы" , ВыборкаДетальныеЗаписи.СтатьяЗатратОтчисления);
КонецЕсли;

КонецЦикла;
Иначе
СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратНачисления" , Справочники.СтатьиЗатрат.ПустаяСсылка());
СтруктураСоответствиеСтатейЗатрат.Вставить("СтатьяЗатратСтраховыеВзносы", Справочники.СтатьиЗатрат.ПустаяСсылка());
КонецЕсли;
//окончание

Возврат СтруктураСоответствиеСтатейЗатрат;

КонецФункции
156. Владимир Анашкин (kondrp) 889 20.04.12 15:02 Сейчас в теме
(155) васисубатор,
Спасибо за проделанную работу, обязательно проанализирую и добавлю в следующей публикации.

Еще огромная к Вам просьба: куски кода, тем более такие массивные, лучше отправлять в личку, а то уж очень много места занимает.
157. Василий (васисубатор) 64 20.04.12 15:12 Сейчас в теме
ок, еще добавил заполнение субконто подразделений на счетах затрат - это тоже нужно
158. Владимир Анашкин (kondrp) 889 20.04.12 15:54 Сейчас в теме
(157) васисубатор,
Мой адрес kondrp@yandex.ru. Присылайте, просмотрю.
159. serg85 (serg85) 29 26.04.12 16:40 Сейчас в теме
Спасибо, очень актуально!
160. Владимир Анашкин (kondrp) 889 26.04.12 23:08 Сейчас в теме
(159) serg85,
Рад помочь. Следите за обновлениями.
161. Валя Гужбина (GVALA) 2 27.04.12 09:54 Сейчас в теме
Спасибо большое за обработку , очень полезна в работе бухгалтерии в свете всех изменений в бухгалтерском учете.
162. Hamann2008 (Hamann2008) 02.05.12 12:19 Сейчас в теме
1) В УПП - удаляются статьи затрат, поэтому убрал ЗаполнитьСтатьюЗатрат(СтрокаОтражениеВУчете, СтатьяЗатратНачисления);
2) В УПП - добавил выбор отдельной статьи для взносов и НС.
В остальном обработка супер, на 1.3.24 работает.
163. Владимир Анашкин (kondrp) 889 02.05.12 12:43 Сейчас в теме
(162) Hamann2008,
Спасибо за комментарий. Обязательно проверю правильность заполнения статей затрат и исправлю в следующей публикации.
164. Hamann2008 (Hamann2008) 03.05.12 00:30 Сейчас в теме
Как-то так
	Статьи = Новый Запрос();
	Статьи.Текст = "ВЫБРАТЬ
					|	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.ВидСтатьиЗатрат,
					|	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатрат,
					|	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатратНачисления
					|ИЗ
					|	РегистрСведений.СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете КАК СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете
					|ГДЕ
					|	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатратНачисления = &СтатьяЗатратНачисления";
	
	// Заполнение строк по начислению резерва
	Для Каждого СтрокаРезервы из Резервы Цикл
		
		СпособОтраженияВБухУчете 	= СтрокаРезервы.СпособОтраженияВБухУчете;
		
		Если ТипЗнч(СпособОтраженияВБухУчете.СубконтоДт1) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
			Статьи.УстановитьПараметр("СтатьяЗатратНачисления",СпособОтраженияВБухУчете.СубконтоДт1);	
		ИначеЕсли ТипЗнч(СпособОтраженияВБухУчете.СубконтоДт2) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
			Статьи.УстановитьПараметр("СтатьяЗатратНачисления",СпособОтраженияВБухУчете.СубконтоДт2);	
		ИначеЕсли ТипЗнч(СпособОтраженияВБухУчете.СубконтоДт3) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
			Статьи.УстановитьПараметр("СтатьяЗатратНачисления",СпособОтраженияВБухУчете.СубконтоДт3);
		КонецЕсли;	
		
		СтатьиРезультат = Статьи.Выполнить().Выбрать();
		
		Пока СтатьиРезультат.Следующий() Цикл
			если СтатьиРезультат.ВидСтатьиЗатрат = Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы Тогда
				СтатьяЗатратСтраховыеВзносы = СтатьиРезультат.СтатьяЗатрат;
			ИначеЕсли СтатьиРезультат.ВидСтатьиЗатрат = Перечисления.ВидыДополнительныхСтатейЗатрат.ФСС_НС Тогда
				СтатьяЗатратСтраховыеВзносыНС = СтатьиРезультат.СтатьяЗатрат;
			КонецЕсли;
		КонецЦикла;	
...Показать Скрыть
165. d d (rassss) 21.05.12 08:04 Сейчас в теме
день добрый ! Нужная обработка. спасибо автору. правельность сумм еще не проверяли. но на первый взгляд вроде бы похожиие на реальность.еще раз спасибо...!!!!!!!!!!!!!!!!!!1
166. Денис Шевченко (denium) 110 28.05.12 10:38 Сейчас в теме
Респект автору, проделал хорошую работу.
Но есть неточности в ее работе, позже после анализа и выявления ошибок, поясню в чем именно.
Существует ли более свежий релиз на текущий момент времени, чтобы не исправлять уже найденные и исправленные ошибки ?
167. Владимир Анашкин (kondrp) 889 28.05.12 13:17 Сейчас в теме
(166) denium,
Был в отпуске, поэтому ничего принципиально нового в обработку не добавил.
В данный момент дорабатываю возможность выводить данные таблицы на печать с помощью СКД. Пока это и явлется следующим релизом.

Если Вам не сложно, опишите возникшие ошибки, чтобы я мог их проанализировать и исправить перед публикацией нового релиза.
168. Денис Шевченко (denium) 110 28.05.12 15:45 Сейчас в теме
1. В нашей организации множество записей в регистре "СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете"
Соответсвенно вы находите лишь первую запись, что не верно.
Заменил структуру на соответствия, предварительно объявив соответствия для всего модуля.
Процедура ПолучитьСоответствияСтатейЗатрат()
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
	               |	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатратНачисления КАК СтатьяЗатратНачисления,
	               |	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатрат КАК СтатьяЗатратСтраховыеВзносы
	               |ИЗ
	               |	РегистрСведений.СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете КАК СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете
	               |ГДЕ
	               |	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.ВидСтатьиЗатрат = &ВидСтатьиЗатрат
	               |
	               |СГРУППИРОВАТЬ ПО
	               |	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатратНачисления,
	               |	СоответствиеСтатейЗатратОтраженияЗарплатыВРеглУчете.СтатьяЗатрат";

	
	Запрос.УстановитьПараметр("ВидСтатьиЗатрат", Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы);
	
	Результат 				= Запрос.Выполнить();
	ВыборкаДетальныеЗаписи	= Результат.Выбрать();
	
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		СоответствиеСтатейЗатратСтраховые.Вставить(ВыборкаДетальныеЗаписи.СтатьяЗатратНачисления	,ВыборкаДетальныеЗаписи.СтатьяЗатратСтраховыеВзносы );
	КонецЦикла;
		
	Запрос.УстановитьПараметр("ВидСтатьиЗатрат", Перечисления.ВидыДополнительныхСтатейЗатрат.ФСС_НС);
	
	Результат 				= Запрос.Выполнить();
	ВыборкаДетальныеЗаписи	= Результат.Выбрать();
	
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		СоответствиеСтатейЗатратНС.Вставить(ВыборкаДетальныеЗаписи.СтатьяЗатратНачисления	,ВыборкаДетальныеЗаписи.СтатьяЗатратСтраховыеВзносы );
	КонецЦикла;

	
КонецПроцедуры


////////////////////////////////////////////////////////////­////////////////////
// ИНИЦИАЛИЗАЦИЯ ОБЪЕКТА 

СоответствиеСтатейЗатратСтраховые   = Новый Соответствие;
СоответствиеСтатейЗатратНС 			= Новый Соответствие;


...Показать Скрыть


Вы получаете две проводки по каждому затратному счету.
Первая проводка - зарплата, вторая проводка - начисление в фонды.
Но это не совсем верно, так как у нас в том же регистре соответсвий проводки по ФСС и НС ложаться на отдельные статьи затрат.
Т.е. в итоге должно быть три проводки на одном затратном счете, с одним подразделением, о одной статьей затрат начисление заработной платы.
Поэтому я получаю два соответствия отдельно для ФСС_НС и отдельно для Страховых взносов.

Переписал также процедуру "ЗаполнитьСтатьюЗатрат", и ее вызовы.

Процедура ЗаполнитьСтатьюЗатрат(СтрокаОтражениеВУчете,ВидСтатьиЗатрат)

	Если ТипЗнч(СтрокаОтражениеВУчете.СубконтоДт1) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
	    СтрокаОтражениеВУчете.СубконтоДт1 = 
            ?(ВидСтатьиЗатрат=Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы,
            СоответствиеСтатейЗатратСтраховые.Получить (СтрокаОтражениеВУчете.СубконтоДт1),
            СоответствиеСтатейЗатратНС.Получить(СтрокаОтражениеВУчете.СубконтоДт1));
	КонецЕсли;	
	
	Если ТипЗнч(СтрокаОтражениеВУчете.СубконтоДт2) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
	    СтрокаОтражениеВУчете.СубконтоДт2 = 
            ?(ВидСтатьиЗатрат=Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы,
            СоответствиеСтатейЗатратСтраховые.Получить(СтрокаОтражениеВУчете.СубконтоДт2),
            СоответствиеСтатейЗатратНС.Получить(СтрокаОтражениеВУчете.СубконтоДт2));
	КонецЕсли;	
	
	Если ТипЗнч(СтрокаОтражениеВУчете.СубконтоДт3) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
	     СтрокаОтражениеВУчете.СубконтоДт3 =
             ?(ВидСтатьиЗатрат=Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы,
             СоответствиеСтатейЗатратСтраховые.Получить      (СтрокаОтражениеВУчете.СубконтоДт3),
             СоответствиеСтатейЗатратНС.Получить(СтрокаОтражениеВУчете.СубконтоДт3));
	КонецЕсли;	
	
	Если ОценочныеОбязательстваФормироватьНУ Тогда
		
		Если ТипЗнч(СтрокаОтражениеВУчете.СубконтоДтНУ1) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
			СтрокаОтражениеВУчете.СубконтоДтНУ1 = 
?(ВидСтатьиЗатрат=Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы,СоответствиеСтатейЗатратСтраховые.Получить(СтрокаОтражениеВУчете.СубконтоДтНУ1),
СоответствиеСтатейЗатратНС.Получить(СтрокаОтражениеВУчете.СубконтоДтНУ1));
		КонецЕсли;	
	
		Если ТипЗнч(СтрокаОтражениеВУчете.СубконтоДтНУ2) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
			СтрокаОтражениеВУчете.СубконтоДтНУ2 =
?(ВидСтатьиЗатрат=Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы,СоответствиеСтатейЗатратСтраховые.Получить(СтрокаОтражениеВУчете.СубконтоДтНУ2),
СоответствиеСтатейЗатратНС.Получить(СтрокаОтражениеВУчете.СубконтоДтНУ2));

		КонецЕсли;	
	
		Если ТипЗнч(СтрокаОтражениеВУчете.СубконтоДтНУ3) = Тип("СправочникСсылка.СтатьиЗатрат") Тогда
			СтрокаОтражениеВУчете.СубконтоДтНУ3 = 
?(ВидСтатьиЗатрат=Перечисления.ВидыДополнительныхСтатейЗатрат.СтраховыеВзносы,СоответствиеСтатейЗатратСтраховые.Получить(СтрокаОтражениеВУчете.СубконтоДтНУ3),
СоответствиеСтатейЗатратНС.Получить(СтрокаОтражениеВУчете.СубконтоДтНУ3));
		КонецЕсли;	
		
	КонецЕсли;
	
КонецПроцедуры	
...Показать Скрыть


Блок ниже должен быть удален, так как в первозданной "СтрокаОтражениеВУчете" уже содержится аналитика требуемой для проводки по заработной плате.
Какой смысл определять ее вновь ?

// {{D.28.05.12/1522-DENIS   
// {{
//ЗаполнитьСтатьюЗатрат(СтрокаОтражениеВУчете, СтатьяЗатратНачисления);
// }}
// }}D.28.05.12/1522-DENIS
...Показать Скрыть



2. Ранее уже писал про подразделения (88) vladir, этой аналитики у вас не хватает, вопосльзовался тем кодом котрый выложен в комментариях, код работоспособен, аналитику по подразделениям получаю.

В итоге получил такой результат:
Прикрепленные файлы:
169. Владимир Анашкин (kondrp) 889 29.05.12 07:55 Сейчас в теме
(168) denium,
Спасибо за комментарий. Действительно блок формирования проводок еще не является досконально проработанным, т.к. изначально делался "на коленке" и в дальнейшем, при обновлении публикаций, практически не затрагивался.
Обязательно переварю информацию, которую Вы предоставили и добавлю изменения в блок формирования проводок в следующей публикации.
170. Денис Шевченко (denium) 110 29.05.12 10:24 Сейчас в теме
Отлично, вы молодец, перваривать и поддерживать непросто.
У меня есть еще замечания.
В данный момент не могу понять цифры при инвентаризации ???

Сумма на начало (17 546 809,68) + страховые взносы <> Общая сумма обязательств (9 841 258,45)<> Отражение зп в рег учете (27 388 068.29)


Скриншоты во вложении.
Прикрепленные файлы:
171. Владимир Анашкин (kondrp) 889 29.05.12 10:33 Сейчас в теме
(170) denium,
Думаю - ошибка в расчетах. Возможно из-за того, что при выпуске предыдущих обновлений этот блок не затрагивался. Проанализирую. Спасибо.
172. Денис Шевченко (denium) 110 29.05.12 10:37 Сейчас в теме
Есть еще момент, котрый стоит учесть.
Компенсация за неиспользованный отпуск, выплачиваемая при увольнении, за счет резерва на отпуска не списывается
25.05.2012
В письме от 03.05.2012 № 03-03-06/4/29 Минфин России рассмотрел вопрос о том, можно ли суммы компенсаций за неиспользованные отпуска, выплачиваемые работникам при увольнении, списывать в налоговом учете за счет резерва предстоящих расходов на оплату отпусков.
Финансовое ведомство разъяснило, что расходы на оплату труда, сохраняемую работникам на время отпуска, и денежные компенсации за неиспользованный отпуск являются разными видами расходов на оплату труда, поскольку первые из названных затрат предусмотрены п. 7 ст. 255 НК РФ, а вторые - п. 8 этой статьи. Поэтому указанные компенсации за счет резерва не списываются, а учитываются для целей налогообложения прибыли в порядке, предусмотренном для других расходов на оплату труда.
173. Владимир Анашкин (kondrp) 889 29.05.12 11:30 Сейчас в теме
(172) denium,
Тут я, к сожалению, бессилен, т.к. моя обработка предназначена только для формирования резервов (кредитового оборота 96 счета). Закрытие резерва (дебетовый оборот 96 счета) формируется документом "Отражение зарплаты в регл.учете" на основании данных документов "Начисление отпуска", "Расчет при увольнении работника".
Остается надеятся, что Уважаемые методологи и программисты фирмы "1С" реализуют этот механизм.
174. Денис Шевченко (denium) 110 29.05.12 12:02 Сейчас в теме
(173) kondrp,
Согласен, но с оговоркой, вы двигаете Дт затратный счет Кт 96 на величину начислений.
Типовой делает проводку Кт 96 Дт затратный (отчисления в фонды) на величину использования отпуска.
Т.о. если типовой будет списывать отпуск при увольнении, можно увеличивать на ту же величину Дт затратный счет Кт 96 счет.
Или делать сторно проводку, но таком случае нужно писать блок по списанию сторно ...
175. Денис Шевченко (denium) 110 29.05.12 14:20 Сейчас в теме
(170)
// Расчет страховых взносов при изменении начисленной суммы
Процедура ИзменитьСуммыСтраховыхВзносовВыбраннойСтроки()
	
	ТекущиеДанные	= ЭлементыФормы.Резервы.ТекущиеДанные;
	ТекущаяСтрока	= ЭлементыФормы.Резервы.ТекущаяСтрока;
	
	// ПФР страховая и накопительная
	Если ТекущиеДанные.БазаПФРСНачалаГода > ТекущиеДанные.ПределСтраховыхВзносов Тогда
		ТекущаяСтрока.СуммаПФРСтраховая		= 0;
		ТекущаяСтрока.СуммаПФРНакопительная = 0;
	// {{A.29.05.12/1551-DENIS
	ИначеЕсли ИнвентаризацияРезервовПредстоящихОтпусков Тогда
		ТекущаяСтрока.СуммаПФРСтраховая		= (ТекущаяСтрока.СуммаНачальныйОстаток+ТекущаяСтрока.СуммаНачислено)* ТекущаяСтрока.СтавкаПФРСтраховая / 100;
		ТекущаяСтрока.СуммаПФРНакопительная = (ТекущаяСтрока.СуммаНачальныйОстаток+ТекущаяСтрока.СуммаНачислено)* ТекущаяСтрока.СтавкаПФРНакопительная / 100
	// }}A.29.05.12/1551-DENIS	
	Иначе
		ТекущаяСтрока.СуммаПФРСтраховая		= ТекущаяСтрока.СуммаНачислено * ТекущаяСтрока.СтавкаПФРСтраховая / 100;
		ТекущаяСтрока.СуммаПФРНакопительная = ТекущаяСтрока.СуммаНачислено * ТекущаяСтрока.СтавкаПФРНакопительная / 100;
	КонецЕсли;	
	
	// ФОМС
	Если ТекущиеДанные.БазаФОМССНачалаГода > ТекущиеДанные.ПределСтраховыхВзносов Тогда
		ТекущаяСтрока.СуммаФОМС		= 0;
	// {{A.29.05.12/1551-DENIS
	ИначеЕсли ИнвентаризацияРезервовПредстоящихОтпусков Тогда
		ТекущаяСтрока.СуммаФОМС = (ТекущаяСтрока.СуммаНачальныйОстаток+ТекущаяСтрока.СуммаНачислено) * ТекущаяСтрока.СтавкаФОМС / 100
	// }}A.29.05.12/1551-DENIS	
	Иначе
		ТекущаяСтрока.СуммаФОМС = ТекущаяСтрока.СуммаНачислено * ТекущаяСтрока.СтавкаФОМС / 100;
	КонецЕсли;	

	// ФСС
	Если ТекущиеДанные.БазаФСССНачалаГода > ТекущиеДанные.ПределСтраховыхВзносов Тогда
		ТекущаяСтрока.СуммаФСС		= 0;
		ТекущаяСтрока.СуммаФССНС	= 0;
	// {{A.29.05.12/1551-DENIS
	ИначеЕсли ИнвентаризацияРезервовПредстоящихОтпусков Тогда
		ТекущаяСтрока.СуммаФСС 		= (ТекущаяСтрока.СуммаНачальныйОстаток+ТекущаяСтрока.СуммаНачислено)* ТекущаяСтрока.СтавкаФСС / 100;
		ТекущаяСтрока.СуммаФССНС	= (ТекущаяСтрока.СуммаНачальныйОстаток+ТекущаяСтрока.СуммаНачислено)* ТекущаяСтрока.СтавкаФССНС / 100;
	// }}A.29.05.12/1551-DENIS	
	Иначе
		ТекущаяСтрока.СуммаФСС		= ТекущаяСтрока.СуммаНачислено * ТекущаяСтрока.СтавкаФСС / 100;
		ТекущаяСтрока.СуммаФССНС	= ТекущаяСтрока.СуммаНачислено * ТекущаяСтрока.СтавкаФССНС / 100;
	КонецЕсли;	

	// Общая сумма обязательства (с учетом страховых взносов)
	// {{E.29.05.12/1422-DENIS
	// {{
	//ТекущаяСтрока.ОбщаяСуммаНачислено = ТекущиеДанные.СуммаНачислено + ТекущиеДанные.СуммаПФРНакопительная + ТекущиеДанные.СуммаПФРСтраховая + ТекущиеДанные.СуммаФОМС + ТекущиеДанные.СуммаФСС + ТекущиеДанные.СуммаФССНС;
	// }}
	Если ИнвентаризацияРезервовПредстоящихОтпусков Тогда
		ТекущаяСтрока.ОбщаяСуммаНачислено = (ТекущаяСтрока.СуммаНачальныйОстаток+ТекущаяСтрока.СуммаНачислено) + ТекущиеДанные.СуммаПФРНакопительная + ТекущиеДанные.СуммаПФРСтраховая + ТекущиеДанные.СуммаФОМС + ТекущиеДанные.СуммаФСС + ТекущиеДанные.СуммаФССНС;
	Иначе	
		ТекущаяСтрока.ОбщаяСуммаНачислено = ТекущиеДанные.СуммаНачислено + ТекущиеДанные.СуммаПФРНакопительная + ТекущиеДанные.СуммаПФРСтраховая + ТекущиеДанные.СуммаФОМС + ТекущиеДанные.СуммаФСС + ТекущиеДанные.СуммаФССНС;
	КонецЕсли;
	// }}E.29.05.12/1422-DENIS
КонецПроцедуры	
...Показать Скрыть



// {{E.29.05.12/1610-DENIS
// {{
//ОбщаяСуммаНачислено		= СуммаНачислено + СуммаПФРНакопительная + СуммаПФРСтраховая + СуммаФОМС + СуммаФСС + СуммаФССНС;
// }}
Если ИнвентаризацияРезервовПредстоящихОтпусков Тогда
     ОбщаяСуммаНачислено		= СуммаНачальныйОстаток +СуммаНачислено + СуммаПФРНакопительная + СуммаПФРСтраховая + СуммаФОМС + СуммаФСС + СуммаФССНС;
Иначе	
     ОбщаяСуммаНачислено		= СуммаНачислено + СуммаПФРНакопительная + СуммаПФРСтраховая + СуммаФОМС + СуммаФСС + СуммаФССНС;
КонецЕсли;	
// }}E.29.05.12/1610-DENIS
...Показать Скрыть



Т.е. получается следующий метод, получения остатков:
1. Вычисляем Сальдо на начало + Прирост начислений отпусков Это делает данная обработка.
2. Типовой функционал делает списание по расходу уже использованныъ отпусков.
3. Остаток на конец периода и даст нам инвентаризированное сальдо.

Данную инвентаризацию нужно проводить месяцем, до которого мы хотим получить сальдо на начало периода.
Т.е. например у себя я провел ее декабрем 2011 и получил остатки на конец года.
Но в данном методе есть спорный вопрос, об этом уже ранее писали. Средний будет исчислен на начало месяца.


Я думаю как альтернативу, можно рассмотреть следующий вариант: в документе, с взведенной галкой инвентаризации получать средний,
включая месяц в котором мы ведем инвентаризацию. В таком случае метод ология обработки будет такой.
1. Вычисляем сальдо на конец, делаем движения только по Кт 96 счета.
2. Очищаем все движения типового по Дт 96 , т.е. испоьзования отпусков нам не нужно в данном случае.
3. Предела страховых взносов не должно быть для исчисления сальдо, ведь мы не знаем в какой момент сотрудники запросят весь объем денег по отпуску. А если считаем на конец года, то по сути хотим увидеть сальдо на начало, а в начале года предела нет.

// {{E.31.05.12/1421-DENIS
// {{
// ПределСтраховыхВзносов	= СтруктураСтавкиСтраховыхВзносов.ПределСтраховыхВзносов;
// }}
	Если ИнвентаризацияРезервовПредстоящихОтпусков Тогда
			ПределСтраховыхВзносов = 1000000000;
	Иначе	
			ПределСтраховыхВзносов	= СтруктураСтавкиСтраховыхВзносов.ПределСтраховыхВзносов;
	КонецЕсли;
// }}E.31.05.12/1421-DENIS
...Показать Скрыть


Думаю данный вариант сальдо на конец более приемлем.
176. Денис Шевченко (denium) 110 01.06.12 07:18 Сейчас в теме
Нашел еще косяк по инвалидам, определяет не верно тех у кого бессрочный срок инвалидности.
Вот решение.
Функция ПолучитьТаблицуОсобыхУсловийНачисленияСтраховыхВзносов(парамМассивФизлица)
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
	               |	ГражданствоИнвалидность.ФизЛицо КАК ФизЛицо,
	               |	МАКСИМУМ(ГражданствоИнвалидность.ВидЗастрахованногоЛица) КАК ВидЗастрахованногоЛица,
	               |	МАКСИМУМ(ГражданствоИнвалидность.ПринятПоДолгосрочномуДоговору) КАК ПринятПоДолгосрочномуДоговору,
	               |	МАКСИМУМ(ГражданствоИнвалидность.Инвалидность) КАК Инвалидность
	               |ИЗ
	               |	(ВЫБРАТЬ
	               |		ГражданствоФизЛицСрезПоследних.ФизЛицо КАК ФизЛицо,
	               |		ГражданствоФизЛицСрезПоследних.НеИмеетПравоНаПенсию КАК НеИмеетПравоНаПенсию,
	               |		ГражданствоФизЛицСрезПоследних.ВидЗастрахованногоЛица КАК ВидЗастрахованногоЛица,
	               |		ЕСТЬNULL(ВременноПребывающиеПринятыеПоДолгосрочнымДоговорамСрезПослед­них.ПринятПоДолгосрочномуДоговору, ЛОЖЬ) КАК ПринятПоДолгосрочномуДоговору,
	               |		ЛОЖЬ КАК Инвалидность
	               |	ИЗ
	               |		РегистрСведений.ГражданствоФизЛиц.СрезПоследних(&Период, ФизЛицо В (&Физлица)) КАК ГражданствоФизЛицСрезПоследних
	               |			ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ВременноПребывающиеПринятыеПоДолгосрочнымДоговорам.СрезПоследних(
	               |					&Период,
	               |					Организация = &Организация
				   |						И ВЫБОР
	               |							КОГДА ПериодЗавершения = ДАТАВРЕМЯ(1, 1, 1)
	               |								ТОГДА ИСТИНА
	               |							ИНАЧЕ ПериодЗавершения >= &Период
	               |						КОНЕЦ
	               |						И ФизЛицо В (&Физлица)) КАК ВременноПребывающиеПринятыеПоДолгосрочнымДоговорамСрезПослед­них
	               |			ПО ГражданствоФизЛицСрезПоследних.ФизЛицо = ВременноПребывающиеПринятыеПоДолгосрочнымДоговорамСрезПослед­них.ФизЛицо
	               |	
	               |	СГРУППИРОВАТЬ ПО
	               |		ГражданствоФизЛицСрезПоследних.НеИмеетПравоНаПенсию,
	               |		ГражданствоФизЛицСрезПоследних.ФизЛицо,
	               |		ГражданствоФизЛицСрезПоследних.ВидЗастрахованногоЛица,
	               |		ЕСТЬNULL(ВременноПребывающиеПринятыеПоДолгосрочнымДоговорамСрезПослед­них.ПринятПоДолгосрочномуДоговору, ЛОЖЬ)
	               |	
	               |	ОБЪЕДИНИТЬ ВСЕ
	               |	
	               |	ВЫБРАТЬ
	               |		СведенияОбИнвалидностиФизлицСрезПоследних.Физлицо,
	               |		ЛОЖЬ,
	               |		ЗНАЧЕНИЕ(Перечисление.ВидыЗастрахованныхЛицОбязательногоСтрахования.ГражданеРФ),
	               |		ЛОЖЬ,
	               |		СведенияОбИнвалидностиФизлицСрезПоследних.Инвалидность
	               |	ИЗ
	               |		РегистрСведений.СведенияОбИнвалидностиФизлиц.СрезПоследних(
	               |				&Период,
	               |				ФизЛицо В (&Физлица)
	               |					И Инвалидность
		       // {{E.01.06.12/0936-DENIS
		       // {{
		       // И СрокДействияСправки >= &Период
		       // }}
	               |					И ВЫБОР
	               |						КОГДА СрокДействияСправки = ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)
	               |							ТОГДА  ИСТИНА
	               |						ИНАЧЕ СрокДействияСправки >= &Период
	               |					КОНЕЦ
		       // }}E.01.06.12/0936-DENIS
		       |) КАК СведенияОбИнвалидностиФизлицСрезПоследних
	               |	
	               |	СГРУППИРОВАТЬ ПО
	               |		СведенияОбИнвалидностиФизлицСрезПоследних.Физлицо,
	               |		СведенияОбИнвалидностиФизлицСрезПоследних.Инвалидность) КАК ГражданствоИнвалидность
	               |
	               |СГРУППИРОВАТЬ ПО
	               |	ГражданствоИнвалидность.ФизЛицо";

	Запрос.УстановитьПараметр("Организация"	, Организация);
	Запрос.УстановитьПараметр("Период"		, КонецПериода);
	Запрос.УстановитьПараметр("Физлица"		, парамМассивФизлица);

	Результат = Запрос.Выполнить();

	ТаблицаОсобыеУсловияНачисленияСтраховыхВзносов = Результат.Выгрузить();
	
	Возврат ТаблицаОсобыеУсловияНачисленияСтраховыхВзносов;
	
КонецФункции	
	
...Показать Скрыть
177. Владимир Анашкин (kondrp) 889 01.06.12 13:25 Сейчас в теме
(176) denium,
Очередной раз Спасибо. Подготовили Вы мне фронт работы на выходные!
Думаю к понедельнику опубликую новый релиз обработки куда обязательно включу и предложенные Вами изменения.
178. Ксения (LadyDy) 5 02.06.12 10:41 Сейчас в теме
При открытии обработки выходит следующая ошибка:

{Форма.Форма.Форма(1773)}: Значение не является значением объектного типа (ПериодРегистрации)
НачалоПериода = НачалоМесяца(ОбъектЗаполнения.ПериодРегистрации);

Релиз 2.5.49.2, с чем связано?
179. Владимир Анашкин (kondrp) 889 02.06.12 18:01 Сейчас в теме
(178) LadyDy,
Возможно у Вас не записан документ "Отражение зарплаты в рег.учете", из которого вы запускаете эту обработку.
Попробуйте записать документ, а затем нажать кнопку "Заполнить..."
180. Ксения (LadyDy) 5 02.06.12 18:08 Сейчас в теме
(179) kondrp, я ее просто попыталась открыть, в итоге получила ошибку. Ее зарегистрировать нужно в доп. отчетах и обработках?
181. Ксения (LadyDy) 5 02.06.12 18:51 Сейчас в теме
Плюсую автору, спасибо.
Все отлично работает.
182. Владимир Анашкин (kondrp) 889 02.06.12 23:38 Сейчас в теме
(181) LadyDy,
Всегда рад помочь. Следите за обновлениями
183. Денис Шевченко (denium) 110 03.06.12 08:30 Сейчас в теме
Владимир (kondrp) - я затачиваю вашу обработку под наши требования, возможно будет вам полезным.
1. Вы писали про то, что собираетесь реализовать печатную форму для данной обработки, я тоже, но напрямую делать ее не стал, изначально создал независимый регистр сведений.
И добавляю туда записи, которые создает обработка, в дальнейшем можно построить отчет на основе среза данного регистра.
Почему такой путь? Потому что в нашей базе огромное количество сотрудников, обработка по одной организации формируется 2 часа, поэтому, если сразу не распечатать, или по каким то иным причинам вернуться к уже ранее сформированным данным, бухгалтеру придется вновь ждать эти два часа, что не есть правильно.
2. Расчет суммы прироста начислений я изменил, следуя принципу: конечное сальдо это аксиома, от которой стоит рассчитывать прирост.
Объясню почему, вы вычисляете по данному алгоритму:
ПриростНачиcлений = ДнейНачислено*СреднийЗаработок, далее Вы вычисляете
СальдоНаКонец = СальдоНаНачало+ПриростНачислений-ИзрасходованоОтпусков.

Но по многим факторам, как то средний на конец не равен среднему на начало месяца, иногда косячат службы и не верно компенсируют неиспользованный отпуск (Для уволенных в любом случае сальдо на конец должно быть 0), и т.п. ситуациям исчисленное твоим методом сальдо на конец не будет равно ДнямНаКонец*СреднийЗаработокНаКонец.

Поэтому, лично я переписал так что прирост вычсиляется в последнюю очередь.
Т.е. СальдоНаКонец = ДниНаКонец*СреднийЗаработок

ПриростНачислений= СальдоНаКонец-СальдоНаНачало + ИзрасходованоОтпусков
184. Евгений Рачковский (eugen91) 08.06.12 17:58 Сейчас в теме
Очень полезная вещь! надеюсь поможет нам!
185. Владимир Анашкин (kondrp) 889 13.06.12 20:12 Сейчас в теме
(183) denium,
Наконец руки дошли до оформления нового релиза. Релиз разместил, но к сожалению с сайтом был глюк и я не смог увидеть комментарии дальше №162. Поэтому в обновлении присутствует только измененный модуль по определению статей затрат. Реализовал его я по своему, но за идею спасибо. А также реализовал печатную форму на СКД (перетащил типовую с изменениями). К счастью сегодня все комментарии читаются, поэтому до конца недели надеюсь разместить еще один релиз.

P.S.
Если нашли еще какие-нибудь неточности или есть идеи для улучшения обработки - пишите.
186. Дмитрий Ярославцев (DimanYa) 14.06.12 12:02 Сейчас в теме
Плюсую за подробное описание истории процесса.
Плюсую за качесвенную доработку.
Плюсую за то, что обработка продолжает развиваться.
187. Галина (Beta) 11 18.06.12 10:03 Сейчас в теме
Очень хорошая обработка, читаемая, для бухгалтеров просто сказка... Что касается использования механизмов типовой конфигурации: у меня возникла такая проблема: с 1марта 2012 года изменилось количество дней отпуска для очень многих должностей предприятия. Сначала ввели остатки на 01.03, но гл.бух хочет видеть остатки на 01.01 с нарастающими итогами по месяцам. Сделала кадровые перемещения на новые должности с новым кол-вами дней с 01.03 - как единственно возможный вариант отразить периодику... Но увы остатки считаются не верно.... типовыми алгоритмами, особенно если были введены остатки на "дату приема"+ 2011г. Может есть какие-то идеи как их отладить... Иначе вся работа пойдет на смарку...
188. Ксения (LadyDy) 5 19.06.12 08:56 Сейчас в теме
Релиз 2.5.52.1. Выдает ошибку Метод объекта не обнаружен (ПодготовитьДанныеПоРегламентированнымОтпускам). Где можно поправить ошибку.
189. Ксения (LadyDy) 5 19.06.12 08:58 Сейчас в теме
История вопроса:
Как известно, до 1 января 2011 года организации имели право создавать резервы в целях равномерного включения предстоящих расходов в издержки производства или обращения отчетного периода, например по оплате вознаграждений по итогам года.
В 2012 в соответствии с ПБУ 8/2010 «Оценочные обязательства, условные обязательства и условные активы» организации обязаны отражать в отчетности оценочные обязательства. Это положение обязательно для всех организации, кроме субъектов малого предпринимательства.
190. Ксения (LadyDy) 5 19.06.12 08:58 Сейчас в теме
Обработка табличной части документа "Отражение зарплаты в регламентированном учете".

Обработка позволяет:
- рассчитывать сумму оценочных обязательств предстоящих отпусков по каждому сотруднику;
- рассчитывать сумму страховых взносов по оценочным обязательствам;
- формировать проводки по оценочным обязательствам (кредит 96 счета);
- проводить инвентаризацию оценочных обязательств;
- получать отчет по сформированным оценочным обязательствам (механизм СКД);
- максимально использовать типовые механизмы расчета дней отпуска и сумм среднего заработка, заложенные в ЗУП
191. Ксения (LadyDy) 5 19.06.12 10:22 Сейчас в теме
Чего то не туда натыкала, как можно сообщения удалить, я не туда вставила инструкцию по использованию. А вопрос то такой - Релиз 2.5.52.1. Выдает ошибку Метод объекта не обнаружен (ПодготовитьДанныеПоРегламентированнымОтпускам). Где можно поправить ошибку.
192. Владимир Анашкин (kondrp) 889 19.06.12 10:47 Сейчас в теме
(191) LadyDy,
Сейчас проверю. Отпишусь
193. Владимир Анашкин (kondrp) 889 19.06.12 10:48 Сейчас в теме
(191) LadyDy,
Для релизов начиная с 2.5.52.1 необходимо переписывать запрос по получению количества дней отпуска. Разработчики 1С добавили новый общий модуль "ОстаткиОтпусков" и полностью переписали принцип действия всех функций по получению остатков дней отпусков.
Сегодня вечером перепишу эту часть обработки и отдельно опубликую релиз для ЗУП 2.5.52.1
194. Оксана Проненко (prochka) 19.06.12 18:44 Сейчас в теме
При правке вручную в табличной части количества дней начисленного отпуска выдает следующую ошибку:

{Форма.Форма.Форма(1246)}: Поле объекта не обнаружено (ОбщаяОценочныеОбязательства)
ТекущаяСтрока.ОбщаяОценочныеОбязательства = ТекущиеДанные.СуммаНачислено + ТекущиеДанные.СуммаПФРНакопительная + ТекущиеДанные.СуммаПФРСтраховая + ТекущиеДанные.СуммаФОМС + ТекущиеДанные.СуммаФСС + ТекущиеДанные.СуммаФССНС;

На качество работы обработки не влияет (не заметила), но автору к сведению.
195. Ксения (LadyDy) 5 19.06.12 18:46 Сейчас в теме
(193) kondrp, спасибо огромное, будем ждать с нетерпением.
196. Владимир Анашкин (kondrp) 889 19.06.12 19:37 Сейчас в теме
(194) prochka,
Спасибо за комментарий. Обязательно поправлю!
197. Оксана Проненко (prochka) 19.06.12 19:41 Сейчас в теме
При использовании 10-11 версий обработки возникли проблемы:

1) При формировании проводок перестали разбиваться суммы по каждому затратному счету, т.е первая проводка - зарплата, вторая проводка - начисление в фонды. Регистр "Соответствие статей затрат отражения зарплаты в регл учете" настроен и не изменялся. При этом 9 версия обработки в этом направлении продолжает работает абсолютно корректно.

2) Мой коммент (125) для меня остался открытым - последние изменения Способа отражения в бух.учете у меня происходили еще в 2011 году. Что не так с моими ручками?
198. Владимир Анашкин (kondrp) 889 19.06.12 20:37 Сейчас в теме
199. Владимир Анашкин (kondrp) 889 20.06.12 10:55 Сейчас в теме
(197) prochka,
Проверил. Ошибок не нашел. На моей базе все работает корректно.
Если вопрос остался открытым, пришлите мне скриншот состояния регистра сведений "Соответствие статей затрат".
И опишите пожалуйста как вы изменяете способ отражения для конкретного сотрудника.
200. Владимир Анашкин (kondrp) 889 20.06.12 11:00 Сейчас в теме
(193) kondrp,
Добавил поддержку релиза 2.5.52.1. Но есть особенности:
1. При расчете количества дней теперь идет округление до целых. В результате при компенсации отпуска могут выходить начисления с минусом (Разница целых остатков и дробной компенсации).
2. Почему то изменились суммы среднего заработка работников.

Пока в причинах этих изменений не разобрался, но подозреваю, что в скором времени 1С выпустит еще один релиз с исправлениями. Очень уж они лихо и кардинально все поменяли.
202. Ксения (LadyDy) 5 20.06.12 11:28 Сейчас в теме
(200) kondrp, т.е. пока новый файл не качать, а почему изменился средний, может 1С что то изменили в расчете среднего?