gifts2017

Очистка кэша 1С из 1С

Опубликовал Сергей Белькин (Belkin_Sergey) в раздел Программирование - Практика программирования

Очистка кэша 1С из 1С.
Простенькая доработка конфигурации для автоматической чистки пользовательского кэша.

Часто, при использовании динамического обновления конфигурации, у пользователей забивается кэш и программма не работает так, как надо. Проблема устраняется путем чистки пользовательского кэша. Но основновная загвоздка в том, что не возможно определить у какого пользователя (особенно если их больше 100) кэшированные модули соотвествуют текущей версии конфигурации, а у какого нет. Программист понимает это только тогда, когда у пользователя возникла ошибка и он присылает в отдел 1С письмо с руганью, принт-скринами и матами. 

Подумав, как можно очищать кэш автоматом, было решено вызывать всем известный скрипт очистки кэша непосредственно из 1С.

В типовых конфигурациях уже предусмотрен обработчик оповещения, который проверяет не изменена ли конфигурация динамически. Если изменена, то пользователю предлагается перезапустить 1С, для того чтобы изменения вступли в силу. 

Суть метода в том, чтобы при завершении работы проверить изменена ли конфигурация динамически еще раз, собрать скрипт, записать его и вызвать в момент закрытия программы. Скрипт сначала засыпает на 5 секунд, ожидая, пока закроется процесс 1С. После этого, смотрит есть ли запущенные процессы 1С, если есть, то убивает их. Затем, удаляет папки кэша и, в случае, если пользователь выбрал перезапуск сеанса, перезапускает 1С.

Т.к. мы пока не написали ничего на управляемом приложении, все описанное ниже, предназначено только для обычного.

В модуле обычного приложения есть процедура ОбработчикОповещения(), в ней периодически вызывается еще одна процедура ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ () 

// Проверяет в конфигурации ИБ наличие изменений появившихся после старта сеанса
//
Процедура ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ() Экспорт

    // Если в конфигурации после старта текущего сеанса что-то изменилось
    Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда

        // Завершим проверку обновления
        ЗавершитьПроверкуДинамическогоОбновленияИБ();

        // Спросим пользователя о его желании перезапустить сеанс
        ТекстВопроса = "В конфигурацию ИБ внесены изменения." + Символы.ПС +
                                "Для работы с ними рекомендуется перезапустить программу." + Символы.ПС +
                                "Перезапустить?";
        РезультатВопроса = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);

        // Если пользователь не хочет перезапускать сеанс
        Если РезультатВопроса = КодВозвратаДиалога.Нет Тогда
            // Запустим проверку обновления опять
            НачатьПроверкуДинамическогоОбновленияИБ();
            Возврат;
         КонецЕсли;

         глЗначениеПеременнойУстановить("глПерезапускатьСеансРаботыСПрограммой", Истина);

        // Попробуем перезапустить
        ПерезапуститьСеансРаботыСПрограммой();

    КонецЕсли;

КонецПроцедуры 

// Процедура перезапуска сеанса работы с программой
Процедура ПерезапуститьСеансРаботыСПрограммой() Экспорт
    глЗначениеПеременнойУстановить("глЗапрашиватьПодтверждениеПриЗакрытии", Ложь);

    ЗавершитьРаботуСистемы(Истина);
КонецПроцедуры

 

При перезапуске используется метод  ЗавершитьРаботуСистемы(Истина, Истина), в нем необходимо поправить второй параметр на Ложь (или опустить ео вообще), вследствие чего 1С не будет перезапускаться. Запуск 1С будет осуществлен непосредственно из скрипта.

 

Далее в модуле обычного приложения  в процедуре ПриЗавершенииРаботыСистемы() необходимо прописать следующий код

Процедура ПриЗавершенииРаботыСистемы()

    //...

    Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда

        // у всех кроме программистов, т.к. у нас слишком часто открыты как рабочие базы так и конфигуратор.
        Если НЕ РольДоступна("Администрирование") Тогда
            ОчиститьКэшИПерезапуститьПрограмму();
        КонецЕсли;
     КонецЕсли;

 
КонецПроцедуры

Процедура ОчиститьКэшИПерезапуститьПрограмму() находится в глобальном модуле.

// Процедура создает и запускает vbs файл, который производит очистку кэша.
// 1С и презапускает программу
//
Процедура ОчиститьКэшИПерезапуститьПрограмму() Экспорт

     СкриптФайл = Новый ТекстовыйДокумент;

     СтрокаСоединенияСБД = СтрокаСоединенияИнформационнойБазы();
     СтрокаЗапускаПрограммы = КаталогПрограммы();

     ПутьКФайлуСкрипта = КаталогВременныхФайлов() + "CacheCleaning.vbs";
     ПутьКФайлу1С = СтрокаЗапускаПрограммы + "1cv8.exe";

     ИмяСервера = "";
     ИмяБазы = "";
     Путь = "";
     КомандаЗапуска = "";

     Один = """";
     Два = """""";
     Три = """""""";  

    Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
          Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
          Путь = Лев(Путь, СтрДлина(Путь)-1);
          КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
     Иначе
          МассивПараметровСоединения = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
          МассивПараметровСервера = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
          ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
          МассивПараметровБазы = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
          ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
          КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
     КонецЕсли;

     // Если пользователь не хочет перезапускать сеанс 1С, то после выполнения скрипта ничего не делаем. 

     Если Не глЗначениеПеременной("глПерезапускатьСеансРаботыСПрограммой")  Тогда
          КомандаЗапуска = ""
     КонецЕсли; 

     СкриптФайл.УстановитьТекст("WScript.Sleep(5000)
     |
     |Dim FSO
     |Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
     |Set WshShell = WScript.CreateObject(""WScript.Shell"")
     |Set colEnvVars = WshShell.Environment(""Process"")
     |
     |strComputer = "".""
     |Set objWMIService = GetObject(""winmgmts:"" _
     |& ""{impersonationLevel=impersonate}!\\"" _
     |& strComputer & ""\root\cimv2"")
     |
     |Set colProcesses = objWMIService.ExecQuery( _
     |""Select * From Win32_Process "" _
     |& ""Where Name = '1cv8.exe'"")
     |
     |For Each objProcess In colProcesses
     | objProcess.Terminate
     |Next
     |
     |WScript.Sleep(1000)
     |
     |FolderName1 = ""\Local Settings\Application Data\1C\1Cv82""
     |FolderName2 = ""\Local Settings\Application Data\1C\1Cv81""
     |FolderName3 = ""\appdata\Local\1C\1Cv82""
     |FolderName4 = ""\appdata\Local\1C\1Cv81""
     |
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName1) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName1
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName2) Then
     |GoSubFolders colEnvVars(""userprofile"") & FolderName2
     | End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName3) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName3
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName4) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName4
     |End If
     |
     |" + КомандаЗапуска + "
     |Set WshShell = Nothing
     |
     |Sub DelFile(sFILE)
     | On Error Resume Next
     | FSO.DeleteFile sFILE, True
     | If Err.Number <> 0 Then
     | Wscript.Echo ""Error deleting file: "" & sFILE
     | End If
     |End sub
     |
     |Function GetFolder(sFOLDER)
     | On Error Resume Next
     | Set GetFolder = FSO.GetFolder(sFOLDER)
     | If Err.Number <> 0 Then
     | Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
     | Wscript.Quit Err.Number
     | End If
     |End Function
     |
     |Sub GoSubFolders (objDIR)
     | ProcessFilesInFolder objDIR
     | Set sFolder = GetFolder(objDIR)
     | For Each eFolder in sFolder.SubFolders
     | GoSubFolders eFolder
     | Next
     | FSO.DeleteFolder sFolder, True
     |End Sub
     |
     |Sub ProcessFilesInFolder (objDIR)
     |Set sFolder = GetFolder(objDIR)
     |For Each objFile in sFolder.Files
     | DelFile objFile
     |Next
     |End Sub");

     Попытка
            СкриптФайл.Записать(ПутьКФайлуСкрипта, КодировкаТекста.Системная);
            ЗапуститьПриложение(ПутьКФайлуСкрипта);
     Исключение

     КонецПопытки;

КонецПроцедуры

 

Ну вот как-то так.

Я не знаю, может быть кто-то скажет, что постоянная чистка кэша сильно замедляет работу 1С (и это правда, первый запуск после чистки идет довольно таки долго), может быть это не оптимально и не правильно,  но у нас значительно поубавилось недовольных пользователей у которых ошибки возникали по вине досадного глюка динамического обновления системы.

 

Развитие темы.

Я тут подумал как развитие данной темы можно сделать следующее:

Создать регистр сведений, в котором можно будет указать дату очистки кэша, пользователя и флаг того что кэш очищен.

В процедуре ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ(), если конфигурация изменена динамически, то добавлять запись с текущей датой по текущему пользователю. Флаг оставить как ложь.

В процедуре ПриЗавершенииРаботыСистемы() можно проверять не на то что конфигурация изменена динамически, а на наличие записи в регистре сведений без флага.

Если такая запись имеется, то чистим кэш и пишем в регистр флаг - истина.

Что это даст?

Например, возникла следующая ситуация. Конфигурация была изменена динамически, но пользователь сам не закрыл 1С, ее вырубил админ на сервере или сам пользователь убил процесс. Таким образом, кэш не будет очищен ни при этом закрытии ни при следующем запуске - при следующем запуске конфигурация уже не будет изменена динамически. Но у нас в регистре же есть запись без флага. Система при следующем закрытии (да хоть после отпуска) все равно очистит кэш пользователя. Да к тому же программисту можно выборочно назначать счастливчиков. 

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Сергей Белькин (Belkin_Sergey) 26.03.12 13:31
Очистка кэша 1С из 1С.
Простенькая доработка конфигурации для автоматической чистки пользовательского кэша.

Перейти к публикации

1. Nio Nio (Nio) 26.03.12 13:31
Класс. Сейчас прикручу на кнопку и когда у пользователя будет появляться ошибка буду просить давить на эту кнопку.
2. Роман Фомин (system-3000) 27.03.12 10:22
Зачем кнопка. Все и так прекрасно работает. Как только клиент узнал о том что конфига изменена динамически, запускается сценарий на VB убивает процессы 1с и чистит кеш.
3. ВладимирП Пономарев (владимирп) 27.03.12 11:40
Здорово! Главное работает в клиент-сервере.
Вопрос такой: А как будет в терминале?
4. geterosser (Belkin_Sergey) 27.03.12 12:11
в терминале так же. Будет чиститься кэш текущего пользователя.
5. Иван (Spartan) 27.03.12 13:26
(0) К сожалению будет корректно работать, только если пользователи работают с одной ИБ :(
Если на момент динамического обновления будет открыто несколько баз, то скрипт убьет все процессы, в том числе и те, которые трогать не нужно - соответственно могут быть потеряны данные.
sanfoto; Aleskey_K; adhocprog; MasterTonLab; i_lo; Stamper; Belkin_Sergey; +7 Ответить 2
6. geterosser (Belkin_Sergey) 27.03.12 13:58
Вы правы насчет всех процессов и данных. Я думаю, что в тексте вопроса, который задается пользователю, его надо просто предупредить о том, что будут закрыты все экземпляры 1С и ему перед перезапуском надо сохранить все данные в других базах.
7. geterosser (Belkin_Sergey) 27.03.12 14:00
(5) Spartan,
Вы правы насчет всех процессов и данных. Я думаю, что в тексте вопроса, который задается пользователю, его надо просто предупредить о том, что будут закрыты все экземпляры 1С и ему перед перезапуском надо сохранить все данные в других базах.
8. Олег Шалимов (CaSH_2004) 27.03.12 16:27
Отличный подход чтобы упростить жизнь программисту! Полностью одобряю!
Маленькое замечание по эргономике текста: я обычно записываю скрипт в макет, и вместо склеивания кусков текста ("кусок скрипат 1" + хх + "кусок скрипат 2") использую переменные которые потом передаю в скрипт или просто заменяю их как кусок текста (главное чтобы они были уникальные), в итоге удобства:
- текст легко просматривается и редактируется, т.е. структура использования становиться удобной
- более того текст скрипта легко записать в файл-скрипт и выполнить его для проверки результата
а иначе очень сложно такие вещи модифицируются или переносятся в другие места
9. geterosser (Belkin_Sergey) 27.03.12 16:49
(8) CaSH_2004,
Была такая идея - создать макет с текстом скрипта. Но что-то как-то при написании увлекся, а переделывать уже не хотелось.
10. Misha ⁠ (Magister) 27.03.12 16:51
Одобряю!
Надо будет поставить в базу, а то достали уже глюки с этим кэшем...
11. Stamper (Stamper) 28.03.12 01:04
1С 8.2.15.301 Новое в версии:
http://downloads.v8.1c.ru/content/Platform/8_2_15_301/V8Update.htm
Вызов метода "ОбновитьИнтерфейс()" приводит к очистке кэшей: представления ссылок, данных объектов, данных быстрого выбора, форм выбора, ограничений по типу.

Идея автора очень полезная, спору нет! Сам уже устал постоянно переподключать ИБ'ы.
Но кажется, в ту же сторону задумались и разрабы 1С.

Что скажете?
AndrewVVS; daho; MasterTonLab; reboot234; i_lo; Spartan; +6 Ответить 3
12. Иван Мелихов (ivn75) 28.03.12 08:56
Актуальная тема, но лучше бы разработчики допилили динамическое обновление баз без глюков. А то возможность придумали хорошую, но реализация глючная.
13. Алекс Алекс (Evrepid) 28.03.12 10:11
14. Игорь Юндин (kereo) 28.03.12 10:30
(7) geterosser, или найти guid базы в списке баз(файл в расширением .v8i, который лежит там же где и кэш) по строке соединения(метод глобального контекста СтрокаСоединенияИнформационнойБазы()) и удалять не все, а только необходимое.

И еще зачем вот это все
     |FolderName1 = ""\Local Settings\Application Data\1C\1Cv82""
     |FolderName2 = ""\Local Settings\Application Data\1C\1Cv81""
     |FolderName3 = ""\appdata\Local\1C\1Cv82""
     |FolderName4 = ""\appdata\Local\1C\1Cv81""
     | 
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName1) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName1
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName2) Then
     |GoSubFolders colEnvVars(""userprofile"") & FolderName2
     | End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName3) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName3
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName4) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName4
     |End If
     
...Показать Скрыть

Если есть переменная windows %appdata%, а версию программы можно узнать у самой 1С-ки (ВерсияПриложения).
Spartan; Stamper; +2 Ответить 1
15. Stamper (Stamper) 28.03.12 10:39
(2) system-3000, опубликуйте, пожалуйста :)
16. geterosser (Belkin_Sergey) 28.03.12 10:47
(11) Stamper,
Если они что-нибудь сделают в этом направлении, я думаю все вздохнут спокойно и не надо будет уже ничего придумывать.
17. geterosser (Belkin_Sergey) 28.03.12 10:51
(14) kereo,
Я писал все быстро, пришла идея, взял готовый скрипт, дописал убиение процессов, а остальное оставил как было. Можно конечно и версию 1С определять. Даже нужно. Тут уже на ваше усмотрение.
18. Stamper (Stamper) 28.03.12 10:58
(16) geterosser, осталось только протестить работоспособность этого нового функционала метода :)
19. ВладимирП Пономарев (владимирп) 28.03.12 14:57
Попробовал на УПП конф 1.3.23 платформа 8.2.533
Говорит что не определена переменная глЗапрашиватьПодтверждениеПриЗакрытии в модуле "РаботаСобщимиПеременнымиПовтИсп"
Или ее прописывать в модуле "РаботаСОбщимиПеременными"
20. geterosser (Belkin_Sergey) 28.03.12 16:33
Переменная глЗапрашиватьПодтверждениеПриЗакрытии объявлена в модуле обычного приложения. Она используется в процедуре ПередЗавершениемРаботыСистемы() модуля обычного приложения.
21. geterosser (Belkin_Sergey) 28.03.12 16:37
(19) владимирп, можете код "глЗначениеПеременнойУстановить("глЗапрашиватьПодтверждениеПриЗакрытии", Ложь);" вообще опустить. Для успешной чистки кэша значение данной переменной не важно. Просто пользователю, если у него в настройках "Спрашивать подтверждение при закрытии" задано значение Истина, после нажатия на кнопку "Да" (вопрос о перезапуске из-за динамического обновления) будет еще раз задан вопрос, о подтверждении закрытия 1С.
22. ВладимирП Пономарев (владимирп) 28.03.12 20:34
geterosser, спасибо за ответ попробую убить эту строку
23. Maxim Kolkin (the1) 28.03.12 23:43
юзаю батник из ТоталКоммандер 1С Эдишн

@echo off
set cache_dir="%userprofile%\Local Settings\Application Data\1c\1Cv82"
FOR /D %%i IN (%cache_dir%\*) DO rd /s /q "%%i
24. Александр Лукин (i_lo) 29.03.12 02:16
(0) Я так понял, что убивается все. А не проще чистить только файлы кэшей?

erase /s "%UserProfile%\cache.1c?"
erase /s "%UserProfile%\cacheData."
erase /s "%UserProfile%\cacheStorage."
erase /s "%UserProfile%\cacheVersions."
MasterTonLab; +1 Ответить 1
25. geterosser (Belkin_Sergey) 29.03.12 07:10
26. geterosser (Belkin_Sergey) 29.03.12 07:12
(24) i_lo, проще.
Прошу воспринимать данную статью как идею. Если поставите плюсик - вообще замечательно будет. Вариации на тему приветствуются. Сейчас соберу все предложения, сделаю версию 2.0 )
27. Александр Лукин (i_lo) 29.03.12 08:01
(5) Spartan, мои коллеги лепят батник с очисткой кэша в автозапуск. От подобной ошибки спасает. Но попадаются на терминалках, где нет принудительного завершения отключенных сессий, а пользователи не выходят по правилам...
28. Дмитрий Юхтимовский (7o2uYXg) 29.03.12 10:32
а вот этого разве недостаточно:
ЗавершитьРаботуСистемы(Истина,Истина,"/ClearCache");
?
29. Ruslan (rus128) 29.03.12 10:36
(0) Хорошая идея!
(23) а кто батник запускает?
(27) Принудительно? Тогда запуск 1С идет медленнее, а здесь очистка кеша выполняется только при необходимости.
30. geterosser (Belkin_Sergey) 29.03.12 10:56
(28) 7o2uYXg, смысл доработки в том, чтобы очистить кэш у пользователя в любом случае, если у него была открыта база в момент динамического обновления. А что если пользователь не захотел перезапускать сеанс и закрыл 1С в конце рабочего дня? При использовании ЗавершитьРаботуСистемы(Истина,Истина,"/ClearCache"), дополнительный параметр /ClearCache будет актуален, если только пользователь на вопрос о перезапуске сказал да, и при вызове ЗавершитьРаботуСистемы второй параметр указан как Истина. Если вы заметили в моем коде, второго параметра нет.
31. geterosser (Belkin_Sergey) 29.03.12 10:58
(29) rus128, такая идея тоже была. 1С запускается в два раза медленнее. Пользователи не довольны.
32. Александр Лукин (i_lo) 29.03.12 12:42
(31) geterosser, тогда лучше бы при обнаружении обновления какой-то конфигурации, в укромное предопределенное место записывался фиксированный файл, наличие которого при повторном входе, вызывало очистку кэша. Количество замедленных запусков сократится! Может куда-то в этом направлении подумать?
33. geterosser (Belkin_Sergey) 29.03.12 13:01
(32) i_lo, получается тоже самое, но через другую дверь. Можно и так.
34. Сергей (sstar90) 29.03.12 13:02
(11) Stamper, очистка кэша при обновлении системной информации присутствовала уже и в версии 8.1
35. Ruslan (rus128) 29.03.12 14:53
(31) так и я говорю (защищая ваше решение), что не принудительно нужно кеш чистить, а только в случае необходимости.
37. geterosser (Belkin_Sergey) 29.03.12 21:27
(36) yaidiot123, классный никнэйм!
38. Алексей Бачев (MultiLexx) 30.03.12 10:28
Очень полезная вещь! Частенько приходится клиентам обновлять динамически, и потом начинаются чудеса. То у всех пользователей работает с обновлениями, а у одного-двух нет, то еще чего нибудь.
39. Stamper (Stamper) 30.03.12 10:39
(34) sstar90, а как это можно было сделать, например, программно?
40. Сергей (sstar90) 30.03.12 14:05
(39) Stamper, честно говоря вопросом, как это сделать программно, не задавался, но и в Вашем комментарии (11) Вы тоже не поднимаете этот вопрос, а только даете сообщение, что данная возможность появилась в 8.2.15, я же указал что она появилась гораздо раньше. С другой стороны, все процедуры и функции, описанные в данной публикации в 8.1 присутствуют, т.ч. программно этот вопрос может быть решен в 8.1 аналогично.
41. Stamper (Stamper) 30.03.12 17:29
(40) sstar90, видимо, мы не поняли друг-друга :)
я исходил из того, что раз эта функция описана в "новшествах" версии 8.2.15.301, то в предыдущих версиях её не было. сам метод реализован, видимо, давно. но, как я понял, его выполнение не совершало именно очистку кэшей.
прочитав (34) я подумал, что речь идёт о каком-то другом способе.
итак, в (34) имелось в виду что в 8.1 этот же метод ОбновитьИнтерфейс() осуществлял очистку кэшей???
42. Сергей (sstar90) 31.03.12 14:28
(41) Stamper, в (34) я хотел сказать, что и в 8.1 и 8.2 ОбновитьИнтерфейс() выполняются одинаково
43. Иван (Spartan) 02.04.12 17:07
(30) В дополнение идеи с сохранением статуса очистки кэша для пользователя...
Есть такая мысль: вместо использования регистра, можно применить функции СохранитьЗначение(), ВосстановитьЗначение() - они как раз работают в разрезе комбинации Пользователь - ИБ.
Произошло динамическое обновление, в процедуре ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ() пишем флаг:
СохранитьЗначение("НеобходимоОчиститьКэш", Истина);

Если пользователь ответил утвердительно на вопрос о перезапуске, вызываем метод ЗавершитьРаботуСистемы() с параметром "/ClearCache" в процедуре ПерезапуститьСеансРаботыСПрограммой() и снимаем флаг, т.к. кэш будет очищен при повторном запуске, а заодно запоминаем в текущем сеансе, что действия по очистке кэша уже выполнены:
	глКэшОчищен = Истина;
	СохранитьЗначение("НеобходимоОчиститьКэш", Ложь);
	ЗавершитьРаботуСистемы(Истина, Истина, "/ClearCache");

Если же пользователь отказался, и закрыл программу сам или сделал это раньше, чем сработал обрабочик ожидания, то в процедуре ПриЗавершенииРаботыСистемы() проверяем дополнительно, нужно ли чистить кэш при следующем запуске:
Если глКэшОчищен <> Истина И КонфигурацияБазыДанныхИзмененаДинамически() Тогда
		СохранитьЗначение("НеобходимоОчиститьКэш", Истина);
	КонецЕсли;
Ну и при каждом запуске в процедуре ПриНачалеРаботыСистемы() проверяем флаг очистки кэша. Если кэш не был ощищен - выполняем перезагрузку с параметром:
Если ВосстановитьЗначение("НеобходимоОчиститьКэш") = Истина Тогда
		ПерезапуститьСеансРаботыСПрограммой();
		Возврат;
	КонецЕсли; 

Будет работать или нет - надо проверять, но на первый взгляд должно прокатить...
44. Иван (Spartan) 02.04.12 17:14
Конечно чуть дольше будет выполняться загрузка с повторным перезапуском, но, думаю, не критично.
45. geterosser (Belkin_Sergey) 03.04.12 07:26
(43) Spartan, с одной стороны этот вариант лучше, чем регистр сведений. Но с другой, как назначить пользователю регламентную очистку кэша? С регистром сведений - это просто.
46. Иван (Spartan) 03.04.12 10:11
(45) Да, согласен. Но зато тут минимум доработок - только пара дописок в модуль. С регистром конечно можно сделать более продвинутую систему.
47. Misha ⁠ (Magister) 03.04.12 11:13
(43) не будет работать, если пользователь заходит с разных компьютеров. кэш нужно чистить на каждом компе.
sanfoto; Spartan; +2 Ответить 1
48. Иван (Spartan) 03.04.12 11:52
(47) Тут и регистр не поможет, разве что хранить в нем еще имя компьютера... Ну и плюс ко всему, можно сделать кнопку в общем интерфейсе, на которую повесить процедуру перезапуска с очисткой кэша для разного рода случаев - пусть вручную давит на кнопку, когда нужно.
49. Иван (Spartan) 03.04.12 12:00
+(48) Можно, в общем, и с СохранитьЗначение выкрутиться - писать соответствие, а не просто флаг.
50. Misha ⁠ (Magister) 04.04.12 10:23
(48) Я пока что на каждом компе в автозапуск поставил скрипт очистки кэша. Минус - утром всегда 1С запускается медленнее. Зато, если что-то глючит, можно пользователю сказать: перезагрузи компьютер. Никакой мороки :)
51. Иван (Spartan) 10.04.12 12:38
ЗавершитьРаботуСистемы(Истина, Истина, "/ClearCache") ни хрена не работает - после перезапуска глюки остаются... а после ручной чистки - пропадают
52. geterosser (Belkin_Sergey) 10.04.12 13:06
(51) Spartan, значит все не зря писалось тут.
53. Федор Иванов (fred20002) 13.04.12 15:51
В чем проблема ЗавершитьРаботуСистемы(Истина, Истина, "/ClearCache")?
54. Антон Чарушкин (hulio) 18.04.12 14:56
55. jack smith (jsmith) 18.04.12 14:58
Очень полезная штука, щас скачаю
56. Иван (Spartan) 19.04.12 20:09
(54) Периодически обращаются пользователи с проблемами, которые решаются очисткой кэша: неработающие пункты меню и пр. Попробовал перезапустить с параметром - ничего не изменилось. Очистка файлов кэша вручную помогла как и раньше.
57. Антон Чарушкин (hulio) 27.04.12 14:02
(56) Spartan, действительно, ничего не очищается ...
Я сделал кнопку, по нажатию на которую вызывается небольшая процедурка с таким кодом:

#Если Клиент Тогда
Процедура ОчиститьКэш() Экспорт 
	
	Текст = "Ваш сеанс работы с 1С будет перезапущен, все несохраненные данные при этом будут утеряны. Продолжить?";
	Ответ = Вопрос(Текст, РежимДиалогаВопрос.ОКОтмена, 30, КодВозвратаДиалога.ОК, "Очистка кэша", КодВозвратаДиалога.Отмена);
	
	Если Ответ = КодВозвратаДиалога.ОК Тогда 
		ПрекратитьРаботуСистемы(Истина, "/ClearCache");
	КонецЕсли;
	
КонецПроцедуры
#КонецЕсли
...Показать Скрыть

Работоспособность проверил следующим образом:
Зашел в 1С, в интерфейс добавил себе кнопку для открытия какой-то формы, пооткрывал разные окна и побаловался с ними (менял размеры, перемещал). Затем я закрыл 1С, чтобы настройки окон и интерфейса сохранились, открыл снова, проверил, что все настройки восстановились, и нажал на кнопку, по которой вызывается указанная мной процедура. Настройки форм и интерфейса остались прежними :)
Версия платформы: 8.2.15.310
58. Денис Шарабоков (zShamaNz) 15.05.12 20:55
Скидываю свой вариант: кэш чиститься только в одной базе, т.к.баз много и закрывать все и чистить их при динамическом обновлении одной нерационально... Сделан регистр сведений для фиксации пользователей, которые работали в момент обновления, их кэш очищаем.

// Проверяет в конфигурации ИБ наличие изменений появившихся после старта сеанса
//
Процедура ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ() Экспорт
	
	//Очиска Кэша
	НаборОчискаКэша					= РегистрыСведений.ОчискаКэша.СоздатьНаборЗаписей();
	НаборОчискаКэша.Отбор.Пользователь.Установить(ПараметрыСеанса.ТекущийПользователь);
	
	Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда
		НовыйНабор						= НаборОчискаКэша.Добавить();
		НовыйНабор.Пользователь			= ПараметрыСеанса.ТекущийПользователь;
		НовыйНабор.ОбновленаДинамически	= Истина;
		НаборОчискаКэша.Записать();
		
	КонецЕсли;
	
	НаборОчискаКэша.Прочитать();
	// Если в конфигурации после старта текущего сеанса что-то изменилось
	Если НЕ НаборОчискаКэша.Количество() = 0 И НаборОчискаКэша[0].ОбновленаДинамически Тогда

		// Завершим проверку обновления
		ЗавершитьПроверкуДинамическогоОбновленияИБ();

		// Спросим пользователя о его желании перезапустить сеанс
		ТекстВопроса = "В конфигурацию ИБ внесены изменения." + Символы.ПС +
						"Для работы с ними рекомендуется перезапустить программу." + Символы.ПС +
						"Перезапустить?";
		РезультатВопроса = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);

		// Если пользователь не хочет перезапускать сеанс
		Если РезультатВопроса = КодВозвратаДиалога.Нет Тогда
			// Запустим проверку обновления опять
			НачатьПроверкуДинамическогоОбновленияИБ();
			Возврат;
		КонецЕсли;

	
		// Попробуем перезапустить
		глЗапрашиватьПодтверждениеПриЗакрытии = Ложь;
		
		ЗавершитьРаботуСистемы(Истина, Ложь);

	КонецЕсли;

КонецПроцедуры

// Процедура создает и запускает vbs файл, который производит очистку кэша.
// 1С и презапускает программу
//
Процедура ОчиститьКэшИПерезапуститьПрограмму() Экспорт
	
	НаборОчискаКэша							= РегистрыСведений.ОчискаКэша.СоздатьНаборЗаписей();
	НаборОчискаКэша.Отбор.Пользователь.Установить(ПараметрыСеанса.ТекущийПользователь);
	
	НаборОчискаКэша.Прочитать();
	Если НЕ НаборОчискаКэша.Количество()	= 0 И НаборОчискаКэша[0].ОбновленаДинамически Тогда
		НаборОчискаКэша[0].ОбновленаДинамически	= Ложь;
		НаборОчискаКэша.Записать();
	Иначе
		Возврат;	
	КонецЕсли;   
	
	WshShell	= Новый COMОбъект("wscript.shell");
	СкриптФайл	= Новый ТекстовыйДокумент;
	
	СтрокаСоединенияСБД = СтрокаСоединенияИнформационнойБазы();
	СтрокаЗапускаПрограммы = КаталогПрограммы();
	
	AppData	= WshShell.SpecialFolders.Item("AppData");
	ПутьКФайлуСИДБаз = AppData + "\1C\1CEStart\ibases.v8i";
	ПутьКФайлу1С = СтрокаЗапускаПрограммы + "1cv8.exe";
	
	НазваниеПапки	= "";
	Текст = Новый ЧтениеТекста(ПутьКФайлуСИДБаз, КодировкаТекста.ANSI);
	Стр = Текст.ПрочитатьСтроку();
	Пока Стр <> Неопределено Цикл // строки читаются до символа перевода строки
	    Стр = Текст.ПрочитатьСтроку();
		Если Найти(Стр, СтрокаСоединенияСБД)>0 Тогда
		    Стр = Текст.ПрочитатьСтроку();
			НазваниеПапки	= СокрЛП(СтрЗаменить(Стр, "ID=", ""));
			Прервать;
		КонецЕсли; 
	КонецЦикла;	
	
	ИмяКаталогаСКэшем	= СтрЗаменить(AppData,"Roaming","Local") + "\1C\1Cv82\" + НазваниеПапки;	
	КаталогСКэшем = Новый Файл(ИмяКаталогаСКэшем);
	Если НЕ НазваниеПапки = "" И КаталогСКэшем.Существует()  Тогда
	Иначе
		Сообщить("Каталог с кэшем не найден.");
		Возврат;
	КонецЕсли; 
	
	ИмяСервера = "";
	ИмяБазы = "";
	Путь = "";
	КомандаЗапуска = "";
	
	Один = """";
	Два = """""";
	Три = """""""";  
	
	Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
		Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
		Путь = Лев(Путь, СтрДлина(Путь)-1);
		КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
	Иначе
		МассивПараметровСоединения = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
		МассивПараметровСервера = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
		ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
		МассивПараметровБазы = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
		ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
		КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
	КонецЕсли;
	
	СкриптФайл.УстановитьТекст
	(" WScript.Sleep(5000)
	|Dim FSO
	|Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
	|Set WshShell = WScript.CreateObject(""WScript.Shell"")
	|If FSO.FolderExists(""" + ИмяКаталогаСКэшем + """) Then
	| GoSubFolders """ + ИмяКаталогаСКэшем + """
	|End If
	|" + КомандаЗапуска+ "
	|Set WshShell = Nothing
	|Sub DelFile(sFILE)
	| On Error Resume Next
	| FSO.DeleteFile sFILE, True
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error deleting file: "" & sFILE
	| End If
	|End sub
	|
	|Function GetFolder(sFOLDER)
	| On Error Resume Next
	| Set GetFolder = FSO.GetFolder(sFOLDER)
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
	| Wscript.Quit Err.Number
	| End If
	|End Function
	|
	|Sub GoSubFolders (objDIR)
	| ProcessFilesInFolder objDIR
	| Set sFolder = GetFolder(objDIR)
	| For Each eFolder in sFolder.SubFolders
	| GoSubFolders eFolder
	| Next
	| FSO.DeleteFolder sFolder, True
	|End Sub
	|
	|Sub ProcessFilesInFolder (objDIR)
	|Set sFolder = GetFolder(objDIR)
	|For Each objFile in sFolder.Files
	| DelFile objFile
	|Next
	|End Sub");
	Попытка
		СкриптФайл.Записать(КаталогВременныхФайлов()+"clean.vbs",КодировкаТекста.Системная);
                ЗапуститьПриложение(""""+КаталогВременныхФайлов()+"clean.vbs""");
		WshShell	= Неопределено;
	Исключение
		
	КонецПопытки;
	
КонецПроцедуры
...Показать Скрыть
7OH; Belkin_Sergey; +2 Ответить 2
59. geterosser (Belkin_Sergey) 16.05.12 07:39
(58) zShamaNz,

Кул. Это именно тот вариант, до которого все тут дошли во время обсуждения, но никто не решился сделать. Спасибо.
60. geterosser (Belkin_Sergey) 16.05.12 07:43
(58) zShamaNz,

В регистре сведений еще можно добавить флаг "Принудительно". Например, для того, чтобы не ждать от пользователя утвердительного ответа, а тупо дать ему минуту на сохранение данных и все убить.
61. Dmitriy (daho) 12.10.12 11:37
Есть еще вариант, но он самый убийственный.. :)
rmdir "%AppData%\1C\1Cv82" /S /Q
rmdir "%LOCALAPPDATA%\1C\1Cv82" /S /Q
Где-то здесь же и нарыл...
62. Максим Федоточев (fedotochevm) 12.10.12 11:42
63. Владимир Гусев (adhocprog) 11.12.12 13:33
(6) geterosser, а зачем грохать все, если глючит одна база? :)
64. Александр Кузьмин (@vk) 08.02.13 10:28
А чем отличается этот вариант очистки от варианта с помощью батника?
65. Беслан Байрамов (besometr) 29.04.13 10:19
Спасибо большое! Решает множество проблем.
Интересно, а будет работать в домене? Там же временные файлы хранятся на сервере.
66. Alex Azarnin (1985Alex1985) 30.04.13 11:42
Спасибо. Из всех вариантов очистки кеша этот самый интересный.
Belkin_Sergey; +1 Ответить
67. geterosser (Belkin_Sergey) 30.04.13 13:35
(64) @vk, это тот же самый батник, но генерится он из 1С при закрытии программы. А отличие в том что вам не надо идти к пользователю (или высылать файл по почте), можно просто поставить признак необходимости очистки кэша в 1С.
68. Alex Azarnin (1985Alex1985) 13.05.13 18:27
Пытаюсь такую штуку встроить в конфу.
И глазами и поиском и глобальным поиском искал - не могу найти "ОбработчикОповещения" впринципе в конфе. (ППЦ я слепоглазое днище наверное). Конфа УТП 1.2.13.2 Подскажите, что я делаю не так?
69. Alex Azarnin (1985Alex1985) 13.05.13 20:14
Олилуя!!! нашел я эту штуку. Это не процедура модуля обычного приложения ОбработчикОповещения(), а стандартная функция ПодключитьОбработчикОжидания(). С ее помощью получилось добиться, что бы при динамическом изменении пользователи получали сообщение о необходимости перезапуска 1С.
70. Alex Azarnin (1985Alex1985) 14.05.13 11:58
Посоветуйте пожалуйста литературу или может хелп какой, что бы в тексте скрипта помог разобраться (что бы понять ЧТО ИМЕННО он делает и при необходимости его модифицировать), а то так то вроде все работает, но клиентам сцыкотно внедрять "шаманский код" до конца не понимая его.
71. Alex Azarnin (1985Alex1985) 15.05.13 16:02
Еще такой вопрос: Если произошло ДО, пользователь не вышел из базы, сеанс грохнули, кэш НА ЭТОМ компе не очистился.
Пользователь "обиделся" и сменил терминал. Зашел там, поработал, нажал завершение работы. В регистре записано, что надо пичистить ему кэш. Но! Кэш то почистить надо НА ДРУГОМ компе. В таком случае пострадает "невинный" кэш, а нужный не очистится. Мне кажется, что в регистр надо кроме измерения "Пользователь" добавить имя ПК, что бы чистился "тот самый... испорченный кэш", а не первый попавшийся. Сильно бредовое предположение или нормальное?
72. geterosser (Belkin_Sergey) 16.05.13 07:16
(71) 1985Alex1985, предложение отличное.
73. Alex Azarnin (1985Alex1985) 16.05.13 14:54
ТекПользователь = ПараметрыСеанса.ТекущийПользователь;
	ТекКомпьютер = ИмяКомпьютера();
	СтруктураОтбора = Новый Структура;
	СтруктураОтбора.Вставить("Пользователь",ТекПользователь);
	СтруктураОтбора.Вставить("ИмяПК",ТекКомпьютер);
	ПараметрыОчисткиКэша = РегистрыСведений.hiДинамическиеОбновления.ПолучитьПоследнее(ТекущаяДата(),СтруктураОтбора);
	ПараметрыОчисткиКэша.КэшОчищен = ?(ПараметрыОчисткиКэша.КэшОчищен = Неопределено,Истина,ПараметрыОчисткиКэша.КэшОчищен);
...Показать Скрыть

Написал такой код. Думал, что
ПараметрыОчисткиКэша.КэшОчищен = Неопределено
будет в то случае, если по отбору не будет записи. А вот и нет. Возвращает "ложь" для измерения типа булево, если не найдена запись.

И далее
Если НЕ ПараметрыОчисткиКэша.КэшОчищен Тогда
первый раз для всех пользователей система будет считать что надо перегрузиться. вижу два выхода - использовать не булево а другой тип, или получать данные запросом(там результат будет пустой если нет записи по такому отбору). Может кто нить предложить третий вариант? (Вариант подогнать Ложь\Истина так, что бы мне для первого запуска подходила ложь - не рассматриваю).

Вот такой вариант пока буду использовать как конечный(если подскажете, что в нем улучшить, пожелаю вам здоровья):
  ТекПользователь = ПараметрыСеанса.ТекущийПользователь;
	ТекКомпьютер = ИмяКомпьютера();
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	hiДинамическиеОбновленияСрезПоследних.Период,
		|	hiДинамическиеОбновленияСрезПоследних.Пользователь,
		|	hiДинамическиеОбновленияСрезПоследних.ИмяПК,
		|	hiДинамическиеОбновленияСрезПоследних.КэшОчищен
		|ИЗ
		|	РегистрСведений.hiДинамическиеОбновления.СрезПоследних(
		|			,
		|			Пользователь = &Пользователь
		|				И ИмяПК = &ИмяПК) КАК hiДинамическиеОбновленияСрезПоследних";

	Запрос.УстановитьПараметр("ИмяПК", ТекКомпьютер);
	Запрос.УстановитьПараметр("Пользователь", ТекПользователь);

	Результат = Запрос.Выполнить();

	Выборка= Результат.Выбрать();
	
	Если Выборка.Количество() = 0 Тогда
	
		КэшОчищен = Истина;
	Иначе
		Выборка.Следующий();
		КэшОчищен = Выборка.КэшОчищен;
	
	КонецЕсли;
	
	Если НЕ КэшОчищен Тогда
...Показать Скрыть
74. geterosser (Belkin_Sergey) 17.05.13 08:07
(73) 1985Alex1985, зачем делать регистр сведений периодическим?
У меня регистр не периодический.
Делается отбор по текущему пользователю, если есть записи, то читается признак необходимости очистки кеша, если их нет, то происходит выход из процедуры. В вашем случае, нужно просто дополнительный отбор сделать по имени ПК.

вот мой код.
	НаборОчискаКэша = РегистрыСведений.бссОчискаКэша.СоздатьНаборЗаписей();
	НаборОчискаКэша.Отбор.Пользователь.Установить(ПараметрыСеанса.ТекущийПользователь);
	// отбор по имени ПК
	НаборОчискаКэша.Отбор.ИмяПК .Установить(ИмяКомпьютера());

	НаборОчискаКэша.Прочитать();
	
	ЕстьЗаписи = (НаборОчискаКэша.Количество() > 0);
	
	Если НЕ ЕстьЗаписи Тогда
		Возврат;   
	КонецЕсли;   
	
	// У нас всегда 1 пользователь, 1 ПК - 1 запись.
	ТребуетсяПерезапуск 	= НаборОчискаКэша[0].ТребуетсяПерезапуск;
	ОбновленаДинамически 	= НаборОчискаКэша[0].ОбновленаДинамически;
	НеОчищатьНикогда 	= НаборОчискаКэша[0].НеОчищатьНикогда;
	
	Если НЕ ОбновленаДинамически Тогда
		Возврат;
	КонецЕсли;
	
	Если НеОчищатьНикогда Тогда
		НаборОчискаКэша[0].ОбновленаДинамически = Ложь;
		НаборОчискаКэша[0].ТребуетсяПерезапуск = Ложь;
		НаборОчискаКэша.Записать();
		Возврат;
	КонецЕсли;
		
	WshShell   	= Новый COMОбъект("wscript.shell");
	СкриптФайл  = Новый ТекстовыйДокумент;
	
	СтрокаСоединенияСБД 	= СтрокаСоединенияИнформационнойБазы();
	СтрокаЗапускаПрограммы 	= КаталогПрограммы();
	
	AppData   		= WshShell.SpecialFolders.Item("AppData");
	ПутьКФайлуСИДБаз 	= AppData + "\1C\1CEStart\ibases.v8i";
	ПутьКФайлу1С 		= СтрокаЗапускаПрограммы + "1cv8.exe";
	
	НазваниеПапки   = "";
	Текст = Новый ЧтениеТекста(ПутьКФайлуСИДБаз, КодировкаТекста.ANSI);
	Стр = Текст.ПрочитатьСтроку();
	Пока Стр <> Неопределено Цикл // строки читаются до символа перевода строки
		Стр = Текст.ПрочитатьСтроку();
		Если Найти(Стр, СтрокаСоединенияСБД)>0 Тогда
			Стр = Текст.ПрочитатьСтроку();
			НазваниеПапки = СокрЛП(СтрЗаменить(Стр, "ID=", ""));
			Прервать;
		КонецЕсли; 
	КонецЦикла;   
	
	ИмяКаталогаСКэшем = СтрЗаменить(AppData,"Roaming","Local") + "\1C\1Cv82\" + НазваниеПапки;   
	КаталогСКэшем = Новый Файл(ИмяКаталогаСКэшем);
	Если НЕ НазваниеПапки = "" И КаталогСКэшем.Существует()  Тогда
	Иначе
		//Сообщить("Каталог с кэшем не найден.");
		Возврат;
	КонецЕсли; 
	
	ИмяСервера = "";
	ИмяБазы = "";
	Путь = "";
	КомандаЗапуска = "";
	
	Один = """";
	Два = """""";
	Три = """""""";  
	
	Если ТребуетсяПерезапуск Тогда
		Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
			Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
			Путь = Лев(Путь, СтрДлина(Путь)-1);
			КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
		Иначе
			МассивПараметровСоединения = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
			МассивПараметровСервера = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
			ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
			МассивПараметровБазы = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
			ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
			КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
		КонецЕсли;
	КонецЕсли;
	
	ТекстСкрипта = "WScript.Sleep(5000)
	|Dim FSO
	|Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
	|Set WshShell = WScript.CreateObject(""WScript.Shell"")
	|If FSO.FolderExists(""" + ИмяКаталогаСКэшем + """) Then
	| GoSubFolders """ + ИмяКаталогаСКэшем + """
	|End If
	|" + КомандаЗапуска+ "
	|Set WshShell = Nothing
	|Sub DelFile(sFILE)
	| On Error Resume Next
	| FSO.DeleteFile sFILE, True
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error deleting file: "" & sFILE
	| End If
	|End sub
	|
	|Function GetFolder(sFOLDER)
	| On Error Resume Next
	| Set GetFolder = FSO.GetFolder(sFOLDER)
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
	| Wscript.Quit Err.Number
	| End If
	|End Function
	|
	|Sub GoSubFolders (objDIR)
	| ProcessFilesInFolder objDIR
	| Set sFolder = GetFolder(objDIR)
	| For Each eFolder in sFolder.SubFolders
	| GoSubFolders eFolder
	| Next
	| FSO.DeleteFolder sFolder, True
	|End Sub
	|
	|Sub ProcessFilesInFolder (objDIR)
	|Set sFolder = GetFolder(objDIR)
	|For Each objFile in sFolder.Files
	| DelFile objFile
	|Next
	|End Sub";
	
	СкриптФайл.УстановитьТекст(ТекстСкрипта);
	
	Если НЕ РольДоступна("ПравоАдминистрирования") Тогда // у нас кеш чистится всем кроме программистов

		Попытка
			СкриптФайл.Записать(КаталогВременныхФайлов()+"clean.vbs",КодировкаТекста.Системная);
			ЗапуститьПриложение(""""+КаталогВременныхФайлов()+"clean.vbs""");
			WshShell = Неопределено;
		Исключение
			МассивПолучателей = Новый Массив;
			МассивПолучателей.Добавить("Sergey@kss.com");
			ПроцедурыДляЗапускаНаСервере.ВыполнитьОтправкуПочты(МассивПолучателей, Новый Массив, "Ошибка автоматической очистки 1С кэша у пользователя " + КодПользователя, ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
	КонецЕсли;
	
	НаборОчискаКэша[0].ОбновленаДинамически = Ложь;
	НаборОчискаКэша[0].ТребуетсяПерезапуск = Ложь;
	НаборОчискаКэша.Записать();
...Показать Скрыть
75. Alex Azarnin (1985Alex1985) 17.05.13 09:15
(74) geterosser, Ну может я со временем придумаю что нибудь еще что добавить в этот регистр. Думаю период не повредит. Я бы еще добавил очистку кэша ОПРЕДЕЛЕННОЙ базы, а не всех подряд (как я понял из названий папок с кэшем у самой базы тоже есть гуид). Даже погуглил на эту тему, но ничего определенного пока не нашел. Доработка интересная в любом случае, и просто так я ее оставлять не буду.

П.С. в локалсетингс\аппдата находится кэш, в просто \аппдата находятся настройки... а еще где может быть кэш который портится? Или какие ситуации динамического обновления может не учесть эта доработка? Как то все не сложно получилось, аж не верится что 1С сами не впихнули что то такое во все конфы.
76. Андрей Овсянкин (Evil Beaver) 18.07.13 10:12
Столько комментариев, не осилил все, возможно выше уже что-то такое предложили.
Идея:
1.У каждого пользователя есть файл со списком ИБ - лежит в %APPDATA%\1Cestart
2.На сетевой шаре создается реестр баз, для которых нужно очистить кеш. В файле написаны строки подключения к базам (пути или адреса серверов)
3.На пользовательских машинах в планировщике задач ставится этот скрипт, который смотрит на сетевую шару и для заданных ИБ (если у пользователя они есть в списке баз) очищает кеш.
5.На Скрипт можно повесить ярлык и научить пользователей запускать принудительно

Плюсы:
Не модифицируем конфигурации
Управляем удаленно необходимостью чистки
Скрипт пускается автоматически, скажем каждую ночь и проверяет не надо ли чего почистить
Возможно ошибаюсь, по-моему в домене можно настроить планировку заданий на каждой машине удаленно, т.е. не надо ходить к каждому и настраивать расписание.
77. Сергей Сергей (26178@mail.ru) 18.07.13 13:51
Да кэш это беда 1с, иногда даже не понятночто такое а все дело в кэше
78. Александр Потапов (tiniji) 18.07.13 15:24
Помнится мне, сам Нуралиев писал на партнерском форуме, что проблема кэша будет решена в 8.3.
79. ZLENKO.PRO (ZLENKO) 23.07.13 15:49
(78) Они уже столько раз обещали ее решить в 8.2 ... и так и не решили. А в 8.3 у них Такси :-) приехало. Теперь уж точно не исправят. Просили ж их сделать тупую настройку в базе чтоб при запуске очищало кеш. А они что сделали - ключ запуска. Спасибо им конечно, но вот как мне его на практике использовать ?
80. max pik (maxopik2) 24.07.13 10:00
( Помнится мне, сам Нуралиев писал на партнерском форуме, что проблема кэша будет решена в 8.3.

Изменено: tiniji - 18.07.13 15:25 )

Наверное Нуралиев сам мало работает в 1с и не знает как это сидеть, смотреть в монитор и удивляться непонятным цифрам в отчете.
81. Александр Милютин (sanfoto) 25.07.13 11:43
(79) ZLENKO.PRO,

делаем общий для всех файл списка инф.баз ibases.v8i на расшареном ресурсе

пример
------------------
[WEB_Управление_Персоналом]
Connect=Srvr="server1c";Ref="WEB_Управление_Персоналом";
ID=c43ff957-1669-435e-be37-6eb729ee45bc
OrderInList=16384
Folder=/
OrderInTree=16384
External=0
App=Auto
WA=1
AdditionalParameters=/ClearCache

ПС:
Да всегда будет при запуске чистится кэш, но время запуска увеличивается таки не критично, зато нет гемора с кэшем.
82. Алекс Ю (AlexO) 27.07.13 15:35
(81) sanfoto,
делаем общий для всех файл списка инф.баз ibases.v8i на расшареном ресурсе

Можно, но совсем не обязательно, так как все решается проще: в Параметры на вкладке "Запуск 1С Предприятия" в "Параметр запуска" базы указывается этот ключ.
И у всех пользователей при старте идет очистка кэша (если ключ сработает). А файл загрузки забивать различными параметрами - их там и так много :)
83. Алекс Ю (AlexO) 27.07.13 15:39
(4) geterosser,
Написали много тут всего. Но не все знают, что кэш бьется не только и не столько при динамическом обновлении, и чистить его надо строго у определенных пользователей.
А вот почему бьется кэш в 1С - тут и интенсивность работы, и обновления, и еще куча всего вплоть до состояния жесткого и коллизий в сети.
Наверное, 1С могла бы дать более четкое определение причин, но не дала и не исправила до сих пор.
84. geterosser (Belkin_Sergey) 28.07.13 12:20
(83) AlexO,
и чистить его надо строго у определенных пользователей.
- true story.
Такая задумка была.
85. Алекс Ю (AlexO) 28.07.13 13:45
(84) geterosser,
Такая задумка была.

Алгоритм сам не определит таковых, а указать можно и скриптом вручную. Без изысков.
86. Артем Артеменко (dock) 20.12.13 12:01
по теме КЕШа... судя по работе, в 8.3 не решена эта проблема.
работаем с ЗУП 2.5, уже столкнулся с проблемами...
87. Алексей Штепа (unknownDaemon) 11.04.14 14:06
$DirLocal = "$env:LOCALAPPDATA\1C"
$DirRoaming = "$env:APPDATA\1C"

function _ClearCache {
        #
        $Dir = $args[0]
        #
        gci $Dir -rec -include *cache* | where { $_.psiscontainer } | gci -include *cache* | where { ! $_.psiscontainer } | foreach ($_) {remove-item $_.fullname}
        gci $Dir -rec -include *cache* | where { ! $_.psiscontainer } | foreach ($_) {remove-item $_.fullname}
        #
    }
...Показать Скрыть
88. artur rakhmatulin (нормальный такой) 06.08.14 12:25
(81) sanfoto, с этим флагом чистится только СЕРВЕРНЫЙ кеш.
на сколько я понял, в данной статье скрипт чистит локальный кеш пользователя, причем со всеми корнями. заполнениями форм и прочими настройками, некоторые пользователи будут ругаться что им всё приходится "забивать" заново.
89. Сергей Иванов (1Service2) 26.11.14 16:53
90. Александр Воронов (ya.Avoronov) 18.12.14 13:26
Полезная статья, а пробовал кто-то соединить все это в одной обработке и доступно предоставить нам пользователям? Что удивительно с ошибками кЭша при динамическом обновлении я начал сталкиваться только в последних релизах 1С. Не припомню такого на 8.0 и 8.1, или я был занят чем-то другим!
91. Евгений (le_) 20.05.16 12:35
А я вызов вот такой процедуры поместил в ПриЗавершенииРаботыСистемы():

Процедура ЗапуститьСкриптДляОчисткиКэша() Экспорт
	
	Если НЕ РольДоступна("ОчисткаКэшаПриЗавершенииРаботы")	 Тогда
		Возврат;
	КонецЕсли;

	ПутьКФайлуСкрипта = КаталогВременныхФайлов() + "Cache.vbs";
	
	Скрипт = Новый ТекстовыйДокумент;
	Скрипт.УстановитьТекст("
	|On Error Resume Next
	|Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
	|Set WshShell = WScript.CreateObject(""WScript.Shell"")
	|Set objWMIService = GetObject(""winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2"") 
    |
	|'логин, под которым работает пользователь
	|CurrentUserName = wshShell.ExpandEnvironmentStrings(""%USERNAME%"")
    |
	|'Если запущенных процесов 1cv8.exe больше 1, завершаем скрипт; если 1, ждем пока процесс завершится, чтобы продолжить работу скрипта
	|UserProcessesCount = GetUserProcessesCount(CurrentUserName)
	|If UserProcessesCount > 1 Then
  	|	WScript.quit
	|End If
	|Do While UserProcessesCount > 0
    |	WScript.Sleep(1000)'1 sek
    |	UserProcessesCount = GetUserProcessesCount(CurrentUserName)
	|Loop
    |
	|'удаление папок с кэшем целиком
	|UserProfileFolder = wshShell.ExpandEnvironmentStrings(""%USERPROFILE%"")
	|Set Folder = FSO.GetFolder(UserProfileFolder & ""\AppData\Local\1C\1Cv82"")
	|Folder.Delete
	|Set Folder = FSO.GetFolder(UserProfileFolder & ""\AppData\Roaming\1C\1Cv82"")
	|Folder.Delete
    |
	|Function GetUserProcessesCount(CurrentUserName)
    |
	|  GetUserProcessesCount = 0
	|  strNameOfUser = """"
	|  
	|  Set colProcesses = objWMIService.ExecQuery(""Select Name From Win32_Process Where Name = '1cv8.exe'"") 
    |
	|  For Each objProcess In colProcesses 
	|    Return = objProcess.GetOwner(strNameOfUser)
	|      If Return <> 0 Then
	|         'Wscript.Echo ""Could not get owner info for process "" & objProcess.Name & VBNewLine & ""Error = "" & Return
	|      Else
	|        If strNameOfUser = CurrentUserName Then
	|          GetUserProcessesCount = GetUserProcessesCount + 1 
	|        End If  
	|      End If
	|  Next
    |
	|End Function
	|	
	|");
	 
    Скрипт.Записать(ПутьКФайлуСкрипта, КодировкаТекста.Системная);
	ЗапуститьПриложение(ПутьКФайлуСкрипта);
КонецПроцедуры
...Показать Скрыть
92. jamirza emirbekov (jamirza) 27.05.16 18:28
Вот уж спасибо. Отличная идея.
93. jamirza emirbekov (jamirza) 27.05.16 18:34
Вот такую вещь разместил в обработчик ожидания. В параметрах сеанса в нашей конфе есть справочник компьютеры, туда добавил реквизит ДинамическоеОбновлениеИБ. В УТшке есть похожий параметр сеанса рабочее место.

	Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда
		
		Комп = ПараметрыСеанса.Компьютер.ПолучитьОбъект();
		Комп.ДинамическоеОбновлениеИБ = Истина;
		Комп.Записать();
		
		ТекстВопроса = "В конфигурацию ИБ внесены изменения." + Символы.ПС +
		"Настоятельно рекомендуется перезапустить программу." + Символы.ПС +
		"Сделать это сейчас?";
		Кнопки = Новый СписокЗначений;
		Кнопки.Добавить(1,"Да");
		Кнопки.Добавить(2,"Нет");
		Кнопки.Добавить(3,"Не уверен(а)");
		Кнопки.Добавить(4,"Воздержусь");
		
		РезультатВопроса = Вопрос(ТекстВопроса, Кнопки, 10);
		Если РезультатВопроса = 2 Тогда
			Возврат;
		КонецЕсли;
		
		ЗавершитьРаботуСистемы(Истина);
		
	КонецЕсли;
...Показать Скрыть


А перед завершением работы вот так
	Если ПараметрыСеанса.Компьютер.ДинамическоеОбновлениеИБ Тогда
	Комп = ПараметрыСеанса.Компьютер.ПолучитьОбъект();
		Комп.ДинамическоеОбновлениеИБ = Ложь;
		Комп.Записать();
		ОчиститьКэшИПерезапуститьПрограмму();
	КонецЕсли;
...Показать Скрыть


Процедуру со скриптом позаимстовал из статьи.
Теперь в любом случае при динамическом обновлении кэш почистится.
Еще раз спасибо за статью. Столько гемора у меня было с этим.
arakelyan; +1 Ответить