gifts2017

Пересчет элементов базы

Опубликовал Evil Grym (Evilgrym) в раздел Администрирование - Статистика базы данных

Обработка для пересчета элементов базы. Позволяет пересчитывать элементы базы несколько раз. При каждом пересчете в таблицу выводится новая колонка с количеством элементов.

Полезно для отлавливания мертвых, неиспользуемых элементов базы, для трассировки работы загадочных конфигураций,  а также в любых других случаях, где нужно знать количество объектов базы.

Скачать файлы

Наименование Файл Версия Размер
Обработка пересчета всех элементов базы 22
.zip 4,30Kb
21.03.12
22
.zip 4,30Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Evil Grym (Evilgrym) 22.03.12 12:03
Обработка для пересчета элементов базы. Позволяет пересчитывать элементы базы несколько раз. При каждом пересчете в таблицу выводится новая колонка с количеством элементов.

Перейти к публикации

1. Юлия Мазур (JJMM) 22.03.12 12:03
Спасибо, весьма полезная для нас обработка. А нельзя ли добавить параметры периода, чтобы подсчитывать количество операций/документов за месяц, квартал, и т.п., а так же расчетные поля = среднее за последние 3 месяца; среднее за последние полгода; среднее за последний год..

Заранее благодарна.
2. Антон (woozee) 28.03.12 13:47
Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Макет = ПолучитьМакет("Макет");
	ТабДок = ЭлементыФормы.ТабДок;
	ТабДок.Очистить();
	
	ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
	ТабДок.Вывести(ОбластьШапки);
	
	ОбластьСтроки = Макет.ПолучитьОбласть("Строка");
	
	ОбщееКоличество = 0;
	
	Для каждого Справочник Из Метаданные.Справочники Цикл
		Запрос = Новый Запрос("Выбрать * Из Справочник."+Справочник.Имя+"");
		КоличествоЭлементов = Запрос.Выполнить().Выбрать().Количество();
		Если КоличествоЭлементов <> 0 Тогда
			ОбластьСтроки.Параметры.ВидОбъекта = "Справочник";
			ОбластьСтроки.Параметры.Объект = Справочник.Имя;
			ОбластьСтроки.Параметры.Количество = КоличествоЭлементов;
			ТабДок.Вывести(ОбластьСтроки);
			ОбщееКоличество = ОбщееКоличество + КоличествоЭлементов;
		КонецЕсли; 
	КонецЦикла; 
	Для каждого Документ Из Метаданные.Документы Цикл
		Запрос = Новый Запрос("Выбрать * Из Документ."+Документ.Имя+"");
		КоличествоЭлементов = Запрос.Выполнить().Выбрать().Количество();
		Если КоличествоЭлементов <> 0 Тогда
			ОбластьСтроки.Параметры.ВидОбъекта = "Документ";
			ОбластьСтроки.Параметры.Объект = Документ.Имя;
			ОбластьСтроки.Параметры.Количество = КоличествоЭлементов;
			ТабДок.Вывести(ОбластьСтроки);
			ОбщееКоличество = ОбщееКоличество + КоличествоЭлементов;
		КонецЕсли;
	КонецЦикла; 
	ОбластьИтого = Макет.ПолучитьОбласть("Итого");
	ОбластьИтого.Параметры.ОбщееКоличество = ОбщееКоличество;
	ТабДок.Вывести(ОбластьИтого);
	
	ТабДок.Показать();
КонецПроцедуры
...Показать Скрыть


Пожелание автору - сделайте пожалуйста понавороченнее. С отборами, с графиками и прочей удобностью... Иначе смысла нету от публикации....
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа