gifts2017

Получение формы внешней обработки заполнения табличных частей

Опубликовал Sidor Petrov (1cinfo1) в раздел Программирование - Практика программирования

Столкнулся с проблемой невозможности получения формы внешней обработки заполнения табличных частей. Раньше в 8.1 с этим проблем не было - форму можно было получить простым методом - ЭтотОбъект.ПолучитьФорму("НужнаяФорма"). На релизе 8.2.13.219 (мы работаем на нем, как наиболее стабильном по нашим тестам) использование данного метода возвращает неопределенное значение. После ряда ухищрений удалось получить доступ к форме, ниже привожу алгоритм и пример обработки.

Предистория: возникла необходимость без изменения конфигурации реализовать заполнение табличной части одного документа на основании другого. Для решения подобных задач хорошо подходит методика использования обработки заполнения табличных частей, встроенного в типовые конфигурации 1С.

Для 8.1 работала такая методика.

Для выбора документа, на основании котого производилось заполнение в нужном документе, добавлялась форма во внешнюю обработку и прозводилось ее открытие:

Процедура Инициализировать(ДокументОбъект, Материалы, ТабПоле) Экспорт
    Если ТипЗнч(ДокументОбъект) = Тип("ДокументОбъект.АвизоМПЗИсходящее") Тогда
         ТекущийДокумент =ДокументОбъект;   
            НужнаяФорма = ПолучитьФорму("Форма");
            НужнаяФорма.Открыть();
    КонецЕсли    
КонецПроцедуры

Ну и далее в самой форме был код наподобии такого:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    Для Каждого ТекСтрокаТовары Из ДокРеализация.Товары Цикл
        лНоваяСтрока =     ТекущийДокумент.Товары.Добавить();
        лНоваяСтрока.Номенклатура  = ТекСтрокаТовары.Номенклатура;
        лНоваяСтрока.Количество    = ТекСтрокаТовары.Количество;
        ЗаполнитьЗначенияСвойств(лНоваяСтрока, ТекСтрокаТовары);       
        
    КонецЦикла;       
    
КонецПроцедуры

 

На платформе 8.2.19 такой код перестал работать (неуправляемое приложение, конфигурация 1С: Бухгалтерия КОРП 2.0).

Погуглив, перепробывал некоторые решения - результат отрицательный.

На инфостарте есть такой вариант для управляемых форм. Но он в нашем случае не подходит.

В итоге взял за основу следующую методику, пришлось только внести следующие изменения в код:

Процедура Инициализировать(ОбъектДок,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт
   
    ИмяОтчета="ЗаполнениеТЧАвизоПоРеализации";
    ИмяФайла = ПолучитьИмяВременногоФайла();
   
    Отчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета);
    ДвоичныеДанные = Отчет.ХранилищеВнешнейОбработки.Получить();
    ДвоичныеДанные.Записать(ИмяФайла);
    ФормаСписка = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
               
    ФормаСписка.ОбъектДокумент        = ОбъектДок;
    ФормаСписка.ИмяТЧ        = ИмяТабличнойЧасти;
    ФормаСписка.ТабПоле        = ТабличноеПолеОбъекта;
    ФормаСписка.Открыть();

КонецПроцедуры // ИнициироватьОбъект()

При этом нужно обязательно при добавлении во внешние обработки название обработки.

Во вложении привожу готовый работающий вариант (заполнение табличной части авизо исходящее по МПЗ на основании реализации.

P.S. Если кто знает более изящное решение - прошу сообщить.

 

 



Скачать файлы

Наименование Файл Версия Размер
Заполнение табличной части Авизо ПО МПЗ на основании реализации 22
.epf 17,96Kb
05.04.12
22
.epf 17,96Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Sidor Petrov (1cinfo1) 11.04.12 10:03
Столкнулся с проблемой невозможности получения формы внешней обработки заполнения табличных частей. Раньше в 8.1 с этим проблем не было - форму можно было получить простым методом - ЭтотОбъект.ПолучитьФорму("НужнаяФорма"). На релизе 8.2.13.219 (мы работаем на нем, как наиболее стабильном по нашим тестам) использование данного метода возвращает неопределенное значение. После ряда ухищрений удалось получить доступ к форме, ниже привожу алгоритм и пример обработки.

Перейти к публикации

1. Сергей Сергеев (Рамзес) 11.04.12 10:03
Лично у меня метод ПолучитьФорму работает. Платформа 8.2.15. Конфигурация УПП 1.3. И на платформе 8.2.14 работал.
2. Ирина Филиппова (ia57) 11.04.12 12:58
Придется, наверное, вам платформу обновить.
3. Дмитрий (sommid) 17.08.12 17:19
проблема не в безопасном режиме?
БезопасныйРежим = ИСТИНА;
обрДополнительная = ВнешниеОбработки.Создать(стрИмяВременногоФайла, БезопасныйРежим);

хотя там вроде сообщение соответствующее выдается.., для моих задач с внешними обработками явная установка безопасного режима помогла
4. Vlad (kitminsk) 24.10.12 15:02
Непонятно где это должно работать. Если на сервере, то там интерактивные процедуры недоступны(ПолучитьФорму), если на клиенте(тонком), то там ВнешниеОбработки доступны только на толстом клиенте.
5. andy3626603 (andy3626603) 27.12.14 16:23
Платформа 8.2.19.90
Все работает с помощью ПолучитьФорму("Форма");