gifts2017

Сортировка строк формы, с сохранением второго порядка

Опубликовал Илья (i132) в раздел Программирование - Практика программирования

Более удобная чем стандартная сортировка строк табличной части формы обычного приложения 8.х

Идея очень простая: пользователю удобно что если таблицу обработки отсортировать по галочке, сортировка по Номенлатуре / контрагенту внутри одниаковых галочек осталось прежней.

При стандартной сортировке при нажатии на кнопку сортировать, сортировка по одинаковым реквизитам изменяется произвольным образом. В 1С сделали наверно это для скорости - если надо можно указать несколько полей сортировке, но для интерфейса пользователя проще сделать чтобы при сортировке по одинаковым значениям из колонки сортировки старый порядок строк сохранялся. (таким образом мы получаем удобную сортировку по нескольким колонкам.)

Еще одно достоинство преопределения кнопки сортировать можно делать сортировку по галочкам -где заполнено свойство данные флажка. Можно добавить сортировку по артикулу и коду табличной части Товары.

Метод расчитан на то что имя колонки формы и колонки Таблицы/Дерева/ТабЧасти совпадают

Наврено 1С в скоре сделает разные методы сортировки по кнопке формы и метода .Сортировать(..) или добавит параметр -сохранять порядок. У меня сейчас стоит 8.2.14.540 и второй порядок нарушается.

(? -кто-ни-будь пользовался объектом сортировки ? -на что он влияет?)

Пока 1С это не поправила можно из  обработчика кнопки сортировать вызывать процедуру:

СортироватьЭкраннуюТаблицу(..)

//Сортирует Таблицу в соотвествии с порядком строк
//Параметры:
//ЭлементФормы -- Таблица на форме, тип значения данных: Табличная часть, ТаблицаЗначений, ДеревоЗначений
//Направление -- Направление сортировки ={ "Возр"/"Убыв" }
//ВходИмяКолонкиПорядокСтрок -- Если у таблицы есть клонка для скорости можно ее указать, иначе она будет создаваться и удаляться после сортировки
Процедура СортироватьЭкраннуюТаблицу(ЭлементФормы,Направление="Возр",ВходИмяКолонкиПорядокСтрок="") // Сортирует Таблицу в соотвествии с порядком строк //+Илья 130412
   
Перем КолонкаПорядка;

   
ИмяТекКолонки = ЭлементФормы.ТекущаяКолонка.Имя;
   
ТекТаблица = ЭлементФормы.Значение;
   
ЭтоТЗ = (ТипЗНЧ(ТекТаблица)=Тип("ТаблицаЗначений"));
   
ЭтоДерево = ?(ЭтоТЗ,Ложь,ТипЗНЧ(ТекТаблица)=Тип("ДеревоЗначений"));

    Если Не (
ЭтоТЗ или ЭтоДерево) Тогда //Может быть Таб чать?
       
МДТабчасти = Метаданные.НайтиПоТипу(Тип(ТекТаблица));
        Если
МДТабчасти = Неопределено или НЕ МДТабчасти.Родитель().ТабличныеЧасти.Найти(МДТабчасти.Имя)=МДТабчасти Тогда  //Это не табЧасть?
           
ТекТаблица.Сортировать(ИмяТекКолонки+" "+Направление);
            Возврат;
        КонецЕслИ;

        Если
МДТабчасти.Реквизиты.Найти(ИмяТекКолонки)=Неопределено Тогда
            Если Не
МДТабчасти.Реквизиты.Найти(ЭлементФормы.ТекущаяКолонка.Данные)=Неопределено Тогда
               
ИмяТекКолонки = ЭлементФормы.ТекущаяКолонка.Данные;
            ИначеЕсли Не
МДТабчасти.Реквизиты.Найти(ЭлементФормы.ТекущаяКолонка.ДанныеФлажка)=Неопределено Тогда
               
ИмяТекКолонки = ЭлементФормы.ТекущаяКолонка.ДанныеФлажка;
            Иначе
                Возврат;
//Нет реквизита сортировки
           
КонецЕсли;
        Конецесли;
       
ЭтоТабЧасть = Истина;

       
ВходИмяКолонкиПорядокСтрок = "НомерСтроки";
       
ТекТаблица = ТекТаблица.Выгрузить();
    КонецЕсли;

    Если
ТекТаблица.КОлонки.Найти(ИмяТекКолонки)=Неопределено Тогда //нет связи с таблицей
       
Если Не ТекТаблица.КОлонки.Найти(ЭлементФормы.ТекущаяКолонка.Данные)=Неопределено Тогда
           
ИмяТекКолонки = ЭлементФормы.ТекущаяКолонка.Данные;
        ИначеЕсли Не
ТекТаблица.КОлонки.Найти(ЭлементФормы.ТекущаяКолонка.ДанныеФлажка)=Неопределено Тогда
           
ИмяТекКолонки = ЭлементФормы.ТекущаяКолонка.ДанныеФлажка;
        Иначе
            Возврат;
        КонецЕсли;
    КонецЕсли;

   
ИмяКолонкиПорядокСтрок = ВходИмяКолонкиПорядокСтрок//"" => удалять колонку порядок
   
КолонкаПорядка = ВернутьСоздатьКОлонкуСтарогоПорядка(ТекТаблица,ИмяКолонкиПорядокСтрок);

   
ТхтСортировки = ИмяТекКолонки+" "+Направление+","+КолонкаПорядка.Имя;
    Если
ЭтоТЗ Тогда
       
МассивПрежнегоПорядка = ТекТаблица.ВыгрузитьКолонку(КолонкаПорядка);
       
ТекТаблица.Сортировать(ТхтСортировки);
        Если
ВходИмяКолонкиПорядокСтрок="" Тогда
           
ТекТаблица.Колонки.Удалить(КолонкаПорядка);
        Иначе
           
ТекТаблица.ЗагрузитьКолонку(МассивПрежнегоПорядка,КолонкаПорядка); //Количество строк не изменилось!
       
КонецЕслИ;
    ИначеЕсли
ЭтоДерево Тогда //Дерево
       
СтрокиДерева = ТекТаблица.Строки;
       
СтрокиДерева.Сортировать(ТхтСортировки,Истина);
        Если
ВходИмяКолонкиПорядокСтрок="" Тогда
           
ТекТаблица.Колонки.Удалить(КолонкаПорядка);
        Иначе
           
ПронумероватьСТрокиДерева(СтрокиДерева,КолонкаПорядка.Имя);
        КонецЕслИ;
    Иначе
//ТабЧасть
       
ТекТаблица.Сортировать(ТхтСортировки);
       
ЭлементФормы.Значение.Загрузить(ТекТаблица);
    КонецЕсли;
КонецПроцедуры
//----------------------------------------------
Функция ВернутьСоздатьКОлонкуСтарогоПорядка(ТекТаблица,ИмяКолонкиПорядокСтрок)
    Если
ПустаяСтрока(ИмяКолонкиПорядокСтрок) Тогда
       
ИмяКолонкиПорядокСтрок=СтрЗаменить("_"+(Новый УникальныйИдентификатор()),"-","");
    КонецЕслИ;

   
КолонкаПорядка = ТекТаблица.Колонки.Найти(ИмяКолонкиПорядокСтрок);
    Если
КолонкаПорядка = Неопределено Тогда
       
КолонкаПорядка = ТекТаблица.Колонки.Добавить(ИмяКолонкиПорядокСтрок,Новый ОписаниеТипов("Число"));
        Если
ТипЗНч(ТекТаблица)=Тип("ТаблицаЗначений") Тогда;
           
МассивИндексов = Новый Массив;     //Так быстрее: http://forum.infostart.ru/forum24/topic53488/message604616/
           
Для й=1 по ТекТаблица.Количество() Цикл
               
МассивИндексов.Добавить(й);
            КонецЦикла;
           
ТекТаблица.ЗагрузитьКолонку(МассивИндексов,КолонкаПорядка);
        Иначе
//Дерево значений
           
ПронумероватьСТрокиДерева(ТекТаблица.Строки,ИмяКолонкиПорядокСтрок);
        КонецЕсли;
    КонецЕсли;
    Возврат
КолонкаПорядка;
КонецФункции
//----------------------------------------------
Процедура ПронумероватьСТрокиДерева(СтрокиДерева,ИмяКолонкиПорядокСтрок,й=1)
    Для Каждого
СтрокаДерева из СтрокиДерева Цикл
       
СтрокаДерева[ИмяКолонкиПорядокСтрок]=й;
       
й=й+1;
        Если
СтрокаДерева.Строки.Количество()>0 тогда
           
ПронумероватьСТрокиДерева(СтрокаДерева.Строки,ИмяКолонкиПорядокСтрок,й);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Пример реализации: http://infostart.ru/public/116645/

Пример неудобной сортировки (для 7.7): http://infostart.ru/public/20464/

pls: подскажите как отловить нажатие на заголовок колонки таб части?

См. также

Подписаться Добавить вознаграждение

Комментарии

Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа