gifts2017

Печать Счета-фактуры из документа реализации

Опубликовал Андрей Бандурин (andrey1312) в раздел Печать - Печатные формы документов

Позволяет печатать из документа Реализация товаров и услуг, связанную с ним Счет-фактуру, если таковая имеется. Очень удобно при использовании пакетной печати документов, нет необходимости запускать отдельно распечатку счетов-фактур, сразу указываешь все необходимые ПФ для распечатки, да и группируются тогда печатные документы по клиентам.

Просто подключите данную внешнюю ПФ к документу Реализация товаров и услуг. Печатная форма в документе Счет-фактура должна называться "Счет-фактура", если она у вас называется по другому, то переименуйте ее или поправьте название в обработке. Сама обработка не содержит печатной формы СФ, а запускает существующую ПФ.

Скачать файлы

Наименование Файл Версия Размер
Файл обработки 135
.epf 4,67Kb
19.04.12
135
.epf 4,67Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. ghOst Bu (ilonnaa) 06.06.12 12:54
Наверное иногда может пригодится.
2. Павел Хорев (w22u) 12.08.12 21:08
Правильный подход. В печатных формах нужно иметь всего одну форму сф, которая в зависимости от даты документа сама вызывает на печать утвержденную постановлением правительства на эту дату форму. Эх сюда бы ещё механизм с добавками к названиям "Копий 2", "Копий 3" и т.д. ...
3. serko krav (serko8547) 16.08.12 22:47
4. serko krav (serko8547) 16.08.12 23:49
а, переписал форму, вот полный работающий код:

перем СсылкаНаОбъект экспорт;
перем НаПРинтер экспорт;
перем КоличествоЭкземпляров экспорт;

функция Печать() экспорт

Запрос = новый запрос;
Запрос.Текст = "ВЫБРАТЬ
| СчетФактураВыданныйДокументыОснования.Ссылка.Ссылка
|ИЗ
| Документ.СчетФактураВыданный.ДокументыОснования КАК СчетФактураВыданныйДокументыОснования
|ГДЕ
| СчетФактураВыданныйДокументыОснования.ДокументОснование = &ДокументОснование";
Запрос.УстановитьПараметр("ДокументОснование",СсылкаНаОбъект);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() тогда
СФ = Выборка.Ссылка.ПолучитьОбъект();
СФФорма = СФ.ПолучитьФорму("ФормаДокумента");


СтруктураВнутреннихПечатныхФорм = СФ.ПолучитьСтруктуруПечатныхФорм();
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(СФ.Ссылка, СтруктураВнутреннихПечатныхФорм);
Для каждого Строка Из ДеревоМакетовПечати.Строки Цикл

Если Строка.ТипКнопки = ТипКнопкиКоманднойПанели.Разделитель Тогда
Продолжить;
КонецЕсли;
Если Строка.Расшифровка = Неопределено Тогда
Продолжить;
КонецЕсли;
Если СокрЛП(Строка.Текст) = "Счет-фактура" тогда
УниверсальныеМеханизмы.ОткрытьФормуВыбораПечатныхФормОбъекта(СФ, СФФорма);
КонецЕсли;
КонецЦикла;

КонецЕсли;
КонецФункции
МимохожийОднако; +1 Ответить 1
5. serko krav (serko8547) 16.08.12 23:51
можно было конечно оставить и старый код, немного его подправив, но... лень-матушка мучает - да не дает этого сделать, да и горящие проекты...
6. Макас (makas) 28.11.12 15:22
Ошибка в типовой конф.УТ 10,3

Не удалось сформировать внешнюю печатную форму!
Слишком много фактических параметров
7. Yalo (yalo) 03.12.13 09:13
Для ленивых бухгалтеров
8. Надежда Игнатьева (Ignat_n) 17.10.14 17:11
(4) serko8547, Добавьте условие еще "И СчетФактураВыданныйДокументыОснования.Ссылка.Проведен = ИСТИНА" у реализации могут быть сч/ф помеченные на удаление и не проведенные.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа