Поиск и замена дублирующих элементов (условие по нескольким полям, определение правильных по заполненности реквизитов)

Опубликовал Юрий Соколов (sokol_5441) в раздел Администрирование - Сервисные утилиты

Поиск и замена дублирующих элементов (условие по нескольким полям, определение правильных по заполненности реквизитов)

Отличается от типовой:

1. добавлена возможности поиска на равное значение по нескольким реквизитам

2. добавлена возможность вручную дописывать условие текста запроса поиска дублей

3. добавлена возможность определения правильных элементов, не помеченных на удаление

4. добавлена возможность определения правильных элементов, заполненным реквизитом (выбирается в диалоге)

 

Обработка полезна для замены дублей подчиненных справочников (например: "Единицы измерения", так как при использовании стандартной обработки по наименованию найдутся все одинаковые единицы измерения, а необходимо искать в пределах подчинения), а так же других ситуаций.

 

Обработка универсальна и может применятся для любой конфигурации.

 

После установки условия поиска и поиска дублей добавлена возможность установки верным элемент не помеченный на удаление.

Так же добавлено условие установки верным элементом, с условием на равенство реквизита (в примере это реквизит "Управленческий код")

Скачать файлы

Наименование Файл Версия Размер
ПоискИЗаменаДублирующихсяЭлементов_Доработанный.epf
.epf 53,78Kb
26.04.12
505
.epf 53,78Kb 505 Скачать
Поиск и замена дублей подчиненных справочников.docx
.docx 563,11Kb
26.04.12
47
.docx 563,11Kb 47 Скачать

См. также

Комментарии
1. IR IR (Artemuch2) 26.04.12 13:13 Сейчас в теме
Добрый день! А в обработке вы учли функционал наработанный коллегами в предыдущих версиях или это совсем другая обработка замены значений"
2. Юрий Соколов (sokol_5441) 107 27.04.12 08:09 Сейчас в теме
Это обработка взята из "Управление торговлей 10.3", доработана. Она универсальна
3. Андрей (xrays) 25.07.12 16:59 Сейчас в теме
Замечательная обработка. Здорово помогла для исправления ситуации с задвоенной номенклатурой. Спасибо!!!
4. ylyas v (ylyas) 25 14.09.12 15:45 Сейчас в теме
доп отборы на сравнение не работают.
проверял на упп справочник договоров.
задав сравнение на орг = орг и контрагент= контрагент и вид договора = вид договора
получил в совпавших группах договора разных организаций.
5. Пимшин 1 (Pim) 154 11.01.13 08:30 Сейчас в теме
согласен с (4).

жаль, только поздно понял...

вот "заплатка":
вместо НайтиПоРавенствуРеквизитов надо вставить
вроде больше ничего не менял ( :-P )
------------------------------------------------------------------
///=========================================================­=====================
function CheckAttrsForDifference(vLine, vStructForCompare)

for each item in vStructForCompare do
fieldName = item.Key;
if vLine[fieldName] <> item.value then
return true;
endIf;
endDo;
return false;
endFunction // CheckAttrsForDifference

///=========================================================­=====================
Процедура НайтиПоРавенствуРеквизитов()

//СоколовЮВ+
structForCompare = new Структура;
attrStr = "";
ПостроительОтчета.Текст = ПолучитьТекстЗапросаДляПостроителя(РежимПоиска);
Если ЗначениеЗаполнено(ДопУсловие) Тогда
ПостроительОтчета.Текст = СтрЗаменить(ПостроительОтчета.Текст, "{ГДЕ", ДопУсловие + " {ГДЕ");
ТекстПоля = "";
ТекстСгруппировать = "";
Для Каждого ЭлементСписка Из СписокРеквизитовСправочника Цикл
Если Не ЭлементСписка.Пометка Тогда
Продолжить;
КонецЕсли;

ТекстПоля = ТекстПоля + Символы.ПС + "Спр1." + ЭлементСписка.Значение + ", ";
structForCompare.Insert(ЭлементСписка.Значение, "-");
attrStr = attrStr + ", " + ЭлементСписка.Значение;
КонецЦикла;

ПостроительОтчета.Текст = СтрЗаменить(ПостроительОтчета.Текст, "СГРУППИРОВАТЬ ПО", " СГРУППИРОВАТЬ ПО " + ТекстПоля);
ПостроительОтчета.Текст = СтрЗаменить(ПостроительОтчета.Текст, "ВЫБРАТЬ", "ВЫБРАТЬ " + ТекстПоля);
КонецЕсли;
//СоколовЮВ-

ПостроительОтчета.Выполнить();

мРезультатыПоиска = ПостроительОтчета.Результат.Выгрузить();
мРезультатыПоиска.Колонки.Добавить("НомерГруппы");
мРезультатыПоиска.Колонки.Добавить("Правильный", Новый ОписаниеТипов("Булево"));
мРезультатыПоиска.Колонки.Добавить("КоличествоСсылок");
мРезультатыПоиска.Сортировать("ЗначениеРеквизита" + attrStr);

ТаблицаГрупп.Очистить();

ЗначениеРеквизита = Неопределено;
ТекущаяГруппа = 0;
ЭлементовВГруппе = 0;
Для Каждого СтрокаПоиска ИЗ мРезультатыПоиска Цикл
Если (СтрокаПоиска.ЗначениеРеквизита <> ЗначениеРеквизита) or CheckAttrsForDifference(СтрокаПоиска, structForCompare) Тогда
for each item in structForCompare do
structForCompare.Insert(item.Key, СтрокаПоиска[item.Key]);
endDo;

ДобавитьНовуюГруппу(ТаблицаГрупп, ТекущаяГруппа, ЭлементовВГруппе, ЗначениеРеквизита);
ЗначениеРеквизита = СтрокаПоиска.ЗначениеРеквизита;
ТекущаяГруппа = ТекущаяГруппа + 1;
ЭлементовВГруппе = 0;
КонецЕсли;

СтрокаПоиска.НомерГруппы = -ТекущаяГруппа;
ЭлементовВГруппе = ЭлементовВГруппе + 1;
КонецЦикла;

ДобавитьНовуюГруппу(ТаблицаГрупп, ТекущаяГруппа, ЭлементовВГруппе, ЗначениеРеквизита);

ТаблицаГрупп.Сортировать("Количество");

ТекущаяГруппа = 1;
КолвоЭлементовКоллекции = ТаблицаГрупп.Количество();
Для ОбратныйИндекс = 1 По КолвоЭлементовКоллекции Цикл
ЭлементКоллекции = ТаблицаГрупп[КолвоЭлементовКоллекции - ОбратныйИндекс];

МассивСтрок = мРезультатыПоиска.НайтиСтроки(Новый Структура("НомерГруппы", -ЭлементКоллекции.НомерГруппы));

Если ЭлементКоллекции.Количество = 1 Тогда

Для каждого СтрокаГруппы ИЗ МассивСтрок Цикл
мРезультатыПоиска.Удалить(СтрокаГруппы);
КонецЦикла;
ТаблицаГрупп.Удалить(ЭлементКоллекции);

Иначе

Для каждого СтрокаГруппы ИЗ МассивСтрок Цикл
СтрокаГруппы.НомерГруппы = ТекущаяГруппа;
КонецЦикла;
ЭлементКоллекции.НомерГруппы = ТекущаяГруппа;
ТекущаяГруппа = ТекущаяГруппа + 1;

КонецЕсли;

КонецЦикла;

ТаблицаГрупп.Сортировать("Группа");
Если мРезультатыПоиска.Количество() > 0 Тогда
ВывестиГруппу(1);
КонецЕсли;
КонецПроцедуры
------------------------------------------------------------------


2-ой нюанс: не до конца исправлен косяк типовой обработки в части замены в регистрах бухгалтерии.
функция ВыполнитьЗаменуЭлементов

ЭтоДвижениеРегистраБухгалтерии = Метаданные.РегистрыБухгалтерии.Содержит(Движение);
ЕстьКорреспонденция = ЭтоДвижениеРегистраБухгалтерии и Параметры[Движение.Имя + "Корреспонденция"];

НаборЗаписей = Параметры.Объект.Движения[Движение.Имя];
НаборЗаписей.Прочитать();
НадоЗаписывать = Ложь;
ТаблицаНабора = НаборЗаписей.Выгрузить();
Для Каждого Измерение ИЗ Движение.Измерения Цикл
Если Измерение.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
Если ЕстьКорреспонденция and (ТаблицаНабора.Columns.Find(Измерение.Имя) = undefined) Тогда
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "ДТ");
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Измерение.Имя + "ДТ"] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "ДТ");
КонецЦикла;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "КТ");
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Измерение.Имя + "КТ"] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "КТ");
КонецЦикла;
Иначе

СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Измерение.Имя] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
КонецЦикла;
КонецЕсли;
КонецЕсли;
КонецЦикла;


Думаю, мои изменения здесь заметны без комментариев. Вот и ответ, тем кто спрашивает, почему я использую англ. язык.
6. ylyas v (ylyas) 25 13.01.13 06:42 Сейчас в теме
ну использование английского чтобы отличать свой код среди остального - не супер четкий аргумент, скажем так ))
Дмитрий74Чел; +1 Ответить
7. Василий К (tofree) 13 29.04.13 15:46 Сейчас в теме
не работает в УТ 11 в серверном варианте (заупк клиента: обычное приложение)
8. program program (prodines) 103 06.05.13 13:36 Сейчас в теме
Привязки в форме не установлены.
9. Павел Жданов (heavymetal) 86 07.04.15 11:32 Сейчас в теме
(0) исправьте ошибку, указанную в 4 комментарии, тогда плюсану
10. Павел Жданов (heavymetal) 86 07.04.15 11:38 Сейчас в теме
(5) Pim, спасибо, Ваша дописка помогла