gifts2017

Структура подчиненности для УТ 10.3

Опубликовал Андрей Акулов (DrAku1a) в раздел Отчеты - Разное

Структура подчиненности, в виде отчета (выводится в Табличный документ).
Дополнительно: возможность помимо суммы документа вывести суммы по регистрам "Взаиморасчеты с контрагентами", "Продажи", "Закупки" и "Товары на складах".
А также, выводит текущий долг по заказу покупателя (если возможно).

Дерево структуры подчиненности выводится в табличный документ с графическим представлением связей между документами и состояний этих документов.

Дополнительно: есть возможность вывести сумму документа, а также суммы и количества оборотов по регистрам "Взаиморасчеты с контрагентами", "Продажи", "Закупки", "Товары на складах", а также выводит текущий долг по заказу покупателя (если возможно).

Если в структуре подчиненности будет найден документ отгрузки (Реализация товаров и услуг) и в этом документе выбран договор с признаком ведения учета "По заказам", то при формировании внизу (под отчетом) будет выведена информация о долге (по взаиморасчетом) по сделке на рабочую дату.

Выводимые данные настраиваются...

Насколько все это удобно будет - пока что не знаю. Пробуем...

По быстродействию - медленнее стандартного будет...

Скачать файлы

Наименование Файл Версия Размер
НоваяСтруктураПодчиненности 122
.epf 26,19Kb
02.05.12
122
.epf 26,19Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Евгений В (Jkey) 30.07.13 09:04
Скачал. Открыл в "Управление торговлей", редакция 10.3 (10.3.20.2).
В УТ создан новый док "Потребности к заказу", скопированный из "Заказа поставщику" который вводится на основании "Заказа покупателя". На основании этого Дока "Потребности к Заказу", вводится док "Заказ поставщику". Док присутствует в КритерияхОтбора (в Составе) по ДокументОснование и полю ТЧ Товары "Заказ". Т.е. в связанныхДокументах он есть. Стандартная в УТ обработка Подчиненности выводит структуру нового дока немного некоректно. Вот так:

Заказ покупателя
Потребности к Заказу
	|-- Заказа поставщику


Хотелось бы стандартно Вот так:

Заказ покупателя
	|--Потребности к Заказу
		|-- Заказа поставщику

Решил попытать вашу обработку.
Без подчиненности нового дока выводит нормально.

Проверил с подчиненностью нового дока
Выбрал Заказ -> Сформировать.
В ответ Ошибка.
{Форма.СтруктураПодчиненности.Форма(418)}: Значение не является значением объектного типа (Дата) Если ТекРодительДата>ЗначениеРеквизита.Дата Тогда

в отладчике последний проверяемый реквизит Реквизит.Имя = ДокументОснование.

Добавьте проверку на заполненность Значения
Строка 416
Если ЗначениеРеквизита<>Неопределено Тогда // <
	Если ДокВсеСсылки.СодержитТип(ТипЗнч(ЗначениеРеквизита)) Тогда
...
	КонецЕсли;
КонецЕсли; // <
...Показать Скрыть

И строка 448

Если ЗначениеРеквизита<>Неопределено Тогда // <
	Если (ЗначениеРеквизита=неопределено) и ДокВсеСсылки.СодержитТип(ТипЗнч(ЗначениеРеквизита)) Тогда
...
	КонецЕсли;
КонецЕсли; // <
...Показать Скрыть


А так конечно Плюс.
2. Вадим Никонов (V.Nikonov) 28.11.13 08:50
Лично мне не хватает в структуре подчиненности возможности напечатать результат...
3. Андрей Акулов (DrAku1a) 28.11.13 18:32
(2) Здесь эта возможность, разумеется, присутствует, т.к. результат выводится в обычный табличный документ...
(1) Спасибо, добавлю.