gifts2017

Получение иерархии справочника "Номенклатура"

Опубликовал Константин Седорчук (snikers44) в раздел Программирование - Универсальные функции

Элементарная обработка для получения иерархии групп справочника "Номенклатура" без дублей.

 Для запуска одна кнопка...

Легко перепишется под любой другой справочник. 

Первая публикация, - не судите строго... Отчет создал на скорую руку для себя, так как не нашел такого на инфостате, решил поделиться, чтоб народ мог легко получить иерархию справочника "Без дублей", тех, которые создаются при группировке итогов по иерархии. Очистка дублей производится дополнительной функцией. 

	 Функция обУбратьОшибкиИтоговПоИерархии(Строки, Поле="Ссылка", Родитель=Неопределено) Экспорт
    //Убираем все элементы, равные текущему
    Всего=Строки.Количество();
    Для Инд=1 По Всего Цикл
        Стр=Строки[Всего-Инд];
        Зн=Стр[Поле];
        Если Родитель<>Неопределено И Зн=Родитель Тогда
            Строки.Удалить(Стр);
            Иначе
            обУбратьОшибкиИтоговПоИерархии(Стр.Строки, Поле, Зн);
        КонецЕсли;
    КонецЦикла;
КонецФункции 

Скачать файлы

Наименование Файл Версия Размер
ИерархияСправочника 24
.erf 8,30Kb
12.05.12
24
.erf 8,30Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Александр Медведев (anig99) 15.05.12 11:50
Техническая сложность исполнения и практическая значимость данной обработки равно 0
2. Константин Седорчук (snikers44) 15.05.12 18:01
(1) anig99, если для вас она не представляет практической значимости, - это не значит, что не представляет ни для кого... насчет технической сложности, - не все гуру программирования 1С и для кого-то это может представлять сложность...
3. DesireePatygorsk (cinfo) 16.05.12 02:19
4. Дмитрий Ташланов (Necytij) 16.05.12 07:28
К сожалению, у меня не достаточно рейтинга чтобы ставить минусы.
Ваш супер функционал не гуру может сформировать типовой отчет "универсальный", который в типовых уже очень давно в наличии...
5. Александр Медведев (anig99) 16.05.12 07:57
(2) данная обработка не представляет ценности ни для кого, кроме Вас. Так как обучаться нужно по учебникам, курсам и гораздо более сложным разработкам.
6. Андрей Волин (kser87) 16.05.12 10:52
А я скажу: спасибо за обработку.
7. Вадим Никонов (V.Nikonov) 16.05.12 12:23
Элементарная обработка для получения иерархии групп справочника "Номенклатура" без дублей.

Вообще-то это отчет. А что Значит "БЕЗ ДУБЛЕЙ"?

Теоретически запуск мог бы встраиваться в какую нибудь форму-список или Форму элемента...(для справочников в которых отсутствует доп.окно с деревом). Или дополнение к обработке результатов запроса возвращающего список элементов, а просмотреть желательно иерархию этих элементов...

Только, если это есть учебное пособие, то удобнее опубликовать в тексте фрагменты кода с комментариями поясняющие логику...
Если это есть полезная примочка к программе, то есть смысл расписать случаи полезности...

P.S. Соответственно для Публикации в таком виде хочется поставить минус!
8. Константин Седорчук (snikers44) 16.05.12 13:09
(7) V.Nikonov, Согласен, вид публикации оставляет желать лучшего, просто первая публикация, - не судите строго... Отчет создал на скорую руку для себя, так как не нашел такого на инфостате, решил поделиться, чтоб народ мог легко получить иерархию справочника "Без дублей", тех, которые создаются при группировке итогов по иерархии. Очистка дублей производится дополнительной функцией.
Функция обУбратьОшибкиИтоговПоИерархии(Строки, Поле="Ссылка", Родитель=Неопределено) Экспорт 
    //Убираем все элементы, равные текущему
    Всего=Строки.Количество();
    Для Инд=1 По Всего Цикл
        Стр=Строки[Всего-Инд];
        Зн=Стр[Поле];
        Если Родитель<>Неопределено И Зн=Родитель Тогда
            Строки.Удалить(Стр);
        Иначе
            обУбратьОшибкиИтоговПоИерархии(Стр.Строки, Поле, Зн);
        КонецЕсли;
    КонецЦикла;
КонецФункции
...Показать Скрыть
9. Вадим Никонов (V.Nikonov) 16.05.12 21:11
(8) snikers44, И что? Редактировать Публикацию не будем?

Оставим её для галочки? :-(
10. Андрей Акулов (DrAku1a) 17.05.12 02:39
Ну-ка-дети-скажем-дружно "НА-ФИГА-НАМ ЭТО НУЖНО?"
11. Константин Седорчук (snikers44) 17.05.12 13:30
(9) V.Nikonov, Отредактировал чуток=) спасибо за адекватную помощь в публикации...
P.S. Просто от нахлынувших негативных отзывов хотелось просто закрыть публикацию, и, возможно, не сэкономить пару минут действительно нуждающимся людям...