gifts2017

Документ "Корректировка Записей Регистров" "ввод на основании"

Опубликовал max maxx (motorkuzbassa.it) в раздел Программирование - Практика программирования

Небольшое дополнение, для автоматизации работ в УПП (в сети......, а кому то всегда надо)

Достаточно популярный документ у бухгалтеров не имеет ввода на основании, для любых документов. Исправим.

Создайте подписку на события для документов (если нет):

  • Источник=ДокументОбъект,
  • Событие=ОбработкаЗаполнения,
  • Обработчик=свой_ОбщегоНазначения._ОбработкаЗаполненияДокументовОбработкаЗаполнения,
  • Текст процедуры:
	 Процедура _ОбработкаЗаполненияДокументовОбработкаЗаполнения(Источник, Основание) Экспорт
    Если (ТипЗнч(Источник.Ссылка)= Тип("ДокументСсылка.КорректировкаЗаписейРегистров")) Тогда
        Если Основание<>Неопределено Тогда
            Источник.ИспользоватьЗаполнениеДвижений=истина;
            ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(Источник, Основание);
            СтрокаТабличнойЧасти = Источник.ЗаполнениеДвижений.Добавить();
            СтрокаТабличнойЧасти.Документ=Основание;
            СтрокаТабличнойЧасти.Действие="Сторно движений документа";
            ФормаДок = Источник.ПолучитьФорму("ФормаДокумента");
            ФормаДок.КоманднаяПанельЗаполнениеДвиженийЗаполнитьДвижения("ЗаполнитьДвижения")
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

И не забудьте в самом Документе КорректировкаЗаписейРегистров, на вкладке "Ввод на основании" добавить все интересующие Вас документы основания. 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Колесников (EastGuy) 04.06.12 11:56
"Достаточно популярный документ у бухгалтеров" - по рукам бью бухгалтеров за использование этого документа.
Diego_Iv; +1 Ответить
2. Сергей (necropunk) 06.06.12 11:13
Плохо, если у вас он популярный, да. У меня - запрещен всем кроме руководителя, каждое его использование обосновывается в письменном виде.
Жолтокнижниг; +1 Ответить
3. Алексей Ко (Жолтокнижниг) 06.06.12 21:13
Ибанутсо, извиняюсь но по другому никак, "Достаточно популярный", еще и конфигу править...
4. Александр Когон (kogon) 10.06.12 17:45
Необходимо пояснить - чем не устраивает в штатном доке КЗР - режим
"Заполнение движений"?
По-моеиу - данная статья является иллюстрацией поговорки -
"ломиться в открытую дверь".
5. max maxx (motorkuzbassa.it) 13.06.12 06:18
Всем устраивает, он то и взят за основу обработки. А чего бы все документы не сделать без ввода на основании, а только на аналоге КЗР.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа