gifts2017

Шифратор 1С

Опубликовал Виктор (victor) в раздел Администрирование - Защита, права, пароли

Данная программа позволяет шифровать программный код 1С, который находится в отчетах и обработках. Обработка работает по следующим принципам:
- идет переименование всех процедур и функций;
- идет переименование всех переменных;
- удаляется форматирование текста;
- удаляются комментарии;
- шифруются текстовые значения;
- учитываются имена переменных и функций из глобального модуля;
- учитываются имена переменных и функций, которые используются в таблице отчета.
В результате текст программы приводится к нечитаемому виду.

Пример:

Перем z09A1D100696E,zA8E5D31AC263,z1224287F391A,zC541400AFF53,
z331134D925E9,z25B73D1A480B,z3E6356D56060
,zE39F3BBF6FB4,zCBF7EA4D1967,z19D8B58AE181,zE037D3BAB8FC,
z71D6E52B999C,z9576A8A97B05,z3ECB216F3213,zA28A3D229584
,z778EF620D17B,zFA03BB1BA5BF,z0BCEBEEE2A8B,zB1C2A7D5D7B6,
z1EDE4E350EFA,z177DB322B571,z9FAB701699A1,z630773255216
,zF928132CEF9C,z5368A0886B17,zB7191DF2608A,z04F586C097C3,
zC3FA71AD0358,zBB2BFF927B7E,z25FD6954AE4F;Перем
zD31D2EF22ABF;Перем zA2ADB6112B5D;Перем zDD05AFE2A3B4;Перем
z46427946389A;Перем ТекстУсловия;Функция z5A0323B4A718
(z04AC2A7AA61F)Перем z98C6BEB1E3DF,z04FA687F1274,zF35868B0A6F3,
z5C8DC43CDB79;z98C6BEB1E3DF=Строка(ПолучитьПустоеЗначение
());z04FA687F1274=СтрДлина(z04AC2A7AA61F)/3;Для zF35868B0A6F3=1 по
z04FA687F1274 Цикл z5C8DC43CDB79=Строка
(999-Число(Сред(z04AC2A7AA61F,(zF35868B0A6F3-1)*3+1,3)));
z5C8DC43CDB79=Прав(Строка(0)+Строка(0)+z5C8DC43CDB79
,3);z5C8DC43CDB79=Прав(z5C8DC43CDB79,2)+Лев(z5C8DC43CDB79,1);
z98C6BEB1E3DF=z98C6BEB1E3DF+Симв(z5C8DC43CDB79
);КонецЦикла;Возврат z98C6BEB1E3DF;КонецФункции Процедура
ИзмТекстУсловия()Если УслИскл=0 Тогда ТекстУсловия
=z09A1D100696E;Иначе ТекстУсловия=zA8E5D31AC263;КонецЕсли;
КонецПроцедуры

В приведенной демонстрационной версии не производится анализ использования вызовов функций и переменных из печатных форм. Как следствие нельзя зашифровать отчеты, и прочие вещи, формирующие вывод печатных форм. Так же отсутствует шифрование текстовых констант (сообщений).

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Демо-версия "Шифратор 1С"
.zip 175,24Kb
25.09.09
208
.zip 175,24Kb 208 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. asg (asg) 12.02.06 23:55
Браво, маэстро... Ковырял демку больше часа, строковые константы МД.Обработки.РазборГЛ расшифровал но понять остальные переменные и логику программы сложнее, чем написать свой код. Кстати, какое мыло для связи?
2. asg (asg) 12.02.06 23:57
3. Александр (imsoftware) 11.04.06 12:22
Просто замечательный способ зашифровать свои данные! Огромный респект!! Единственное, чтобы я посоветовал, функцию дешифровки вставлять не в самом начале, а где-нибудь в середине модуля и строковые константы разбивать на бОльшее количество кусков (чтобы и желания не возникало возиться с этим текстом).
5. Доржи Цыденов (support) 03.08.06 12:08
есть еще шифровка модуля с помощью переименовки всех переменных и функций
http://www.infostart.ru/projects/?id=70&ref=53
6. VasilyKushnir (vasilykushnir) 03.08.06 13:50
Вопросс автору (немного не в тему), не принимал ли он участия в разработке Новейшего Отчета, или его разработчики просто применили твой шифровальщик? Пробовал расковырять: в принципе возможно, но тоскли-и-и-во...
7. Михаил (mdzen) 03.08.06 12:40
"На злобу дня" Дома поковыряю. Особенно как поведет себя на конфе где 1С++ прикручен.
8. Доржи Цыденов (support) 03.08.06 13:59
Да, шифратор был создан специально для защиты Новейшего отчета.
9. VasilyKushnir (vasilykushnir) 03.08.06 14:45
+1
Тогда усе понятно - то-то смотрю: знакомые крякозяблики. С чистой совестью добавляю рейтинг.
10. VasilyKushnir (vasilykushnir) 03.08.06 14:49
И еще вопросс: а обратный ход у шифровальщика есть? Или это уже будет называтся готовый кряк?
11. Доржи Цыденов (support) 03.08.06 15:30
обратного хода нет, этот процесс шифрования необратим
12. АЛьФ (АЛьФ) 03.08.06 15:33
Еще как обратим :)
Естественно, не имена переменных, но удобочитаемый текст можно сделать.
ineoosaki; +1 Ответить
13. Доржи Цыденов (support) 03.08.06 15:54
не знаю насколько он станет удобочитаемый
14. АЛьФ (АЛьФ) 03.08.06 16:38
Достаточным для разбора алгоритма. Если после этого немного ручками доработать, то станет вообще как новенький.
tonger; ineoosaki; +2 Ответить
15. Доржи Цыденов (support) 03.08.06 16:51
смотря какой алгоритм, и его количество
16. VasilyKushnir (vasilykushnir) 03.08.06 17:01
Я, например, убрал для начала все символы новой строки(получилась длинющая строка), затем после каждой точки с запятой опять их вставил, а потом в конфигураторе уже ручками настучал по клаве Энтер и редактор сам подформатировал текст. Что-то более суръезное писать было в лом. Получилось не ахти что, но вполне читаемое.
17. Доржи Цыденов (support) 03.08.06 17:17
Вообще, сначала надо решить, от чего защищаем. От копирования продукта?
Так для этого шифратор не предназначен
От изменения кода? Нет, тоже можно разобраться.
Шифратор 1С защищает от копирования алгоритма. Просто в таком случае, разобраться с данным алгоритмом сложнее, чем написать свой собственный, притом, если множество процедур и функций и продукт достаточно сложный, то разбираться с зашифрованным кодом, это тоже самое, что открыть ассемблер. Никто же не берет ассемблер в качестве основы для своей разработки, в любом случае, нужен читаемый алгоритм программы.
18. АЛьФ (АЛьФ) 03.08.06 17:36
"смотря какой алгоритм, и его количество"
ИМХО любой.
ineoosaki; +1 Ответить
19. АЛьФ (АЛьФ) 03.08.06 17:38
"Никто же не берет ассемблер в качестве основы для своей разработки, в любом случае, нужен читаемый алгоритм программы."
Вот это ты зря. На ассемблере до сих пор некоторые умельцы даже операционки пишут.
ineoosaki; +1 Ответить
20. Василий (васисубатор) 04.12.07 17:46
сам то как потом расшифруешь?
21. Аркадий Кучер (Abadonna) 04.12.07 17:59
(20)>сам то как потом расшифруешь?
А зачем самому расшифровывать? Конечно, если мозгов нет и исходники не сохранил - тогда чуток повозиться придется
22. Олег Гладких (OzzY) 12.12.07 01:33
Отличная вещь! Обратим - не обратим. Глупости все это. Любая защита подразумевает определенный уровень подготовки взломщика. Есть медвежатники для которых вообще не существует "не ломаемых" сейфов, так что теперь отменим все сейфы нафиг? Пусть кто-нибудь расшифрует не одну ert-шку, а всю конфу, зашифрованную данным продуктом, да еще сделает ее удобочитаемой, а потом посмотрит на часы.....
Однозначно +1
23. Serg Лифшиц (Slesh-01) 18.02.09 20:20
24. ev-kov (ev-kov) 02.04.09 12:01
с классами 1с++ не работает однако ...
25. Tonger Geren (tonger) 07.11.11 15:19
Большое Спасибо!
Очень полезная обработка
26. Олег Почекутов (PochekutovOleg) 21.11.11 07:59
А зачем шифровать
Можно все сделать стандартами средствами Windows Server
28. Гость 20.12.11 12:28
очень интересная и полезная обработка,спасибо,очень кстати
31. Алексей Толков (zsder) 31.05.12 10:28
Спасибо автору!
Пригодилась и не раз!!
32. Константин (maverick76) 19.02.13 12:19
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа