gifts2017

Расчет дней компенсации по всем видам ежегодных отпусков в документе «Увольнение из организаций» 1С УПП

Опубликовал Дмитрий Николайчук (dimetra2008) в раздел Программирование - Практика программирования

Как известно в типовых решениях 1С «Зарплата и управление персоналом»  и «Управление производственным предприятием» в документе «Увольнение из организаций» не предусмотрен расчет дней компенсации отпуска по всем видам ежегодных отпусков. Этот документ позволяет рассчитать остаток дней отпуска только по основному ежегодному отпуску. Поскольку некоторые сотрудники помимо ежегодного отпуска могут иметь дополнительные виды отпусков такие как «Дополнительный ежегодный отпуск», «Отпуск за ненормированный рабочий день» и т.д. то возникает необходимость при увольнении сотрудника компенсировать ему остатки всех видов отпусков.

Ниже приведен код процедуры которая позволяет рассчитывать общий остаток отпуска по всем видам ежегодных отпусков, которые имеет сотрудник.

Код процедуры приведен полностью со всеми изменениями, которые необходимо внести в типовой код. Комментарии вида: // *** ИТР … показывают изменения типового кода

// Процедура рассчитывает количество дней отпуска, которые необходимо компенсировать или удержать //
Процедура РассчитатьКоличествоДнейОтпуска(СтрокаТЧ, СведенияОСотрудниках = Неопределено) Экспорт
	
	Если Не ЗначениеЗаполнено(СтрокаТЧ.Сотрудник) ИЛИ Не ЗначениеЗаполнено(СтрокаТЧ.ДатаУвольнения) ИЛИ СтрокаТЧ.ПорядокРасчетаОтпуска.Пустая() Тогда
		Возврат;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	
	Если СтрокаТЧ.ПорядокРасчетаОтпуска = Перечисления.ПорядокРасчетаОтпуска.ПоКалендарнымДням Тогда
		ВидНачисления = ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.КомпенсацияОтпускаКалендарныеДни;
	Иначе
		ВидНачисления = ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.КомпенсацияОтпускаШестидневка;
	КонецЕсли;
	
	Запрос.УстановитьПараметр("ВидНачисления",	ВидНачисления);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ДополнительныеНачисленияОрганизаций.ВидЕжегодногоОтпуска
	|ИЗ
	|	ПланВидовРасчета.ДополнительныеНачисленияОрганизаций КАК ДополнительныеНачисленияОрганизаций
	|ГДЕ
	|	ДополнительныеНачисленияОрганизаций.Ссылка = &ВидНачисления
	|	И ДополнительныеНачисленияОрганизаций.ВидЕжегодногоОтпуска <> ЗНАЧЕНИЕ(Справочник.ВидыЕжегодныхОтпусков.ПустаяСсылка)";
	Выборка = Запрос.Выполнить().Выбрать();
	
	Если Выборка.Следующий() Тогда
		ВидЕжегодногоОтпуска = Выборка.ВидЕжегодногоОтпуска;
	Иначе
		Возврат;
	КонецЕсли;
	
	ТаблицаПериодов = Новый ТаблицаЗначений;
	ТаблицаПериодов.Колонки.Добавить("НомерСтроки",				Новый ОписаниеТипов("Число"));
	ТаблицаПериодов.Колонки.Добавить("Сотрудник",				Новый ОписаниеТипов("СправочникСсылка.СотрудникиОрганизаций"));
	ТаблицаПериодов.Колонки.Добавить("ВидЕжегодногоОтпуска",		Новый ОписаниеТипов("СправочникСсылка.ВидыЕжегодныхОтпусков"));
	ТаблицаПериодов.Колонки.Добавить("ДатаНачала",				Новый ОписаниеТипов("Дата"));
	ТаблицаПериодов.Колонки.Добавить("ДатаОкончания",				Новый ОписаниеТипов("Дата"));
	ТаблицаПериодов.Колонки.Добавить("ДатаРасчетаПриУвольнении",	Новый ОписаниеТипов("Дата"));
	
	ДлинаСуток = 86400;
 Строка = ТаблицаПериодов.Добавить();
	Строка.НомерСтроки = 1;
	Строка.Сотрудник = СтрокаТЧ.Сотрудник;
	Строка.ВидЕжегодногоОтпуска = ВидЕжегодногоОтпуска;
	Строка.ДатаНачала = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
	Строка.ДатаОкончания = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
	Строка.ДатаРасчетаПриУвольнении = СтрокаТЧ.ДатаУвольнения;
	
	// *** ИТР Добавляем для компенсации все оставщиеся отпуска из справочника виды ежегодных отпусков
	ТекНомерСтроки = 1;
	ВыборкаВидыЕжегодныхОтпусков = Справочники.ВидыЕжегодныхОтпусков.Выбрать();
	Пока ВыборкаВидыЕжегодныхОтпусков.Следующий() Цикл
		//Пропускам ранее добавленный отпуск
		Если ВыборкаВидыЕжегодныхОтпусков.Ссылка = ВидЕжегодногоОтпуска Тогда Продолжить КонецЕсли;
		
		ТекНомерСтроки = ТекНомерСтроки + 1;
		
		Строка = ТаблицаПериодов.Добавить();
		Строка.НомерСтроки = ТекНомерСтроки;
		Строка.Сотрудник = СтрокаТЧ.Сотрудник;
		Строка.ВидЕжегодногоОтпуска = ВыборкаВидыЕжегодныхОтпусков.Ссылка;
		Строка.ДатаНачала = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
		Строка.ДатаОкончания = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
		Строка.ДатаРасчетаПриУвольнении = СтрокаТЧ.ДатаУвольнения;
	КонецЦикла;
	// *** ИТР Добавляем дополнительный ежегодный отпуск для компенсации
	
	ВыборкаПоОтпускам = ПроцедурыУправленияПерсоналом.ПодготовитьДанныеПоРегламентированнымОтпускам(ТаблицаПериодов, Ссылка);
	
	// *** ИТР Суммируем полученные остатки отпусков
	ОстатокРасчитан = Ложь;
	СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = 0;
	Пока ВыборкаПоОтпускам.Следующий() Цикл
		Если ВыборкаПоОтпускам.ВидЕжегодногоОтпуска = ВидЕжегодногоОтпуска Тогда
			СтрокаТЧ.РабочийГодС = ВыборкаПоОтпускам.ДатаНачалаРабочегоГода;
			СтрокаТЧ.РабочийГодПо = СтрокаТЧ.ДатаУвольнения;
			СтрокаТЧ.ПризнакКомпенсацииОтпуска = ВыборкаПоОтпускам.Количество >= 0;
		КонецЕсли;
		
		СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска + ВыборкаПоОтпускам.Количество;  // * ?(ВыборкаПоОтпускам.Количество >= 0, 1, -1)
		
		ОстатокРасчитан = Истина;
	КонецЦикла;
	СтрокаТЧ.ПризнакКомпенсацииОтпуска = ?(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска >= 0, Истина, Ложь);
	СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска * ?(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска >= 0, 1, -1); 
	
	//Если нету что компенсировать
	Если Не ОстатокРасчитан Тогда
		СтрокаТЧ.РабочийГодС = Дата(1,1,1);
		СтрокаТЧ.РабочийГодПо = Дата(1,1,1);
		СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = 0;
		СтрокаТЧ.ПризнакКомпенсацииОтпуска = Ложь;
	КонецЕсли;
	// *** ИТР Суммируем полученные остатки отпусков
	
	// *** ИТР Не используем типовой расчет остатка отпуска 
//Если ВыборкаПоОтпускам.Следующий() Тогда
// СтрокаТЧ.РабочийГодС = ВыборкаПоОтпускам.ДатаНачалаРабочегоГода;
// СтрокаТЧ.РабочийГодПо = СтрокаТЧ.ДатаУвольнения;
// СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = ВыборкаПоОтпускам.Количество * ?(ВыборкаПоОтпускам.Количество >= 0, 1, -1);
// СтрокаТЧ.ПризнакКомпенсацииОтпуска = ВыборкаПоОтпускам.Количество >= 0;
// УвольнениеИзОрганизацийПереопределяемый.ДополнительноУточнитьДниКомпенсации(СтрокаТЧ, ПолучитьСведенияОСотрудниках(СведенияОСотрудниках, СтрокаТЧ.Сотрудник));
//Иначе
// СтрокаТЧ.РабочийГодС = Дата(1,1,1);
// СтрокаТЧ.РабочийГодПо = Дата(1,1,1);
// СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = 0;
// СтрокаТЧ.ПризнакКомпенсацииОтпуска = Ложь; //КонецЕсли;
// *** ИТР Не используем типовой расчет остатка отпуска
Если мОкруглятьДниОтпускаПриКомпенсации = Неопределено Тогда мОкруглятьДниОтпускаПриКомпенсации = Константы.ОкруглятьДниОтпускаПриКомпенсации.Получить(); КонецЕсли; Если мОкруглятьДниОтпускаПриКомпенсации Тогда СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = Цел(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска) + ?(Цел(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска) = СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска, 0, 1); КонецЕсли; КонецПроцедуры

См. также

Подписаться Добавить вознаграждение
Комментарии
1. zero_nv (Zero_nv) 14.06.12 04:41
Самое обидное, что данный функционал должен быть типовым
2. zero_nv (Zero_nv) 21.06.12 08:28
Теперь, начиная с 2.5.52.2 этот фукционал стал типовым
3. Дмитрий Николайчук (dimetra2008) 21.06.12 09:42
Интересно как этот функционал станет типовым в УПП...
4. Наталья Волкова (IamNataly) 25.06.12 06:41
5. Алексей Ниценко (snik-2) 18.07.12 04:31
В действительности в релизе 2.5.52.3 процедура была полность изменена, но доп. отпуск по прежнему при увольнении не учитывается.
6. Алексей Ниценко (snik-2) 18.07.12 07:57
Хорошо есть еще добрые люди, подсказали как устранить проблему.
Прилагаю текст процедуры, может кому пригодится.


Процедура РассчитатьКоличествоДнейОтпуска(СтрокаТЧ, СведенияОСотрудниках = Неопределено) Экспорт

Если Не ЗначениеЗаполнено(СтрокаТЧ.Сотрудник) ИЛИ Не ЗначениеЗаполнено(СтрокаТЧ.ДатаУвольнения) ИЛИ СтрокаТЧ.ПорядокРасчетаОтпуска.Пустая() Тогда
Возврат;
КонецЕсли;
//убираем эти параметры из отбора: ,Истина, СтрокаТЧ.ПорядокРасчетаОтпуска
Результат = ОстаткиОтпусков.ОстатокОтпускаСотрудникаНаДату(СтрокаТЧ.Сотрудник, СтрокаТЧ.ДатаУвольнения); // ,Истина, СтрокаТЧ.ПорядокРасчетаОтпуска);

СтрокаТЧ.РабочийГодС = Результат.РабочийГодС;
СтрокаТЧ.РабочийГодПо = Результат.РабочийГодПо;
СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = Результат.ОстатокНаДату * ?(Результат.ОстатокНаДату >= 0, 1, -1);
СтрокаТЧ.ПризнакКомпенсацииОтпуска = Результат.ОстатокНаДату >= 0;

УвольнениеИзОрганизацийПереопределяемый.ДополнительноУточнитьДниКомпенсации(СтрокаТЧ, ПолучитьСведенияОСотрудниках(СведенияОСотрудниках, СтрокаТЧ.Сотрудник));

КонецПроцедуры
7. Гульнара Р (Эсти) 16.03.15 08:00
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа