gifts2017

Бухгалтерские отчёты с множественным фильтром по разделителям учета

Опубликовал WWWolfy (WWWolfy) в раздел Отчеты - Бухгалтерские

Бухгалтерские отчёты с возможностью формирования по нескольким Разделителям Учёта.

Бухгалтерские отчёты с возможностью формирования по нескольким Разделителям Учёта. Сохранена стандартная возможность перехода между отчётами (по двойному клику на цифре).

Включены отчёты:
1. ОтчетПоПроводкам
2. АнализСчета
3. КарточкаСчета
4. ОборотноСальдоваяВедомостьПоСчету
5. ОборотноСальдоваяВедомость
6. ГлавнаяКнига
7. ЖурналОрдер

Для работы необходимо открыть конфигурацию из архива (MD) в пустой папке, скопировать (copy/paste) в свою конфигурацию отчёты (без изменений идентификаторов) и прописать их в интерфейс.

Скачать файлы

Наименование Файл Версия Размер
MFRU_3.rar 121
.rar 82,30Kb
25.09.09
121
.rar 82,30Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Алина 14.04.06 14:19
А можно сделать, чтобы эти отчеты были, как внешние файлы?
2. WWWolfy (WWWolfy) 14.04.06 17:01
Можно внешними, но тогда для нормального их взаимодействия надо будет переписать строки:
Расшифровка.Установить("Отчет", "КарточкаСчета_2");


в виде таких:
Расшифровка.Установить("Отчет", "ПутьКФайлу_КарточкаСчета.ert");
или таких:
Расшифровка.Установить("Отчет", КаталогИБ+"КарточкаСчета_2.ert");
3. nasta borodasta (nasta_2004) 13.10.11 11:33
В отчете "Отчет по проводкам" нужно подправить - перед выборкой операции проверить на пустое значение разделитель учета, т.к. выборка операций, если Разделительучета=0 проводится по пустому РУ, а нам нужно без учета РУ.
А так все супер, очень полезная вещь. Спасибо.

Если ИспФильтр=1 Тогда   
     Если РазделительУчета=0 Тогда
	  Опер.ВыбратьОперацииСПроводками(Дата1, Дата2, Фильтр, ?(ПоВалюте=1,Валюта,""), ПланСчетов);
     Иначе  
	  Опер.ВыбратьОперацииСПроводками(Дата1, Дата2, Фильтр, ?(ПоВалюте=1,Валюта,""), ПланСчетов,   РазделительУчета);
    КонецЕсли;
Иначе   
    Если РазделительУчета=0 Тогда  
	 Опер.ВыбратьОперацииСПроводками(Дата1, Дата2, Счет, КорСчет, ДтКт, ?(ПоВалюте=1,Валюта,""), ПланСчетов); 
    Иначе
	 Опер.ВыбратьОперацииСПроводками(Дата1, Дата2, Счет, КорСчет, ДтКт, ?(ПоВалюте=1,Валюта,""), ПланСчетов, РазделительУчета); 
    КонецЕсли;
КонецЕсли;
...Показать Скрыть
4. WWWolfy (WWWolfy) 13.10.11 13:54
Без учета РУ - можно тогда и стандартные отчеты использовать, поэтому такая ситуация и не учитывалась.
Но за замечание спасибо.

Рад что пригодилось, успехов!
6. Taras Shewchenko (yuyu1) 04.11.13 18:25
Могли бы скрины выложить, чтобы было видно форму.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа