gifts2017

Товарный отчет

Опубликовал Андрей (smirnov.a) в раздел Отчеты - Управленческие

Товарный отчет для ТиС, отображает начальный остаток, конечный остаток, приход, возврат, расход и реализацию.

Табличная часть слизана из бухпроги "Мир торговли" :)))

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.ert 47,00Kb
25.09.09
548
.ert 47,00Kb 548 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Доржи Цыденов (support) 28.04.06 12:14
нормальный такой отчет, работает без проблем.
только вопрос, сумма остатка по какой цене считается?
2. r_p (smirnov.a) 29.04.06 17:00
3. Che Burashka 08.05.06 02:26
1. Качнул, посмотрел. Порадовала нормальная печ.форма.
Не порадовало:
//
Докум.ВыбратьСтроки();
Пока Докум.ПолучитьСтроку() = 1 Цикл
Если Докум.Вид() = "ВозвратОтПокупателя" Тогда
Если Докум.Номенклатура = Запрос.Номенклатура Тогда
ТЗД.СкидкаВоз = Окр(Докум.Цена*Докум.Количество,2,1) - Докум.Сумма;
ТекСкидкаВоз = ТекСкидкаВоз + ТЗД.СкидкаВоз;
КонецЕсли;
КонецЕсли;

Если (Докум.Вид() = "Реализация") ИЛИ (Докум.Вид() = "РеализацияРозница") Тогда
Если Докум.Номенклатура = Запрос.Номенклатура Тогда
ТЗД.СкидкаР = Окр(Докум.Цена*Докум.Количество,2,1) - Докум.Сумма;
ТекСкидкаР = ТекСкидкаР + ТЗД.СкидкаР;
КонецЕсли;
КонецЕсли;
КонецЦикла;
//
Cомнительна правильность получаемых таким методом итогов в случае, когда в табличной части документа есть несколько строк с одиноаковй номенклатурой (например - партии с разными свойствами). Хотя, я, возможно, неправ.. было бы хорошо если автор бы прокомментировал...
А так отчет понравился, постараюсь взять на вооружение...
2. По вопросу саппорта и ответу на него - по моему, в ответе - полная хрень, так как в коде прописано
ТЗ.КонОст = Запрос.КонОстС;
а КонОстС определяется как
|Сумма = Регистр.ПартииНаличие.СуммаРуб;
|Функция КонОстС = КонОст(Сумма);
3. Все-так всегда удивляет ленивость аффторов: ну что мешает вставить энное количество строк кода из типовой конфиги и получить нормальный множ.фильтр? Или это надо сделать мне и выставить под своим именем...?
4. Анатолий 06.06.06 22:41
У меня ТИС для Украины, не хочет работать обработка, будет ли для Украины подобная?
5. Den 07.06.06 14:58
(2) Che Burashka - может ты и прав, но может ты доделаешь его до ума и выставишь нам а мы оценим?
6. Stepan Shipitsyn (Stepan_1c) 27.09.11 15:09
7. Ольга Арбузова (olenionok) 22.10.11 20:11
Какой клевый отчётец! И по документам разбивку делает, при этом в документы можно "провалиться" и посмотреть и поправить сразу!
Я в восторге! Это именно то, что я искала. Естественно, можно выбрать номенклатуру или группу.
Спасибище автору!
8. Ольга Арбузова (olenionok) 22.10.11 20:45
Скажите, пожалуйста, а возможно ли в ТиС создать карточку движения товара (то есть как в бухгалтерии: дата - документ - показатель - сальдо конечное)?
Спасибо.
9. Александр Федоров (Sasha255n) 25.01.13 18:01
Хороший отчет я доволен
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа