gifts2017

Калькуляция плановой стоимости продукции

Опубликовал Юрий (Kurt) в раздел Обработки - Ценообразование, прайсы

Калькуляция плановой стоимости продукции

Попросил начальник сделать ему калькулятор для расчета "на скорую руку" плановой стоимости продукции....
Обработка Калькуляция.ert написана для Комплексной конфигурации (под Торговлей думаю тоже должна работать).
Частично похожа на документ "Комплектация ТМЦ", но в добавление к этому считает еще и статьи затрат на изготовление продукции. Использует справочник "Комплекты" Комплексной конфигурации.

В архиве три обработки (две вспомогательные) - выложите их в одну папку.
В приложенном файле *.xls пояснение используемых формул расчета (на втором листе формулы из конфигурации для Планового отдела от Латыпова Ильяса, которые я использовал для себя как пример). Элементы диалога имеют описания, думаю все будет понятно.

Расчет производится прямой, т.е. от стоимости материалов, заработной платы и статей затрат выводится конечная цена. Обратный расчет от конечной цены не предусмотрен, т.к. лично я считаю этот метод "не честным". Но тем не менее есть возможность подогнать цену прибылью или какой-либо статьей затрат.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Калькуляция стоимости продукции
.rar 61,27Kb
12.02.14
8
.rar 61,27Kb 8 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Доржи Цыденов (support) 03.05.06 14:26
2. Иннокентий (delete009) 29.05.08 15:52
3. cheri (cheri) 26.11.08 14:16
Подскажите, пожалуйста, в архиве 3 файла с расширением ert. Какие именно файлы нужно добавить в дополнительные возможности и как правильно это сделать?
4. Юрий (Kurt) 26.11.08 17:10
В архиве три обработки:
Kalculyasiya.ert
DlgSum.ert
DLGQUERY.ERT
(две вспомагательные) - выложите их в одну папку.
Это значит все три файла поместить в один (любой) каталог.
Из 1С запустить файл Kalculyasiya.ert из каталога, в который вы их поместили.
Это простейший вариант запуска.

Для запуска из "дополнительных возможностей":
1. Все три этих файла надо поместить в папку "ExtForms" вашей информационной базы.
2. Создать (хоть в блокноте) файл с названием Kalculyasiya.EFD (обращаем внимание
на расширение файла, можете сначала создать текстовый файл Kalculyasiya.txt, а потом
в проводнике переименовать с расширением .efd !).
Содержание файла должно иметь всего одну строчку:
Название=Калькуляция плановой стоимости продукции

(название, как вы понимаете можете нарисовать по вашему вкусу. Главное, что бы совпадали
названия файлов, т.е. если Kalculyasiya.ert, то файл описания должен быть Kalculyasiya.EFD)

3. Полученный файл Kalculyasiya.EFD также помещаем в папку "ExtForms" вашей информационной базы.
4. Заходим в "Дополнительные возможности", находим строчку с наименованием "Калькуляция плановой стоимости продукции" и запускаем.
5. Мухтар Газизов (Pah77) 12.04.11 19:34
Вот такое мне дает!!!

Форма.ТекстФирмы .Заголовок(глСтрокаФирмы <<?>>(Контекст));
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(51)}: Функция не обнаружена (глСтрокаФирмы)
Форма.ТекстФирмы .Заголовок(глСтрокаФирмы (Контекст)<<?>>);
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(51)}: Неопознанный оператор
ИсхТабл.Опции(0,0,0,0,ПарСтрДок<<?>>,ПарСтрДок);
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(422)}: Переменная не определена (ПарСтрДок)
ИсхТабл.Опции(0,0,0,0,ПарСтрДок,ПарСтрДок<<?>>);
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(422)}: Переменная не определена (ПарСтрДок)
ИсхТабл.Опции(0,0,0,0,ПарСтрДок<<?>>,ПарСтрДок);
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(501)}: Переменная не определена (ПарСтрДок)
ИсхТабл.Опции(0,0,0,0,ПарСтрДок,ПарСтрДок<<?>>);
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(501)}: Переменная не определена (ПарСтрДок)
Если глПолучитьПолномочие<<?>>("РазрешитьРедактированиеТаблиц") = 0 Тогда
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(503)}: Функция не обнаружена (глПолучитьПолномочие)
Если ПустоеЗначение(глКомплектуется<<?>>(Комплект)) = 1 Тогда
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(565)}: Функция не обнаружена (глКомплектуется)
Если ПустоеЗначение(глКомплектуется(Комплект)<<?>>) = 1 Тогда
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(565)}: Выражение должно иметь логический тип
ФлагКомплект=ПустоеЗначение(глКомплектуется<<?>>(Комплект));
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(684)}: Функция не обнаружена (глКомплектуется)
ФлагКомплект=ПустоеЗначение(глКомплектуется(Комплект)<<?>>);
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(684)}: Неопознанный оператор
ФлагКомплект=ПустоеЗначение(глКомплектуется(Комплект))<<?>>;
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(684)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ЗаполнитьТЗ2)
ФлагКомплект=ПустоеЗначение(глКомплектуется(Комплект))<<?>>;
{\\SERVER\BASE1C\BUH\EXTFORMS\KALCULYASIYA.ERT(684)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (Расчитать)
6. Юрий (Kurt) 13.04.11 11:39
(5) Обработка для Комплексной конфигурации 7.7.
Кажется мне, что у Вас не эта конфигурация.
Под чем запускали? Какой релиз?
7. Мухтар Газизов (Pah77) 13.04.11 14:13
8. Юрий (Kurt) 13.04.11 16:43
Вооот как интересно.
Текущий релиз платформы - 7.70.027
Текущий релиз Комплексной - ред. 4.5 (7.70.505)
у Торговли и того больше - 7.70.965

...т.е. Вы понимаете, что со времён 7.70.449 релиза конфигурация была значительно изменена-доработана, в том числе изменены и добавлены многочисленные функции и процедуры глобального модуля.

Отсюда и возникает ошибка при обращении к глСтрокаФирмы... посмотрим, что же там такое. Похоже понадобится ещё и глСтрокаСклада.

Вам в модуль обработки надо вставить следующие функции:

//******************************************************************************
//  глСтрокаСклада(Конт) 
// 
// Параметры: 
// 	Склад - элемент справочника "Склады"
// 
// Возвращаемое значение:
// 	Строковое представление склада
// 
// Описание:
// 	Функция, формирующая информационную строку о складе
//
Функция глСтрокаСклада(Склад) Экспорт
	Перем Результат;              
	
	Если ПустоеЗначение(Склад)=0 Тогда
		Результат=Склад.Наименование;
		Если ПустоеЗначение(Склад.МОЛ)=0 Тогда
			Результат=Результат+" ("+СокрП(Склад.МОЛ.Наименование)+")";
		КонецЕсли;                                             
	Иначе
		Результат="НЕ ВЫБРАН СКЛАД";
	КонецЕсли;

    Возврат(Результат);
КонецФункции  // глСтрокаСклада

//******************************************************************************
//  глСтрокаФирмы(Конт) 
// 
// Параметры: 
//	Конт - контекст формы документа
// 
// Возвращаемое значение:
// 	Строковое представление фирмы (Юр. и Упр. лица)
// 
// Описание:
// 	Функция, формирующая информационную строку о фирме
//
Функция глСтрокаФирмы(Конт) Экспорт
	Перем Результат;
	
	Результат = "";
	Если ПустоеЗначение(Конт.Фирма) = 0 Тогда
		Результат = Результат + Конт.Фирма.Наименование;  
	Иначе
		Результат = Результат + "НЕ ВЫБРАНА ФИРМА";  
	КонецЕсли;
	
	Возврат(Результат);
КонецФункции  // глСтрокаФирмы()

//******************************************************************************
...Показать Скрыть


Или закоментировать строки 51-52.

Возможно будут еще ошибки, но без внесения этих изменений они не проявятся.
9. Юрий (Kurt) 13.04.11 16:54
И ещё в довесок:
//******************************************************************************
// глПолучитьПолномочие(ИмяПолномочия)
//
// Параметры: 
//  ИмяПолномочия - строка наименования полномочия
//
// Возвращаемое значение:
//  Значение полномочия, если не задано, то возвращает 0
//
// Описание:
//  Определяет и возвращает полномочие текущего пользователя с переданным наименованием.
//  Полномочия пользователя определяются выбранным для него элементом справочника "ПолномочияПользователей"
//
Функция глПолучитьПолномочие(ИмяПолномочия)  Экспорт

	Полномочие = глПользователь.Полномочия;
	Если ПустоеЗначение(Полномочие) = 1 Тогда
		Возврат 0;
	Иначе
		Возврат Полномочие.ПолучитьАтрибут(ИмяПолномочия);
	    
	КонецЕсли;
	                                  
КонецФункции // глПолучитьПолномочие()

//******************************************************************************
// глКомплектуется(ТМЦ)
//
// Параметры: 
//  ТМЦ - элемент справочника Номенклатура, для которого надо определить наличие комплектующих
//
// Возвращаемое значение:
//  "Комплектуется" - если есть комлектующие
//  Пустая строка   - иначе
//
// Описание:
//  Определяет наличие комплектующих у данной ТМЦ
//
Функция глКомплектуется(ТМЦ) Экспорт
	
	 Рез = 0;
	                    
	 Если ТМЦ.Выбран() = 1 Тогда
	 	
		СпрКомплекты = СоздатьОбъект("Справочник.Комплектация");
		СпрКомплекты.ИспользоватьВладельца(ТМЦ);
		Рез = СпрКомплекты.ВыбратьЭлементы();
	     
	 КонецЕсли;
	
	Возврат ?(Рез = 1,"Комплектуется","");
	
КонецФункции // глКомплектуется()

//******************************************************************************
...Показать Скрыть

Возможно после этого обнаружится еще набор ошибок. Т.к. уж очень старый у Вас релиз.
10. coollerok (Coollerok) 08.11.11 16:11
12. Ирина 111 (Ирина1978) 31.01.15 17:48
а для 1с 7.7 бухгалтерия есть такая ?
13. Юрий (Kurt) 02.02.15 10:50
(12) Для бухгалтерии нет (мы работаем с Комплексной конфигурацией). Бухгалтерию я к сожалению не знаю.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа