gifts2017

Универсальный отчет: "Доходы, расходы, планирование".

Опубликовал Олег Пономаренко (O-Planet) в раздел Отчеты - Финансовые

Этот универсальный отчет навсегда решит вопрос с выводом расчета прибыли и убытков из 1С:Бухгалтерия предприятия 8.2. Отчет строится по бухгалтерским проводкам, позволяет определять статьи доходов и расходов и формулы их расчета на уровне пользователя. Позволяет сравнивать фактические данные с плановыми за выбранный период. Подарок всем бухгалтерам от ООО "О-Планет".
 

Универсальный отчет: "Доходы, расходы, планирование"

Автор этой разработки - Желонкина Мария, ведущий специалист ООО "О-Планет", профессионал высшей категории. 

 

Этой разработкой мы продолжаем линейку авторских работ сотрудников ООО "О-Планет". Вы ищете слаженную команду профессиональных разработчиков бизнес решений на базе 1С и web-технологий? Вам нужны гарантии? Проверьте сами надежность наших программ, скачав бесплатно и опробовав наши коммерческие разработки на сайте infostart.ru!

 

Желаем приятной работы!

 

 

Работа со статьями.

Сначала нам нужно создать описание отчета.
Для начала добавим вариант формирования отчета.

В появившемся окне ввести название настройки. 

В один файл можно включить несколько вариантов формирования, отличающихся составом статей или настройками (например, с разными организациями).

Далее переходим к вводу статей, которые будут отображаться в нашем отчете. Вводим их в виде дерева на закладке «Статьи затрат».

Готовое дерево выглядит следующим образом:

Все статьи рассчитываются от параметров и от других статей, параметры рассчитываются непосредственно по данным информационной базы.

Работа с параметрами

Далее необходимо ввести в программу параметры на закладке «Параметры».

Параметры можно вводить самостоятельно или создать по ранее введенным статьям. Редактировать параметры можно списком и поодиночке.

Окно редактирования выглядит следующим образом:

 

Параметр – имя самого параметра
Счет — счет, данные которого мы используем
Тип ресурса — какие именно данные по счету мы хотим получить. Возможные варианты: Оборот, Оборот Дт, Оборот Кт, Остаток, Остаток Дт, Остаток Кт.
Субконто 1-3 — указываем субконто, которые должны попасть в выборку. Если не заполнено, то выбираются данные по всем субконто. Если у нам нужно сделать отбор по нескольким разным субконто, то для каждого нужно создавать отдельный параметр.
Кор. счет — счет задается только если нужно получить обороты в корреспонденции именно с этим счетом. Для него также могут быть указаны отборы по субконто (кор. субконто1-3).
Ресурс — имя выбираемого ресурса. Возможные варианты: количество, сумма.

В целом настройка параметра по своей логике идентична настройке типового отчета по проводкам.

Параметр попадает в расчет только, если для него установлен признак использования. Его можно устанавливать для каждого параметра вручную или для всех разом.

Создание формул статей

Когда введены параметры, можно создавать формулы для статей.
Формула может состоять из нескольких строк и содержать как параметры (колонка Параметр), так и статьи (колонка Статья). Действие содержит арифметическое действие, которое необходимо выполнить с данной строкой. Для первой строки можно не указывать. Если не указано никакое, то интерпретируется как «+». Коэффициент — это произвольное число, на которое умножаются данные, прежде чем над ними будет выполнена арифметическая операция.

Примеры:

Содержит данные одного параметра:

 

Задан коэффициент:

Состоит из нескольких параметров:

Разность  статей:

Сохранение/загрузка настройки

Сохраним введенную настройку. Для этого достаточно указать имя файла, куда мы хотим сохранить, кодировку (можно использовать значение по-умолчанию) и нажать кнопку «Сохранить».

Что восстановить ранее сохраненные данные необходимо нажать на кнопку Прочитать.

Формирование отчета

Для отчетов определены два основных вида: план-фактный и сравнительный. Но путем комбинации вспомогательных параметров можно существенно изменять их внешний вид. Выбор способа формирования отчета в поле "Тип"

План-фактный отчет

Имеет следующие отличительные черты:

1. Может быть периодическим
2. Может иметь итоги
3. При формировании использует плановые данные.

Дополнительные параметры:

Шаг — позволяет выполнить разбивку отчета на несколько периодов. Например, если период формирования указан квартал. Шаг «произвольный» предполагает формирование за весь указанный период.
С итогами — выводит дополнительно колонку с итогами.

Например:

Если установить флажок «План», то в отчет будет добавлена колонка «План», содержащая введенные пользователем плановые данные за данный период (о вводе плана см. ниже). Флажки абсолютное и относительное отклонение добавляют соответствующие колонки, показывая разницу между плановыми и фактическими данными.

Сравнительный отчет

Формирует данные за указанный период и за аналогичный период прошлого года. Отклонения выводятся также опционально

Ввод плановых данных

Выполняется на закладке «Ввод плана». При вводе плановых данных важно соответствие статей статьям, введенным для основного расчета. Поэтому рекомендуется пользоваться функцией . Она скопирует ранее введённые статьи из закладки «Статьи затрат». Ввод данных выполнятся на год в разрезе месяцев. Пользователь может заполнить вручную все статьи или заполнить только часть из них, а расчетные (те, которые считаются только от других статей) рассчитать по кнопке "Рассчитывать итоговые строки". Для выполнения расчета обязательно должна быть заполнена настройка статей затрат (закладки «Параметры» и «Статьи затрат»), т.к. все формулы подтягиваются оттуда.

Сохранение и восстановление данных плана из файла выполняется на этой же закладке.

Для использования плановых данных при формировании план-фактного отчета необходимо на закладке «Настройки» указать файлы с сохраненными планами и нажать «Загрузить». Только после этого они попадут в отчет.


Качайте, пользуйтесь! Мы будем рады услышать Ваши отзывы, комментарии и пожелания. 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
unirep.zip
.zip 289,08Kb
20.06.12
355
.zip 289,08Kb 355 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Олег Пономаренко (O-Planet) 20.06.12 06:17
Этот универсальный отчет навсегда решит вопрос с выводом расчета прибыли и убытков из 1С:Бухгалтерия предприятия 8.2. Отчет строится по бухгалтерским проводкам, позволяет определять статьи доходов и расходов и формулы их расчета на уровне пользователя. Позволяет сравнивать фактические данные с плановыми за выбранный период. Подарок всем бухгалтерам от ООО "О-Планет".

Перейти к публикации

1. Оракул Айметдинов (jhfrek) 20.06.12 18:38
2. Eugeneer (Eugeneer) 20.06.12 19:55
В прошлый раз была публикация где была другая девушка ведущим специалистом ООО О-Планет?
Когда ты их успеваешь менять как перчатки?
3. Олег Пономаренко (O-Planet) 21.06.12 00:33
(2) У нас два параллельных направления по 1С, за каждое отвечает отдельный специалист. Остальные могут участвовать как в работе первого, так и второго, в зависимости от необходимости.
5. Олег Пономаренко (O-Planet) 21.06.12 00:47
Да вы что все?! :D У нас ДВА ведущих специалиста, потому что ДВА направления, которые не пересекаются, хотя оба - по 1С.
6. Eugeneer (Eugeneer) 21.06.12 12:21
(5) когда появится третья разработка будет три ведщих програмистки? и три направления? )))))
Если я был султан....(песня)))
7. Олег Пономаренко (O-Planet) 21.06.12 12:33
(6) Эхехе, зачем сравниваешь нас с собой? Маша - ведущий на текущих разработках и сопровождении. Лену арендует крупная торговая сеть на аутсорсинге, на постоянной основе.
8. NtS (NtS) 21.06.12 14:20
можно ли отчет использовать для вывода выручки и себестоимости по товару?
9. Олег Пономаренко (O-Planet) 21.06.12 15:16
10. StronG-X (Dethmond) 25.06.12 10:21
Спасибо, как раз то, что нужно
11. Denis Elmanov (jack_nsk) 26.06.12 14:15
а для 8.1 нет версии? а то что-то сильно не хочется заниматься копипастом :(
12. розница.net (ZLENKO) 06.07.12 11:17
Похоже что весьма толковая разработка. Жаль только что для бухгалтерии - я бухгалтерией мало занимаюсь.
Если бы нечто подобное было для УТ ...
13. Евгений Шабалин (xzorkiix) 09.07.12 12:47
Зашел убедиться, что первый комментарий будет про девушку. Убедился.
14. Юлия Мазур (JJMM) 11.07.12 20:06
Здравствуйте.
Спасибо, очень полезная разработка. Жаль, не могу воспользоваться: расходы учитываются по подразделениям. А подразделения по какой-то странной, я бы даже сказала - болезненной прихоти разработчиков конфигурации (8.2, Бухгалтерия) не являются субконто к счету 26, например, а зашиты где-то там ещё..
Скажите, пожалуйста, в Вашем отчете можно ли как-то всё же выбрать подразделения при создании параметров?
Спасибо.
15. Андрей Мухин (Muhin555) 12.07.12 14:17
Почему бы не приложить к описанию заполнения простой пример файла с настройками????
16. Александр Матросов (scream) 23.07.12 23:45
(13) есть для ут и упп в одном флаконе ;)
17. Александр Матросов (scream) 23.07.12 23:46
пример с настройками нужен обязательно
так не взлетит
18. Александр Удалов (higs) 29.07.12 22:36
Да, с примером было бы лучше. Но попробую разобраться в такой, на днях попросили показать подобный отчет с возможностью построения своей структуры. И как раз по бухсчетам, несмотря на источник УПП
19. ascold pancershrec (ascold) 02.08.12 15:11
есть глюк в программе, там когда во вкладке "статьи затрат" добавляешь подчиненную строку, то она не считается.
20. Yackov . (Yackov) 30.08.12 17:03
У меня ваще не считается ничего..:(
21. Ольга (son_v) 04.10.12 12:12
Ну чтож. Рискнем, скачаем. Наш главный бухгалтер попросила отчет "такой же как в Отчетах руководителю как Доходы/расходы/прибыль/убыток, но расширенный с группировкой по организациям,подразделениям и с математикой по расчету прибыли" и т.д. За труды плюс)
22. алексей (Alex141516) 09.10.12 16:17
(19) ascold,

да, судя по коду - выложили черновик

по дереву статей (не считается по нижним веткам) - ошибка здесь

Процедура РазобратьВТаблицу(ТабФормул, Строки_) Экспорт

Для Каждого Текстр из Строки_ Цикл

Если текстр.Строки.Количество() = 0 и ЗначениеЗаполнено(Текстр.родитель) Тогда

Надо поставить НЕ ЗначениеЗаполнено.

Второй глюк - не считает если формула для статьи основана на других статьях. Щас найдем и это.

Идея и сама работа отличная! Но с сюрпризами ))) Исправлю второй глюк, а сколько их там еще, чую не к добру все это...
23. алексей (Alex141516) 09.10.12 17:10
интересно, вот этот кусок кода из представленной работы:

Продолжаем	=	истина;
	макс		=	30;
	нн			=	0;
	
	Пока Продолжаем Цикл
		
		нн	=	нн +1;
		РассчитатьСтатьиТаблицы(ТЗСтатьи, ТаблицаФормул, ТаблицаИнтервалов, кМакс);
		ТЗСтатьи	=	ТЗСтатьи.Скопировать(Новый Структура("СтрокаРассчитана", ложь));
		Продолжаем	=	не (ТЗСтатьи.количество()=0);
		Если нн >= Макс тогда
			Прервать;
		КонецЕсли;
		
	КонецЦикла;
...Показать Скрыть


нельзя написать вот так?:

Для  С = 1 По 30 Цикл
		
		РассчитатьСтатьиТаблицы(ТЗСтатьи, ТаблицаФормул, ТаблицаИнтервалов, кМакс);
		ТЗСтатьи	=	ТЗСтатьи.Скопировать(Новый Структура("СтрокаРассчитана", ложь));
		Если (ТЗСтатьи.количество()=0) Тогда Прервать; КонецЕсли;
		
	КонецЦикла;
...Показать Скрыть
24. алексей (Alex141516) 09.10.12 18:05
по второму глюку (не считает если формула статьи основана на другой статье) - вот этот кусок кода показался странным

Для Каждого Стр из ТЗВсеСтатьи Цикл
  стр.СтрокаРассчитана	=	ложь;
	для н =1 по кМакс Цикл
	  Имя	=	"Значение"+Строка(н);
	  Стр[имя]	=	0;
  КонецЦикла;
КонецЦикла;
...Показать Скрыть


т.е. программист в таблице обнулил только-что рассчитанные цифры по статьям (далее по коду - из этой таблицы он переносит данные в основную). Детально не разбирался, может и не понял или не увидел логику, но убрал этот кусок - все стало нормально выводится. Если в первом случае это ошибка была, то это то что такое?
25. алексей (Alex141516) 10.10.12 09:34
там глюк на глюке, код абсурдный, авторам лучше убрать это творение дабы не позорится
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа