gifts2017

Прогресс бар для 1С 7.7

Опубликовал Михаил Журавлев (Gmix) в раздел Программирование - Работа с интерфейсом

Внешняя обработка (Прогресс бар) легко встраивается в любую конфигурацию, есть возможность выводить комментарий текущего действия

Внутри архива файл для демострации возможностей

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ProgressBar77
.rar 12,39Kb
25.09.09
338
.rar 12,39Kb 338 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Антон Рощин (wolfsoft) 15.05.06 18:48
Простенько, но прикольно :)
2. Rexx 04.08.06 12:24
Можно сказать даже "гламурненько".(+1)
4. Kiselev (kiselev) 25.05.07 08:31
5. Vitaly Peskovsky (Lavalit) 27.11.09 10:33
ЗачОтно!!! встраивается в конфигу легко! вся интеграция заняла минут 20 с учетом специфики своей конфиги +1!!! 8-)
6. Павел Смирнов (pav_cupa) 18.06.10 20:05
Подскажите, пожалуйста, начинающему.
Каким образом эту обработку встроить в конфигурацию, если это можно "на пальцах" описать.
7. Михаил Журавлев (Gmix) 21.06.10 09:01
Внутри архива файл для демонстрации возможностей
8. Александр Рытов (Арчибальд) 21.06.10 09:49
9. Vitaly Peskovsky (Lavalit) 02.07.10 16:45
прогресс бар штука конечно очень удобная... но есть один маленький нюанс:
что бы все работало красиво необходимо изначально знать значение ста процентов бара. а потом уже передавать текущее значение и получать процент выполнения чего либо... отчет или копирование файлов или еще к чему там прикрутите прогрессбар.

//***********************
// Функции для работы с прогресс бар
//__________________________________________________________­______________
Функция ОткрытьПрогресБар(Знач Ч_Число="", Знач Стр_Имя="Запрос")
Если ФС.СуществуетФайл(КаталогИБ()+"Классы\ПрогрессБар.ert")=1 Тогда
Об_СЗ=СоздатьОбъект("СписокЗначений");
Об_СЗ.ДобавитьЗначение(Ч_Число);
Об_СЗ.ДобавитьЗначение(Стр_Имя);
Попытка
ОткрытьФорму("Обработка",Об_СЗ.ВСтрокуСРазделителями(), КаталогИБ()+"Классы\ПрогрессБар.ert");
Исключение
Состояние(СокрЛП(Стр_Имя)+" "+Строка(Ч_Число)+"%");
КонецПопытки;
КонецЕсли;
КонецФункции //ОткрытьПрогресБар
//__________________________________________________________­______________
Функция ЗакрытьПрогресБар()
Попытка
ОткрытьФорму("Обработка","", КаталогИБ()+"Классы\ПрогрессБар.ert");
Исключение
КонецПопытки;
КонецФункции //ЗакрытьПрогресБар


ОткрытьПрогресБар(ЗначениеСтаПроцентов); //Здесь надо передать стопроцентное значение при открытии как раз прогрессбар и будет понимать сколько оно есть стопроцентов
ОткрытьПрогресБар(0);

Сч=1;
Пока Запрос.Группировка(1) = 1 Цикл
ОткрытьПрогресБар(Сч,Запрос.ЗначениеУпорядочивания(*,*)); // теперь в цикле открываем прогресс и передаем текущее значение прогресса. на самом деле прогресс бар будет "Переоткрываться" -( но мы то знаем, что открытие уже было и прогрессбар еще пока помнит значение ста процентов... ну и есс-но стопроцентов /100 * на текущее значение аккурат вычислит текущий прогресс в процентах)

Сч=Сч+1;
КонецЕсли;

вот собственно и вся интеграция 8-)

10. Vitaly Peskovsky (Lavalit) 02.07.10 16:51
А если в прогрессбаре использовать фонт для индикатора "Webdings" символ "g" например то уж совсем красота получается.
8-)
11. Андрей Моисеев (nihfalck) 24.11.11 12:32
Внешняя обработка (Прогресс баГ)

:)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа