Прогресс бар для 1С 7.7

Опубликовал Gmix в раздел Программирование - Работа с интерфейсом

Внешняя обработка (Прогресс бар) легко встраивается в любую конфигурацию, есть возможность выводить комментарий текущего действия

Внутри архива файл для демострации возможностей

Файлы

Наименование Файл Версия Размер Кол. Скачив.
ProgressBar77
.rar 12,39Kb
25.09.09
297
.rar 12,39Kb 297 Бесплатно

См. также

Комментарии

1. wolfsoft 15.05.2006 18:48
Простенько, но прикольно :)
Ответили: (9)
# Ответить
2. Rexx 04.08.2006 12:24
Можно сказать даже "гламурненько".(+1)
# Удалить Изменить Ответить
3. АЛьФ 04.08.2006 13:15
4. Kiselev 25.05.2007 08:31
Спасибо! Будем юзать! :)
# Ответить
5. Lavalit 27.11.2009 10:33
ЗачОтно!!! встраивается в конфигу легко! вся интеграция заняла минут 20 с учетом специфики своей конфиги +1!!! 8-)
# Ответить
6. pav_cupa 18.06.2010 20:05
Подскажите, пожалуйста, начинающему.
Каким образом эту обработку встроить в конфигурацию, если это можно "на пальцах" описать.
# Ответить
7. Gmix 21.06.2010 09:01
Внутри архива файл для демонстрации возможностей
# Ответить
8. Арчибальд 21.06.2010 09:49
Зачет
# Ответить
9. Lavalit 02.07.2010 16:45
прогресс бар штука конечно очень удобная... но есть один маленький нюанс:
что бы все работало красиво необходимо изначально знать значение ста процентов бара. а потом уже передавать текущее значение и получать процент выполнения чего либо... отчет или копирование файлов или еще к чему там прикрутите прогрессбар.

//***********************
// Функции для работы с прогресс бар
//__________________________________________________________­______________
Функция ОткрытьПрогресБар(Знач Ч_Число="", Знач Стр_Имя="Запрос")
Если ФС.СуществуетФайл(КаталогИБ()+"Классы\ПрогрессБар.ert")=1 Тогда
Об_СЗ=СоздатьОбъект("СписокЗначений");
Об_СЗ.ДобавитьЗначение(Ч_Число);
Об_СЗ.ДобавитьЗначение(Стр_Имя);
Попытка
ОткрытьФорму("Обработка",Об_СЗ.ВСтрокуСРазделителями(), КаталогИБ()+"Классы\ПрогрессБар.ert");
Исключение
Состояние(СокрЛП(Стр_Имя)+" "+Строка(Ч_Число)+"%");
КонецПопытки;
КонецЕсли;
КонецФункции //ОткрытьПрогресБар
//__________________________________________________________­______________
Функция ЗакрытьПрогресБар()
Попытка
ОткрытьФорму("Обработка","", КаталогИБ()+"Классы\ПрогрессБар.ert");
Исключение
КонецПопытки;
КонецФункции //ЗакрытьПрогресБар


ОткрытьПрогресБар(ЗначениеСтаПроцентов); //Здесь надо передать стопроцентное значение при открытии как раз прогрессбар и будет понимать сколько оно есть стопроцентов
ОткрытьПрогресБар(0);

Сч=1;
Пока Запрос.Группировка(1) = 1 Цикл
ОткрытьПрогресБар(Сч,Запрос.ЗначениеУпорядочивания(*,*)); // теперь в цикле открываем прогресс и передаем текущее значение прогресса. на самом деле прогресс бар будет "Переоткрываться" -( но мы то знаем, что открытие уже было и прогрессбар еще пока помнит значение ста процентов... ну и есс-но стопроцентов /100 * на текущее значение аккурат вычислит текущий прогресс в процентах)

Сч=Сч+1;
КонецЕсли;

вот собственно и вся интеграция 8-)
# Ответить
10. Lavalit 02.07.2010 16:51
А если в прогрессбаре использовать фонт для индикатора "Webdings" символ "g" например то уж совсем красота получается.
8-)
# Ответить
11. nihfalck 24.11.2011 12:32
Внешняя обработка (Прогресс баГ)

:)
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл