gifts2017

Astrisk.dll + NativeAPI

Опубликовал Zeleboba_ в раздел Оборудование - Телефония, SIP

Компонента для 1С на NativeAPI для связи 1С 8.2 и Asterisk.

Из бесплатных компонент не нашел ничего, поэтому пришлось написать самому.

Поддерживаются две функции: оригинация и внешнее событие при входящем звонке.

Компоненту можно положить в макет и загружать оттуда.

 

Пример использования:

////////////////////////////////////////////

Перем ОбъектВК экспорт;

Процедура ПриНачалеРаботыСистемы()

ПодключитьВнешнююКомпоненту("D:\AsteriskDll.dll","AsteriskDll",AddInType.Native);
ОбъектВК = Новый("AddIn.AsteriskDll.ExecExtention");

Пр = ОбъектВК.Инициализировать("10.10.0.4", "5038", "login", "pass", "111");

//Параметры:

//  " 10.10.0.4 ",  "5038"  - IP адрес и порт менеджера Asterisk

//   " login ", "pass" - логин и пароль

//   "111" - номер, при входящем звонке на который должно срабатывать внешнее событие

 

Если Пр Тогда Сообщить("Зарегились на сервере!"); Иначе Сообщить("Ошибка регистрации!"); КонецЕсли;

КонецПроцедуры 

 

Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)

ПоказатьОповещениеПользователя(,,Источник+" -- "+Событие+" -- "+Данные);

// В поле "Данные" выводится номер с которого нам позвонили

КонецПроцедуры  

 

 

ОбъектВК.Оригинация("111", "222", "from-internal");

//Параметры:

//  "111" - наш номер, с которого звоним

//  "222" - номер на который звоним

//  "from-internal" - контекст Asterisk

/////////////////////////////////////////// 

 

 

Скачать файлы

Наименование Файл Версия Размер
Компонета 45
.dll 1,50Mb
26.06.12
45
.dll 1,50Mb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Serg Kondrasgov (SergDi) 27.06.12 10:03
оу, супер!
давно планирую связать 1с и Asterisk.
в Asterisk настраивать AMI нужно, или работает через sip?
2. Кирилл Краснов (kirillkr) 27.06.12 15:55
3. Zeleboba_ 27.06.12 16:18
4. Serg Kondrasgov (SergDi) 27.06.12 16:36
5. Serg Kondrasgov (SergDi) 31.08.12 15:40
что-то не проходит инициализация к Asterisk...
6. Serg Kondrasgov (SergDi) 31.08.12 15:51
на астере в логах вообще ничего...