gifts2017

Доработка ТиС 9.2 на предмет запрета одинаковых (дублей) артикулов

Опубликовал Артур Карелин (atb123) в раздел Программирование - Универсальные функции

Проверка уникальности артикула

В модуле Справочника.Номенклатура, в процедуре записи добавляем строки 

	 //***************************************************************************************
Спр = СоздатьОбъект("Справочник.Номенклатура");
Если Спр.НайтиПоРеквизиту("Артикул", Артикул, 1) = 1 Тогда
    Если Спр.Код <> Код Тогда
         Вопрос("Артикул НЕ УНИКАЛЕН !!! ATB Forever !!!","" ,60);
         СтатусВозврата(0);
     КонецЕсли;
    Возврат;
КонецЕсли;
// **************************************************************************************

См. также

Подписаться Добавить вознаграждение
Комментарии
1. max maxx (motorkuzbassa.it) 04.07.12 05:57
А кто назовет какой товар совпадает?

Вопрос("Артикул НЕ УНИКАЛЕН !!! Совпадает с: "+Спр.Наименование+"ATB Forever !!!","" ,60);
2. Maxim k (maxis33) 04.07.12 09:13
А если пользователь хочет код товара поменять, что произойдет?
3. Артур Карелин (atb123) 19.07.12 08:29
Если он уникальный, то все нормально новая номенклатура запишется !!!
4. Иваныч Иванов (Иваныч) 03.11.12 09:15
5. Владимир Щербаков (2sw) 16.11.12 13:49
Оригинальный код не позволяет сохранять номенклатуру с пустым артикулом. Вот доработанный код

Спр = СоздатьОбъект("Справочник.Номенклатура");
Если Спр.НайтиПоРеквизиту("Артикул", Артикул, 1) = 1 Тогда
	Если Спр.Код <> Код Тогда   
		Если сокрлп(артикул)="" Тогда
		СтатусВозврата(1); 
	Иначе Вопрос("Обнаружен дубль. Артикул НЕ УНИКАЛЕН !!! Совпадает с: "+Спр.Наименование+"
		|
		|Наименование для печати: "+Спр.ПолнНаименование+"
		|
		|Совет: Если требуется записать элемент, оставьте артикул пустым","" ,60);   
   		СтатусВозврата(0);  
	    КонецЕсли;
	
    КонецЕсли;
Возврат;  
КонецЕсли; 
...Показать Скрыть
6. Иваныч Иванов (Иваныч) 05.05.14 14:43
Я использую поле Артикул как каталожный номер детали. Производителей 3, каталожный номер - общий. Как быть?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа