gifts2017

Обработка Заполнения ГТД и стран в документы поступления и возврат товаров

Опубликовал Виталий Винтов (Vint88) в раздел Обработки - Обработка документов

Обработка позволяет менять ГТД и страны в документах поступления и возврате. Полезна когда много номенклатуры в документе и ГТД у всех нужно поменять на одинаковую какую-нибудь. В данных документах лишь создаём кнопку на эту обработку.

В кнопке документа необходимо прописать похожую процедуру:

	 Процедура КоманднаяПанельТоварыПодборГТД(Кнопка)
    ЭтотОбъект.Записать(РежимЗаписиДокумента.Запись);
    Эл= Обработки.ЗаполнениеГТДиСтраныВДокументы.Создать();     
    i=1;
    Эл.ДокССылка = ЭтотОбъект.Ссылка;
    Для Каждого Стр Из Товары Цикл
        Если ПустаяСтрока(Стр.СерияНоменклатуры) Тогда
            СтрокаТабЧ=Эл.Товары.Вставить(i);
            СтрокаТабЧ.Номерок=Стр.НомерСтроки;
            СтрокаТабЧ.Флажок=Истина;
            СтрокаТабЧ.Номенклатура=Стр.Номенклатура;
            СтрокаТабЧ.Код=Стр.Номенклатура.Код;
            СтрокаТабЧ.Артикул=Стр.Номенклатура.Артикул;
            СтрокаТабЧ.НомерГТД="";
            СтрокаТабЧ.СтранаПроисхождения="";
            СтрокаТабЧ.Количество=Стр.Количество;
        КонецЕсли;
        i=i+1;
    КонецЦикла;
    Форма=Эл.ПолучитьФорму("Форма",ЭтотОбъект);
    Форма.Открыть();
КонецПроцедуры



Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗаполнениеГТДиСтраныВДокументы.epf
.epf 11,51Kb
04.07.12
12
.epf 11,51Kb 12 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Виталий Винтов (Vint88) 03.07.12 14:51
Обработка позволяет менять ГТД и страны в документах поступления и возврате. Полезна когда много номенклатуры в документе и ГТД у всех нужно поменять на одинаковую какую-нибудь. В данных документах лишь создаём кнопку на эту обработку.

Перейти к публикации

1. ninch (ninch) 13.07.12 06:50
В УТ10 по кнопке "изменить" можно сделать такую же фигню (в поступлении точно) - то есть все стандартно. А в УПП нету чтоли?
2. Виталий Винтов (Vint88) 13.07.12 16:20
В Упп тоже есть такая фигня, просто она выдаёт всю номенклатуру, а нужно чтобы только те позиции, у которых нет ГТД. Чтобы вручную не искать, а если просто ГТД захотел поменять, то можно пользоваться именно стандартной функцией
3. Сергей Ожерельев (Поручик) 24.07.12 14:11
(2) Ради этого курочить конфигурацию? Про внешние обработки заполнения табличных частей не слыхали?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа