gifts2017

Управление пользователями и компами пользователей

Опубликовал Александр Хомяк (logarifm) в раздел Администрирование - Защита, права, пароли

Тут сморел народ грит, что там процесы, завершение роботы и т.п. (и попросили у мну мое выложить), короче опять же выкладываю внешний отчет заточен под мою конфу, а точнее под ИТРП. Короче не оижайтесь, я переписывать его под универсал не буду, кто умный разберется сам в конфе, у мну просто времени и так мало!
Причем валит в даун в резет компы которые в списке, а также их процесы, фильтрация процесов, там у мну есть закладка по рейтингу пользователей в 1С - это можете выбросить или попробовать в себя реализовать, а еще одно посылка сообщений выбраным компам!)))

Скачать файлы

Наименование Файл Версия Размер
Управление пользователями 122
.rar 172,31Kb
25.09.09
122
.rar 172,31Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Den (DDD2005) 27.10.06 11:56
Если Пользователь<<?>>.Код<>"Sasha" Тогда
{C:\DOCUMENTS AND SETTINGS\DENIS\РАБОЧИЙ СТОЛ\УПРАВЛЕНИЕ ПОЛЬЗОВАТЕЛЯМИ.ERT(200)}: Переменная не определена (Пользователь)
2. Sasha_H (logarifm) 27.10.06 11:58
Я же говорю, я под свою ИТРП писал!! В конфигураторе надо доработать вам ее под себя! Я ж ее под себя замутил!
3. Click2006 27.10.06 13:56
Не мог бы ты еще тексты следующих процедур выложить:
глДобавитьСтрокиВСписок()
глУдалитьСтрокиИзСписка()

и то что добавил в процедуру ПриНачалеРаботыСистемы()
4. Sasha_H (logarifm) 27.10.06 14:03

Процедура глДобавитьСтрокиВСписок(Список,Знач ТипОбъекта,МультиДобавление=0,ВыборГруппы=1,Знач ВидыДляВыбора="") Экспорт
//*****
Перем ЗначОбъекта;
Перем ФлПервыйВход,ФлВыбран;
Перем Справ,Счет,Док;
Перем СписВидов,СписПарам,ВыбрВид;
Перем ТипСтр,Идент,Предст;
Перем Поз;
//*****
Если ТипЗначенияСтр(ТипОбъекта)="СписокЗначений" Тогда
ТипСтр="СписЗнач";
Иначе
Если Лев(ТипОбъекта,10)="Справочник" Тогда
ТипСтр="Справ";
ИначеЕсли Лев(ТипОбъекта,4)="Счет" Тогда
ТипСтр="Счет";
ИначеЕсли Лев(ТипОбъекта,8)="Документ" Тогда
ТипСтр="Докум";
Иначе
ТипСтр="Прочее";
КонецЕсли;
КонецЕсли;
//*****
Если ПустаяСтрока(ВидыДляВыбора)=0 Тогда
//*****
ВидыДляВыбора=ВидыДляВыбора+",";
СписВидов=СоздатьОбъект("СписокЗначений");
//*****
Пока ПустаяСтрока(ВидыДляВыбора)=0 Цикл
//*****
Поз=Найти(ВидыДляВыбора,",");
Идент=Лев(ВидыДляВыбора,Поз-1);
ВидыДляВыбора=Сред(ВидыДляВыбора,Поз+1);
//*****
Если ТипСтр="Справ" Тогда
Предст=Метаданные.Справочник(Идент).Представление();
ИначеЕсли ТипСтр="Докум" Тогда
Предст=Метаданные.Документ(Идент).Представление();
КонецЕсли;
СписВидов.ДобавитьЗначение(Идент,Предст);
//*****
КонецЦикла;
//*****
СписВидов.СортироватьПоПредставлению();
Если СписВидов.ВыбратьЗначение(ВыбрВид,"Выберите вид")=1 Тогда
ТипОбъекта=ТипОбъекта+"."+ВыбрВид;
Иначе
Возврат;
КонецЕсли;
//*****
КонецЕсли;
//*****
ФлПервыйВход=1;
Пока (ФлПервыйВход=1) ИЛИ (МультиДобавление=1) Цикл
//*****
ФлПервыйВход=0;
ЗначОбъекта=?(Список.ТекущаяСтрока()>0,Список.ПолучитьЗначение(Список.ТекущаяСтрока()),ПолучитьПустоеЗначение(ТипОбъекта));
//*****
Если ТипСтр="СписЗнач" Тогда
ФлВыбран=ТипОбъекта.ВыбратьЗначение(ЗначОбъекта,"Выберите значение:");
ИначеЕсли ТипСтр="Справ" Тогда
Справ=СоздатьОбъект(ТипОбъекта);
Справ.ВыборГруппы(ВыборГруппы);
Если ПустоеЗначение(ЗначОбъекта)=0 Тогда
Справ.НайтиЭлемент(ЗначОбъекта);
КонецЕсли;
ФлВыбран=Справ.Выбрать("Выберите элемент","");
Если ФлВыбран=1 Тогда
ЗначОбъекта=Справ.ТекущийЭлемент();
КонецЕсли;
Справ=0;
ИначеЕсли ТипСтр="Счет" Тогда
Счет=СоздатьОбъект(ТипОбъекта);
Счет.ВыборГруппы(ВыборГруппы);
Если ПустоеЗначение(ЗначОбъекта)=0 Тогда
Счет.НайтиСчет(ЗначОбъекта);
КонецЕсли;
ФлВыбран=Счет.Выбрать("Выберите счет","");
Если ФлВыбран=1 Тогда
ЗначОбъекта=Счет.ТекущийСчет();
КонецЕсли;
Счет=0;
Иначе
Если ТипОбъекта="Документ.Спецификация" Тогда
//***** это особый случай
ФлВыбран=0;
ЗначОбъекта=глВыборСпецификации(ПолучитьПустоеЗначение("Справочник.Номенклатура"),ЗначОбъекта,ФлВыбран);
Иначе
ФлВыбран=ВвестиЗначение(ЗначОбъекта,,ТипОбъекта);
КонецЕсли;
КонецЕсли;
//*****
Если ФлВыбран=1 Тогда
Если Список.Принадлежит(ЗначОбъекта)=1 Тогда
Предупреждение("Данный элемент уже есть в списке !!!");
Иначе
Если (ТипОбъекта="Документ.Спецификация") И (ПустоеЗначение(ЗначОбъекта)=1) Тогда
//***** это особый случай
Список.ДобавитьЗначение(ЗначОбъекта,"Базовая спецификация");
Иначе
Список.ДобавитьЗначение(ЗначОбъекта);
КонецЕсли;
Список.ТекущаяСтрока(Список.РазмерСписка());
КонецЕсли;
Иначе
Прервать;
КонецЕсли;
//*****
КонецЦикла;
//*****
КонецПроцедуры //глДобавитьСтрокиВСписок
//*****
Процедура глУдалитьСтрокиИзСписка(Список,РежОчистка) Экспорт
Если Список.РазмерСписка()>0 Тогда
Если РежОчистка=1 Тогда
Список.УдалитьВсе();
Иначе
Список.УдалитьЗначение(Список.ТекущаяСтрока());
КонецЕсли;
КонецЕсли;
КонецПроцедуры //глУдалитьСтрокиИзСписка
5. Sasha_H (logarifm) 27.10.06 14:04
так бы благодарство хотябы кто-то оставил)
6. Антон Рощин (wolfsoft) 27.10.06 15:29
Еще бы обработку сжал в архив - качать "полметра", чтобы просто посмотреть, что-то не хочется.
7. Sasha_H (logarifm) 27.10.06 15:57
8. Serg76 (serg76) 27.10.06 18:37
А с русским языком у Вас как-то туговато, батенька
Bezeus; Istur; +2 Ответить
9. Равиль Каримов (karaw) 28.10.06 09:58
Вещь прикольная, даже я бы сказал СУПЕРНАЯ!!!
Не мог бы ты описать какие компоненты использовал и выложить md-шник.
10. Sasha_H (logarifm) 28.10.06 13:34
Не про мд даже не мечтайте ))))
11. Равиль Каримов (karaw) 01.11.06 07:36
Или хотя бы все глобальные процедуры и функции используемые в твоей обработке и то что добавил в процедуру ПриНачалеРаботыСистемы()
Также описание всех реквизитов в добавленных справочниках. Если конечно тебе не сложно. Я думаю тебе за это многие будут благодарны. Вот!
12. Sasha_H (logarifm) 01.11.06 12:04
Щас вложу все глоб пртоцы в ткст архива)
13. Sasha_H (logarifm) 01.11.06 12:20
Ось! Там скрин справочника пользователи, но это вы сами уже вруляйте как я там его писал)
И 2 процы в ткст ПриНачалеРаботы() и ПриОкончанииРаботыСистемы()
14. Ехидный (ExugHa) 23.11.06 08:06
И зачем такое выкладывать?
15. Дмитрий Елисеев (w-divin) 17.10.09 23:49
"Вообще вот нечем народу занятся" (с) аффтар

Мне это не нужно - получите минус...
16. Ярослав Володимирович (myr4ik07) 30.10.16 18:23
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа