Игра Color Breakers v.2

Опубликовал Anselm Petrov (Anselm) в раздел Сообщество - Игры

Обновленная версия игры. Игра представляет собой вариацию на тему игр Jawbreaker (на PocketPC) и Clickomania.

Игровое поле состоит из множества случайным образом расположенных цветных шариков. Группы шариков можно выделять и затем удалять с игрового поля. Удалять можно группы шариков, начиная с 2-х. Чем больше шариков в группе, тем больше дается очков за их удаление. При удалении группы вышележащие шарики "падают" вниз, заполняя пустое пространство внизу. Если игра идет в режиме "Сдвиг", то шарики еще смещаются вправо, также заполняя свободное место. За каждые 300 очков дается "Бомба", с помощью которой можно "взорвать" мешающие шарики (максимально - 5 шариков).

Скачать файлы

Наименование Файл Версия Размер
ColorBreakers2.epf
.epf 47,87Kb
08.08.12
40
.epf 47,87Kb 40 Скачать

См. также

Комментарии
1. Александр Шадрин (Shadal) 14 15.11.06 06:42 Сейчас в теме
В процедуру ИгровоеПолеВыбор() Добавь внизу вот это ))) тогда будут столбцы сдвигаться влево если весь столбец внутри пустой)))..
Если ИксЦветной>-1 Тогда //начинаем опускать квадратики
ПромежуточныйИксЦветной=ИксЦветной;
Пока ИксЦветной>=0 Цикл
ИгровойМассив[ИксБелый][к]=ИгровойМассив[ИксЦветной][к];
ИгровойМассив[ИксЦветной][к]=Белый;
ИксБелый=ИксБелый-1;
ИксЦветной=ИксЦветной-1;
КонецЦикла;
ИначеЕсли ИксБелый=РазмерностьСтрок-1 Тогда
Икс=РазмерностьСтрок-1;
Пока Икс>=0 Цикл
Если к<РазмерностьКолонок-1 тогда
ИгровойМассив[Икс][к]=ИгровойМассив[Икс][к+1];
ИгровойМассив[Икс][к+1]=Белый;
КонецЕсли;
Икс=Икс-1;
КонецЦикла;
КонецЕсли;
2. Anselm Petrov (Anselm) 33 15.11.06 18:10 Сейчас в теме
Спасибо! :-)) Я это уже сделал :-) Сейчас хочу графику улучшить :-)), а потом обновлю файл.
3. Сhe Burashka (CheBurator) 16.11.06 01:27 Сейчас в теме
Зайдите на Т1С и поищите "Кликомания" для 7.7 есть
4. Anselm Petrov (Anselm) 33 16.11.06 02:33 Сейчас в теме
5. Iom Nuerto (n949eo) 13.11.11 19:06 Сейчас в теме
6. Иляна Кандаурова (lilly) 12.01.12 22:09 Сейчас в теме
7. vladal (Vladal) 17.10.12 17:35 Сейчас в теме
Игра не на флеше? настоящая 1С-ная?
8. Anselm Petrov (Anselm) 33 17.10.12 17:58 Сейчас в теме
(7) не на флеше, настоящая 1С-ная. Весь код открыт - можно посмотреть :-)
9. vladal (Vladal) 17.10.12 18:29 Сейчас в теме