gifts2017

Простой пример как открыть форму внешней обработки из другой формы внешней обработки. 8.2. (Управляемые формы)

Опубликовал {ÐƦǑƝȊ} mx (dour-dead) в раздел Программирование - Практика программирования

Простой пример как открыть форму внешней обработки из другой формы внешней обработки. 8.2. (Управляемые формы)

Вот пример простого кода.


Путь - Это реквизит на форме;


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ПутьКФормам = ПолучитьОбработку().Метаданные().ПолноеИмя() + ".Форма.";
КонецПроцедуры

&НаСервере
Функция ПолучитьОбработку()
Возврат РеквизитФормыВЗначение("Объект");
КонецФункции

&НаКлиенте
Процедура ОткрытьНовуюФорму(Команда)
ОткрытьФормуМодально(Путь+"НоваяФорма",,ЭтаФорма);
КонецПроцедуры

Аналогичные примеры:

http://infostart.ru/public/82526/

http://infostart.ru/public/137048/

http://its.1c.ru/db/metod81#content:3556:1 


 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Пример
.epf 7,37Kb
26.07.12
35
.epf 7,37Kb 35 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 26.07.12 22:46
(0) Завтра я вывалю ещё один пример, как открыть форму внешней обработки из другой формы внешней обработки
2. {ÐƦǑƝȊ} mx (dour-dead) 27.07.12 08:53
(1) Поручик, как будет готово дайте посмотреть
3. Сергей Ожерельев (Поручик) 27.07.12 23:40
(2) Вывалил на своём сайте, смотрите профиль. Здесь пока модератор не одобрил. Вы обхохочетесь.
4. {ÐƦǑƝȊ} mx (dour-dead) 28.07.12 13:44
(3) Поручик,что то я не нашел
5. Михаил Ражиков (tango) 28.07.12 14:09
(3) Поручик, шеф, своими словами скажи прикол, некогда твой сайт парсить :)
6. Сергей Ожерельев (Поручик) 28.07.12 14:29
(5) Ваши проблемы, я тоже шибко занятой.
7. Александр Лыткин (TrinitronOTV) 12.12.13 11:26
Скачал примерчик, но никак не получается у меня сделать такое: программно запускается через батник файл внешней обработки, из которого надо запустить последовательно два других файла внешних обработок и всё закрыть после выполнения этих двух внешних обработок. Я только осваиваю управляемые формы. Под обычные формы модуль формы выглядел так:

Процедура ПриОткрытии()
КаталогИБ = Строка(НСтр(СтрокаСоединенияИнформационнойБазы(), "File"));

ИмяФайла = КаталогИБ+"\ExtProcesRep\"+"ОбменADS_Справочники.epf";
Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
Форма.ВариантЗапуска = 1;
Форма.Открыть();
Форма.Закрыть();

ИмяФайла = КаталогИБ+"\ExtProcesRep\"+"ОбменADS_Документы.epf";
Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
Форма.ВариантЗапуска = 1;
Форма.Открыть();
Форма.Закрыть();

ЭтаФорма.Закрыть();
КонецПроцедуры

В этом коде ругается на "ВнешниеОбработки"
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа