gifts2017

Использование функций внешнего отчета в вычисляемых полях системы компоновки данных. Добавлена поддержка расшифровки.

Опубликовал Александр Загребельный (hobi) в раздел Программирование - Практика программирования

Нужно ли при необходимости использования новой функции в вычисляемых полях СКД  всякий раз описывать её в общем модуле ?
НЕТ ! Если один раз описать в общем модуле универсальную функцию.
По предложению sam441 добавлена поддержка расшифровки в отчете.
В демонстрационном примере расшифровка открывается для всех полей отчета.

Отмазка

Некоторым эта статья покажется диким баяном - бабаяном ... но не все же являются матерыми одинэсниками в седьмом поколении. Так что эта статья для тех, кто не является.

Преамбула

Зачем это нужно ? При сопровождении больших проектов, как правило, новые релизы конфигураций выпускаются намного реже, чем новые внешние отчеты  и печатные формы. А обновляются у заказчика еще реже, особенно если баз данных у него много :)  Поэтому часто возникают ситуации, когда отчет заказчику нужен срочно, а конфигурации, установленные у него, не имеют нужной прямо сейчас функции общего модуля. Можно, конечно, выкрутиться, если передать в отчет объект (например - таблицу значений), который можно вычислить как душе угодно. Но зачем выкручиваться, если можно использовать экспортные функции этого же отчета в вычисляемых полях СКД ? Статья как раз о том, как это сделать.

Амбула

Собственно, всё достаточно просто:

  1. в сопровождаемую конфигурацию внедряем экспортную функцию общего модуля;
  2. добавляем параметр со своим любимым именем в макет СКД отчета (в примере это имя "Отчет");
  3. в модуле формы этому параметру при запуске отчета присваиваем значение объекта;
  4. в вычисляемом поле вызываем функцию модуля отчета через посредника - функцию общего модуля, например: ом.Фу(&Отчет,"Ф2",Наименование,5) . В этом вызове &Отчет - это введенный нами параметр, Ф2 - имя функции, размещенной в модуле отчета, Наименование и 5 - это аргументы, которые будут переданы в Ф2.

Небольшой пример: демо-база и демонстрационный внешний отчет для управляемого приложения прилагаются. Но и для обычного нет преград. Тоже всё работает. Представленная технология позволяет вызывать экспортные функции модулей внешних отчетов и обработок.        

Внедрение одной небольшой универсальной экспортной функции-посредника в общий модуль конфигурации позволяет забыть об ограничении платформы - разрешении на использование в вычисляемых полях СКД только экспортных функций общих модулей конфигурации.

Замечания:

В ходе тестирования обнаружилось различное поведение конфигурации при запуске под платформой 8.3, несмотря на то, что установлен режим совместимости с версией 8.2.16.

Сравнивались версии платформы 1С:Предприятие 8.3 (8.3.2.172) и 1С:Предприятие 8.2 (8.2.17.153)
Тестирование для режимов запуска "Тонкий клиент" и "Толстый клиент (управляемое приложение).

В серверной функции модуля формы внешнего отчета в платформе 8.2 успешно работает метод
 ПоместитьВоВременноеХранилище(ЭтотОбъект,УникальныйИдентификатор)  и в "Толстом" и в "Тонком" клиентах.

При запуске под платформой 8.3 метод не работает (и в "Толстом" и в "Тонком"), отображается сообщение об ошибке:
"Переданное значение не может быть помещено во временное хранилище".

Пока не знаю - это баг 8.3 или запланированное изменение поведение системы. Странно, что это проявляется в режиме совместимости с 8.2. На всякий случай отправил письмо на v8@1c.ru с описанием ситуации.

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Архив с демонстрационным материалом
.rar 72,91Kb
01.01.13
116
.rar 72,91Kb 116 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Осипов Сергей (fixin) 29.07.12 00:05
(0) Блжад, а ведь к этому методу я пришел самостоятельно... ;-)
Но рад что молодёжь тоше открыла его.
3. Владимир Чаклин (vec435) 01.08.12 15:02
вообще все не основные функ/проц можно вынести во внешнюю обработку. тогда в общем модуле получим код для вызова функ внешней обработки общиймодуль.во().внешняяфунк(парам1)
4. Артем Гусаров (Flashback1979SE) 15.08.12 04:15
Вообще, клевый обход ограничения)). Спасибо за статью, теперь не придется "придумывать велосипед"). Побольше бы таких фишек, особенно для СКД.
5. Олег Крапивный (powerpc) 15.08.12 09:12
Сорри, почему у меня ошибка как на скриншоте ???
Прикрепленные файлы:
6. Sam Sam (sam441) 23.08.12 09:18
Спасибо, получилось, но есть момент не получается добавить расшифровку, формирование делаю так:
в модуле отчета процедура

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
	Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
	ЭлементыНастроек = Настройки.ПараметрыДанных.Элементы;
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Отчет", ЭтотОбъект);
	
	КомпановщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпановки = КомпановщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки,ДанныеРасшифровки);
	
	ПроцессорКомпановки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпановки.Инициализировать(МакетКомпановки,,ДанныеРасшифровки,Истина);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпановки);
	
КонецПроцедуры
...Показать Скрыть

Выходит: Ошибка отображения типов:
Отсутствует отображение для типа 'ВнешнийОтчетОбъект.Тест'

Без параметра ДанныеРасшифровки работает, но ес-но расшифровка нет
7. Олег Крапивный (powerpc) 18.10.12 11:01
У меня не работает все равно
8. Олег Крапивный (powerpc) 18.10.12 11:05
9. Александр Загребельный (hobi) 18.10.12 21:52
С расшифровкой отчет не пробовал, надо посмотреть, как прикрутить.
10. Александр Загребельный (hobi) 01.01.13 13:44
(6) sam441, (7) powerpc, публикацию поправил.
В последней выгрузке была ошибка с вызовом экспортной функции менеджера справочника.
Разбираться особо не стал, поскольку это экзотический вариант использования, на практике
нужны вызовы функций из модуля самого внешнего отчета. Просто убрал вызов функции менеджера
справочника.
Но прикрутил работу с расшифровкой , спасибо sam441 за замечания.
Отчет тоже слегка изменил - изменил источник данных с запроса на объект и использовал макет.
По поводу источника: с объектом,по моему мнению,работать удобнее, поскольку полностью контролируется процесс
получения данных (можно посмотреть ТЗ, временные таблицы и пр.). А запрос в схеме компоновки данных -
своего рода "черный ящик", внутрь которого особо не заглянешь.
И еще один нюанс - столкнулся в ЗУПе как-то с ситуацией, когда в обычном приложении, на SQL базе были проблемы
с правами при исполнении запроса внутри схемы компоновки данных. Поскольку (цитата из справки к платформе по методу УстановитьПривилегированныйРежим): "В клиент-серверном варианте при выполнении на клиенте данный метод не выполняет никаких действий"). Так вот, запрос внутри схемы компоновки данных, выполняется именно на клиенте (если клиент - толстый, обычное приложение).
После переноса запроса в модуль отчета и передачи результата (ТЗ) в виде объекта, всё чудесным
образом разрешилось. Это я все к тому, зачем изменил источник на объект.
11. nanik nanik (nanik) 19.03.13 14:23
С коллегами разбираем как раз вопросы об вычисляемых полях в компоновке данных, вернее ограничения (минимум функций, которые можно использовать). В Платформе 8.3 их уже конечно больше, но переходим на 8.2, да и 8.3 не покроет потребности, а выносить каждый раз их в общий модуль не выход.
12. nanik nanik (nanik) 19.03.13 14:25
Подобная мысль была, а теперь есть и факт и реализация.
13. Сергей Лещенко (legrey) 26.04.13 16:25
Просто бобмба ! Очень кстати. Сэкономил кучу времени
14. Владимир (Svb84) 21.03.14 09:48
Как в функции-посреднике вызывается функция модуля отчета?
15. Александр Полтава (Патриот) 04.04.14 15:31
(14) Svb84, я так написал:
//Данная функция позволяет использовать в вычисляемых полях СКД экспортные функции самого отчета
//Объект - ОтчетОбъект
//НаименованиеФункции - Имя экспортной функции этого объекта
//Парам1 - Парам9 - Параметры, которые будут переданы в эту функцию
Функция _Фу(Объект, НаименованиеФункции, Парам1 = Неопределено, Парам2 = Неопределено, Парам3 = Неопределено, Парам4 = Неопределено, Парам5 = Неопределено, Парам6 = Неопределено, Парам7 = Неопределено, Парам8 = Неопределено, Парам9 = Неопределено)Экспорт
	Результат = Неопределено;
	Если Не Объект = Неопределено Тогда 
		Попытка
			СписокПараметров = "";
			Для Итератор = 1 По 9 Цикл
				Если Не Вычислить("Парам" + Итератор + " = Неопределено") Тогда
					СписокПараметров = СписокПараметров + "Парам" + Итератор + ",";	
				КонецЕсли;
			КонецЦикла;
			СписокПараметров = Лев(СписокПараметров, СтрДлина(СписокПараметров) - 1);
			Результат = Вычислить("Объект." + НаименованиеФункции + "(" + СписокПараметров + ")");
		Исключение
			Сообщить("Ошибка при попытке нахождения вычисляемого поля. Ошибка в функции """ + НаименованиеФункции + """" + Символы.ПС + ОписаниеОшибки());
		КонецПопытки;
	Иначе
		Сообщить("Ошибка при попытке нахождения вычисляемого поля. Не задан Объект.");	
	КонецЕсли;
	Возврат Результат; 	
КонецФункции	
...Показать Скрыть
16. Александр Полтава (Патриот) 04.04.14 15:46
(0) Штука очень полезная, автору однозначно плюс. Но нужно было указать один важный момент - при закрытии отчета ссылку на объект (которую мы поместили в параметр компоновщика настроек) надо убить (присвоить этому параметру "неопределено"), иначе, после закрытия отчета, старый объект будет жить вплоть до завершения сеанса 1С. Кроме того, что это в принципе зло, это может помешать отладке отчета, т.к. все время будет запускаться старая версия (т.к. по факту отчет не будет перезапускаться).
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа