gifts2017

Скрытие помеченных на удаление в справочнике

Опубликовал MIK В (mikukrnet) в раздел Программирование - Практика программирования

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

В глобальник кидаем одну функцию


Функция глПолучитьСписокЭлементов(Иерархически,ТекРодитель,Конт) Экспорт

   
Спр=СоздатьОбъект("Справочник."+Конт.Вид());

   
Сп=СоздатьОбъект("СписокЗначений");

    Если
Иерархически=1 Тогда

       
Спр.ВключатьПодчиненные(0);

       
Спр.ИспользоватьРодителя(ТекРодитель);

    КонецЕсли;

   
Спр.ВыбратьЭлементы();

    Пока
Спр.ПолучитьЭлемент()=1 Цикл

        Если
Спр.ПометкаУдаления()=0 Тогда

           
Сп.ДобавитьЗначение(Спр.ТекущийЭлемент());

        КонецЕсли;

    КонецЦикла;

    Возврат
Сп;

КонецФункции

В форме списка справочника:


Процедура ПриВыбореРодителя(Элемент)

   
ИспользоватьСписокЭлементов(глПолучитьСписокЭлементов(1,Элемент,Контекст));

КонецПроцедуры



Процедура
ПриОткрытии()

   
ИспользоватьСписокЭлементов(глПолучитьСписокЭлементов(ИерархическийСписок(),Родитель,Контекст));

КонецПроцедуры 
//ПриОткрытии



Процедура ПриСменеИерархии(Иерархически)

   
ИспользоватьСписокЭлементов(глПолучитьСписокЭлементов(Иерархически,Родитель,Контекст));

КонецПроцедуры

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Литовченко (kompas-dm) 08.08.12 12:21
(0) Списки элементов справочников в типовых применяются широко (Зарплата и кадры, Предприятие )
2. Alex Melnichuk (Amel2010) 15.08.12 10:28
Представьте, как это будет работать на справочниках с тысячами элементов и групп.
Кстати, в конфигурациях часто применяются уже эти приемы для других целях в формах списков справочников.
В таком случае этот способ и вовсе не подойдет.
3. Вадим Никонов (V.Nikonov) 16.08.12 20:36
Можно использовать не для всех справочников. Можно включать опционально... Например, при подборе в документы.
Голова программисту зачем? Надо только помнить про возможные последствия применённых решений.
4. Сергей Скурихин (skurser) 06.10.14 09:55
Спасибо за заметку. Пригодилось. Возможно ли таким образом, добавить галочку сверху в окне справочника, чтобы можно было скрыть или отобразить помеченные на удаление элементы?
5. Сергей Фамилия (antares2010) 31.10.14 12:36
Спасибо, очень пригодилось
6. Сергей Фамилия (antares2010) 29.12.14 09:45
Сделал как у Вас написано в справочнике номенклатура, но при подборе товаров набирая на клавиатуре название набор символов как то притормаживается, и не ищется по всему справочнику, пока не нажмёшь и отожмёшь кнопку "режим вывода списка по группам". Кроме того стала неактивна кнопка создания и копирования элементов.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа