Печать штрих-кода на обычном принтере (ТиС)

Опубликовал Poppy (poppy) в раздел Печать - Ценники

Обработка позволяет печатать этикетки со штрих-кодами на обычном принтере (типовая ТиС).

Задача обработки - печатать этикетки со штрих-кодами на обычном (например, лазерном) принтере. Для этого необходимо использовать специальую самоклеющуюся бумагу формата А4 (например, http://www.komus.ru/show.php3?art=73566).

Обработку можно вызывать из справочников Номенклатура и Единицы, а так-же из документов ПоступлениеТМЦ и Реализация.

При вызове из справочника пользователь должен ввести количество экземпляров этикеток. При печати из документа будет подготовлено этикеток по количеству товара в документе.

Обработку можно подключить к любому другому документу, у которого есть реквизиты табличной части: "Номенклатура", "Единица", "Количество".

Для установки необходимо разархивировать файл в каталог ExtForms\PrnForms каталога информационной базы. Обработка будет зарегистрирована как внешняя печатная форма.

Обработка заточена под типовую конфигурацию "Торговля+Склад". В других конфигурациях не работает.

Скачать файлы

Наименование Файл Версия Размер
-
.1178738756 9,58Kb
27.09.09
1051
.1178738756 9,58Kb 1051 Скачать

См. также

Комментарии
1. Доржи Цыденов (support) 4395 10.05.07 00:37 Сейчас в теме
2. rjhev korum (корум) 298 10.05.07 10:12 Сейчас в теме
Хм... на лазерном принтере можно и без дополнительной обработки печатать. Другое дело - штатная по одной штуке выводит ;о)
3. Poppy (poppy) 3298 13.05.07 22:43 Сейчас в теме
> Другое дело - штатная по одной штуке выводит ;о)

Именно по этому пришлось писать обработку...
4. Сhe Burashka (CheBurator) 14.05.07 02:42 Сейчас в теме
+1
делал аналогичную клиенту,
основное отличие было - пустой стикер-разделитель между товарами.
5. артем (mambo.80) 16.10.07 21:15 Сейчас в теме
Помогите очень нужно но не работает
pavelprogram; +1 Ответить
6. Олег Пономаренко (O-Planet) 6656 16.10.07 22:59 Сейчас в теме
Хм... А по группе сразу, или по документу? У мну такая печатает по-всякому. Цены берет опять же, либо из регистра, либо из документа, либо из справочника...
7. артем (mambo.80) 17.10.07 10:20 Сейчас в теме
{C:\PROGRAM FILES\1CV77\1SBBDB\EXTFORMS\PRNFORMS\LABEL.ERT(14)}: Процедура не обнаружена (глВесыПолучитьВес)
zE5CD96751498=z78ED4EB33A7A;КонецЕсли;КонецЕсли;глОбработкаВнешнегоСобытия<<?>>(z8780890267D5,z5E1CEBDE34CF
{C:\PROGRAM FILES\1CV77\1SBBDB\EXTFORMS\PRNFORMS\LABEL.ERT(15)}: Процедура не обнаружена (глОбработкаВнешнегоСобытия)
,z6A93277144AB);КонецПроцедуры Процедура ЗакрытьФорму()глВесыУстановитьРежим<<?>>(0);СохранитьЗначение("УстройствоВыводаЭтикетки"
{C:\PROGRAM FILES\1CV77\1SBBDB\EXTFORMS\PRNFORMS\LABEL.ERT(16)}: Процедура не обнаружена (глВесыУстановитьРежим)
(zA14C99B8DB87=13)Тогда Если глКонтрольныйСимволEAN<<?>>(Лев(Штрихкод,12),13)=Прав(Штрихкод,1)Тогда zC83DABE347FB
{C:\PROGRAM FILES\1CV77\1SBBDB\EXTFORMS\PRNFORMS\LABEL.ERT(22)}: Функция не обнаружена (глКонтрольныйСимволEAN)
=1;КонецЕсли;ИначеЕсли(zA14C99B8DB87=8)Тогда Если глКонтрольныйСимволEAN<<?>>(Лев(Штрихкод,7),8)=Прав(Штрихкод
{C:\PROGRAM FILES\1CV77\1SBBDB\EXTFORMS\PRNFORMS\LABEL.ERT(23)}: Функция не обнаружена (глКонтрольныйСимволEAN)

вот что он мне выдал, при запуске обработки!
8. Poppy (poppy) 3298 17.10.07 20:29 Сейчас в теме
(7) 2mambo.80
Эта обработка предназначена для использования как внешняя печатная форма к типовой конфигурации ТиС. Для бухгалтерской базы она не заточена.
9. Лёша Авто (Lesha1C) 229 14.10.08 17:55 Сейчас в теме
только зачем же шифровать если вы ее выкладываете на общее пользование?!
10. Poppy (poppy) 3298 21.10.08 11:57 Сейчас в теме
(9)
Это у меня почерк такой... хи-хи. ;)
11. Дмитрий (DARKDEAD) 14.11.08 09:49 Сейчас в теме
Таким "подчерком" пишется однозначно не такое...
12. ИВАН НЕ ВАЖНО (ivvan) 09.01.09 20:15 Сейчас в теме
13. Иван Черновалов (chernovalov) 27.01.09 10:34 Сейчас в теме
А эта обработка подходит для не весовых товаров?
14. Евгений (reel) 25.05.09 02:06 Сейчас в теме
Сэнкс! все работает. Вопросик. В России товары вроде начитаются с 46, а штрихкод автоматом формируется с 20. Где это задается?
15. tenev 26.05.09 14:53 Сейчас в теме
ОБАЛДЕТЬ!!! Огромное спасибо!!!
16. Юрий Тимофеев (Tatitutu) 3569 26.05.09 15:30 Сейчас в теме
(14)
"В России товары вроде начитаются с 46"
с 2 (по умолчанию) - для внутреннего использования.
Во всем должен быть порядок.
Где задается в конфигураторе - что то типа ПрефиксШтрихкода


О штрих кодах почитай здесь http://www.ean.ru/
17. Валерий (Валерий_) 01.06.09 11:23 Сейчас в теме
Отлично работает, благодарим.
По сей день, пользуемся другой обработкой, в которой можно указать количество колонок и строк на А4, но количество штрихкодов товара из документа, в ней, не проставляется, приходится проставлять количество штрихкодов каждого наименования в ручную.
Пожелание - возможность указать количество колонок и строк на А4
Например, 5столбцов х 13строк или 10столбцов х 26строк, такое количество на специальной самоклеющейся бумаге формата А4 арт.024065 надрезаны 65прямоугольников (этикеток), в каждый прямоугольник реально напечатать 4 штрихкода и они считываются сканером. В этом случае на листе А4 размещается 260 этикеток (экономия самоклеющейся бумаги), так же из-за минимальных размеров этикетки 10,25мм х 18,75мм производится этикетирование товара с очень небольшими габаритами.
18. Илья Брежнев (bambula) 2 01.07.09 22:05 Сейчас в теме
туфта, не работает на конфе ТиС для украины
19. Poppy (poppy) 3298 01.07.09 22:31 Сейчас в теме
(18) Спасибо, bambula, за сообщение.

Обработка работает только в типовой ТиС. В других = не работает. Исправлено описание обработки.
20. Сергей (Che) Коцюра (CheBurator) 3370 02.07.09 02:37 Сейчас в теме
шо я вам имею сказать... вот если я возьму эту обработку для вывода наклеек у себя - есть очень большой шанс что 1ска рухнет... потому как наклеек я вывожу бывает листов этак 150-200... вывод за 1 раз 1ска не выдердивает..
21. Poppy (poppy) 3298 17.07.09 00:35 Сейчас в теме
(20)
Эта обработка не заточена под девелоперов ;-)
22. Сергей (Che) Коцюра (CheBurator) 3370 17.07.09 03:27 Сейчас в теме
(21) это говорит только о том, что обработка не проходила обкатку на реально больших объемах печати... знаем.. проходили...
кстати, надысь наваял свою обработку печати ценников, специфика в том, что цена вбита сразу в ШК.
23. Шухер (Шухер) 23 12.08.09 12:32 Сейчас в теме
Скачал, понравилось +1
за плохой почерк денег не дам ;)
24. mirco brons (mirco) 70 10.11.09 05:37 Сейчас в теме
poppy? А где ты такие картинки, как в шапке статьи берешь :?:
Я тоже такие хочу :D
25. Poppy (poppy) 3298 10.11.09 09:53 Сейчас в теме
26. mirco brons (mirco) 70 12.11.09 12:48 Сейчас в теме
27. Евгений Евгений (leasing) 1 18.06.10 15:05 Сейчас в теме
Не понимаю, зачем эта тайнопись, да еще с ошибками типа Найти ("бррр",Тута) тут присутствует. Чтоб показать нам что?
28. Влад (levoven) 16.09.11 11:36 Сейчас в теме
очень полезная пользуюсь постоянно только добавил кол-во ценников из документа
29. divalis (divalis) 13.10.11 16:44 Сейчас в теме
30. Павел Межевикин (pavlo_xxxl) 02.05.12 14:59 Сейчас в теме
31. Сергей Е (lcdgm) 16.01.13 15:16 Сейчас в теме
Подскажите, пожалуйста, очень нужна помощь! Выдает такую ошибку:

ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
{Документ.Реализация.Форма.Модуль(1807)}: Ошибка создания внешнего отчета I:\путь к базе\ExtForms\PrnForms\LABEL.ert


Стандартная конфигурация ТиС 7.70.970. В чем может быть проблема?