gifts2017

1С 8 Настраиваемый рабочий стол

Опубликовал Rustam Samandarov (rustamsmax) в раздел Программирование - Работа с интерфейсом

Настраиваемая форма рабочего стола для обычного приложения.

Обработка позволяет настраивать рабочий стол нужными справочниками документами отчетами и обработками. Также для отчетов можно настраивать по сохраненными настройками.

для полноценного работы обработки надо добавить регистра сведения "НастройкиРабочегоСтола"

с измерениями

-Пользователь(СправочникСсылка.Пользователи)

-Раздель(Строка)

с русурсам

-Значение(ХранилищеЗначения)


В новой версии настройки рабочего стола сохраняется в регистре "СохраненныеНастройки".

То есть не надо добавить доп.регистр.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Панель функции
.epf 238,67Kb
02.09.12
189
.epf 238,67Kb 189 Скачать
Рабочый стол версия 1.2
.epf 75,44Kb
09.07.13
64
.epf 75,44Kb 64 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. ProGramMoS ProGramMoS (ProGramMoS) 01.09.12 18:39
{Форма.РабочийСтол.Форма(121,3)}: Переменная не определена (Adinsoft_Modulu)
<<?>>Adinsoft_Modulu.ОткрытьФормуИзПанелФункции(НайдСтр);
Вот такое сообщение...при попытке открыть обработку - вроде в конфигураторе все прописал
2. Rustam Samandarov (rustamsmax) 02.09.12 17:05
Извиняюсь добавьте функцию а модуль обработки:

Функция ОткрытьФормуИзПанелФункции(СтрокаМеню) Экспорт
Если СтрокаМеню <> Неопределено
И (Не ЕстьРеквизитьОбъекта(СтрокаМеню, "Родитель") ИЛИ СтрокаМеню.Родитель <> Неопределено) Тогда
Если ЕстьРеквизитьОбъекта(СтрокаМеню, "Родитель") Тогда
Тип = СтрокаМеню.Родитель.ИмяОбъекта;
Иначе
Тип = СтрокаМеню.Тип;
КонецЕсли;
Если Тип = "ОбщиеФормы" Тогда
ПолучитьОбщуюФорму(СтрокаМеню.ИмяОбъекта).Открыть();
ИначеЕсли Тип = "Справочники" Тогда
Справочники[СтрокаМеню.ИмяОбъекта].ПолучитьФормуСписка().Открыть();
ИначеЕсли Тип = "Документы" Тогда
Документы[СтрокаМеню.ИмяОбъекта].ПолучитьФормуСписка().Открыть();
ИначеЕсли Тип = "ЖурналыДокументов" Тогда
ЖурналыДокументов[СтрокаМеню.ИмяОбъекта].ПолучитьФорму().Открыть();
ИначеЕсли Тип = "Отчеты" Тогда
ОтчетОбъект = Отчеты[СтрокаМеню.ИмяОбъекта].Создать();
ФормаОтчета = ОтчетОбъект.ПолучитьФорму();
ФормаОтчета.Открыть();
Если ЕстьРеквизитьОбъекта(ОтчетОбъект, "УниверсальныйОтчет") Тогда
СтруктураНастройки = Новый Структура;
СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
СтруктураНастройки.Вставить("ИмяОбъекта", Строка(ОтчетОбъект));
СтруктураНастройки.Вставить("НаименованиеНастройки", СтрокаМеню.ИмяНастройки);
Если УниверсальныеМеханизмы.ПолучитьНастройку(СтруктураНастройки) Тогда
ОтчетОбъект.УниверсальныйОтчет.мТекущаяНастройка = СтруктураНастройки;
ОтчетОбъект.ВосстановитьНастройкиИзСтруктуры(СтруктураНастройки.СохраненнаяНастройка);
ОтчетОбъект.УниверсальныйОтчет.УстановитьЗаголовокФормы(ОтчетОбъект.УниверсальныйОтчет, ОтчетОбъект, ФормаОтчета);
КонецЕсли;
КонецЕсли;
ИначеЕсли Тип = "Обработки" Тогда
Обработки[СтрокаМеню.ИмяОбъекта].ПолучитьФорму().Открыть();
КонецЕсли;
КонецЕсли;
КонецФункции
3. Rustam Samandarov (rustamsmax) 02.09.12 17:07
и это


Функция ЕстьРеквизитьОбъекта(Объект, ИмяРеквизита) Экспорт
УИ = Новый УникальныйИдентификатор();
СтрРеквизит = Новый Структура(ИмяРеквизита, УИ);
ЗаполнитьЗначенияСвойств(СтрРеквизит, Объект);

Возврат СтрРеквизит[ИмяРеквизита] <> NULL И СтрРеквизит[ИмяРеквизита] <> УИ;
КонецФункции
4. Дмитрий Глеков (glek) 03.09.12 15:40
За идею - плюс. Но Вы бы хоть орфографию подправили.
"акже для отчетов можно настраивать по сохраненными настройками.
. Это на каком языке? А это:
-Пользователь(СправочникСсылка.Пользователи)
-Раздель(Строка)
с русурсам
-Значение(ХранилищеЗначения)
:-)
5. Иван (iones) 12.09.12 15:35
Это на нармальнановорускам языке)))
+ за идею
6. Иван (iones) 20.09.12 11:07
Мое решение универсального и настраиваемого рабочего стола, для любой конфигурации.
Пока только для обычного приложения.
http://infostart.ru/public/152771/
7. water water (-water-) 05.12.12 19:30
Перед тем как выкладывать проверял бы..нифига не работает
8. Ольга Николаевна (ron1) 26.03.13 16:55
Здравствуйте. Очень нужен такой Рабочий стол. Но смущает последний комментарий.
Рустам, не могли бы Вы сказать, работает ли Ваше обработка на версии 10.3.21.2?
Заранее спасибо.
9. Rustam Samandarov (rustamsmax) 09.07.13 13:45
(8) ron1, Здравствуйте! да работает
10. Андрей Штоколов (Alfer) 16.01.14 19:04
совсем неплохо - будем пользоваться - спасибо разработчику
11. Тима Осипов (net7wolf) 18.09.14 08:35
8.1 "Управление торговлей", редакция 10.3 (10.3.5.1) не работает
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа