IE2017

Удаление и/или копирование сохраненных в 1С настроек (например настроек печати табличных форм)

Администрирование - Сервисные утилиты

Иногда нужно удалить сохраненную в 1С "покореженную" настройку или скопировать "удачную" другому пользователю...

 

Позволяет увидеть все сохранённые в 1С настройки (печати табличных форм, отчетов, ...)

Удалить ненужные (борьба за размер, "битые" настройки, ...)

Скопировать "удачную" настройку другим пользователям...

 

ВНИМАНИЕ! Работает на релизе не ниже 8.2.15

СПАСИБО sanfoto (//infostart.ru/profile/24807/) за публикацию //infostart.ru/public/149007/  где он "ткнул меня носом", что в 1С у некоторых объектов иногда появляются новые методы и свойства, а также разработчикам платформы 1С, что не устают нас радовать...

19/06/2013 Добавлена обработка для 

СтандартноеХранилищеНастроекМенеджер

ХранилищеПользовательскихНастроекОтчетов

ХранилищеОбщихНастроек

ХранилищеНастроекДанныхФорм

ХранилищеВариантовОтчетов

 

 

 

 

Скачать файлы

Наименование Файл Версия Размер
Обработка (для СтандартноеХранилищеНастроекМенеджер, ХранилищеПользовательскихНастроекОтчетов, ХранилищеОбщихНастроек, ХранилищеНастроекДанныхФорм, ХранилищеВариантовОтчетов)
.epf 17,84Kb
19.06.13
666
.epf 17,84Kb 666 Скачать
Обработка (для ХранилищеСистемныхНастроек)
.epf 17,33Kb
19.06.13
531
.epf 17,33Kb 531 Скачать

См. также

Комментарии
1. Андрей Вовк (wowkai) 4 01.09.12 13:19 Сейчас в теме
Искал ранее такую обработку для 1с 8.1, но так и не нашел
2. anry mc (AnryMc) 713 01.09.12 13:54 Сейчас в теме
(1) wowkai,
К сожалению до 8.2.15 можно было только через перебор метаданных (скорость - до скончания века...)
3. Ирина Х (Amara) 05.09.12 10:07 Сейчас в теме
Обработка неплохая, полезная. Единственный минус - неудобный отбор. Как пожелание - добавить возможность отбора по пользователю на форму.
4. anry mc (AnryMc) 713 05.09.12 11:01 Сейчас в теме
(3) Amara,
В системном хранилище настроек пользователи хранятся как "Строка" а не ссылка на справочник "Пользователи", что позволяет хранить их настройки без привязки к этому справочнику (который может называться по разному в разных конфигурациях), плюс система поэтому может (И ХРАНИТ) настройки уже полностью удаленных пользователей.
Поэтому сделать фильтрацию по пользователю как элементу справочника можно, но не всегда целесообразно.
Пока есть отбор по "строке" "Пользователь", см. рисунок.
Прикрепленные файлы:
5. Ирина Х (Amara) 05.09.12 12:10 Сейчас в теме
Да, я видела возможность такого отбора, но согласитесь отбор по строке не очень удобен. И еще при первой попытки установить отбор запутало то, что доступен выбор типа: строка, справочник. Если данные только типа строка, то тип справочник "Пользователи", на мой взгляд, следует убрать.
6. anry mc (AnryMc) 713 05.09.12 18:20 Сейчас в теме
(5) Amara,
Добавил колонку "Пользователь ссылка" - элемент справочника "Пользователи".
Добавил обработку удаления настроек удаленных (в базе и конфигурации) пользователей
7. Александр Кикабидзе (capshow) 07.09.12 09:53 Сейчас в теме
Автор, это те настройки (на уровне платформы), которые хранятся в файлах pfl в папках юзеров или это настройки на уровне конфигурации в спец регистрах и справочника? Если первое, то это супер, особенно если работает для настроек форм диалога и списка документов!
8. anry mc (AnryMc) 713 07.09.12 10:10 Сейчас в теме
(7) capshow,
Настройки из СИСТЕМНОГО ХРАНИЛИЩА НАСТРОЕК, тех что хранятся в базе (Системный аналог -> Конфигурация - Общие - Хранилища настроек)
А если пользовательские то Вам сюда - http://infostart.ru/public/77702/
9. Кирилл (kiros) 51 10.09.12 12:50 Сейчас в теме
Вот спасибо, как раз начались "глюки" с принтерами, теперь можно будет проще бороться с такими проблемами.
10. Александр Синцов (Sintson) 336 10.09.12 21:47 Сейчас в теме
Молодец, я сам давно хотел нечто подобное замутить, да все, как говорится руки не доходили!
Плюсую!
11. arjuna (arjuna) 23.10.12 22:24 Сейчас в теме
Мелочь, а приятно. Полезная штучка.
12. Arikite (ArikiteSun) 08.02.13 16:56 Сейчас в теме
13. anry mc (AnryMc) 713 06.05.13 17:40 Сейчас в теме
(11) arjuna, (12) Arikite,

Очень мне нравяться пользователи которые говорят спасибо, даже не скачав файл. И даже не поставив "+".
14. Мансур Девятияров (demanru) 28 18.06.13 13:00 Сейчас в теме
+ хорошо бы ещё ХранилищеВариантовОтчетов и ХранилищеНастроекДанныхФорм :)
15. anry mc (AnryMc) 713 18.06.13 16:01 Сейчас в теме
(14) demanru,

А у вас есть на чем проверить (да и желание проверить)?
Есть вариант с остальными, но не доделывал, т.к. не начем попробовать...
16. anry mc (AnryMc) 713 19.06.13 16:53 Сейчас в теме
(14) demanru, Выложил второй файл - по всем (почти) хранилищам
17. Владимир (vladir) 107 01.07.13 14:20 Сейчас в теме
(0) Опять чудеса с Тестом на интеллект. Sm за скачивание успешно снялось, файл не скачался... :(((
18. Владимир (vladir) 107 01.07.13 14:24 Сейчас в теме
+ к (17) Все же удалось скачать с пятой попытки...
19. anry mc (AnryMc) 713 03.07.13 13:51 Сейчас в теме
ВНИМАНИЕ!!! Первый файл
Обработка (для СтандартноеХранилищеНастроекМенеджер, ХранилищеПользовательскихНастроекОтчетов, ХранилищеОбщихНастроек, ХранилищеНастроекДанныхФорм, ХранилищеВариантовОтчетов)

включает в себя функционал второго!!!

Просто я его оставил, т.к. небыло возможности хорошо потестировать новый (первый)...
20. Владимир Клименко (KliMich) 18.10.13 20:24 Сейчас в теме
Спасибо! В работе будет полезно.
21. lett Любимов (lett) 6 07.11.13 12:11 Сейчас в теме
Копирование настройки возможно только одному пользователю, потом снова нужно копировать настройку в буфер и выбирать другого пользователя. Удобнее было бы указывать список пользователей, ну или хотя бы возможность копировать сразу всем пользователям.
За обработку - спасибо.
22. Алексей Белоусов (AllexSoft) 24.12.13 12:58 Сейчас в теме
Спасибо, пробывал на 8.3, вроде работает, если закомментировать условие при открытии окна. Плюс если бы под УФ переделать было бы шикарно
23. Максим Жохов (ZhokhovM) 281 06.02.14 10:34 Сейчас в теме
24. anry mc (AnryMc) 713 06.02.14 14:54 Сейчас в теме
(23) ZhokhovM, Мне понравилось ;-)
25. ффф ыыы (zqzq) 16 07.02.14 10:36 Сейчас в теме
Плюсую.

Сделал для себя альтернативную кнопку копирования, можете использовать, если хотите.
1. Выбор сразу нескольких пользователей
2. Пофиксил копирование описания настроек
3. 1 кнопка вместо 2 :)
Тестировал на вариантах отчетов СКД.

Процедура КнопкаКопировать2(Элемент)

	текСтрока=ЭлементыФормы.СписокСистемныхНастроек.ТекущиеДанные; Если текСтрока = Неопределено Тогда Возврат КонецЕсли;
	
	КешЗначения=НОВЫЙ Структура;
	КешЗначения.Вставить("КлючОбъекта", текСтрока.КлючОбъекта);
	КешЗначения.Вставить("КлючНастроек", текСтрока.КлючНастроек);
	КешЗначения.Вставить("Пользователь", текСтрока.Пользователь);
	Описание = Новый ОписаниеНастроек;
	ЗаполнитьЗначенияСвойств(Описание, текСтрока);
	КешЗначения.Вставить("Представление", Описание);
	СтрокаКоманды="КешЗначения.Вставить(""Настройка"", "+ЭлементыФормы.ПолеВыбораТипаХранилища.Значение+".Загрузить(текСтрока.КлючОбъекта, текСтрока.КлючНастроек, текСтрока.Представление, текСтрока.Пользователь))";
	Выполнить(СтрокаКоманды);

	//------------------------------------------------
	Для каждого ДляПользователя Из СписокПользователейБазы Цикл
		ДляПользователя.Пометка = Ложь;
	КонецЦикла;
	СписокПользователейБазы.ОтметитьЭлементы("Отметьте пользователей, которым скопировать");
	
	Для каждого ДляПользователя Из СписокПользователейБазы Цикл
		Если ДляПользователя.Пометка //И НЕ СокрЛП(ДляПользователя.Значение.Код)=КешЗначения.Пользователь - для изменения названия можно того же выбрать 
			Тогда
			СтрокаКоманды=ЭлементыФормы.ПолеВыбораТипаХранилища.Значение+".Сохранить(КешЗначения.КлючОбъекта, КешЗначения.КлючНастроек, КешЗначения.Настройка, КешЗначения.Представление, ДляПользователя.Значение.Код)";
			Выполнить(СтрокаКоманды);
		КонецЕсли;
	КонецЦикла;
	
	КешЗначения=НЕОПРЕДЕЛЕНО;
	ПолучитьСохраненныеНастройки();
	
КонецПроцедуры
...Показать Скрыть
katilek; ZhokhovM; Terve!R; AnryMc; +4 Ответить 2
26. anry mc (AnryMc) 713 07.02.14 10:50 Сейчас в теме
27. MasterSVS (MasterSVS) 54 20.02.14 14:17 Сейчас в теме
Спасибо! Понадобилась...
Модераторы удалите минус!!! Сорри...
28. екатерина (katilek) 2 04.09.14 09:39 Сейчас в теме
29. Алексей Белоусов (AllexSoft) 04.09.14 13:17 Сейчас в теме
(23) ZhokhovM, дело в том что у меня их было примерно 700мб! одна только таблица настроек ) поэтому пришлось разрабатывать свою обработину которая смогла бы вообще переварить подобные объемы
30. Виталий Довыденко (d_vit) 8 29.10.14 06:51 Сейчас в теме
31. Роман Грук (gruk) 3 01.12.14 05:00 Сейчас в теме
Сделал отбор по имени пользователя, нажал отметить все, и потом удалить отмеченные.....
=-O А настройки то удалились все полностью!!!!
Обработка нужная и актуальная, но вот за такое не то что плюс непоставить - минусовать хочется.

P.S. Глянул код: вы кнопку "отметить все" неправильно назвали, надо было "отметить все, игнорируя отбор" :)
32. anry mc (AnryMc) 713 01.12.14 09:03 Сейчас в теме
(31) gruk, Спасибо, за замечание.
Появиться время - сразу исправлю...

ЗЫ. Просто я сначала сделал кнопки, а затем добавил отбор...
34. Anatoly Pugin (Matador) 108 17.02.15 12:26 Сейчас в теме
отличная обработка, только ГДЕ управляемая форма.
35. anry mc (AnryMc) 713 19.02.15 11:14 Сейчас в теме
(34) Matador,
только ГДЕ управляемая форма.

вот обработка на УФ http://infostart.ru/public/345667/.
36. Геннадий (DrSender) 48 18.03.15 16:40 Сейчас в теме
Спасибо. Конечно плюс. Использую сейчас при отладке. Еще бы видеть поле Настройка в форме списка, как в (35) - было бы еще удобнее.
37. Инна Милакина (_Маша) 25.03.15 09:30 Сейчас в теме
Спасибо, полезная обработка, только изменили, для версии 1С:Предприятие 8.3 (8.3.5.1248) не пускало))
вместо
ВП=Лев(ВП, 6);
ВП=СтрЗаменить(ВП,".","");
сделала
ВП=СтрЗаменить(ВП,".","");
ВП=Лев(ВП, 4);
корум; cdromscsi; +2 Ответить
38. Максим Жохов (ZhokhovM) 281 13.04.15 15:27 Сейчас в теме
39. Максим Жохов (ZhokhovM) 281 14.04.15 10:40 Сейчас в теме
В управляемой форме добавил все те возможности, что и у вас. На всякий случай оставлю тут ссылочку http://infostart.ru/public/345667/. Спасибо автору за такие возможности!
40. Максим Жохов (ZhokhovM) 281 14.04.15 11:09 Сейчас в теме
(25) zqzq, спасибо, так же для себя сделал кнопку копирования другим пользователям.
41. Назлыгуль Нургалиева (naziknazik333) 16.10.15 15:59 Сейчас в теме
42. anry mc (AnryMc) 713 18.10.15 08:35 Сейчас в теме
(41) naziknazik333, Для обычных форм.
43. Роман Саенко (fagust19821112) 24.02.16 10:14 Сейчас в теме
нужна обработка для сброса настроек пользователя УПП
44. anry mc (AnryMc) 713 24.02.16 12:56 Сейчас в теме
(43) fagust19821112,
Это "стол заказов"?
Оставьте свое сообщение