gifts2017

Выявление минусов по товарам

Опубликовал Julia (juliasoft) в раздел Отчеты - Управленческие

Отчет "Выявление минусов по товарам"  (для конфигурации Торговля+Склад редакция 9.2)

Предназначен для выявления проблемных позиций товаров, по которым за выбранный период были минусы.
Т.е. минусы не на дату конца отчета, а на любой момент времени из выбранного интервала.
Написан по просьбе трудящихся в свой личный выходной :-)

Необходимо указать период отчета, выбрать склад (если не выбран, то по всем складам), выбрать товар или группу товаров (если не выбрана, то по всем товарам).

Сделан на базе регистра "ОстаткиТМЦ"

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
J_Minusy_po_tov.rar
.1187440754 7,66Kb
25.09.09
269
.1187440754 7,66Kb 269 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Доржи Цыденов (support) 18.08.07 21:13
2. Julia (juliasoft) 18.08.07 21:18
(1) спасибо.. теперь понятно, за что тут плюсы раздают.. за "интерфейс" и за "отзывчивость" :-)
3. Сhe Burashka (CheBurator) 19.08.07 00:10
...нормалек, запихну тут одним любителям косячить...
4. Poppy (poppy) 20.08.07 00:03
> выбрать склад (если не выбран, то по всем складам),

Если склад не выбран, то минусы расчитываются по каждому складу отдельно или по всем вместе?
5. Poppy (poppy) 20.08.07 00:07
Традиционное предложение по "упрощению" кода:

вместо кода
Код
   Если ВыбСклад.Выбран() = 1 Тогда
      ТекстЗапроса = ТекстЗапроса + 
      "Условие(Склад = ВыбСклад);
       |";
   КонецЕсли;  
   Если (ВыбНоменклатура.Выбран() = 1) И (ВыбНоменклатура.ЭтоГруппа() = 1) Тогда
      ТекстЗапроса = ТекстЗапроса +
      "Условие(Номенклатура.ПринадлежитГруппе(ВыбНоменклатура) = 1);
       |";
   ИначеЕсли (ВыбНоменклатура.Выбран() = 1) И (ВыбНоменклатура.ЭтоГруппа() = 0) Тогда   
      ТекстЗапроса = ТекстЗапроса +
      "Условие(Номенклатура = ВыбНоменклатура);
       |";    
   КонецЕсли;
    
   Если ВыбСклад.Выбран() = 1 Тогда
      ТекстЗапроса = ТекстЗапроса +
      "Условие(Склад = ВыбСклад);
       |";
   КонецЕсли;     
Показать полностью


достаточно написать следующее:
Код
   ТекстЗапроса = ТекстЗапроса +
   "Условие(Номенклатура в ВыбНоменклатура);
   |Условие(Склад в ВыбСклад);";    
Показать полностью

lenapar; 33lab; +2 Ответить 2
6. Леонид (leonko38) 20.08.07 05:57
7. Julia (juliasoft) 20.08.07 08:08
(4) - если склад не выбран - по любому, есть группировка по складам.. будет считаться отдельно по каждому складу. Отбор по фирме не учитывала. Кому надо - сам добавит.
(5) - по поводу упрощения кода - правильное замечание, кто захочет - исправит сам. Лучше просто скажите спасибо (если он вам нужен), если не нужен - нет смысла тут писать (или вы каждый код просматриваете: :-) ).
8. Евгений Чуркаев (MACTEP) 21.08.07 23:10
это делается в двух строчках :-)
DobroProd; +1 Ответить
9. Viacht (viacht) 24.08.07 09:37
В ПУБ для Украины не работает, хотя должно. РУгается:
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Склад = Регистр. <<?>> ОстаткиТМЦ.Склад;
Запрос[3] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Номенклатура = Регистр. <<?>> ОстаткиТМЦ.Номенклатура;
Запрос[4] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Количество = Регистр. <<?>> ОстаткиТМЦ.Количество;
Запрос[5] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Док = Регистр. <<?>> ОстаткиТМЦ.ТекущийДокумент;
Запрос[6] : Неверно заданный путь 'ОстаткиТМЦ'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Группировка Склад <<?>> упорядочить по Склад.Наименование;
Запрос[11] : Переменная 'Склад' не опеределена
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Группировка Номенклатура <<?>> без групп;
Запрос[12] : Переменная 'Номенклатура' не опеределена
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Группировка Док <<?>> ;
Запрос[13] : Переменная 'Док' не опеределена
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Условие(Склад = ВыбСклад <<?>> );
Запрос[14] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Условие(Номенклатура = ВыбНоменклатура <<?>> );
Запрос[15] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\1CBASED\EXTFORMS\TEMP.GRP\J_ВЫЯВЛЕНИЕМИНУСОВПОТОВАРАМ.ERT(46)}: Условие(Склад = ВыбСклад <<?>> );
Запрос[16] : Ошибка в условии
10. Poppy (poppy) 24.08.07 12:36
(9)
В твоей конфигурации нет регистра ОстаткиТМЦ, вот и ругается.

С чего ты взял, что должно работать? В описании явно написано, что для конфигурации ТиС 9.2
11. Viacht (viacht) 27.08.07 10:51
Как правило, Тисовские отчеты прекрасно работают в ПУБ для Украины. А насчет регистра ОстаткиТМЦ мне кажется Вы частично не правы, у нас он называется ОстаткиЗапасов.
12. VasilyKushnir (vasilykushnir) 27.08.07 12:09
Ну ей богу, как дети - что не найдут, все в рот тянут... И вообще, это не есть хорошая практика один-к-одному чужие очеты использовать. Используйте как источник идей, подрабатывайте под себя. А идеи у девочки толковые - +1 однозначно.
O-Planet; +1 Ответить
13. Poppy (poppy) 27.08.07 12:25
(11)
Когда твой регистр ОстаткиЗапасов будет называться ОстаткиТМЦ, вот тогда обработка, возможно, заработает.

Или... обработку дорабатывай напильником. ;)
14. Margosha80 (margosha80) 27.08.07 14:01
А для бухгалтерии есть такая обработка?
15. Tiger77 (Tiger77) 29.08.07 11:34
Ерунда! Не проще ли выбрать все партии где приходный документ не приходная накладная ????
16. Poppy (poppy) 30.08.07 01:15
(15)
Не проще.
Во-первых, в качестве приходного документа могут выступать "Возврат от покупателя", "Оприходование ТМЦ".
Во-вторых, регистр ПартииНаличие очень чувствителен к положению ГП, но остатки в регистре ОстаткиТМЦ от ГП не зависят.
17. Аркадий Кучер (Abadonna) 30.08.07 06:51
(5) Poppy, как всегда, права ;)
18. Viacht (viacht) 04.09.07 08:47
13 Как было предложено обработал напильником, и свершилось чудо. ЗАРАБОТАЛА!
Автору гигантский плюс+. Если надо кому могу выложить для конфигурации ПУБ для Украины.
19. VasilyKushnir (vasilykushnir) 04.09.07 11:23
(18) А сам реальный плюс дядя поставит?
20. Олег Пономаренко (O-Planet) 11.10.07 04:31
21. Юрий Португалов (Sprite) 18.11.07 17:00
Оказалось нужным именно сегодня.
22. Сhe Burashka (CheBurator) 09.12.07 01:20
> Невозможно обращение к итогам после ТА
ну такие-то проверки надо вставлять...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа