gifts2017

Универсальный отчет по произвольному регистру за произвольные периоды.

Опубликовал Михаил Жихарев (Misha_J) в раздел Отчеты - Анализ учета

Универсальный отчет по произвольному регистру за произвольные периоды.
Отчет сделан на основе Универсального отчета по регистру Семеняк Евгения Игоревича, с доработкой под конкретную задачу - получить данные за произвольные периоды. Обработка предназначена для платформы 1С:Предприятие 7.7 Торговля и Склад. Добавлены дополнительные фильтры и группировки.

12.09.07 - исправил недочеты.

Скачать файлы

Наименование Файл Версия Размер
- 308
.1189504929 22,55Kb
25.09.09
308
.1189504929 22,55Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Михаил Жихарев (Misha_J) 11.09.07 16:07
Отследили глюк - неправильно сортирует тб.Запрос не определены колонки...
вот код:
Код
Пока тбЗапрос.ПолучитьСтроку()=1 Цикл
   Для кл=1 По КвоИзмерений Цикл
      ПредЗнач=тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки,кл);
         Если (ПустоеЗначение(ПредЗнач)=1) Тогда
            Если (кл=1)и(тбЗапрос.НомерСтроки<>1) Тогда
               тбЗапрос.УстановитьЗначение(тбЗапрос.НомерСтроки,кл,тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки-1,кл));
            Иначе
               тбЗапрос.УстановитьЗначение(тбЗапрос.НомерСтроки,кл,тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки,кл-1));
            КонецЕсли;
         КонецЕсли;
      КонецЦикла;
      Для кл2=НачКолСум По КонКолСум Цикл
         ПредЗнач=тбЗапрос.ПолучитьЗначение(тбЗапрос.НомерСтроки,кл2);
         Если ПустоеЗначение(ПредЗнач)=1 Тогда
            тбЗапрос.УстановитьЗначение(тбЗапрос.НомерСтроки,кл2,0);
         КонецЕсли;
      КонецЦикла;
   КонецЦикла;
тбЗапрос.Свернуть(КолГруппировок,КолСум);
Показать полностью

Получается тбЗапрос.Свернуть(1,2,3,3,4,5,6);
2. Михаил Жихарев (Misha_J) 11.09.07 16:18
Получается тбЗапрос.Свернуть(1,2,3,4,5,6);
3. Михаил Жихарев (Misha_J) 11.09.07 16:31
извеняюсь вот код:
Код
КолГруппировок = "";
Для колГ=1 По КвоИзмерений Цикл 
   КолГруппировок = КолГруппировок + колГ;
   Если колГ<КвоИзмерений Тогда
      КолГруппировок = КолГруппировок + ",";
   КонецЕсли;
КонецЦикла;
КолСум = "";НачКолСум = КвоИзмерений + 1;КонКолСум = тбЗапрос.КоличествоКолонок();
Для кСум=НачКолСум По КонКолСум Цикл 
   КолСум = КолСум + кСум;
   Если кСум<тбЗапрос.КоличествоКолонок() Тогда
      КолСум = КолСум + ",";
   КонецЕсли;
КонецЦикла;
Показать полностью
4. Михаил Жихарев (Misha_J) 12.09.07 12:53
Исправил механизм рекурсии, добавил сортировку по столбцам.
5. VasilyKushnir (vasilykushnir) 12.09.07 13:53
Ну что поддержим товарища? Хотя бы за старания - по-моему подобного не встречал.
6. Михаил Жихарев (Misha_J) 14.09.07 18:01
Кому нибудь пригодилось?
7. Poppy (poppy) 15.09.07 00:29
ИМХО.
На универсальность этот отчет явно не тянет.
Единственный его плюс = это разворачивание разных периодов вправо.

Но, сразу много больших минусов.
Настраивать эти призольные периоды крайне неудобно.
По кнопке "Настрйка" все предыдущие насройки теряются. А если учесть, что настривать неудобно, сложно и долго, то это офигенно неприятно.
По кнопке "Обновить" происход черт знает что. Но не то, что обычно, в типовых конфигурациях.

Однозначно = нИзачОт.
8. Михаил Жихарев (Misha_J) 15.09.07 10:10
по поводу настройки произвольных периодов. выбирается период в окне "Период" и нажать кнопку "добавить период". это, конечно же очень сложно и трудно, впрочем как и выбор самого периода... с кнопкой "обновить" действительно недоработка, спасибо что указал.
9. Михаил Жихарев (Misha_J) 15.09.07 12:16
Исправил "Обновить" и "Настройка"
10. Михаил Жихарев (Misha_J) 15.09.07 12:19
Группа "Фильтры" создана специально для нашей базы. Кому не надо, может не использовать. Кому интересно, могу рассказать по подробнее...
11. Евгений Стоянов (quick) 19.09.07 13:01
12. VasilyKushnir (vasilykushnir) 19.09.07 14:07
Ты прислушайся, прислушайся к poppy - она всегда очень дельные советы дает (прям как требовательный учитель). Иногда просто удивляет ее способность (или настойчивость) ковырятся в чужих разработках. И это, заметь, абсолютно по доброте душевной, чтобы подтолкнуть автора к написанию чего-то путного. При тексте обработки более одной страницы, мне лично уже становится скучно и легче свое написать, чем разбираться в чужом (лень, батенька....)
13. Михаил Жихарев (Misha_J) 19.09.07 14:14
Вот блин, я думал, что это мальчик...
14. Аркадий Кучер (Abadonna) 19.09.07 15:34
Poppy всегда права! (как и я ;) )
15. VasilyKushnir (vasilykushnir) 19.09.07 15:49
(13) и сильно растроился?
(14) Добавлю уточнение: если они не правы - читайте (14)
16. Аркадий Кучер (Abadonna) 19.09.07 15:52
(15) врожденная скромность помешала мне сделать циклическую ссылку ;)
17. Poppy (poppy) 20.09.07 01:08
(16)
Программер чистой воды! ;)
18. Михаил Жихарев (Misha_J) 20.09.07 08:31
это лесть или издивательство?
19. VasilyKushnir (vasilykushnir) 20.09.07 08:53
Не знаю что, но не издевательство - это точно. Просто небольшая расслабуха...
20. Аркадий Кучер (Abadonna) 20.09.07 10:00
Шуткуем мы, не обижайся ;)
21. Аркадий Кучер (Abadonna) 20.09.07 13:07
(18) И, кстати, 17 - это она про меня ;)
22. Михаил Жихарев (Misha_J) 20.09.07 13:25
а..., тогда все стало на свои места :-)
23. Аркадий Кучер (Abadonna) 20.09.07 18:49
(22) +1 за необидчивость и улыбчивость
24. Poppy (poppy) 21.09.07 01:11
(21)... (23)
Мальчики... Я вас люблю ;)
25. VasilyKushnir (vasilykushnir) 21.09.07 08:39
(24) А вот это дорого стоит...
26. Михаил Жихарев (Misha_J) 10.10.07 11:02
Чего-то никто больше не делится впечатлениями.
27. Александр Троицкий (Tasselhof) 15.10.07 19:00
Отличный отчет! Реально помог!
Вот только плохо что не выделяется шрифтом/цветом группы =(
Не удобно смотреть =(
Например отчет по складу - сливается номенклатура со складом и документом. Все одного шрифта и цвета.
28. Бестия (Бестия) 14.12.07 11:14
29. андрей (andrux) 27.02.08 15:53
30. А Р (p1l1gr1m) 24.07.08 01:50
Этот отчет, как и все другие, просто выплёвывает то, что даёт запрос к регистру. Но по моему это должно выглядеть иначе совершенно, т.е. структура должна быть у отчета движений и остатков другая. Интерфейс хромает. Но все равно, автор старался, поэтому молодец!
31. kitt al;dskjf;ldasjkf (kitt) 25.07.08 06:25
(30) Тем не менее, это лучший из универсальных отчетов по регистру, который я знаю. Хотя бы за возможность выводить измерения с типом иерерахический справочник без групп. С некоторыми частями интерфейса конечно туговато (я например так и не понял как сделать группировку по документу, она у меня появляется время от времени, когда я тыкаю во все кнопки подряд:) ). А насчет того что просто выплевывает, не согласен - у меня показывает как раз нормально, если правильно указать расположение группировок. Попропуйте поразбираться еще :)
32. Artem (kalleka) 06.03.09 16:50
я тут кстати похожую разработку выложил... Может кто даст рекомендаций, по улучшению, интерес чисто "академический" - время от времени появляется свободное время на работе

http://infostart.ru/projects/3581/
33. Александр (Креатив) 14.04.09 08:44
Скачал, отчёт интересный. Только у меня по регистру остатков в разрезе документов движения остатки-то нулевые :-((
34. vladal (Vladal) 26.08.09 16:33
(33) Странно, чего нулевые? У меня работает ;)
36. юрий гулидов (gull22) 19.11.14 16:19
Спасибо за обработку, пригодилось
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа