gifts2017

Ускорение работы со списком документов, в котором при выводе строки выполняется запрос по регистрам или ещё что-нибудь трудоемкое

Опубликовал Ким (Ким) в раздел Программирование - Практика программирования

Для ускорения работы со списком документов, в котором при выводе строки выполняется запрос по регистрам или ещё что-нибудь трудоемкое, нужно уменьшить количество выполнений запроса.

Для того чтоб запрос не выполнялся каждый раз при переходах по списку можно использовать Соответствие, которое будет выполнять роль временного хранилища результатов запросов.

Для ускорения работы со списком документов, в котором при выводе строки выполняется запрос по регистрам или ещё что-нибудь трудоемкое, нужно уменьшить количество выполнений запроса.

Для того чтоб запрос не выполнялся каждый раз при переходах по списку можно использовать Соответствие, в котором будет храниться результат запроса. Если запрос по текущему документу уже выполнялся, его результат будет найден в соответствии.

Один недостаток, что данные в соответствии могут устареть за то время что открыт журнал. Но их можно обновить переоткрыв журнал.

Ниже пример кода в модуле формы списка:

Перем СводОстатков;
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)  
    НайденныйОстаток = СводОстатков.Получить(ДанныеСтроки.Ссылка);
    Если НайденныйОстаток = Неопределено Тогда      
        Запрос = Новый Запрос;   
        Запрос.Текст="ВЫБРАТЬ                
        | ЗаказыПоставщикамОстатки.КоличествоОстаток                
        |ИЗ                
        | РегистрНакопления.ЗаказыПоставщикам.Остатки КАК ЗаказыПоставщикамОстатки                
        |ГДЕ                
        | ЗаказыПоставщикамОстатки.ЗаказПоставщику = &ссылка" ;   
        Запрос.УстановитьПараметр("Ссылка", ДанныеСтроки.Ссылка);   
        Рез = Запрос.Выполнить();   
        Если Рез.Пустой() Тогда    
            ОформлениеСтроки.ЦветФона = WebЦвета.Белый;     
            СводОстатков.Вставить(ДанныеСтроки.Ссылка,0);  
        Иначе    
            ОформлениеСтроки.ЦветФона = WebЦвета.СветлоКоралловый;   
            СводОстатков.Вставить(ДанныеСтроки.Ссылка,1);  
        КонецЕсли;   
    Иначе   
        Если НайденныйОстаток = 0 Тогда    
            ОформлениеСтроки.ЦветФона = WebЦвета.Белый;    
        Иначе    
            ОформлениеСтроки.ЦветФона = WebЦвета.СветлоКоралловый;   
        КонецЕсли;   
    КонецЕсли;   
КонецПроцедуры

СводОстатков =  Новый Соответствие();

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Андрей Комар (akomar) 10.09.12 13:27
Вы предполагаете изменять модуль формы или модуль объекта типовой?
2. Dmitry Dmitry (Dimasik2007) 10.09.12 13:43
ПриВыводеСтроки не совсем удачная идея. Лучше данные сразу получать порциями в процедуре ПриПолученииДанных.
Подробности курим тут: http://kb.mista.ru/article.php?id=310
mtv:); artbear; +2 Ответить
3. Модератор раздела Артур Аюханов (artbear) 10.09.12 15:55
(0) Неудачная реализация, намного лучше/быстрее/производительнее ПриПолученииДанных.
Правда, не во всех списках оно работает. Правда, в каких списках его нет, навскидку не вспомню :)
4. Dmitry Dmitry (Dimasik2007) 10.09.12 16:55
Пример быстрой раскраски:





Функция ПолучитьМассивСсылокОформленияСтрок(ОформленияСтрок)

Массив = Новый Массив;

Для каждого
ОформлениеСтроки Из ОформленияСтрок Цикл
Массив.Добавить(ОформлениеСтроки.Данныестроки.Ссылка);
КонецЦикла;

Возврат
Массив;

КонецФункции
// ПолучитьСписокСсылок(ОформленияСтрок)

Функция ПолучитьТаблицаНаличиеФайлов (МассивСсылокОформления)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| КОЛИЧЕСТВО(РАЗЛИЧНЫЕ _ФайловоеХранилищеСрезПоследних.Путь) КАК КоличествоФайлов,
| _ФайловоеХранилищеСрезПоследних.Документ как Ссылка
|ИЗ
| РегистрСведений._ФайловоеХранилище.СрезПоследних(, Документ В (&МассивСсылокОформления)) КАК _ФайловоеХранилищеСрезПоследних
|
|СГРУППИРОВАТЬ ПО
| _ФайловоеХранилищеСрезПоследних.Документ"
;

Запрос.УстановитьПараметр("МассивСсылокОформления", МассивСсылокОформления);

Возврат
Запрос.Выполнить().Выгрузить();

КонецФункции
// ПолучитьТаблицаНаличиеФайлов(ОформленияСтрок)()

// отрисуем значок прикрепленных файлов к документу
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
МассивСсылокОформления = ПолучитьМассивСсылокОформленияСтрок(ОформленияСтрок);
ТаблицаДанныхНаличиеФайлов = ПолучитьТаблицаНаличиеФайлов (МассивСсылокОформления);

Для каждого
ОформлениеСтроки Из ОформленияСтрок Цикл
СтрокаОформленияСтрок = ТаблицаДанныхНаличиеФайлов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "Ссылка");
Если
СтрокаОформленияСтрок <> неопределено Тогда
Если
ЗначениеЗаполнено(СтрокаОформленияСтрок.КоличествоФайлов) Тогда
ОформлениеСтроки.Ячейки.Номер.УстановитьКартинку(БиблиотекаКартинок._Скрепка);
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
5. Dmitry Dmitry (Dimasik2007) 10.09.12 16:57
Таблицу использовал, потому что отрисовывал еще количество файлов, а так можно использовать все тоже соответствие.
6. Василий Антонов (khaoos) 11.09.12 09:46
(1) akomar, в типовых конфигурациях, я думаю, не встретишь тяжелых запросов при выводе каждой строки. А вот в "допиленных" - это сколько угодно :).
7. dfg kjn (zergey128) 12.09.12 09:49
Автор,курите типовые, а не изобретайте велосипед.